Orion33

Опять закольцованные маршруты и утечка памяти.

Рекомендованные сообщения

Добрый день.

Помнится,  4-5 лет назад, когда в качестве роутера у меня был линуксовый ПК, была такая проблема: сразу после включения на поднимаемом l2tp соединении бежал дикий трафик, за минуту несколько Гб набегало, затем соединение перезапускалось, и после этого все работало стабильно.

Вот сегодня ни с того ни с сего стала дико низкая входящая скорость: 2ip.ru показал 0,34 мбит / 84 мбит. Зашел на роутер (TP link wr1043nd-v2 @ OpenWRT), увидел, что тот работает без сбоев 20 с лишком, и решил перезагрузить...
После перезагрузки при поднятии соединения приходили только 3 пакета, а затем в лог сыпались такие сообщения:

do_page_fault(): sending SIGSEGV to xl2tpd for invalid write access to 00000094

Соединения не было. При этом создавать туннель из виндового клиента через роутер получалось, скорость 90 мбит / 84 мбит. То есть коннект отличный, проблема именно в роутере. Подумал, что могла за 4 года повредиться прошивка, решил ее заодно обновить до последней версии. После установки и настройки в лог стали сыпаться уже иные сообщения:

[  379.731378] l2tp-l2tp: recursion detected
[  386.246024] l2tp-l2tp: recursion detected
[  391.624885] l2tp-l2tp: recursion detected
[  396.635802] l2tp-l2tp: recursion detected
[  401.671053] l2tp-l2tp: recursion detected

При этом сам роутер дико висит, ВЕБ интерфейс глючит, иногда даже локальное соединение отваливается. То есть все признаки нехватки памяти. И тут я вспомнил про случай 5х-летней давности и решил написать сюда.

Что-то у вас там поломакалось, товарищи админы, ведь я свой роутер в течение 20 дней не ковырял, а проблемы заметил сегодня утром.

Статических маршрутов нет, только то, что присылает мне Пчелайн:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.75.72.1      0.0.0.0         UG    50     0        0 eth0
10.0.0.0        10.75.72.1      255.0.0.0       UG    50     0        0 eth0
10.75.72.0      0.0.0.0         255.255.248.0   U     50     0        0 eth0
78.107.23.0     10.75.72.1      255.255.255.0   UG    50     0        0 eth0
78.107.52.0     10.75.72.1      255.255.255.0   UG    50     0        0 eth0
78.107.196.0    10.75.72.1      255.255.252.0   UG    50     0        0 eth0
83.102.146.96   10.75.72.1      255.255.255.224 UG    50     0        0 eth0
83.102.254.223  10.75.72.1      255.255.255.255 UGH   50     0        0 eth0
83.102.255.55   10.75.72.1      255.255.255.255 UGH   50     0        0 eth0
83.102.255.224  10.75.72.1      255.255.255.240 UG    50     0        0 eth0
85.21.72.80     10.75.72.1      255.255.255.240 UG    50     0        0 eth0
85.21.79.0      10.75.72.1      255.255.255.0   UG    50     0        0 eth0
85.21.90.0      10.75.72.1      255.255.255.0   UG    50     0        0 eth0
85.21.138.208   10.75.72.1      255.255.255.240 UG    50     0        0 eth0
89.179.134.64   10.75.72.1      255.255.255.240 UG    50     0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan
194.67.18.0     10.75.72.1      255.255.255.0   UG    50     0        0 eth0
233.32.240.0    10.75.72.ХХХ    255.255.255.0   UG    50     0        0 eth0

Мне звонить в поддержку или проблема уже известна?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

звонить, т.к. экстрасенсы в отпуске

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В общем, причина действительно в закольцовывании трафика. Этот скрипт устраняет проблему.

/etc/ppp/ip-up.d/l2tp.sh

ADDR=`route -n | awk '{if ($4=="UH") print $1}'`
route del $ADDR dev l2tp-l2tp
echo "Deleting default route for $ADDR"

В бэкапах настроек с 2015 года этого скрипта нет, что говорит о недавнем появлении проблемы именно со стороны провайдера.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрый день!

Вернулся домой в воскресенье 31. Заметил дикие тормоза. У меня был тариф 30 МБит/350 р. Прошелся по мерялкам, 8 МБит и постоянное прерывание интернета. Захожу в личный кабинет - там другой тариф 80 МБит / 400 р. Ммм, однако. Без моего участия сменили тариф. В кабинете 80 МБит, в реале 8. Воткнул без роутера, произошла долгая перенастройка соединения и да, видим реальные 80. Но! При попытке подключиться через роутер никаких результатов, даже тех же 8. Роутер Smart Box билайновский. У меня в запасе валяется без дела Smart Box One - результат тот же. В настройках роутера внешний кабель не подключен. Напрямую к компу - работает, через любой роутер - никак. При этом на компе висит статус - подключено к интернету.

У меня стоит автоплатеж 1 числа каждого месяца. Сняли по старому тарифу 350 р, но в кабинете уже 31 числа и сейчас висит тариф за 400, который я не заказывал.

Договор 0890955296, Домодедово

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас