LorexDivais

Mikrotik Upnp торрент-клиент

Рекомендованные сообщения

Всем привет! У меня RB951-2n, прошивка стоит последняя - 6.44. В торрент-клиентах пишется, что порт (используемый программой) - заблокирован. Сначала я пытался его пробросить по многочисленным инструкциям в интернете через добавление записи в разделе NAt. Не помогло, порт все равно был закрыт (это подтверждалось и через сайт проверки открытости портов). Потом я прочитал, что проще всего включить режим upnp в настройках торрент-клиента и роутера. В микротике я включил эту службу, добавил два интерфейса ether1 как external и ether2-master как internal. И.. все равно порты не открываются) Bitcomet пишет "Не удалось [UPNP device not found!]" Что делать дальше? Где проверить еще?

upnp.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Проверьте при подключении напрямую (без роутера). Если при прямом подключении проблема с портами сохранится, то роутер настраивать бесполезно: в этом случае Вы -- за CGNAT провайдера, обойти который самостоятельно (тем более -- настройками пользовательского роутера) никак не получится, кроме как заказом платной услуги предоставления статического IP-адреса.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вам надо разрешить в настройка Firewall входящий трафик с порта торрент-клиента, а также настроить nat, чтоб трафик с роутера все-таки попал на комп. настройки ниже актуальны только для "белого" внешнего (динамического/статического) адреса.

1. настройка входящего трафика:

/ip firewall filter
add action=accept chain=input connection-state=new dst-port=44444 protocol=tcp

,где:

  • dst-port=44444 - порт в настройках торрент-клиента

2. настройка нат

/ip firewall nat
add action=dst-nat chain=dstnat comment="torrent" dst-port=44444 in-interface=ether1 protocol=tcp to-addresses=192.168.0.12

,где:

  • dst-port=44444 - порт в настройках торрент-клиента
  • in-interface=ether1 - интерфейс с выходом/входом в интернет
  • to-addresses=192.168.0.12 - адрес компа с торрент-клиентом
Изменено пользователем  Ni©olas

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Подключил статический ип адрес.

Ввел настройки, но опять торренты-трекеры пишут, что порты закрыты. На скрине нат1 видно, что служба upnp работает и создала автоматически правило для уторрента, но траффик не проходит и горит ошибка в приложении уторрент. Что еще можно проверить? Нужно ли где-то вписывать статический адрес?

nat1.jpg

nat2.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Входящее правило надо поместить над первым дропом

У судя по названиям правил, ваш микротик кто-то взломал

Изменено пользователем  Ni©olas

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Переставил наверх.

Видимо проще купить Xiaomi mi router 3g с прошивкой Падавана, чем мучаться с пробросом портов на микротике((

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
8 часов назад, LorexDivais сказал:

Видимо проще купить Xiaomi mi router 3g с прошивкой Падавана, чем мучаться с пробросом портов на микротике((

Купите кинетик, падаван уже давно прошивку забросил , более того он несколько лет в кинетике работает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Боюсь, что без настройки безопасности проблемы будут что у Xiaomi, что у Zyxel ))

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад,  Ni©olas сказал:

что у Zyxel

Я не говорю о Zyxel я говорю о Keenetic - там нет особенных настроек безопасности, в отличии от дырки в микротиках ;) .

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрый день, у меня 6.40.9 потому что в новых версиях я не разобрался с бриджем, у меня через него тв приставка работает, у меня l2tp и таким образом работает проброс портов, я не очень рисую, но уж как смог) вроде понятно, Beeline это порт куда кабель биллайна заходит, а ип адрес, это тот который получает ваш пк от микротика, ну и открываете порт, думаю у вас все получится.

Безымянный.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, NikIv сказал:

там нет особенных настроек безопасности, в отличии от дырки в микротиках ;) .

так в микротике тоже нет дырки в безопасности) просто девайсы для двух разных групп пользователей. в кинетик для дома, микротик для мелкого/среднего бизнеса (но можно и дома использовать). и разные алгоритмы настройки и использования. вот например, затем использовать дефолтные данные для админа устройства - непонятно )

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@romanekb 

в новых сборках отказались от мастер-порта, конфигурации устройств надо менять конечно же, если есть необходимость обновиться. а для тв в настройках бриджа сделали igmp snooping. а если хочется чего-то необычного, можно повторить эксперемент

 

p.s. action=dst-nat вполне подходит для проброса порта, вместо action=netmap

Изменено пользователем  Ni©olas

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@romanekb  По твоему скрину тоже выбрал Beeline как внешний интерфейс и порт открылся!!! Спасибо большое))

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас