zFD1m

Помогите настроить l2tp (2018)

Рекомендованные сообщения

 

Раньше я сидел на l2tp и все было хорошо, потом ни с того ни с сего перестал работать инет. Стал проверять и так и сяк (кучу всего перепробовал) даже брал соседские роутеры. Прошивки не помогали. Перешил на OpenWRT (давно хотел) и тоже не заработало. В итоге оказалось, что проблема не у меня, а у провайдера(билайна), они что-то намудрили и у меня перестал подключаться l2tp. Поддержка послала меня на ..., в не явном виде (не хотят консультировать)

Сейчас у меня работает как статика (ip постоянный) хотя стоит dhcp на wan. Установил - opkg install xl2tpd  (1.3.12-1). Пытался настроить стандартный WAN на L2TP - не получилось, создал новый интерфейс - BEELINE и L2TP (l2tp-Beeline) и тоже ничего. На интерфейсе BEELINE - не присваивается IP.  Последние вопросы(ответы) на данную тему были 2015-2016г. может что-то изменили и поэтому не соединяется или данная проблема только у меня?

ifconfig
br-lan    Link encap:Ethernet  HWaddr <MAC>  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: <IP6> Scope:Global
          inet6 addr: <IP6> Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:121 errors:0 dropped:0 overruns:0 frame:0
          TX packets:107 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:12653 (12.3 KiB)  TX bytes:20056 (19.5 KiB)

eth0      Link encap:Ethernet  HWaddr <MAC>  
          inet6 addr: <IP6> Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:31383422 errors:0 dropped:1 overruns:28 frame:0
          TX packets:31312481 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2667577592 (2.4 GiB)  TX bytes:2661975458 (2.4 GiB)
          Interrupt:4 

eth0.1    Link encap:Ethernet  HWaddr <MAC>  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:121 errors:0 dropped:0 overruns:0 frame:0
          TX packets:107 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:12653 (12.3 KiB)  TX bytes:20056 (19.5 KiB)

eth0.2    Link encap:Ethernet  HWaddr <MAC>  
          inet addr:<IP>  Bcast:<Bcast>  Mask:255.255.252.0
          inet6 addr: <IP6> Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:25 errors:0 dropped:2 overruns:0 frame:0
          TX packets:37 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3511 (3.4 KiB)  TX bytes:5911 (5.7 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2447 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2447 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:170717 (166.7 KiB)  TX bytes:170717 (166.7 KiB)
root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde2:8a26:89c6::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth0.2'
        option reqopts 'routes msstaticroutes'
        option peerdns '0'
        option dns '8.8.8.8'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'
        option reqaddress 'none'
        option reqprefix 'no'
        option auto '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

config interface 'Beeline'
        option ifname 'eth0.2'
        option proto 'l2tp'
        option username '<USERNAME>'
        option password '<PASS>'
        option ipv6 'auto'
        option server 'tp.internet.beeline.ru'
        option keepalive '20 5'
        option peerdns '0'

 

 

 

 

 

 

 

 

Изменено пользователем zFD1m

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас