 Ni©olas

MikroTik RB/MRTG (miniROUTERG). Часть 2

Рекомендованные сообщения

Hap Lite 941, Ipoe настроено по дефолту.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
On 25.08.2017 at 12:56, ShurikG писал:

Доброго всем дня!

Может, кто подскажет, - это у меня в логах разрывы соединения?

МикроЛоги.jpg

Нет, Дружище. Это к тебе незваные гости ломятся по web-интерфейсу.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо, но вижу только две попытки зайти под админом. Можно поподробнее, если ошибаюсь?

Изменено пользователем ShurikG
дополнение

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Техническая поддержка

Уважаемые клиенты! В виду участившихся обращений по поводу выхода оборудования из строя, настоятельно не рекомендуем обновлять RouterOS на Ваших устройствах до версий 6.40 +

Проблема уже выявлена на моделях:

✖ - Mikrotik Hex
✖ - Mikrotik Hex lite
✖ - Mikrotik Hap
✖ - Mikrotik Hap ac lite
✖ - Mikrotik Hap lite
✖ - Metal 52ac

Изменено пользователем  Ni©olas
уменьшил размер шрифта сообщения

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
On 03.09.2017 at 22:08, ShurikG писал:

Спасибо, но вижу только две попытки зайти под админом. Можно поподробнее, если ошибаюсь?

причем эти две попытки из локальной сети (не из интернета)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот же ж... в настройках DHCP Server было по умолчанию аренда 10 минут, поставил теперь на 6 дней - будем посмотреть.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

К сожалению, разрывы продолжаются...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

кто нибудь в курсе почему 751g режет скорость по wifi в половину? в место 90-100 выдает 40-50.. клиент один в сети. а ну на телефоне тож самая скорость. мерил спидестом/торентами. напрямую кабель роутер-комп как положено 90-100 мб/с

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, otets писал:

кто нибудь в курсе почему 751g режет скорость по wifi в половину? в место 90-100 выдает 40-50.. клиент один в сети. а ну на телефоне тож самая скорость. мерил спидестом/торентами. напрямую кабель роутер-комп как положено 90-100 мб/с

Клиент на какой скорости подключается? 72 мбит? Если да , то - это хорошая скорость.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
9 мин назад , otets писал:

300мбит/с

Клиент обычно максимум 270мбит  подключение показывает, вы может не так поняли?

Где вы эту скорость смотрите? Скрин выложите.

 

Изменено пользователем NikIv

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Только что, NikIv писал:

Тогда пробовать поискать канал с наиболее высокой скоростью, хотя если это за преградой не прямой видимости , то нормально. 

я пробывал на всех каналах. одно и тоже. ну не выдает он больше 50нника. что на компе что на телефоне, что на ноуте

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 мин назад , otets писал:

что на компе что на телефоне, что на ноуте

Вы не валите все в кучу, у всех клиентов разная скорость подключения.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

это понятно. там разницы в 5/10 мб/с на них. ну не как ни по тарифу до 100)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@otets если ваши клиенты не 2Т2R и с полосой 20мгц то это нормальная скорость.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
3 часа назад, NikIv писал:

 

в общем я не долго думая купил 962u. обновил его на версию 6.41.2. и он перестал заходить через web. (хром+IE). точнее он заходит, вводишь пароль и все, Loading...... через телефон заходит (там сафари).

по винбоксу тоже все гуд.

Сам факт того, почему веб интерфес не пашет? 

Изменено пользователем otets

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
On 02.06.2016 at 16:12,  Ni©olas писал:

@xsb3, настроить тот профиль, который используется в настройках L2TP

 

  Hide contents

 

2016-06-02_09-07-08.png

 

перезалей плиз картинку) а то не открывается. что там в профиле то указываать

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

День добрый!

Недели за 2 до НГ изменилась адресация с 10.26.168.0/24 на 100.104.192.0/18. После перестал резолвиться tp.internet.beeline.ru.

Скрытый текст

[redgy92@MikroTik] > put [:resolve tp.internet.beeline.ru]
failure: dns name does not exist

> /ip dns print 
                      servers: 
              dynamic-servers: 85.21.192.3,213.234.192.8
        allow-remote-requests: yes
          max-udp-packet-size: 4096
         query-server-timeout: 2s
          query-total-timeout: 10s
       max-concurrent-queries: 100
  max-concurrent-tcp-sessions: 20
                   cache-size: 2048KiB
                cache-max-ttl: 1w
                   cache-used: 160KiB

dns-cache.jpg.e0a8dd7ad3596008bd2233a7f4685716.jpg

Если кабель вставить напрямую в пк, то nslookup отвечает 85.21.66.205/85.21.66.253 и иногда (редко) непонятные 78.107.Х.Х (забыл цифры).  Так же различается шлюз и выданный ип. То 100.104.192.1, то 100.110.128.1. Через роутер всегда 100.104.192.1.

Вбил ip вместо адреса, интернет появился. Звонил в ТП, спрашивал не намечается ли переход на ipoe и не ведутся ли какие работы, ответили что не в курсе :)

Роутер настроен по стандартной схеме из темы "Основные настройки MikroTik", за исключением резервного канала через 3g модем. Конфиг прилагаю.

Собственно вопрос у меня проблемы с днс или что то там происходит у билайна? Конфиг работал исправно много лет до момента смены адресации. Сейчас тоже работает, конечно, но какие то траблы с днс.

Скрытый текст

> export compact 
# jan/05/2020 13:20:12 by RouterOS 6.46.1
# software id =
#
# model = RB952Ui-5ac2nD
# serial number =
/interface bridge
add admin-mac=C4:AD:34:26:F2:BB auto-mac=no comment=defconf igmp-snooping=\
    yes name=bridge
/interface l2tp-client
add add-default-route=yes allow=chap,mschap2 connect-to=85.21.66.205 \
    default-route-distance=5 disabled=no max-mru=1500 max-mtu=1460 name=\
    Beeline password= user=
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX \
    country=no_country_set disabled=no distance=indoors frequency=auto \
    frequency-mode=superchannel installation=indoor mode=ap-bridge ssid=\
    MikroTik-hAP wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=\
    20/40/80mhz-XXXX country=no_country_set disabled=no distance=indoors \
    frequency=auto frequency-mode=superchannel installation=indoor mode=\
    ap-bridge ssid=MikroTik-hAP wireless-protocol=802.11
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
    dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key= \
    wpa2-pre-shared-key=
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp ranges=192.168.0.10-192.168.0.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge lease-time=1d name=\
    defconf
/port
set 0 name=usb1
/interface ppp-client
add apn=internet.tele2.ru data-channel=2 default-route-distance=15 \
    dial-on-demand=no info-channel=2 name=ppp-out1 password=tele2 port=\
    usb1 user=tele2
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge comment=defconf interface=wlan2
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=Beeline list=WAN
add interface=ppp-out1 list=WAN
/ip address
add address=192.168.0.1/24 comment=defconf interface=bridge network=\
    192.168.0.0
/ip dhcp-client
add comment=defconf default-route-distance=10 disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.0.0/24 comment=defconf gateway=192.168.0.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.0.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=accept chain=input comment=BeelineTV protocol=igmp
add action=accept chain=forward comment=BeelineTV dst-address=232.0.0.0/5 \
    protocol=udp
add action=drop chain=input comment="defconf: drop invalid" \
    connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=\
    127.0.0.1
add action=drop chain=input comment=\
    "defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
# ppp-out1 not ready
add action=drop chain=output comment=Failover-3g dst-address=4.2.2.1 \
    out-interface=ppp-out1
# ppp-out1 not ready
add action=drop chain=output comment=Failover-3g dst-address=8.8.4.4 \
    out-interface=ppp-out1
/ip firewall mangle
add action=change-mss chain=forward new-mss=1360 protocol=tcp tcp-flags=\
    syn tcp-mss=!0-1360
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
/ip route
add comment="Failover-3g default route" distance=1 gateway=Beeline
add comment=Failover-3g distance=1 dst-address=4.2.2.1/32 gateway=Beeline
add comment=Failover-3g distance=1 dst-address=8.8.4.4/32 gateway=Beeline
add comment="Route to tp.internet.beeline.ru" disabled=yes distance=1 \
    dst-address=78.107.1.0/24 gateway=100.104.192.1
add comment="Route to tp.internet.beeline.ru" disabled=yes distance=1 \
    dst-address=85.21.66.0/24 gateway=100.104.192.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set winbox address=192.168.0.0/24
set api-ssl disabled=yes
/routing igmp-proxy
set query-interval=30s query-response-interval=20s
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 inte
add interface=bridge
/system clock
set time-zone-name=Europe/Moscow
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
/tool netwatch
add comment=Failover-3g down-script="/log warning \"server 4.2.2.1 fail...\"\r\
    \n:local checkip [/ping 8.8.4.4 count=5]\r\
    \n:if (checkip = 0) do={\r\
    \n/log error \"Beeline is DOWN\"\r\
    \n/ip route set [/ip route find dst-address=0.0.0.0/0 distance=1] gateway=ppp-out1\r\
    \n/interface ppp-client enable ppp-out1\r\
    \n}" host=4.2.2.1 interval=3m up-script="/log warning \"Beeline is UP\"\r\
    \n/ip route set [/ip route find dst-address=0.0.0.0/0 distance=1] gateway=Beeline\r\
    \n/interface ppp-client disable ppp-out1"

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Внезапно упал интернет, сработал скрипт переключения на модем, потом билайн заработал и вот. Через некоторое время опять перестанет резолвиться. А в настройках l2tp тем временем 85.21.66.205 и все подключается и работает.

[redgy92@MikroTik] > put [:resolve tp.internet.beeline.ru]
78.107.1.249
[redgy92@MikroTik] > put [:resolve tp.internet.beeline.ru]
78.107.1.253

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Решил попробовать настроить Ipoe. Работает. Странно, что нигде не сообщается о переходе.

Скрипт переключения на модем пришлось переделать. Может кому пригодится, приложу сам скрипт и мой конфиг (ipoe + tv + 3g)

Скрытый текст

#Check internet
:local gwdef [ /ip route get [find comment="Failover-3g-default-route"] gateway ]
:local gwdhcp [ /ip dhcp-client get number=0 gateway ]
:local checkip [/ping 8.8.4.4 count=5 interface=ether1]
:local checkip2 [/ping 78.88.8.1 count=5 interface=ether1]
:if (checkip = 0 && checkip2 = 0) do={
/log error "Beeline is DOWN"
:if ($gwdef!="ppp-out1") do={
/ip route set [ /ip route find comment="Failover-3g-default-route" ] gateway=ppp-out1
/log error "set gw ppp-out1"
}
} else={
/log warning "Beeline is OK"
:if ($gwdef!=$gwdhcp) do={
/ip route set [ /ip route find comment="Failover-3g-default-route" ] gateway=$gwdhcp
/log error "set gw beeline"
}
}

# jan/06/2020 12:58:25 by RouterOS 6.46.1
# software id = 
#
# model = RB952Ui-5ac2nD
# serial number = 
/interface bridge
add auto-mac=no comment=defconf igmp-snooping=yes name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX \
    country=no_country_set disabled=no distance=indoors frequency=auto \
    frequency-mode=superchannel installation=indoor mode=ap-bridge ssid=\
    MikroTik-hAP wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40mhz-XX \
    country=no_country_set disabled=no distance=indoors frequency=auto \
    frequency-mode=superchannel installation=indoor mode=ap-bridge ssid=\
    MikroTik-hAP wireless-protocol=802.11
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
    dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key= \
    wpa2-pre-shared-key=
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp ranges=192.168.0.10-192.168.0.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge lease-time=1d name=defconf
/port
set 0 name=usb1
/interface ppp-client
add apn=internet.tele2.ru data-channel=2 default-route-distance=15 \
    dial-on-demand=no disabled=no info-channel=2 name=ppp-out1 password=tele2 \
    port=usb1 user=tele2
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge comment=defconf interface=wlan2
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=ppp-out1 list=WAN
/ip address
add address=192.168.0.1/24 comment=defconf interface=bridge network=\
    192.168.0.0
/ip dhcp-client
add comment=defconf default-route-distance=10 disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.0.0/24 comment=defconf gateway=192.168.0.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.0.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=accept chain=input comment=BeelineTV protocol=igmp
add action=accept chain=forward comment=BeelineTV dst-address=232.0.0.0/5 \
    protocol=udp
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall mangle
add action=change-mss chain=forward new-mss=1360 protocol=tcp tcp-flags=syn \
    tcp-mss=!0-1360
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
/ip route
add comment=Failover-3g-default-route distance=1 gateway=ppp-out1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set winbox address=192.168.0.0/24
set api-ssl disabled=yes
/routing igmp-proxy
set query-interval=30s query-response-interval=20s
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=ether1 upstream=yes
add interface=bridge
/system clock
set time-zone-name=Europe/Moscow
/system leds
add interface=ppp-out1 leds=user-led type=interface-activity
/system scheduler
add interval=3m name=failover3g on-event="/system script run failover3g" \
    policy=read,write,test start-date=jan/06/2020 start-time=09:28:28
/system script
add dont-require-permissions=no name=failover3g owner=redgy92 policy=\
    read,write,test source=":local gwdef [ /ip route get [find comment=\"Failo\
    ver-3g-default-route\"] gateway ]\r\
    \n:local gwdhcp [ /ip dhcp-client get number=0 gateway ]\r\
    \n:local checkip [/ping 8.8.4.4 count=5 interface=ether1]\r\
    \n:local checkip2 [/ping 78.88.8.1 count=5 interface=ether1]\r\
    \n:if (checkip = 0 && checkip2 = 0) do={\r\
    \n/log error \"Beeline is DOWN\"\r\
    \n:if (\$gwdef!=\"ppp-out1\") do={\r\
    \n/ip route set [ /ip route find comment=\"Failover-3g-default-route\" ] g\
    ateway=ppp-out1\r\
    \n/log error \"set gw ppp-out1\"\r\
    \n}\r\
    \n} else={\r\
    \n/log warning \"Beeline is OK\"\r\
    \n:if (\$gwdef!=\$gwdhcp) do={\r\
    \n/ip route set [ /ip route find comment=\"Failover-3g-default-route\" ] g\
    ateway=\$gwdhcp\r\
    \n/log error \"set gw beeline\"\r\
    \n}\r\
    \n}"
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

 

 

  • Like 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сделал, проверил, работает, а выложил не доделанный вариант :)

Маршруты к пингуемым адресам через билайн были не добавлены, вот исправленный вариант. Заодно проверка ip шлюза, получаемого по dhcp, и шлюза, прописанного в маршруты, т.к. указать интерфейс ether1 нельзя, в отличии от l2tp и ppp, а ip шлюза может измениться.  Теперь, вроде, все.

Скрытый текст

:local gwdhcp [/ip dhcp-client get number=0 gateway]

#Check gateway
:local gw1 [/ip route get value-name=gateway [find dst-address=8.8.4.4/32]]
:local gw2 [/ip route get value-name=gateway [find dst-address=78.88.8.1/32]]
:if ($gwdhcp!=$gw1 || $gwdhcp!=$gw2) do={
/log error "Gateway is changed!"
/ip route set [ /ip route find comment="Failover3g" ] gateway=$gwdhcp
}

#Check internet
:local gwdef [/ip route get [find comment="Failover-3g-default-route"] gateway]
:local checkip [/ping 8.8.4.4 count=5 interface=ether1]
:local checkip2 [/ping 78.88.8.1 count=5 interface=ether1]
:if (checkip = 0 && checkip2 = 0) do={
:if ($gwdef!="ppp-out1") do={
/log warning "Change to 3g-modem"
/ip route set [ /ip route find comment="Failover-3g-default-route" ] gateway=ppp-out1
}
} else={
:if ($gwdef!=$gwdhcp) do={
/log warning "Change to beeline"
/ip route set [ /ip route find comment="Failover-3g-default-route" ] gateway=$gwdhcp
}
}

# jan/12/2020 00:58:00 by RouterOS 6.46.1
# software id =
#
# model = RB952Ui-5ac2nD
# serial number =
/interface bridge
add admin-mac=C4:AD:34:26:F2:BB auto-mac=no comment=defconf igmp-snooping=yes \
    name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX \
    country=no_country_set disabled=no distance=indoors frequency=auto \
    frequency-mode=superchannel installation=indoor mode=ap-bridge ssid=\
    MikroTik-hAP wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40mhz-XX \
    country=no_country_set disabled=no distance=indoors frequency=auto \
    frequency-mode=superchannel installation=indoor mode=ap-bridge ssid=\
    MikroTik-hAP wireless-protocol=802.11
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
    dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=12345678 \
    wpa2-pre-shared-key=12345678
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp ranges=192.168.0.10-192.168.0.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge lease-time=1d name=defconf
/port
set 0 name=usb1
/interface ppp-client
add apn=internet.tele2.ru data-channel=2 default-route-distance=15 \
    dial-on-demand=no disabled=no info-channel=2 name=ppp-out1 password=tele2 \
    port=usb1 user=tele2
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge comment=defconf interface=wlan2
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=ppp-out1 list=WAN
/ip address
add address=192.168.0.1/24 comment=defconf interface=bridge network=\
    192.168.0.0
/ip dhcp-client
add comment=defconf default-route-distance=10 disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.0.0/24 comment=defconf gateway=192.168.0.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.0.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
    "defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=accept chain=input comment=BeelineTV protocol=igmp
add action=accept chain=forward comment=BeelineTV dst-address=232.0.0.0/5 \
    protocol=udp
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
    invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
    "defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
    ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
    ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add action=accept chain=forward comment=\
    "defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
/ip firewall mangle
add action=change-mss chain=forward new-mss=1360 protocol=tcp tcp-flags=syn \
    tcp-mss=!0-1360
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    ipsec-policy=out,none out-interface-list=WAN
/ip route
add comment=Failover-3g-default-route distance=1 gateway=89.178.128.1
add comment=Failover3g distance=1 dst-address=8.8.4.4/32 gateway=89.178.128.1
add comment=Failover3g distance=1 dst-address=78.88.8.1/32 gateway=89.178.128.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set winbox address=192.168.0.0/24
set api-ssl disabled=yes
/routing igmp-proxy
set query-interval=30s query-response-interval=20s
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=ether1 upstream=yes
add interface=bridge
/system clock
set time-zone-name=Europe/Moscow
/system leds
add interface=ppp-out1 leds=user-led type=interface-activity
/system scheduler
add interval=3m name=failover3g on-event="/system script run failover3g" \
    policy=read,write,policy,test start-date=jan/06/2020 start-time=09:28:28
/system script
add dont-require-permissions=no name=failover3g owner=redgy92 policy=\
    read,write,policy,test source=":local gwdhcp [/ip dhcp-client get numbe\
    r=0 gateway]\r\
    \n\r\
    \n#Check gateway\r\
    \n:local gw1 [/ip route get value-name=gateway [find dst-address=8.8.4.\
    4/32]]\r\
    \n:local gw2 [/ip route get value-name=gateway [find dst-address=78.88.\
    8.1/32]]\r\
    \n:if (\$gwdhcp!=\$gw1 || \$gwdhcp!=\$gw2) do={\r\
    \n/log error \"Gateway is changed!\"\r\
    \n/ip route set [ /ip route find comment=\"Failover3g\" ] gateway=\$gwd\
    hcp\r\
    \n}\r\
    \n\r\
    \n#Check internet\r\
    \n:local gwdef [/ip route get [find comment=\"Failover-3g-default-route\
    \"] gateway]\r\
    \n:local checkip [/ping 8.8.4.4 count=5 interface=ether1]\r\
    \n:local checkip2 [/ping 78.88.8.1 count=5 interface=ether1]\r\
    \n:if (checkip = 0 && checkip2 = 0) do={\r\
    \n:if (\$gwdef!=\"ppp-out1\") do={\r\
    \n/log warning \"Change to 3g-modem\"\r\
    \n/ip route set [ /ip route find comment=\"Failover-3g-default-route\" \
    ] gateway=ppp-out1\r\
    \n}\r\
    \n} else={\r\
    \n:if (\$gwdef!=\$gwdhcp) do={\r\
    \n/log warning \"Change to beeline\"\r\
    \n/ip route set [ /ip route find comment=\"Failover-3g-default-route\" \
    ] gateway=\$gwdhcp\r\
    \n}\r\
    \n}\r\
    \n"
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас