 Ni©olas

MikroTik RB/MRTG (miniROUTERG). Часть 2

Рекомендованные сообщения

/ip route

add distance=1 dst-address=194.186.70.218/32 gateway=10.44.144.1

add distance=1 dst-address=194.186.70.222/32 gateway=10.44.144.1

действительно... вечером проверю

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

после того как настроил пропал доступ к форуму )))) отправляю сообщение через тплинк....

добавил четыре маршрута по аналогии

/ip route

add distance=1 dst-address=194.186.ХХ.ХХХ/32 gateway=10.2.ХХХ.Х

днс адреса подсмотрел на работающем тплинке

вначале микротик начал пинговать билайн, потом определять адреса по именам "левых" сайтов, потом только на них пробиваться и т.д. в итоге минут через 10 борьбы с l2tp и настройками на компьютере стали пинговаться сайты и еще чуть чуть потом открываться.

Про логику в час ночи уже не верю, главное заработало.

В итоге три бриджа, LANы изолированные

bridge-WAN:

ether1-WAN

ether10-IPTV

 

bridge-LANх без dhcp:

ether2-хх

ether3-хх

 

bridge-LANy +dhcp:

ether6-yy

ether7-yy

ether8-yy

ether9-yy

wlan1

 

в резерве:

ether4

ether5

Хорошая железка, но какая же вредная

Всем спасибо за советы

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Помогите настроить. Не пойму, что не так...

Имеем rb951ui-2hnd

Вставляю интернетовский кабель в первый порт.

И начинаю пробовать всякие инструкции по настройке.

Вот последний гайд, который пробовал.

http://homenet.beeline.ru/index.php?showtopic=252615&st=180&p=1065169593entry1065169593

 

Главное с другими роутерами инет робит, а вот микротиком не могу запустить.

Ещё вопрос, могут ли отличаться настройки, если у меня подключен статический айпи.

 

Забыл указать

Версия прошивки: 6.36

Дефолтная конфига

 

маршруты все добавлены, вот только l2tp соединение пишет: server terminating или как-то так, типа не может соединится. Причём бывает так, что делаю хард ресет, настраиваю, вроде как заработает(через раз), потом перезагружаю и усё, не может зацепится.

 

Ещё вопрос, могут ли отличаться настройки, если у меня подключен статический айпи?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@bernard17, настройки одинаковые: что для динамического, что для статического ip-адреса. указанный способ настройки для l2tp вроде как работал ранее. сейчас я вам не помогу (работает или нет), так как у меня другой способ подключения.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

на 951ом с пропиской как и на 2011 всех днс~ов нормально заработало лишь после установки max-mru=1414 и max-mtu=1454

половина сайтов не открывались

это Краснодар...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Микротик разрывает соединение каждые 3 часа

 

 

13:02:50 wireless,info 7C:F9:0E:59:90:49@wlan1: connected 
13:20:44 l2tp,ppp,info Beeline: terminating... 
13:20:44 l2tp,ppp,info Beeline: disconnected 
13:20:44 l2tp,ppp,info Beeline: initializing... 
13:20:44 l2tp,ppp,info Beeline: connecting... 
13:20:44 l2tp,ppp,info Beeline: terminating... - session closed 
13:20:44 l2tp,ppp,info Beeline: disconnected 
13:20:44 l2tp,ppp,info Beeline: initializing... 
13:20:44 l2tp,ppp,info Beeline: connecting... 
13:20:44 l2tp,ppp,info Beeline: terminating... - session closed 
13:20:44 l2tp,ppp,info Beeline: disconnected 
13:20:44 l2tp,ppp,info Beeline: initializing... 
13:20:44 l2tp,ppp,info Beeline: connecting... 
13:20:44 l2tp,ppp,info Beeline: terminating... - session closed 
13:20:44 l2tp,ppp,info Beeline: disconnected 
13:20:45 l2tp,ppp,info Beeline: initializing... 
13:20:45 l2tp,ppp,info Beeline: connecting... 
13:20:45 l2tp,ppp,info Beeline: terminating... - session closed 
13:20:45 l2tp,ppp,info Beeline: disconnected 
13:20:46 l2tp,ppp,info Beeline: initializing... 
13:20:46 l2tp,ppp,info Beeline: connecting... 
13:20:47 l2tp,ppp,info Beeline: authenticated 
13:20:47 l2tp,ppp,info Beeline: connected 
14:15:35 wireless,info C8:3A:35:C4:19:63@wlan1: connected 
14:15:36 dhcp,info defconf assigned 192.168.1.242 to C8:3A:35:C4:19:63 
14:16:30 wireless,info C8:3A:35:C4:19:63@wlan1: disconnected, extensive data loss 
14:25:36 dhcp,info defconf deassigned 192.168.1.242 from C8:3A:35:C4:19:63 
16:20:46 l2tp,ppp,info Beeline: terminating... - session closed 
16:20:46 l2tp,ppp,info Beeline: disconnected 
16:20:46 l2tp,ppp,info Beeline: initializing... 
16:20:46 l2tp,ppp,info Beeline: connecting... 
16:20:46 l2tp,ppp,info Beeline: terminating... - session closed 
16:20:46 l2tp,ppp,info Beeline: disconnected 
16:20:46 l2tp,ppp,info Beeline: initializing... 
16:20:46 l2tp,ppp,info Beeline: connecting... 
16:20:46 l2tp,ppp,info Beeline: terminating... - session closed 
16:20:46 l2tp,ppp,info Beeline: disconnected 
16:20:46 l2tp,ppp,info Beeline: initializing... 
16:20:46 l2tp,ppp,info Beeline: connecting... 
16:20:46 l2tp,ppp,info Beeline: terminating... - session closed 
16:20:46 l2tp,ppp,info Beeline: disconnected 
16:20:47 l2tp,ppp,info Beeline: initializing... 
16:20:47 l2tp,ppp,info Beeline: connecting... 
16:20:47 l2tp,ppp,info Beeline: terminating... - failed to authenticate ourselves 
to peer 
16:20:47 l2tp,ppp,info Beeline: disconnected 
16:20:49 l2tp,ppp,info Beeline: initializing... 
16:20:49 l2tp,ppp,info Beeline: connecting... 
16:20:49 l2tp,ppp,info Beeline: terminating... - session closed 
16:20:49 l2tp,ppp,info Beeline: disconnected 
16:20:52 l2tp,ppp,info Beeline: initializing... 
16:20:52 l2tp,ppp,info Beeline: connecting... 
16:21:00 l2tp,ppp,info Beeline: authenticated 
16:21:00 l2tp,ppp,info Beeline: connected 
17:06:05 wireless,info 74:E2:8C:DD:71:88@wlan1: connected 

 

Изменено пользователем  Ni©olas
Добавил spoiler

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@egorov.nv, держится ли коннект при прямом подключении (без тика)?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вроде да (в 7-20 разрыва не было при подключении на прямую)

 

 

# sep/14/2016 11:33:04 by RouterOS 6.36.3
# software id = E35W-PSP7
#
/interface bridge
add admin-mac=***** auto-mac=no comment=defconf name=bridge
add name=iptv
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
   country=russia disabled=no distance=indoors frequency=auto mode=ap-bridge \
   ssid=158 wireless-protocol=802.11
/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master
/ip neighbor discovery
set ether1-gateway discover=no
set bridge comment=defconf
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
   dynamic-keys wpa-pre-shared-key=***** wpa2-pre-shared-key=*****
/ip pool
add name=dhcp ranges=192.168.1.10-192.168.1.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/ppp profile
add change-tcp-mss=no name=Beeline remote-address=192.168.255.254 \
   use-compression=no use-encryption=no
/interface l2tp-client
add add-default-route=yes allow=chap connect-to=10.255.255.240 disabled=no \
   max-mru=1500 max-mtu=1460 name=Beeline password=***** profile=Beeline \
   user=*****
/interface bridge port
add bridge=bridge comment=defconf interface=ether2-master
add bridge=bridge comment=defconf interface=wlan1
add bridge=iptv interface=ether5
add bridge=iptv interface=ether4
add bridge=iptv interface=ether1-gateway
add bridge=bridge interface=ether3
/ip address
add address=192.168.1.1/24 comment=defconf interface=ether2-master network=\
   192.168.1.0
/ip dhcp-client
add comment=defconf default-route-distance=10 dhcp-options=hostname,clientid \
   disabled=no interface=iptv
/ip dhcp-server network
add address=192.168.1.0/24 comment=defconf gateway=192.168.1.1 netmask=24
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip dns static
add address=192.168.1.1 name=router
/ip firewall filter
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept established,related" \
   connection-state=established,related
add action=drop chain=input comment="defconf: drop all from WAN" in-interface=\
   iptv
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
   connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related" \
   connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" connection-state=\
   invalid
add action=drop chain=forward comment=\
   "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
   connection-state=new in-interface=iptv
/ip firewall mangle
add action=change-mss chain=forward in-interface=Beeline new-mss=1416 protocol=\
   tcp tcp-flags=syn tcp-mss=1417-65535
add action=change-mss chain=forward new-mss=1416 out-interface=Beeline \
   protocol=tcp tcp-flags=syn tcp-mss=1417-65535
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" out-interface=\
   iptv
add action=masquerade chain=srcnat out-interface=Beeline
add action=dst-nat chain=dstnat dst-port=21 protocol=tcp to-addresses=\
   192.168.1.15 to-ports=21
/ip route
add comment="Beeline VPN server subnet" distance=1 dst-address=10.255.255.0/24 \
   gateway=10.26.208.1
add comment="Beeline DNS server subnet" distance=1 dst-address=78.107.196.0/22 \
   gateway=10.26.208.1
add comment="Beeline DNS server subnet" distance=1 dst-address=194.186.70.0/24 \
   gateway=10.26.208.1
/ip service
set telnet address=192.168.1.0/24
set ftp disabled=yes
set ssh address=192.168.1.0/24
/ip upnp
set enabled=yes
/system clock
set time-zone-autodetect=no time-zone-name=Asia/Beirut
/system clock manual
set dst-delta=+03:00 time-zone=+03:00
/system routerboard settings
set init-delay=0s
/system scheduler
add interval=3h name=ddns on-event="/system script run ddns" policy=read,write \
   start-date=sep/13/2016 start-time=10:22:00
/system script
add name=ddns owner=admin policy=read,write,test source="# No-IP automatic Dynam\
   ic DNS update\
   \n\
   \n#--------------- Change Values in this section to match your setup -------\
   -----------\
   \n\
   \n# No-IP User account info\
   \n:local noipuser \"*****\"\
   \n:local noippass \"*****\"\
   \n\
   \n# Set the hostname or label of network to be updated.\
   \n# Hostnames with spaces are unsupported. Replace the value in the quotatio\
   ns below with your host names.\
   \n# To specify multiple hosts, separate them with commas.\
   \n:local noiphost \"*****\"\
   \n\
   \n# Change to the name of interface that gets the dynamic IP address\
   \n:local inetinterface \"Beeline\"\
   \n\
   \n#-------------------------------------------------------------------------\
   -----------\
   \n# No more changes need\
   \n\
   \n:global previousIP\
   \n\
   \n:if ([/interface get \$inetinterface value-name=running]) do={\
   \n# Get the current IP on the interface\
   \n   :local currentIP [/ip address get [find interface=\"\$inetinterface\" d\
   isabled=no] address]\
   \n\
   \n# Strip the net mask off the IP address\
   \n   :for i from=( [:len \$currentIP] - 1) to=0 do={\
   \n       :if ( [:pick \$currentIP \$i] = \"/\") do={ \
   \n           :set currentIP [:pick \$currentIP 0 \$i]\
   \n       } \
   \n   }\
   \n\
   \n   :if (\$currentIP != \$previousIP) do={\
   \n       :log info \"No-IP: Current IP \$currentIP is not equal to previous \
   IP, update needed\"\
   \n       :set previousIP \$currentIP\
   \n\
   \n# The update URL. Note the \"\\3F\" is hex for question mark (\?). Require\
   d since \? is a special character in commands.\
   \n       :local url \"http://dynupdate.no-ip.com/nic/update\\3Fmyip=\$curren\
   tIP\"\
   \n       :local noiphostarray\
   \n       :set noiphostarray [:toarray \$noiphost]\
   \n       :foreach host in=\$noiphostarray do={\
   \n           :log info \"No-IP: Sending update for \$host\"\
   \n           /tool fetch url=(\$url . \"&hostname=\$host\") user=\$noipuser \
   password=\$noippass mode=http dst-path=(\"no-ip_ddns_update-\" . \$host . \"\
   .txt\")\
   \n           :log info \"No-IP: Host \$host updated on No-IP with IP \$curre\
   ntIP\"\
   \n       }\
   \n   }  else={\
   \n       :log info \"No-IP: Previous IP \$previousIP is equal to current IP,\
   \_no update needed\"\
   \n   }\
   \n} else={\
   \n   :log info \"No-IP: \$inetinterface is not currently running, so therefo\
   re will not update.\"\
   \n}"
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=bridge
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=bridge

 

 

скрипт добавлен позже, без скрипта тоже разрыв каждые 3 часа

Изменено пользователем  Ni©olas
Добавил spoiler

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@egorov.nv, скрипт не влияет на продолжительность коннекта. провод билайна приходит в тик напрямую, или через что-то (инжектор, свитч)?было бы не лишним, позвонить на 2-ю линию тп билайна, пообщаться с сетевым инженером на тему поиска ошибок на вашем порту (на провайдерском коммутаторе).

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@egorov.nv, скрипт не влияет на продолжительность коннекта. провод билайна приходит в тик напрямую, или через что-то (инжектор, свитч)?было бы не лишним, позвонить на 2-ю линию тп билайна, пообщаться с сетевым инженером на тему поиска ошибок на вашем порту (на провайдерском коммутаторе).

1. В щитке (откуда приходит кабель) оборудования нет.

2. Микротик не поддерживается билайном, поэтому ошибки они искать не будут.

 

Попробую поставить билайновский дир 300, посмотрю что с коннектом.

 

P.S.

Может все таки в микротике дело? Настраивал методом copy->paste.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@egorov.nv, оборудование у билайна или в подвале или на крыше, в зависимости от дома. при звонке инженерам не говорит, что у вас микротик. для того, чтоб понять в чем дело, надо точно знать, что нет сетевой проблемы. были случаи, что на порту у билайна были ошибки, и после замены порта у пользователя все становилось хорошо с коннектом. комп - не показатель. а вот другой роутер - да, возможно картина повторится.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Похоже дело в настройках микротика, билайновский дир 300 не рвет соединение через 3 часа.

Подскажите какие настройки микротика смотреть?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@egorov.nv, все известные настройки для работы билайновского инета тут. может что с портом ether1 (wan-портом) на вашем девайсе? попробуйте wan-портом назначить, например, ether2, переделав настройки для этого порта.

 

зачем вам гугловский днс?

---------------------------------------------------

к описанному ранее способу обхода блокировок сайтов можно добавить мини-автоматизацию добавления адресов в адрес-лист:

 

 

/ip firewall filter add action=add-src-to-address-list address-list=deblock address-list-timeout=3d chain=forward comment="add site v deblock list" content="Location: http://blackhole.beeline.ru/\?" in-interface=bridge_beeline log-prefix="" protocol=tcp src-port=80

 

при первом переходе по адресу заблоченного ресурса появится чёрная дыра блокировки билайна. при этом, роутер на 3 дня добавляет ip-адрес заблоченного ресурса в address-list=deblock . ну и в течении 3-х дней на ресурс можно попасть через настроенный ранее тунель для обхода блокировок. черная дыра не должна появляться.

 

спустя 3 дня, адрес удалится из address-list=deblock . при необходимости, адрес можно будет добавить еще раз/или изменить время, на которое помещается адрес в лист по своему вкусу.

 

 

p.s. fasttrack пришлось отключить. не работает у меня с ним маркировка трафика. (6.36)

Изменено пользователем  Ni©olas
  • Upvote 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@ Ni©olas, годный способ обхода блокировок. Вот тут можно почитать как получить vpn на халяву.

 

Подскажите какие настройки микротика смотреть?

Можно ради интереса включить дебаг логирование на l2tp, маловероятно что там будет подсказка к проблеме, но вдруг.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@ Ni©olas, годный способ обхода блокировок. Вот тут можно почитать как получить vpn на халяву.

 

Подскажите какие настройки микротика смотреть?

Можно ради интереса включить дебаг логирование на l2tp, маловероятно что там будет подсказка к проблеме, но вдруг.

лог разрыва

 

 

21:23:54 l2tp,debug,packet tunnel-id=4, session-id=0, ns=2, nr=183

21:24:54 l2tp,debug,packet sent control message to 10.255.255.240:1701 from 10.26.

209.114:1701

21:24:54 l2tp,debug,packet tunnel-id=60174, session-id=0, ns=183, nr=2

21:24:54 l2tp,debug,packet (M) Message-Type=HELLO

21:24:54 l2tp,debug,packet rcvd control message (ack) from 10.255.255.240:1701 to

10.26.209.114:1701

21:24:54 l2tp,debug,packet tunnel-id=4, session-id=0, ns=2, nr=184

21:24:56 l2tp,ppp,debug,packet Beeline: rcvd LCP TermReq id=0x41

21:24:56 l2tp,ppp,debug Beeline: LCP closed

21:24:56 l2tp,ppp,debug Beeline: CCP lowerdown

21:24:56 l2tp,ppp,debug Beeline: BCP lowerdown

21:24:56 l2tp,ppp,debug Beeline: BCP down event in starting state

21:24:56 l2tp,ppp,debug Beeline: IPCP lowerdown

21:24:56 l2tp,ppp,debug Beeline: IPCP closed

21:24:56 l2tp,ppp,debug Beeline: IPV6CP lowerdown

21:24:56 l2tp,ppp,debug Beeline: IPV6CP down event in starting state

21:24:56 l2tp,ppp,debug Beeline: MPLSCP lowerdown

21:24:56 l2tp,ppp,debug,packet Beeline: sent LCP TermAck id=0x41

21:24:56 l2tp,ppp,debug Beeline: LCP lowerdown

21:24:56 l2tp,ppp,info Beeline: terminating...

21:24:56 l2tp,debug,packet sent control message to 10.255.255.240:1701 from 10.26.

209.114:1701

21:24:56 l2tp,debug,packet tunnel-id=60174, session-id=28680, ns=184, nr=2

21:24:56 l2tp,debug,packet (M) Message-Type=CDN

21:24:56 l2tp,debug,packet (M) Result-Code=1

21:24:56 l2tp,debug,packet (M) Assigned-Session-ID=1

21:24:56 l2tp,debug session 1 entering state: stopping

21:24:57 l2tp,ppp,debug Beeline: LCP lowerdown

21:24:57 l2tp,ppp,debug Beeline: LCP down event in starting state

21:24:57 l2tp,ppp,info Beeline: disconnected

21:24:57 l2tp,debug,packet rcvd control message from 10.255.255.240:1701 to 10.26.

209.114:1701

21:24:57 l2tp,debug,packet tunnel-id=4, session-id=1, ns=2, nr=184

21:24:57 l2tp,debug,packet (M) Message-Type=CDN

21:24:57 l2tp,debug,packet (M) Assigned-Session-ID=28680

21:24:57 l2tp,debug,packet PPP-Disconnect-Cause-Code=0x00:01:00:00:00:53:65:73

:73:69:6f:6e:20:63:6c:65

21:24:57 l2tp,debug,packet 61:72:65:64:20:62:79:20:61:64:6d:69:6e:69:73:74

 

21:24:57 l2tp,debug,packet 72:61:74:6f:72

21:24:57 l2tp,debug,packet (M) Result-Code=3

21:24:57 l2tp,debug,packet Error-Code=0

21:24:57 l2tp,debug,packet Error-Message="Session cleared by administrator

"

21:24:57 l2tp,debug,packet sent control message (ack) to 10.255.255.240:1701 from

10.26.209.114:1701

21:24:57 l2tp,debug,packet tunnel-id=60174, session-id=0, ns=185, nr=3

21:24:57 l2tp,debug session 1 entering state: stopping

21:24:57 l2tp,debug session 1 entering state: dead

21:24:57 l2tp,debug tunnel 4 entering state: stopping

21:24:57 l2tp,debug,packet rcvd control message (ack) from 10.255.255.240:1701 to

10.26.209.114:1701

21:24:57 l2tp,debug,packet tunnel-id=4, session-id=0, ns=3, nr=185

21:24:57 l2tp,debug,packet sent control message to 10.255.255.240:1701 from 10.26.

209.114:1701

21:24:57 l2tp,debug,packet tunnel-id=60174, session-id=0, ns=185, nr=3

21:24:57 l2tp,debug,packet (M) Message-Type=StopCCN

21:24:57 l2tp,debug,packet (M) Result-Code=1

21:24:57 l2tp,debug,packet (M) Assigned-Tunnel-ID=4

21:24:57 l2tp,debug,packet rcvd control message (ack) from 10.255.255.240:1701 to

10.26.209.114:1701

21:24:57 l2tp,debug,packet tunnel-id=4, session-id=0, ns=3, nr=186

21:24:57 l2tp,debug tunnel 4 entering state: dead

21:24:57 l2tp,ppp,info Beeline: initializing...

21:24:57 l2tp,ppp,info Beeline: connecting...

21:24:57 l2tp,debug tunnel 5 entering state: wait-ctl-reply

21:24:57 l2tp,debug,packet sent control message to 10.255.255.240:1701 from 0.0.0.

0:1701

21:24:57 l2tp,debug,packet tunnel-id=0, session-id=0, ns=0, nr=0

21:24:57 l2tp,debug,packet (M) Message-Type=SCCRQ

21:24:57 l2tp,debug,packet (M) Protocol-Version=0x01:00

21:24:57 l2tp,debug,packet (M) Framing-Capabilities=0x1

21:24:57 l2tp,debug,packet (M) Bearer-Capabilities=0x0

21:24:57 l2tp,debug,packet Firmware-Revision=0x1

21:24:57 l2tp,debug,packet (M) Host-Name="MikroTik"

21:24:57 l2tp,debug,packet Vendor-Name="MikroTik"

21:24:57 l2tp,debug,packet (M) Assigned-Tunnel-ID=5

21:24:57 l2tp,debug,packet (M) Receive-Window-Size=4

21:24:57 l2tp,debug,packet rcvd control message from 10.255.255.240:1701 to 10.26.

209.114:1701

21:24:57 l2tp,debug,packet tunnel-id=5, session-id=0, ns=0, nr=0

21:24:57 l2tp,debug,packet (M) Message-Type=StopCCN

21:24:57 l2tp,debug,packet (M) Assigned-Tunnel-ID=37501

21:24:57 l2tp,debug,packet (M) Result-Code=1

21:24:57 l2tp,debug,packet Error-Code=0

21:24:57 l2tp,debug,packet Error-Message="Reached configured max-tunnels l

imit"

21:24:57 l2tp,debug,packet sent control message (ack) to 10.255.255.240:1701 from

10.26.209.114:1701

21:24:57 l2tp,debug,packet tunnel-id=37501, session-id=0, ns=0, nr=1

21:24:58 l2tp,debug,packet sent control message to 10.255.255.240:1701 from 0.0.0.

0:1701

21:24:58 l2tp,debug,packet tunnel-id=0, session-id=0, ns=0, nr=0

21:24:58 l2tp,debug,packet (M) Message-Type=SCCRQ

21:24:58 l2tp,debug,packet (M) Protocol-Version=0x01:00

21:24:58 l2tp,debug,packet (M) Framing-Capabilities=0x1

21:24:58 l2tp,debug,packet (M) Bearer-Capabilities=0x0

21:24:58 l2tp,debug,packet Firmware-Revision=0x1

21:24:58 l2tp,debug,packet (M) Host-Name="MikroTik"

21:24:58 l2tp,debug,packet Vendor-Name="MikroTik"

21:24:58 l2tp,debug,packet (M) Assigned-Tunnel-ID=5

21:24:58 l2tp,debug,packet (M) Receive-Window-Size=4

21:24:58 l2tp,debug,packet rcvd control message from 10.255.255.240:1701 to 10.26.

209.114:1701

21:24:58 l2tp,debug,packet tunnel-id=5, session-id=0, ns=0, nr=0

21:24:58 l2tp,debug,packet (M) Message-Type=StopCCN

21:24:58 l2tp,debug,packet (M) Assigned-Tunnel-ID=37509

21:24:58 l2tp,debug,packet (M) Result-Code=1

21:24:58 l2tp,debug,packet Error-Code=0

21:24:58 l2tp,debug,packet Error-Message="Reached configured max-tunnels l

imit"

21:24:58 l2tp,debug,packet sent control message (ack) to 10.255.255.240:1701 from

10.26.209.114:1701

21:24:58 l2tp,debug,packet tunnel-id=37509, session-id=0, ns=0, nr=1

21:24:59 l2tp,debug,packet sent control message to 10.255.255.240:1701 from 0.0.0.

0:1701

21:24:59 l2tp,debug,packet tunnel-id=0, session-id=0, ns=0, nr=0

21:24:59 l2tp,debug,packet (M) Message-Type=SCCRQ

21:24:59 l2tp,debug,packet (M) Protocol-Version=0x01:00

21:24:59 l2tp,debug,packet (M) Framing-Capabilities=0x1

21:24:59 l2tp,debug,packet (M) Bearer-Capabilities=0x0

21:24:59 l2tp,debug,packet Firmware-Revision=0x1

21:24:59 l2tp,debug,packet (M) Host-Name="MikroTik"

21:24:59 l2tp,debug,packet Vendor-Name="MikroTik"

21:24:59 l2tp,debug,packet (M) Assigned-Tunnel-ID=5

21:24:59 l2tp,debug,packet (M) Receive-Window-Size=4

21:24:59 l2tp,debug,packet rcvd control message from 10.255.255.240:1701 to 10.26.

209.114:1701

21:24:59 l2tp,debug,packet tunnel-id=5, session-id=0, ns=0, nr=0

21:24:59 l2tp,debug,packet (M) Message-Type=StopCCN

21:24:59 l2tp,debug,packet (M) Assigned-Tunnel-ID=37518

21:24:59 l2tp,debug,packet (M) Result-Code=1

21:24:59 l2tp,debug,packet Error-Code=0

21:24:59 l2tp,debug,packet Error-Message="Reached configured max-tunnels l

imit"

21:24:59 l2tp,debug,packet sent control message (ack) to 10.255.255.240:1701 from

10.26.209.114:1701

21:24:59 l2tp,debug,packet tunnel-id=37518, session-id=0, ns=0, nr=1

21:25:01 l2tp,debug,packet sent control message to 10.255.255.240:1701 from 0.0.0.

0:1701

21:25:01 l2tp,debug,packet tunnel-id=0, session-id=0, ns=0, nr=0

21:25:01 l2tp,debug,packet (M) Message-Type=SCCRQ

21:25:01 l2tp,debug,packet (M) Protocol-Version=0x01:00

21:25:01 l2tp,debug,packet (M) Framing-Capabilities=0x1

21:25:01 l2tp,debug,packet (M) Bearer-Capabilities=0x0

21:25:01 l2tp,debug,packet Firmware-Revision=0x1

21:25:01 l2tp,debug,packet (M) Host-Name="MikroTik"

21:25:01 l2tp,debug,packet Vendor-Name="MikroTik"

21:25:01 l2tp,debug,packet (M) Assigned-Tunnel-ID=5

21:25:01 l2tp,debug,packet (M) Receive-Window-Size=4

21:25:01 l2tp,debug,packet rcvd control message (ack) from 10.255.255.240:1701 to

10.26.209.114:1701

21:25:01 l2tp,debug,packet tunnel-id=5, session-id=0, ns=0, nr=1

21:25:02 l2tp,debug,packet rcvd control message from 10.255.255.240:1701 to 10.26.

209.114:1701

21:25:02 l2tp,debug,packet tunnel-id=5, session-id=0, ns=0, nr=1

21:25:02 l2tp,debug,packet (M) Message-Type=SCCRP

21:25:02 l2tp,debug,packet (M) Protocol-Version=0x01:00

21:25:02 l2tp,debug,packet (M) Framing-Capabilities=0x3

21:25:02 l2tp,debug,packet 46(vendor-id=2352)=0x00:00:00:08

21:25:02 l2tp,debug,packet (M) Bearer-Capabilities=0x0

21:25:02 l2tp,debug,packet Firmware-Revision=0x600

21:25:02 l2tp,debug,packet (M) Host-Name="vpn250.krasnodar"

21:25:02 l2tp,debug,packet Vendor-Name="RedBack Networks"

21:25:02 l2tp,debug,packet (M) Assigned-Tunnel-ID=37533

21:25:02 l2tp,debug,packet (M) Receive-Window-Size=8

21:25:02 l2tp,debug tunnel 5 entering state: established

21:25:02 l2tp,debug,packet sent control message to 10.255.255.240:1701 from 10.26.

209.114:1701

21:25:02 l2tp,debug,packet tunnel-id=37533, session-id=0, ns=1, nr=1

21:25:02 l2tp,debug,packet (M) Message-Type=SCCCN

21:25:02 l2tp,debug session 1 entering state: wait-reply

21:25:02 l2tp,debug,packet rcvd control message (ack) from 10.255.255.240:1701 to

10.26.209.114:1701

21:25:02 l2tp,debug,packet tunnel-id=5, session-id=0, ns=1, nr=2

21:25:02 l2tp,debug,packet sent control message to 10.255.255.240:1701 from 10.26.

209.114:1701

21:25:02 l2tp,debug,packet tunnel-id=37533, session-id=0, ns=2, nr=1

21:25:02 l2tp,debug,packet (M) Message-Type=ICRQ

21:25:02 l2tp,debug,packet (M) Assigned-Session-ID=1

21:25:02 l2tp,debug,packet (M) Call-Serial-Number=7

21:25:02 l2tp,debug,packet (M) Bearer-Type=0x0

21:25:02 l2tp,debug,packet rcvd control message (ack) from 10.255.255.240:1701 to

10.26.209.114:1701

21:25:02 l2tp,debug,packet tunnel-id=5, session-id=0, ns=1, nr=3

21:25:02 l2tp,debug,packet rcvd control message from 10.255.255.240:1701 to 10.26.

209.114:1701

21:25:02 l2tp,debug,packet tunnel-id=5, session-id=1, ns=1, nr=3

21:25:02 l2tp,debug,packet (M) Message-Type=ICRP

21:25:02 l2tp,debug,packet (M) Assigned-Session-ID=27177

21:25:02 l2tp,debug session 1 entering state: established

21:25:02 l2tp,debug,packet sent control message to 10.255.255.240:1701 from 10.26.

209.114:1701

21:25:02 l2tp,debug,packet tunnel-id=37533, session-id=27177, ns=3, nr=2

21:25:02 l2tp,debug,packet (M) Message-Type=ICCN

21:25:02 l2tp,debug,packet (M) Framing-Type=0x1

21:25:02 l2tp,debug,packet (M) Tx-Connect-Speed-BPS=100000000

21:25:02 l2tp,debug,packet rcvd control message (ack) from 10.255.255.240:1701 to

10.26.209.114:1701

21:25:02 l2tp,debug,packet tunnel-id=5, session-id=0, ns=2, nr=4

21:25:02 l2tp,ppp,debug Beeline: LCP lowerup

21:25:02 l2tp,ppp,debug,packet Beeline: sent LCP ConfReq id=0x4

21:25:02 l2tp,ppp,debug,packet <magic 0x4d7f3103>

21:25:02 l2tp,ppp,debug Beeline: LCP open

21:25:02 l2tp,ppp,debug,packet Beeline: rcvd LCP ConfAck id=0x4

21:25:02 l2tp,ppp,debug,packet <magic 0x4d7f3103>

21:25:03 l2tp,ppp,debug Beeline: LCP timer

21:25:03 l2tp,ppp,debug,packet Beeline: sent LCP ConfReq id=0x5

21:25:03 l2tp,ppp,debug,packet <magic 0x4d7f3103>

21:25:03 l2tp,ppp,debug,packet Beeline: rcvd LCP ConfAck id=0x5

21:25:03 l2tp,ppp,debug,packet <magic 0x4d7f3103>

21:25:05 l2tp,ppp,debug Beeline: LCP timer

21:25:05 l2tp,ppp,debug,packet Beeline: sent LCP ConfReq id=0x6

21:25:05 l2tp,ppp,debug,packet <magic 0x4d7f3103>

21:25:05 l2tp,ppp,debug,packet Beeline: rcvd LCP ConfAck id=0x6

21:25:05 l2tp,ppp,debug,packet <magic 0x4d7f3103>

21:25:05 l2tp,ppp,debug,packet Beeline: rcvd LCP ConfReq id=0x6f

21:25:05 l2tp,ppp,debug,packet <mru 1456>

21:25:05 l2tp,ppp,debug,packet <magic 0x441d84>

21:25:05 l2tp,ppp,debug,packet <auth chap>

21:25:05 l2tp,ppp,debug,packet Beeline: sent LCP ConfAck id=0x6f

21:25:05 l2tp,ppp,debug,packet <mru 1456>

21:25:05 l2tp,ppp,debug,packet <magic 0x441d84>

21:25:05 l2tp,ppp,debug,packet <auth chap>

21:25:05 l2tp,ppp,debug Beeline: LCP opened

21:25:05 l2tp,ppp,debug,packet Beeline: rcvd CHAP Challenge id=0x1

21:25:05 l2tp,ppp,debug,packet <challenge len=16>

21:25:05 l2tp,ppp,debug,packet <name vpn250.krasnodar>

21:25:05 l2tp,ppp,debug,packet Beeline: sent CHAP Response id=0x1

21:25:05 l2tp,ppp,debug,packet <response len=16>

21:25:05 l2tp,ppp,debug,packet <name 0897076668>

21:25:05 l2tp,ppp,debug,packet Beeline: rcvd CHAP Success id=0x1

21:25:05 l2tp,ppp,debug,packet CHAP authentication success, unit 210

21:25:05 l2tp,ppp,info Beeline: authenticated

21:25:05 l2tp,ppp,debug Beeline: IPCP lowerup

21:25:05 l2tp,ppp,debug,packet Beeline: sent IPCP ConfReq id=0x7

21:25:05 l2tp,ppp,debug,packet <addr 0.0.0.0>

21:25:05 l2tp,ppp,debug Beeline: IPCP open

21:25:05 l2tp,ppp,debug Beeline: IPV6CP open

21:25:05 l2tp,ppp,debug Beeline: MPLSCP lowerup

21:25:05 l2tp,ppp,debug,packet Beeline: sent MPLSCP ConfReq id=0x1f

21:25:05 l2tp,ppp,debug Beeline: MPLSCP open

21:25:05 l2tp,ppp,debug Beeline: BCP open

21:25:05 l2tp,ppp,debug Beeline: CCP lowerup

21:25:05 l2tp,ppp,debug Beeline: CCP open

21:25:05 l2tp,ppp,debug,packet Beeline: rcvd IPCP ConfReq id=0xfd

21:25:05 l2tp,ppp,debug,packet <addr 95.30.0.1>

21:25:05 l2tp,ppp,debug,packet Beeline: sent IPCP ConfNak id=0xfd

21:25:05 l2tp,ppp,debug,packet <addr 192.168.255.254>

21:25:05 l2tp,ppp,debug,packet Beeline: rcvd IPCP ConfNak id=0x7

21:25:05 l2tp,ppp,debug,packet <addr 95.30.50.176>

21:25:05 l2tp,ppp,debug,packet Beeline: sent IPCP ConfReq id=0x8

21:25:05 l2tp,ppp,debug,packet <addr 95.30.50.176>

21:25:05 l2tp,ppp,debug,packet Beeline: rcvd IPCP ConfReq id=0xfe

21:25:05 l2tp,ppp,debug,packet <addr 95.30.0.1>

21:25:05 l2tp,ppp,debug,packet Beeline: sent IPCP ConfNak id=0xfe

21:25:05 l2tp,ppp,debug,packet <addr 192.168.255.254>

21:25:05 l2tp,ppp,debug,packet Beeline: rcvd IPCP ConfAck id=0x8

21:25:05 l2tp,ppp,debug,packet <addr 95.30.50.176>

21:25:05 l2tp,ppp,debug,packet Beeline: rcvd IPCP ConfReq id=0xff

21:25:05 l2tp,ppp,debug,packet <addr 95.30.0.1>

21:25:05 l2tp,ppp,debug,packet Beeline: sent IPCP ConfNak id=0xff

21:25:05 l2tp,ppp,debug,packet <addr 192.168.255.254>

21:25:05 l2tp,ppp,debug,packet Beeline: rcvd IPCP ConfReq id=0x0

21:25:05 l2tp,ppp,debug,packet <addr 95.30.0.1>

21:25:05 l2tp,ppp,debug,packet Beeline: sent IPCP ConfNak id=0x0

21:25:05 l2tp,ppp,debug,packet <addr 192.168.255.254>

21:25:05 l2tp,ppp,debug,packet Beeline: rcvd IPCP ConfReq id=0x1

21:25:05 l2tp,ppp,debug,packet <addr 95.30.0.1>

21:25:05 l2tp,ppp,debug,packet Beeline: sent IPCP ConfNak id=0x1

21:25:05 l2tp,ppp,debug,packet <addr 192.168.255.254>

21:25:05 l2tp,ppp,debug,packet Beeline: rcvd IPCP ConfReq id=0x2

21:25:05 l2tp,ppp,debug,packet <addr 95.30.0.1>

21:25:05 l2tp,ppp,debug,packet Beeline: sent IPCP ConfRej id=0x2

21:25:05 l2tp,ppp,debug,packet <addr 95.30.0.1>

21:25:05 l2tp,ppp,debug,packet Beeline: rcvd IPCP ConfReq id=0x3

21:25:05 l2tp,ppp,debug,packet Beeline: sent IPCP ConfAck id=0x3

21:25:05 l2tp,ppp,debug Beeline: IPCP opened

21:25:05 l2tp,ppp,info Beeline: connected

21:26:02 l2tp,debug,packet sent control message to 10.255.255.240:1701 from 10.26.

209.114:1701

21:26:02 l2tp,debug,packet tunnel-id=37533, session-id=0, ns=4, nr=2

21:26:02 l2tp,debug,packet (M) Message-Type=HELLO

21:26:02 l2tp,debug,packet rcvd control message (ack) from 10.255.255.240:1701 to

10.26.209.114:1701

21:26:02 l2tp,debug,packet tunnel-id=5, session-id=0, ns=2, nr=5

21:27:02 l2tp,debug,packet sent control message to 10.255.255.240:1701 from 10.26.

209.114:1701

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

21:24:56 l2tp,ppp,debug,packet Beeline: rcvd LCP TermReq id=0x41 

21:24:56 l2tp,ppp,debug,packet Beeline: sent LCP TermAck id=0x41 

Получили запрос на пришибание туннеля со стороны билайна, отправили что согласны. Или я как то криво это интерпретирую? ИМХО стоит это вывалить в разделе общее обсуждение в У Вас есть проблемы с интернетом?.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Как протокол mschap2 может влиять длительность ссесси?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

mschap2 - это протокол авторизации. если данные авторизации валидны - туннель (сессия) поднимается. интересно, почему после успешной авторизации билайн кладёт туннель.

может из-за того, что у вас в конфиге прописан адрес сервера, а не его днс-имя?

/interface l2tp-client
add add-default-route=yes allow=chap connect-to=10.255.255.240 disabled=no \
   max-mru=1500 max-mtu=1460 name=Beeline password=***** profile=Beeline \
   user=*****

что если прописать tp.internet.beeline.ru вместо 10.255.255.240

Изменено пользователем  Ni©olas

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

mschap2 - это протокол авторизации. если данные авторизации валидны - туннель (сессия) поднимается. интересно, почему после успешной авторизации билайн кладёт туннель.

может из-за того, что у вас в конфиге прописан адрес сервера, а не его днс-имя?

/interface l2tp-client
add add-default-route=yes allow=chap connect-to=10.255.255.240 disabled=no \
   max-mru=1500 max-mtu=1460 name=Beeline password=***** profile=Beeline \
   user=*****

что если прописать tp.internet.beeline.ru вместо 10.255.255.240

прописал tp.internet.beeline.ru, включил mschap2 сессия уже 7 часов. ???

Изменено пользователем egorov.nv

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

я не знаю кухню билайна, как там у них сервера работают.

 

могу сделать предположение: роутер спустя 2 часа 59 минут принимает запрос-привет от сервера. но адрес сервера не 10.255.255.240, а какой-то другой, откликающийся на tp.internet.beeline.ru. так вот, этот другой сервер говорит привет, а сессия-то открыта! и он о ней ничего не знал. ну и пришибает ее от греха по дальше.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

я не знаю кухню билайна, как там у них сервера работают.

 

могу сделать предположение: роутер спустя 2 часа 59 минут принимает запрос-привет от сервера. но адрес сервера не 10.255.255.240, а какой-то другой, откликающийся на tp.internet.beeline.ru. так вот, этот другой сервер говорит привет, а сессия-то открыта! и он о ней ничего не знал. ну и пришибает ее от греха по дальше.

Изначально (недели 2 назад) по tp.internet.beeline.ru отказывался соединяться, соединялся только по IP. Сегодня смог соединиться по адресу.???

 

Вообщем проблема устранена. Всем спасибо за участие.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрый день, при базовой настройке возникает ошибка. Отсутствует интерфейс ether1-gateway. Версия RouterOs 6.34.3.

Как настроить, чтобы просто подключится?

 

[admin@MikroTik] > /interface l2tp-client
[admin@MikroTik] /interface l2tp-client> add add-default-route=yes allow=chap,mschap2 connect-to=tp.internet.beeline.ru disabled=no max-mru=1500 max-mtu=1460 name=Beeline password=xxx user=xxx
[admin@MikroTik] /interface l2tp-client> /ip dhcp-client
[admin@MikroTik] /ip dhcp-client> add default-route-distance=1 dhcp-options=hostname,clientid disabled=no interface=ether1-gateway
input does not match any value of interface
[admin@MikroTik] /ip dhcp-client> /ip firewall nat
[admin@MikroTik] /ip firewall nat> add action=masquerade chain=srcnat out-interface=Beeline

 

И еще один вопрос. Как роутер понимает, что l2tp клиента нужно подключать на первом порту? Можно ли этот WAN порт настроить на определенный порт и подключаться через него?

Проблема с ether1-gateway похоже решается просто его заменой на ether1

Изменено пользователем djpopkov

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

1) Не нужно просто копировать настройки, все что здесь так или иначе выкладывали - шаблоны. Я первый порт могу назвать хоть beeline-uplink, хоть как угодно.

2) Роутер руководствуется таблицей маршрутизации.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

1) Не нужно просто копировать настройки, все что здесь так или иначе выкладывали - шаблоны. Я первый порт могу назвать хоть beeline-uplink, хоть как угодно.

2) Роутер руководствуется таблицей маршрутизации.

Привет всем . Обращайтесь кому нужна помощь по настройке mikrotik . Помогу чем смогу . Стучите в skype t83oleg@mail.ru

☺ оперативность гарантирую

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

strator, ну ты сам вызвался)

Дано рб 750р3 с моей стороны, chr с удаленной стороны(digital ocean).

С моей стороны 2 провайдера, билайн и местячковый. В сторону DO поднято 2 EoIP туннеля, по одному на каждый внешний интерфейс. EoIP туннели собраны в bonding. Зеркально с другой стороны.

Трафик ходит через туннель, все как бы хорошо. Теперь внимание вопросы!)

1) Оба канала 100мбит, проверял просто как трафик ходит через EoIP - разгонялся под потолок. С бондингом 10-20мбит. Тестировал торрентами. Подозрение на то, что нужно подрезать mss дабы не фрагментировать пакеты. Помоги посчитать правильный mtu для EoiP и для bonding интерфейса. Считаем что через провайдеров пролазит 1500.

2) Правильно ли выбрал EoIP? Выбрал потому что можно собрать bonding из 2х EoIP интерфейсов, но может стоит как то иначе каналы агрегировать?

Конечный итог всех этих манипуляций - получить 200мбит торрентов через туннель до DO. Но не выходит каменный цветок((

 

 

 

/interface bonding

add mtu=1380 name=bonding-vpn slaves=eoip-tunnel-DO-bee,eoip-tunnel-DO-deg

 

/interface eoip

add allow-fast-path=no ipsec-secret= !keepalive local-address= mac-address=02:2C:50:59:F2:5C name=eoip-tunnel-DO-bee remote-address= tunnel-id=0

add allow-fast-path=no ipsec-secret= !keepalive local-address= mac-address=02:2C:50:59:F2:5C name=eoip-tunnel-DO-deg remote-address= tunnel-id=1

 

/ip route

add distance=1 gateway=192.168.87.1 routing-mark=server-traffic (адрес тика на DO на bonding интерфейсе)

 

/ip firewall mangle

add action=mark-routing chain=prerouting in-interface=bridge-local new-routing-mark=server-traffic passthrough=no src-address=192.168.88.7 (адрес машинки на которой скорость тестирую)

 

Конфиг с другой стороны зеркален, только без правил мангла.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

strator, ну ты сам вызвался)

Дано рб 750р3 с моей стороны, chr с удаленной стороны(digital ocean).

С моей стороны 2 провайдера, билайн и местячковый. В сторону DO поднято 2 EoIP туннеля, по одному на каждый внешний интерфейс. EoIP туннели собраны в bonding. Зеркально с другой стороны.

Трафик ходит через туннель, все как бы хорошо. Теперь внимание вопросы!)

1) Оба канала 100мбит, проверял просто как трафик ходит через EoIP - разгонялся под потолок. С бондингом 10-20мбит. Тестировал торрентами. Подозрение на то, что нужно подрезать mss дабы не фрагментировать пакеты. Помоги посчитать правильный mtu для EoiP и для bonding интерфейса. Считаем что через провайдеров пролазит 1500.

2) Правильно ли выбрал EoIP? Выбрал потому что можно собрать bonding из 2х EoIP интерфейсов, но может стоит как то иначе каналы агрегировать?

Конечный итог всех этих манипуляций - получить 200мбит торрентов через туннель до DO. Но не выходит каменный цветок((

 

 

 

/interface bonding

add mtu=1380 name=bonding-vpn slaves=eoip-tunnel-DO-bee,eoip-tunnel-DO-deg

 

/interface eoip

add allow-fast-path=no ipsec-secret= !keepalive local-address= mac-address=02:2C:50:59:F2:5C name=eoip-tunnel-DO-bee remote-address= tunnel-id=0

add allow-fast-path=no ipsec-secret= !keepalive local-address= mac-address=02:2C:50:59:F2:5C name=eoip-tunnel-DO-deg remote-address= tunnel-id=1

 

/ip route

add distance=1 gateway=192.168.87.1 routing-mark=server-traffic (адрес тика на DO на bonding интерфейсе)

 

/ip firewall mangle

add action=mark-routing chain=prerouting in-interface=bridge-local new-routing-mark=server-traffic passthrough=no src-address=192.168.88.7 (адрес машинки на которой скорость тестирую)

 

Конфиг с другой стороны зеркален, только без правил мангла.

 

 

стучи в скайп :-)

 

Добрый день, при базовой настройке возникает ошибка. Отсутствует интерфейс ether1-gateway. Версия RouterOs 6.34.3.

Как настроить, чтобы просто подключится?

 

[admin@MikroTik] > /interface l2tp-client
[admin@MikroTik] /interface l2tp-client> add add-default-route=yes allow=chap,mschap2 connect-to=tp.internet.beeline.ru disabled=no max-mru=1500 max-mtu=1460 name=Beeline password=xxx user=xxx
[admin@MikroTik] /interface l2tp-client> /ip dhcp-client
[admin@MikroTik] /ip dhcp-client> add default-route-distance=1 dhcp-options=hostname,clientid disabled=no interface=ether1-gateway
input does not match any value of interface
[admin@MikroTik] /ip dhcp-client> /ip firewall nat
[admin@MikroTik] /ip firewall nat> add action=masquerade chain=srcnat out-interface=Beeline

 

И еще один вопрос. Как роутер понимает, что l2tp клиента нужно подключать на первом порту? Можно ли этот WAN порт настроить на определенный порт и подключаться через него?

Проблема с ether1-gateway похоже решается просто его заменой на ether1

чтобы такого типа багов не было рекомендую использовать release из bugfix выпусков они более стабильные . я до сих пор сижу на 6.32.4 и не парюсь если и с этим все работает даже с учетом что у меня Mikrotik HAP AC )))

 

Добрый день, при базовой настройке возникает ошибка. Отсутствует интерфейс ether1-gateway. Версия RouterOs 6.34.3.

Как настроить, чтобы просто подключится?

 

[admin@MikroTik] > /interface l2tp-client
[admin@MikroTik] /interface l2tp-client> add add-default-route=yes allow=chap,mschap2 connect-to=tp.internet.beeline.ru disabled=no max-mru=1500 max-mtu=1460 name=Beeline password=xxx user=xxx
[admin@MikroTik] /interface l2tp-client> /ip dhcp-client
[admin@MikroTik] /ip dhcp-client> add default-route-distance=1 dhcp-options=hostname,clientid disabled=no interface=ether1-gateway
input does not match any value of interface
[admin@MikroTik] /ip dhcp-client> /ip firewall nat
[admin@MikroTik] /ip firewall nat> add action=masquerade chain=srcnat out-interface=Beeline

 

И еще один вопрос. Как роутер понимает, что l2tp клиента нужно подключать на первом порту? Можно ли этот WAN порт настроить на определенный порт и подключаться через него?

Проблема с ether1-gateway похоже решается просто его заменой на ether1

можно .

 

я не знаю кухню билайна, как там у них сервера работают.

 

могу сделать предположение: роутер спустя 2 часа 59 минут принимает запрос-привет от сервера. но адрес сервера не 10.255.255.240, а какой-то другой, откликающийся на tp.internet.beeline.ru. так вот, этот другой сервер говорит привет, а сессия-то открыта! и он о ней ничего не знал. ну и пришибает ее от греха по дальше.

для этого в dhcp client нужно сменить distance с 1 на 2 и все будет норм

 

mschap2 - это протокол авторизации. если данные авторизации валидны - туннель (сессия) поднимается. интересно, почему после успешной авторизации билайн кладёт туннель.

может из-за того, что у вас в конфиге прописан адрес сервера, а не его днс-имя?

/interface l2tp-client
add add-default-route=yes allow=chap connect-to=10.255.255.240 disabled=no \
   max-mru=1500 max-mtu=1460 name=Beeline password=***** profile=Beeline \
   user=*****

что если прописать tp.internet.beeline.ru вместо 10.255.255.240

у билана была проблема с осени по весну ...некоторые сайты не открывались из за где то на линии поломанных днс ))))

про то что вы пишете после версии 6.30.4 уже можно писать tp.internet.beeline.ru / до этого я скриптом делал auto update l2tp ip он проверял каждую секунду адрес и в момент оваливания подменял было очень удобно особенно на версии 5.26 . и с этим же скриптом обновлялся до 6... но потом решил пробывать на версии 6.30.4 просто прописал tp... логин пароль , поставил галку в add default route . поставил в dhcp client distance 2 и для l2tp открыл в firewall . ну и в wifi security / в ip services разрешил только из под сети 192.168.88.0/24 и наче брутфорсом какая нить сволочь завалится )))

Изменено пользователем strator

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

в WinBox 3.7 для hEX 3 пропал (а может его и не было и вовсе) пункт switch, хотя он вроде есть в выхлопе

 

 

interface ethernet switch print 
Flags: I - invalid 
#   NAME                           TYPE             MIRROR-SOURCE                         MIRROR-TARGET                         SWITCH-ALL-PORTS
0   switch1                        MediaTek-MT7621  none                                  none                                 

 

 

 

а также, нет моста в дефолтной конфигурации

 

 

interface bridge print 
Flags: X - disabled, R - running 

 

 

 

в hEX 2 вроде были...

Изменено пользователем  Ni©olas

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

в WinBox 3.7 для hEX 3 пропал (а может его и не было и вовсе) пункт switch, хотя он вроде есть в выхлопе

 

 

interface ethernet switch print 
Flags: I - invalid 
#   NAME                           TYPE             MIRROR-SOURCE                         MIRROR-TARGET                         SWITCH-ALL-PORTS
0   switch1                        MediaTek-MT7621  none                                  none                                 

 

 

не в курсе . не могу сказать

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
в WinBox 3.7 для hEX 3 пропал

6cdfddfc8c0c5c7084d3009857affc13.jpeg

стучи в скайп :-)

так стучу) ник с форумным не софпадает

Изменено пользователем poisons

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас