 Ni©olas

MikroTik RB/MRTG (miniROUTERG). Часть 2

Рекомендованные сообщения

@xsb3, настроить тот профиль, который используется в настройках L2TP

 

 

2016-06-02_09-07-08.png

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрый вечер. А никто не сталкивался с такой проблемой, что роутер microtick не получает ip из сети Билайна?

У меня такая же проблема. Модель роутера Mikrotik hAP RB951Ui-2nD. Обратился в техподдержку билайн, где мне сказали, что ничем не могут помочь и послали сюда, на форум.

 

@pilot125, сталкивался один раз. были проблемы у провайдера в подвале с их коммутатором.

 

Какие действия мне надо предпринять, чтобы все-таки нормально подключился к сети?

Изменено пользователем Dredshad

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

Какие действия мне надо предпринять, чтобы все-таки нормально подключился к сети?

 

Первое, что необходимо сделать, это проверить работу сети Билайн на компьютере при прямом подключении (без роутера). т.е. получает ли комп адрес, если билайновский кабель подключен к сетевой карте компьютера.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

Какие действия мне надо предпринять, чтобы все-таки нормально подключился к сети?

 

Первое, что необходимо сделать, это проверить работу сети Билайн на компьютере при прямом подключении (без роутера). т.е. получает ли комп адрес, если билайновский кабель подключен к сетевой карте компьютера.

 

Спасибо за отклик. Да, все работает и напрямую и со старым модемом D-Link DIR-300 NRU B5. Микротик взял на замену D-Link. Возможно ли вручную произвести настройку Микротика?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Dredshad, какие настройки делали? покажите свой конфиг.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сегодня попробовал еще раз, и... О, чудо!!! Заработало! Роутер увидел сервера. Скорее всего проблема аппаратная. Попробую переобжать соединитель на кабеле. При открытии окна в браузере, Билайн предложил авторизоваться, что я и сделал. Единственное "но". Скорость по спидтесту вместо 40 Мбит - всего 10 Мбит. Буду искать причину такой "обрезки".

Конфиг привожу ниже.

 

 

# jun/07/2016 00:10:46 by RouterOS 6.35.2
# software id = H98N-S5LY
#
/interface bridge
add admin-mac=E4:8D:8C:E0:C9:E9 auto-mac=no comment=defconf name=bridge
/interface ethernet
set [ find default-name=ether2 ] name=ether2-master
set [ find default-name=ether3 ] master-port=ether2-master
set [ find default-name=ether4 ] master-port=ether2-master
set [ find default-name=ether5 ] master-port=ether2-master
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
   country=russia disabled=no distance=indoors frequency=auto mode=ap-bridge \
   ssid=krolik wireless-protocol=802.11
/interface l2tp-client
add add-default-route=yes allow=chap,mschap2 connect-to=\
   tp.internet.beeline.ru disabled=no max-mru=1500 max-mtu=1460 name=Beeline \
   password=ХХХ user=ХХХ
/ip neighbor discovery
set ether1 discover=no
set bridge comment=defconf
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
   dynamic-keys wpa-pre-shared-key=ХХХ wpa2-pre-shared-key=\
   ХХХ
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
#error exporting /tool user-manager customer
#error exporting /tool user-manager profile
#error exporting /tool user-manager profile limitation
/interface bridge port
add bridge=bridge comment=defconf interface=ether2-master
add bridge=bridge comment=defconf interface=wlan1
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2-master network=\
   192.168.88.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=\
   ether1
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1 netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add chain=input comment="defconf: accept ICMP" protocol=icmp
add chain=input comment="defconf: accept established,related" \
   connection-state=established,related
add action=drop chain=input comment="defconf: drop all from WAN" \
   in-interface=ether1
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
   connection-state=established,related
add chain=forward comment="defconf: accept established,related" \
   connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" \
   connection-state=invalid
add action=drop chain=forward comment=\
   "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
   connection-state=new in-interface=ether1
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
   out-interface=ether1
/system clock
set time-zone-name=Europe/Moscow
/system lcd
set contrast=0 enabled=no port=parallel type=24x4
/system lcd page
set time disabled=yes display-time=5s
set resources disabled=yes display-time=5s
set uptime disabled=yes display-time=5s
set packets disabled=yes display-time=5s
set bits disabled=yes display-time=5s
set version disabled=yes display-time=5s
set identity disabled=yes display-time=5s
set bridge disabled=yes display-time=5s
set Beeline disabled=yes display-time=5s
set wlan1 disabled=yes display-time=5s
set ether1 disabled=yes display-time=5s
set ether2-master disabled=yes display-time=5s
set ether3 disabled=yes display-time=5s
set ether4 disabled=yes display-time=5s
set ether5 disabled=yes display-time=5s
/system leds
set 5 interface=wlan1
/system routerboard settings
set cpu-frequency=650MHz protected-routerboot=disabled
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=bridge
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=bridge
#error exporting /tool user-manager database
#error exporting /tool user-manager profile profile-limitation
#error exporting /tool user-manager router
#error exporting /tool user-manager user

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Dredshad, если вы прошли web-авторизацию, то у вас теперь есть выбор по какому протоколу выходить в интернет: l2tp или ipoe.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Помогите пожалуйста... роутер hap lite

Уже не знаю что делать.. настраиваю по инструкции на дефолтную конфигурации вроде все работает, только по DHCP приходит не полная инфа какая то .. не приходят маршруты все (DNS руками добавлял мрашруты), шлюз не приходит тоже.. и самое вымораживающее во всем этом - регулярно рвется соединение L2TP (( раз в час или в два.. от чего зависит хз ( Помогите пожалуйста (

P.S. Прошивка последняя.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@wiazo, соединение может рваться из-за сетевой проблемы: кабель перебит, проблемы в оборудовании провайдера. при прямом подключении без роутера понаблюдайте за стабильностью коннекта.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@wiazo, соединение может рваться из-за сетевой проблемы: кабель перебит, проблемы в оборудовании провайдера. при прямом подключении без роутера понаблюдайте за стабильностью коннекта.

да в принципе до этого висел TP-Link который благополучно сломался на тех же кабелях и проблемы не было ( после приобретения Микротика такое началось.. А что можете сказать по поводу получения данным DHCP клиентом ? почему не приходит шлюз и все маршруты ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@wiazo, покажите конфиг. скопируйте выхлоп команды в терминале:

/export

перед публикацией, уберите свои логины и пароли в нём.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот

 

 

 

MikroTik RouterOS 6.35.2 © 1999-2016 http://www.mikrotik.com/

 

[?] Gives the list of available commands

command [?] Gives help on the command and list of arguments

 

[Tab] Completes the command/word. If the input is ambiguous,

a second [Tab] gives possible options

 

/ Move up to base level

.. Move up one level

/command Use command at the base level

[wiazo@MikroTik] > /export

# jun/23/2016 23:59:32 by RouterOS 6.35.2

# software id = CRYZ-96GW

#

/interface bridge

add admin-mac=3333333333333 auto-mac=no comment=defconf name=bridge

/interface wireless

set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no mode=ap-bridge \

ssid=Wiazo wps-mode=disabled

/interface ethernet

set [ find default-name=ether2 ] name=ether2-master

set [ find default-name=ether3 ] master-port=ether2-master

set [ find default-name=ether4 ] master-port=ether2-master

/interface l2tp-client

add add-default-route=yes connect-to=tp.internet.beeline.ru disabled=no name=\

l2tp-Beeline password=********* user=**********

/ip neighbor discovery

set ether1 discover=no

set bridge comment=defconf

/interface wireless security-profiles

set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\

dynamic-keys wpa-pre-shared-key=8888888888 wpa2-pre-shared-key=\

**************

add authentication-types=wpa-psk,wpa2-psk eap-methods="" management-protection=\

allowed mode=dynamic-keys name=wiazo supplicant-identity="" \

wpa-pre-shared-key=*********** wpa2-pre-shared-key=**************

/ip pool

add name=dhcp ranges=192.168.1.2-192.168.1.20

/ip dhcp-server

add address-pool=dhcp disabled=no interface=bridge name=defconf

/interface bridge port

add bridge=bridge comment=defconf interface=ether2-master

add bridge=bridge comment=defconf interface=wlan1

/ip address

add address=192.168.1.1/24 comment=defconf interface=ether2-master network=\

192.168.1.0

/ip dhcp-client

add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1

/ip dhcp-server lease

add address=192.168.1.18 client-id=!!!!!!!!!!!!!!!!!! mac-address=\

!!!!!!!!!!!!!!!!!! server=defconf

add address=192.168.1.8 client-id=!!!!!!!!!!!!!!!!!! mac-address=\

!!!!!!!!!!!!!!!!!! server=defconf

add address=192.168.1.7 client-id=!!!!!!!!!!!!!!!!!! mac-address=\

!!!!!!!!!!!!!!!!!! server=defconf

add address=192.168.1.19 always-broadcast=yes client-id=!!!!!!!!!!!!!!!!!! \

mac-address=!!!!!!!!!!!!!!!!!! server=defconf

add address=192.168.1.20 mac-address=!!!!!!!!!!!!!!!!!! server=defconf

add address=192.168.1.9 client-id=!!!!!!!!!!!!!!!!!! mac-address=\

!!!!!!!!!!!!!!!!!! server=defconf

add address=192.168.1.3 client-id=!!!!!!!!!!!!!!!!!! mac-address=\

!!!!!!!!!!!!!!!!!! server=defconf

add address=192.168.1.2 client-id=!!!!!!!!!!!!!!!!!! mac-address=\

!!!!!!!!!!!!!!!!!! server=defconf

/ip dhcp-server network

add address=192.168.1.0/24 comment=defconf gateway=192.168.1.1 netmask=24

/ip dns

set allow-remote-requests=yes

/ip dns static

add address=192.168.1.1 name=router

/ip firewall filter

add chain=input comment="defconf: accept ICMP" protocol=icmp

add chain=input comment="defconf: accept established,related" connection-state=\

established,related

add chain=input comment="Allow UDP" protocol=udp

add chain=forward comment="Allow UDP" protocol=udp

add action=drop chain=input comment="defconf: drop all from WAN" in-interface=\

ether1

add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \

connection-state=established,related

add chain=forward comment="defconf: accept established,related" \

connection-state=established,related

add action=drop chain=forward comment="defconf: drop invalid" connection-state=\

invalid

add action=drop chain=forward comment=\

"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \

connection-state=new in-interface=ether1

/ip firewall nat

add action=masquerade chain=srcnat comment="defconf: masquerade" out-interface=\

l2tp-Beeline

add action=masquerade chain=srcnat out-interface=ether1

add action=netmap chain=dstnat in-interface=l2tp-Beeline protocol=tcp \

to-addresses=192.168.1.3 to-ports=32400

/ip route

add distance=1 dst-address=194.186.70.218/32 gateway=10.44.144.1

add distance=1 dst-address=194.186.70.222/32 gateway=10.44.144.1

/system clock

set time-zone-name=Asia/Krasnoyarsk

/system routerboard settings

set cpu-frequency=650MHz protected-routerboot=disabled

/tool mac-server

set [ find default=yes ] disabled=yes

add interface=bridge

/tool mac-server mac-winbox

set [ find default=yes ] disabled=yes

add interface=bridge

[wiazo@MikroTik] > /export

 

 

Изменено пользователем wiazo

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@wiazo,

/interface l2tp-client не все настройки есть, или просто не влезли...mru, mtu

 

/ip dhcp-client тоже отличается от настройки рекомендованной хотя возможно и дефолт роут стоит, просто не показывается в выхлопе /export.

Изменено пользователем  Ni©olas

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@wiazo, /interface l2tp-client не все настройки есть, или просто не влезли...mru, mtu/ip dhcp-client тоже отличается от настройки рекомендованной хотя возможно и дефолт роут стоит, просто не показывается в выхлопе /export.

MTU 1460 MRU 1500

дефолт роут стоит

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

У меня Микротик не качает с локальных пиров торренты. Настраивал по 3 строчкам. Подскажите, где проверить настройки? (Билайн Питер)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ок, второй вопрос. Почему некоторые сайты не открываются, или так скажем, открываются через некоторое время (5 минут). К примеру, vk.com и avito.ru. Не правильно настроен ДНС?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@LorexDivais, пробовали этот способ?

 

 

 

...

Необходимо сделать изменения в Firewall > Mangle.

Удалить динамические правила change MSS all ppp.

Добавить правило:

/ip firewall mangle add action=change-mss chain=forward new-mss=1360 protocol=tcp tcp-flags=syn tcp-mss=1453-65535

 

Изменить профиль, что бы динамические правила больше не создавались:

 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот что пишет терминал после ввода команды:

 

ip firewall add action=change-mss chain=forward new-mss=1360

 

protocol=tcp tcp-flags=syn tcp-mss=1453-65535

 

syntax error (line 1 column 23)

 

Что не правильно в тексте?

 

 

 

@LorexDivais, пробовали этот способ?

 

 

 

...

Необходимо сделать изменения в Firewall > Mangle.

Удалить динамические правила change MSS all ppp.

Добавить правило:

/ip firewall mangle add action=change-mss chain=forward new-mss=1360 protocol=tcp tcp-flags=syn tcp-mss=1453-65535

 

Изменить профиль, что бы динамические правила больше не создавались:

 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@LorexDivais, у меня без ошибок. попробуйте код ниже вставить в терминал циликом.

/ip firewall mangle add action=change-mss chain=forward new-mss=1360 protocol=tcp tcp-flags=syn tcp-mss=1453-65535

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Окей, роутер схавал код.

Подскажите, а как теперь "Изменить профиль, что бы динамические правила больше не создавались" ?

 

@LorexDivais, у меня без ошибок. попробуйте код ниже вставить в терминал циликом.

/ip firewall mangle add action=change-mss chain=forward new-mss=1360 protocol=tcp tcp-flags=syn tcp-mss=1453-65535

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@LorexDivais,

 

@xsb3, настроить тот профиль, который используется в настройках L2TP

 

 

2016-06-02_09-07-08.png

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо большое!! Теперь все работает (все сайты открываются)!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

RB2011UiAS-2HnD-IN

 

Настраивал самыми разными способами уже и все время упираюсь в terminating... - could not resolve name

так понимаю не хватает правила какого-то

вот настройка по скрипту Доступ в интернет по L2TP отсюда http://homenet.beeline.ru/index.php?showtopic=322861

 

# RouterOS 6.35.4
# software id = BCML-GHYP
#
/interface bridge
add admin-mac=E4:8D:8C:07:6E:9E auto-mac=no comment=defconf name=bridge
/interface ethernet
set [ find default-name=ether2 ] name=ether2-master
set [ find default-name=ether3 ] master-port=ether2-master
set [ find default-name=ether4 ] master-port=ether2-master
set [ find default-name=ether5 ] master-port=ether2-master
set [ find default-name=ether6 ] name=ether6-master
set [ find default-name=ether7 ] master-port=ether6-master
set [ find default-name=ether8 ] master-port=ether6-master
set [ find default-name=ether9 ] master-port=ether6-master
set [ find default-name=ether10 ] master-port=ether6-master
/interface l2tp-client
add add-default-route=yes allow=chap,mschap2 connect-to=tp.internet.beeline.ru \
   disabled=no max-mru=1500 max-mtu=1460 name=Beeline password=ХХХ \
   user=ХХХ
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
   disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=\
   MikroTik-076EA7 wireless-protocol=802.11
/ip neighbor discovery
set ether1 discover=no
set bridge comment=defconf
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2-master
add bridge=bridge comment=defconf interface=ether6-master
add bridge=bridge comment=defconf interface=sfp1
add bridge=bridge comment=defconf interface=wlan1
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=\
   192.168.88.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=eth
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add chain=input comment="defconf: accept ICMP" protocol=icmp
add chain=input comment="defconf: accept established,related" connection-sta
   established,related
add action=drop chain=input comment="defconf: drop all from WAN" in-interfac
   ether1
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
   connection-state=established,related
add chain=forward comment="defconf: accept established,related" \
   connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" connection-sta
   invalid
add action=drop chain=forward comment=\
   "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat 
   connection-state=new in-interface=ether1
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" out-interfa
   ether1
# Beeline not ready
add action=masquerade chain=srcnat out-interface=Beeline
/system routerboard settings
set protected-routerboot=disabled
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=bridge
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=bridge

 

 

билайн взорвал мне мозг на этом роутере

Изменено пользователем  Ni©olas
добавил спойлер

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@badneko, что пишет в выхлопе

/ip dns print

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

сейчас нет доступа к кабелю билайновскому (оставил дома на нем зухеля кинетика), но на сколько помню все записи получал кроме шлюза Gateway

с утра пришла мысль прописать маршруты вручную как в случае с йотой (тоже были проблемы с подключением)

сейчас есть доступ к зухелю кинетику, хочу оттуда взять маршруты

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

[admin@MikroTik] > /ip dns print
               servers: 
       dynamic-servers: 194.186.70.218,194.186.70.222
 allow-remote-requests: yes
   max-udp-packet-size: 4096
  query-server-timeout: 2s
   query-total-timeout: 10s
            cache-size: 2048KiB
         cache-max-ttl: 1w
            cache-used: 15KiB

прописал.... упорно отказывается, исходящие пакеты идут, а входящий ни один не проходит, может в фаерволе что не так? дык все с нуля делаю который раз и раком и боком и с прискоком

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 dynamic-servers: 194.186.70.218,194.186.70.222

эти адреса не билайновские вроде.

 

а настройки firewall покажет:

/ip firewall filter print

Изменено пользователем  Ni©olas

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
 dynamic-servers: 194.186.70.218,194.186.70.222

эти адреса не билайновские вроде.а настройки firewall покажет:
/ip firewall filter print

У меня точно такие же адреса))) человеку может руками надо маршрут прописать как у меня ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@badneko, хорошую идею подал @wiazo. может к ва не пришли маршруты до билайновских днс-серверов?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас