Des1re

Настройка IPTV в openWrt для ТВ-приствки

Рекомендованные сообщения

А точно b1 на b5 встанет? Там, на той страничке вроде разделено на ревизии b1-3, b5-7.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Скорее всего не встанет, раз разделили. Я бы пробовать не стал. Можно кирпич получить.

Ставьте тогда BB

 

https://downloads.openwrt.org/barrier_breaker/14.07/ramips/rt305x/

 

У вас оперативки очень мало. А вам не нужны всякие udpxy и т.п.

  • Upvote 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну что я могу сказать, с openwrt 14.07 скорость оказалось еще меньше. Если с 15.09 она была До 45Мбит то здесь уже до 30Мбит. Откатился до zyxel keenetic start скорость без обрезки. Как по тарифу 60Мбит, даже есть скачки и выше тарифной скорости. Вообще он может выдержать до 70-80Мбит. И дело не в слабом оборудование, а в прошивке. Когда была прошивка от билайна там вообще было дно, они специально урезали скорость чтобы покупали их коробочку смартбокс.

Ну я так понимаю больше ничего придумать нельзя?

Кстати, что обрезаная openwrt, что нет - скорость одинаковая. Следовательно это независит от размера прошивки. Озу важно для количества соеденений, но не для скорости.

Ну Любом случае, спасибо вам большое, как минимум мы доказали что для дир300 самая лучшая прошивка это zyxel keenetic.

Изменено пользователем Alex009988

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Alex009988, OpenWRT не поддерживает PPE (HW NAT), потому и скорость ниже. 15.05 быстрее, чем 14.07, потому что туда портировали route cache, удалённый когда-то из ядра linux.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Alex009988, OpenWRT не поддерживает PPE (HW NAT), потому и скорость ниже. 15.05 быстрее, чем 14.07, потому что туда портировали route cache, удалённый когда-то из ядра linux.

Интересно, спасибо за ответ. Интересно потому что всеже почему скорость без обрезаний достигается только на прошивке от зайксела кинетик старт ndms v2?, абсолютно все прошивки от длинка режут скорость значительно, какая то больше какая то меньше. Прошивка от билайн вообще днище. Openwrt 15.09 дает такую же скорость как прошивка от длинка 1.4.0-9.

И еще dir300 nru b5 имеет чип rt 5350 который вроде не поддерживает hw Nat согласно данной теме.

https://forum.openwrt.org/viewtopic.php?id=61594

Эх попробовать бы wive ng там все должно быть, но только для ревизий б5-7 так и не собрали. Причем чип rt5350 вроде бы поддерживается, но прошивки к большому сожалению так никто и не выпустил.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Насколько я помню в 841 один интерфейс и два влана. Настроить можно и в вебморде, но это дольше объяснять.

 

Проще отредактировать файл /etc/config/network

 

У вас там должно быть что-то типа

 

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 5t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0 5t'

 

Отредактируйте файл, чтобы получилось так

 

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 5t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0 4 5t'

 

Если я с нумерацией портов в этом роутере не перепутал, то теперь 4 порт будет в бридже с wan. Туда можно смело включать приставку.

 

Спасибо! получилось с 1го раза

правда долго мучался куда эти команды вписать, тк раньше не работал с этим))

долго искал и наконец то дошло что надо Putty качать) дальше гугл смог тоже помочь)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Проще всего редактировать файлы с помощью программы WinSCP.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрый день.

Подскажите, имеется аналогичная проблема роутер Tp-Link 4300, прошит OpenWrt AA 12.09 сборка от yohimba. IPTV приставка от билайн Cisco.

Пробовал настроить IP TV по инструкции из этой темы и по инструкции из темы про прошивку от yohimba.

Результат одинаковый, изображение виснет через несколько секунд.

Настройки файла network сейчас выглядят вот так. Приставка подключена к 4 физическому порту роутера. Подскажите где я ошибся?

 

config switch

option name 'switch0'

option reset '1'

option enable_vlan '1'

 

config switch_vlan

option device 'switch0'

option vlan '1'

option ports '0t 2 3 4'

option vid '1'

 

config switch_vlan

option device 'swich0'

option vlan '2'

option ports '0t 1 5'

option vid '2'

Изменено пользователем AlleRR

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всем привет.

Надеюсь и мне поможете с моей настройкой.

Роутер: D-Link Dir-615 E4

Порты: WAN, 1, 2, 3, 4

OS: OpenWrt Attitude Adjustment 12.09 / LuCI 0.11.1 Release (0.11.1)

IP-приставка: SML-5050

Провайдер: Ростелеком

Сеть: с подъезда идёт кабель в роутер в порт WAN (естественно), от роутера lan-кабель в приставку.

На роутере настроил WAN (pppoe) и Wi-Fi

P.S. Почему то через Web, после создания VLAN и применения настроек, настройки не запоминаются., буду настраивать через "putty" - может так сохранится.

------------------------------------------------------------------------------------------------------------------------------------------------------

Содержимое: /etc/config/network

-------------------------------------------------------------------------------------------------------------------------------------------------------

root@OpenWrt:~# vi /etc/config/network
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth1'
        option _orig_ifname 'eth1'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username 'секретно'
        option password 'секретно'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 4'

- /etc/config/network 32/32 100%
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth1'
        option _orig_ifname 'eth1'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username 'секретно'
        option password 'секретно'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 4'

---------------------------------------------------------------------------------------------------

Желательно настроить приставку на 4й порт., он получается если отчёт с 0 то 4, если с 1 то 5й (включая WAN)
 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
15 мин назад , systemantih писал:

Провайдер: Ростелеком

Странно что вы задали вопрос в форуме провайдера Билайн.

У Ростелекома совершенно по другому организовано ИПТВ, ищите ответ на его ресурсах.

  • Upvote 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
16 мин назад , NikIv писал:

Странно что вы задали вопрос в форуме провайдера Билайн.

У Ростелекома совершенно по другому организовано ИПТВ, ищите ответ на его ресурсах.

Да я смотрю тут люди как люди (общительные и не посылают), вот и написал тут. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, systemantih писал:

Всем привет.

Надеюсь и мне поможете с моей настройкой.

Роутер: D-Link Dir-615 E4

Порты: WAN, 1, 2, 3, 4

OS: OpenWrt Attitude Adjustment 12.09 / LuCI 0.11.1 Release (0.11.1)

IP-приставка: SML-5050

Провайдер: Ростелеком

Сеть: с подъезда идёт кабель в роутер в порт WAN (естественно), от роутера lan-кабель в приставку.

На роутере настроил WAN (pppoe) и Wi-Fi

P.S. Почему то через Web, после создания VLAN и применения настроек, настройки не запоминаются., буду настраивать через "putty" - может так сохранится.

------------------------------------------------------------------------------------------------------------------------------------------------------

Содержимое: /etc/config/network

-------------------------------------------------------------------------------------------------------------------------------------------------------

root@OpenWrt:~# vi /etc/config/network
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth1'
        option _orig_ifname 'eth1'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username 'секретно'
        option password 'секретно'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 4'

- /etc/config/network 32/32 100%
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth1'
        option _orig_ifname 'eth1'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username 'секретно'
        option password 'секретно'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 4'

---------------------------------------------------------------------------------------------------

Желательно настроить приставку на 4й порт., он получается если отчёт с 0 то 4, если с 1 то 5й (включая WAN)
Можете конфиг подправить, как сделать такое:

Танцы с бубном закончились в объединении порта WAN с портом IPTV в коммутаторе, без дополнительного влана.

 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас