Des1re

Настройка IPTV в openWrt для ТВ-приствки

42 сообщения в этой теме

Здравствуйте! Помогите, пожалуйста, настроить на прошивке openWrt IPTV для приставки. В интернете есть инструкции, при помощи которых можно смотреть IPTV на компьютере, но на приставке не работает.

На официальной прошивке роутера IPTV работает без настройки (его и не надо настраивать). Роутер: TP-Link TL-WR841N

 

Спасибо. :)

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Самое простое это сделать отдельный VLAN для приставки. Какая версия e у вас Openwrt?

1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Самое простое это сделать отдельный VLAN для приставки. Какая версия e у вас Openwrt?

Версия 15.05-ar71xx-generic-tl-wr841n-v8

Редактировано пользователем Des1re
0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Насколько я помню в 841 один интерфейс и два влана. Настроить можно и в вебморде, но это дольше объяснять.

 

Проще отредактировать файл /etc/config/network

 

У вас там должно быть что-то типа

 

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 5t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0 5t'

 

Отредактируйте файл, чтобы получилось так

 

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 5t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0 4 5t'

 

Если я с нумерацией портов в этом роутере не перепутал, то теперь 4 порт будет в бридже с wan. Туда можно смело включать приставку.

Редактировано пользователем Pilot6
1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Хорошо, спасибо. Завтра попробую и отпишусь :)

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Хорошо, спасибо. Завтра попробую и отпишусь :)

Только роутер перезагрузить не забудьте.

1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В общем, в конфиге на свежеустановленной прошивке есть такие строки:

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 4'

 

При создании в интерфейсе нового vlan становится

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 4'
option vid '1'

config switch_vlan
option device 'switch0'
option vlan '2'
option vid '2'

 

По дефолту ни одного порта с тегом:

8177658.png

 

 

После добавления нового vlan:

8184826.png

 

Когда ставлю порт CPU с тегом (не зависимо от количества vlan), то больше не могу достучаться до роутера...

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну неправильно же сделали.

Дайте полный текст /etc/config/network по дефолту. Я дам правильный вариант.

 

Я сейчас посмотрел на сайте Openwrt. Если там информация правильная, то файл с бриджем должен быть таким

 

config interface 'loopback'
       option ifname 'lo'
       option proto 'static'
       option ipaddr '127.0.0.1'
       option netmask '255.0.0.0'

config globals 'globals'
       option ula_prefix 'here is written something, no need to modify it'

config interface 'lan'
       option ifname 'eth0.1'
       option force_link '1'
       option type 'bridge'
       option proto 'static'
       option ipaddr '192.168.11.1' # modify this according to you needsfor the lan network
       option netmask '255.255.255.0'
       option ip6assign '60'

config interface 'wan'
       option type 'bridge'
       option ifname 'eth1 eth0.2'
       option proto 'dhcp'

config interface 'wan6'
       option ifname '@wan'
       option proto 'dhcpv6'

config switch
       option name 'switch0'
       option reset '1'
       option enable_vlan '1'

config switch_vlan
       option device 'switch0'
       option vlan '1'
       option ports '0t 2 3 4'

config switch_vlan
       option device 'switch0'
       option vlan '2'
       option ports '0t 1'

 

Надо сделать 3 изменения:

 

1. Сделать два vlan с портами как я указал. Порт CPU должен быть tagged, в первом влане должно быть 3 порта untagged, во втором 1 untagged, остальные off. Порт 1 в файле соответствует 4 физическому порту в роутере.

 

2. Поменять интерфейс wan на bridge и указать там интрефейсы eth1 и eth0.2

 

3. В интерфейсе lan поменять eth0 на eth0.1

Редактировано пользователем Pilot6
1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Я делал так:

config switch_vlan
       option device 'switch0'
       option vlan '1'
       option ports '0t 1 2 3'

config switch_vlan
       option device 'switch0'
       option vlan '2'
       option ports '0t 4'

 

После перезагрузки конфига, как я писал ранее, я не могу достучаться до роутера.

Приставка у меня на 3 физическом, он является 4 в файле.

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А остальное-то поменяли? eth0 на eth0.1 в интерфейсе lan?

 

Ну а адрес надо оставить как был 192.168.1.1

Редактировано пользователем Pilot6
1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Нет, я просто сейчас не дома. Т.е. мне надо поменять все 3 пункта, которые Вы написали, а потом только перезагружать?

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну да. Иначе действительно не достучаться. Меняется же интерфейс.

1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Pilot6, большое спасибо Вам за помощь! Вы просто выручили :)

 

И так, приставка у меня подключена в 3 физический (4 порт в openWrt), выполнил 3 пункта, который описывал Pilot6, но немного с другими значениями.

Выкладываю свой конфиг из /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'оставить то, что написано у Вас'

config interface 'lan'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option _orig_ifname 'eth1 radio0.network1'
option _orig_bridge 'true'
option ifname 'eth1.1'

config interface 'wan'
option proto 'dhcp'
option type 'bridge'
option _orig_ifname 'eth0'
option _orig_bridge 'true'
option ifname 'eth0 eth1.2'

config interface 'wan6'
option ifname 'eth0'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0t 1 2 3'

config switch_vlan
option device 'switch0'
option vlan '2'
option vid '2'
option ports '0t 4'

Редактировано пользователем Des1re
0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Странные у вас интерфейсы.

 

У вас как-то eth0 и eth1 перепутались похоже.

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Похоже что так. Просто мой роутер особенный :D

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

http://4pda.ru/forum/index.php?showtopic=445383&st=2840#entry40026715

Тип соеденения ipoe все сделал как в этой инструкции. Но iptv так и не заработал.

И еще, почему после перезагрузки сбрасывается пароль, и его не меняеться? Из за этого нет доступа к настройкам.

Железка dir300 b5

edit 1

Как вы меняете config в etc/system/network?

Редактировано пользователем Alex009988
0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Alex009988, вы хотите iptv на только приставке? Для этого не нужны дополнительные приложения, просто выполните инструкцую, которая содержится в этой теме.

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

у DIR-300 могут быть другие порты. Наверняка.

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вероятно это так, но что вам мешает проверить где какие?

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вероятно это так, но что вам мешает проверить где какие?

Ой ребята здесь такие сложности без вашей помощи думаю не справлюсь.

В общем так, железка у меня dir300 b5, использую вот эту прошивку http://homenet.beeline.ru/index.php?showtopic=322462

Накатил сначало фактори затем sysupgrate, из за того что там вврезан opgk, нет доступа к файлам, соеденяеться через телнет via putty, по SSH уже не получаеться соедениться, и как следствие winscp не работает. Следовательно единственный шанс запустить телевидение это помучиться с вебмордой. По опыту с zyxel keenetic start для работы с телевидением нам нужен или выделенный порт или igmp. Я так понял в openwrt igmp нету(так чтобы одной галочкой решить проблему)

Также пробовал и эту инструкцию не помогло.

http://4pda.ru/forum/index.php?s=&showtopic=445383&view=findpost&p=40026715

 

И еще, удивляет то что здесь и здесь

https://wiki.openwrt.org/ru/toh/d-link/dir-300revb

http://denisyuriev.ru/linux/openwrt-linux/d-link-dir-300/openwrt-druzhba-s-dir-300-b5-b6-i-b7/

Версии только для sysupgrate если накотить их без фактори сразу через failsafe ui они не рабочии, даже пароль нельзя сохранить.

Так что посоветуете делать в такой тяжелой ситуации?

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Для начала надо понять что factory и sysupgrade - это не разные версии, а разные файлы для установки.

Factory для установки на заводскую прошивку, a sysupgrade на прошивку из openwrt.

 

Поэтому вы занимались ерундой, когда сначала прошили factory, потом sysupgrade.

 

В Openwrt igmpproxy есть, но проще сделать отдельный vlan, как было сделано для другого устройства.

 

Давайте попробуем разобраться. Выложите файл /etc/config/network

 

Я бы посоветовал поставить стандартную Openwrt СС и там все легко можно сделать парой кликов мышкой (объяснить без картинок сложо) или простым редактированием файла (объяснить очень просто).

Редактировано пользователем Pilot6
1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

root@OpenWrt:~# vi /etc/config/network
       option ifname 'lo'
       option proto 'static'
       option ipaddr '127.0.0.1'
       option netmask '255.0.0.0'

config globals 'globals'
       option ula_prefix '..........::/48'

config interface 'lan'
       option ifname 'eth0.1'
       option force_link '1'
       option macaddr '.........'
       option type 'bridge'
       option proto 'static'
       option ipaddr '192.168.1.1'
       option netmask '255.255.255.0'
       option ip6assign '60'

config interface 'wan'
       option ifname 'eth0.2'
       option force_link '1'
- /etc/config/network 1/46 2%

Ничего не понимаю что то у меня вообще тут switch нету. Помогите пожалуйста.

СПАСИБО Вам Большое за Вашу Помощь!

PS iptv хочу только на одной приставке.

Редактировано пользователем Alex009988
0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вы можете создать switch через luci и он появится в конфиге.

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вы просто не весь файл выложили, а то что влезло на экран.

 

Если посмотрите ниже, то увидите что switch есть. И уже есть два влана.

Надо только один порт перенести из первого во второй.

 

На самом деле это можно в вебморде сделать мышкой в разделе switch.

 

Надо взять порт, куда воткнута приставка и перенести из vlan 1 во vlan 2.

То есть в первой строке поменять untagged на off, а во второй наоборот.

 

Только надо понять какой порт. Нумерация может не совпадать. Но вы по картинкам увидите, куда что-то подключено.

Чтобы найти приставку можно временно отключить все остальное.

 

Так что с файлом можете не заморачиваться. Уже понятно по этой части файла как сделаны интерфейсы.

Редактировано пользователем Pilot6
1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо, телик заработал. Выкладываю конфиг может кому то поможет. Порт для IPTV №4


config interface 'loopback'
       option ifname 'lo'
       option proto 'static'
       option ipaddr '127.0.0.1'
       option netmask '255.0.0.0'

config globals 'globals'
       option ula_prefix 'твоя запись'

config interface 'lan'
       option ifname 'eth0.1'
       option force_link '1'
       option macaddr 'твой мак адрес'
       option type 'bridge'
       option proto 'static'
       option ipaddr '192.168.1.1'
       option netmask '255.255.255.0'
       option ip6assign '60'

config interface 'wan'
       option ifname 'eth0.2'
       option force_link '1'
       option proto 'dhcp'
       option mtu '1460'
       option type 'bridge'
       option macaddr 'твой мак адресс'

config interface 'wan6'
       option ifname 'eth0.2'
       option proto 'dhcpv6'
       option type 'bridge'

config switch
       option name 'switch0'
       option reset '1'
       option enable_vlan '1'

config switch_vlan
       option device 'switch0'
       option vlan '1'
       option ports '1 2 3 6t'

config switch_vlan
       option device 'switch0'
       option vlan '2'
       option ports '0 4 6t'

Были проблемы и с вайфай но вродебы удалось их решить. А так есть проблема и похуже.

OpenWRT режит скорость что делает его ни чем не лучше длинковских прошивок. Есть ли возможность исправить это? На Zyxel keenetic Start(прошивка) скорость была по тарифу.

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А зачем mtu 1460? Это надо убрать.

 

А вообще на слабом железе версиz СС - далеко не лучший вариант. Поставьте AA. Резать не будет скорее всего. Тяжеловата CC.

А свич там настраивается так же.

1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Так вроде mtu должно быть каким то: по умолчанию 1500, тех поддержка билайн говорит 1460. В вебморде так и написано "назначить mtu" То есть какое то значение должно быть.

Что то у не понял что такое openwrt сс и аа. Сейчас использую вот эту обрезанную прошивку http://homenet.beeline.ru/index.php?showtopic=322462, есть еще две другие сборки в приведенных сылках мною выше(которые потяжелее) и все. Их самому чтоли нужно собирать из изходников?

0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

1460 - это когда L2TP, да и то устанавливется автоматически. нет нужды там прописывать. А с Ipoe вообще 1500 нормально.

 

Ну почему из исходников? Есть собранные прошивки на сайте Openwrt Attitude Adjustment.

 

https://downloads.openwrt.org/attitude_adjustment/12.09/

 

Только похоже ваш девайс старыми версиями не поддерживается.

 

Наврал. Все поддерживается.

https://downloads.openwrt.org/attitude_adjustment/12.09/ramips/rt305x/

1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Date,ConnType,Lat,Lon,Download,Upload,Latency,ServerName,InternalIp,ExternalIp

"2016-02-01 21:43","Wifi","55.72463","37.57722",19.47,2.18,3,"Moscow","192.168.1.107",

"2016-02-01 20:39","Wifi","55.72463","37.57729",20.46,4.33,3,"Moscow","192.168.1.107",

"2016-01-31 18:36","Wifi","55.72457","37.57714",30.69,39.28,3,"Moscow","192.168.1.34",

ВОТ кстати тест скорости вайфай. 1) Openwrt mtu по умолчанию 2)openwrt mtu 1460 3) zyxel keenetic start mtu 1460. Так что и с вайфак тут тоже серьезные проблемы.

И всетаки openwrt.12.09 не поддерживается, там для ревизии b1, а мне нужно для ревизии b5,6,7. Это немного разные железки.

Может стоит попробовать самому собрать openwrt сс, хотя я тут буду первопроходцем.

Эта инструкция поможет? http://denisyuriev.ru/linux/openwrt-linux/openwrt-sborka-iz-isxodnikov/

Хотя если никто не собрал, я так понимаю там какие то штуки для чипа подходят только для 15,09?

Редактировано пользователем Alex009988
0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вы читаете старые инструкции, которые про L2TP. У вас же IPoE. Поэтому вам не нужна никакая "специальная" прошивка для Билайна, и не нужно менять mtu.

 

А ревизия b5 поддерживатся той же прошивкой Openwrt, что и b1. Поэтому файл так и называется.

 

То же самое для 15.05.

 

https://wiki.openwrt.org/toh/d-link/dir-300revb

 

Так что я поставил бы более легкую стандартную Openwrt AA. Она намного меньше весит, и намного меньше жрет оперативки.

И заметно быстрее на слабом железе. Ну и на сильном тоже быстрее, хотя это не так заметно, когда речь идет о скоростях более 100 мегабит.

 

Хотя может быть и наврал про ревизии. Посмотрел внимательнее, там b7 надо.

 

Но тогде можете поставить Barrier Braker. Она точно поддерживает ваш девайс, и тоже быстрее, чем CC.

Редактировано пользователем Pilot6
1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Зарегистрироваться на нашем форуме.


Register a new account

Авторизоваться

Уже имеете аккаунт? Авторизоваться здесь.


Авторизоваться сейчас