Рекомендованные сообщения

Удалить настройку dhcp клиента

2018-10-31_21-02-00.png.815b07eedc6372dfab23b008d1827726.png

Затем выполнить в терминале

/ip dhcp-client
add add-default-route=special-classless default-route-distance=2 dhcp-options=hostname,clientid disabled=no interface=ether1-gateway

И перезагрузить роутер.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всё равно нет интернета по wifi,

Смущает надпись Beeline: terminating... - could not resolve name, не может превратить адрес tp.internet.beeline.ru в цифровой по какой-то причине, днс не работает?

8.jpg

Изменено пользователем Шпинат

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

После
скрипта

/ip dhcp-client
add add-default-route=special-classless default-route-distance=2 dhcp-options=hostname,clientid disabled=no interface=ether1-gateway

пинговаться всё перестало(

9.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Что в IP - Routes? И в IP- DHCP Client?

Изменено пользователем fartontm

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Нет ни одной настройки DHCP клиента. Лучше настраивать через winbox https://download.mikrotik.com/routeros/winbox/3.18/winbox.exe

Напишите вывод команды 

/interface print

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Выполнить в терминале. В прошлый раз я неправильно написал имя интерфейса, так как в в приведенном вами было именно оно - ether1-gateway , а надо ether1.

/ip dhcp-client
add add-default-route=special-classless default-route-distance=2 dhcp-options=hostname,clientid disabled=no interface=ether1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Переключился на вкладку quickset там Static встал почему-то, переставил на Automatic

14.JPG

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

quick set не надо было трогать. переключился на static, т.к. отключили dhcp client.

Нужно его заново удалить и выполнить команду, которую я писал выше.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
7 минут назад, fartontm сказал:

Выполнить в терминале. В прошлый раз я неправильно написал имя интерфейса, так как в в приведенном вами было именно оно - ether1-gateway , а надо ether1.


/ip dhcp-client
add add-default-route=special-classless default-route-distance=2 dhcp-options=hostname,clientid disabled=no interface=ether1

Выполнил, вот результат!

15.JPG

16.JPG

17.JPG

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
3 минуты назад, fartontm сказал:

quick set не надо было трогать. переключился на static, т.к. отключили dhcp client.

Нужно его заново удалить и выполнить команду, которую я писал выше.

 

Понял, сейчас сделаю!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

dchp клиент удалил (всё равно во вкладке quickset в автомате стояла, а не на Статике)

скринпт выполнил

/ip dhcp-client
add add-default-route=special-classless default-route-distance=2 dhcp-options=hostname,clientid disabled=no interface=ether1

ребут роутера сделал

всё равно нет интернета по wifi

19.JPG

20.jpg

Изменено пользователем Шпинат

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Интернет на роутере есть, уже хорошо, вначале даже не определялся адрес tp.internet.beeline.ru

Вывод команды 

/ip firewall nat print

и

/ip firewall filter print

 

Изменено пользователем fartontm

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Только что, fartontm сказал:

Интернет на роутере есть. уже хорошо.

Вывод команды 


/ip firewall nat print

и


/ip firewall filter print

 

 

22.JPG

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Если правильно понимаю, за пределы роутера интернет не выходит, в маскараде правило нужно сделать, только как правильно?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

нужно с ether1 на Beeline переключить?

23.JPG

Изменено пользователем Шпинат

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Верно. И выполнить команду, а то перестанут работать внутренние ресурсы Билайн, например этот форум.

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1

 

Изменено пользователем fartontm

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
7 минут назад, fartontm сказал:

Верно. И выполнить команду, а то перестанут работать внутренние ресурсы Билайн, например этот форум.


/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1

 

Огромное тебе человеческое СПАСИБО!!!

Мужик!!! низкий поклон тебе!

Сохраню настройки!

Изменено пользователем Шпинат

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Пожалуйста. Сам намучился с настройками, пока победил свой роутер ))

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

После настройки quickset homeap

Полноценный скрипт, получается будет таким?:

/interface l2tp-client
add add-default-route=yes allow=chap,mschap2 connect-to=tp.internet.beeline.ru disabled=no max-mru=1500 max-mtu=1460 name=Beeline password=XXXX user=XXXX
/ip dhcp-client
add add-default-route=special-classless default-route-distance=2 dhcp-options=hostname,clientid disabled=no interface=ether1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=Beeline

Чтобы сохранить раз и навсегда)

Изменено пользователем Шпинат

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да. Только вначале нужно удалить существующую настройку dhcp client, правила nat и выполнить.

Обязательные условия - дефолтная настройка микротика, свежая RouterOS (у меня 6.42.9), а то имена интерфейсов могу отличаться.

/interface l2tp-client
add add-default-route=yes allow=chap,mschap2 connect-to=tp.internet.beeline.ru disabled=no max-mru=1500 max-mtu=1460 name=Beeline password=XXXX user=XXXX
/ip dhcp-client
add add-default-route=special-classless default-route-distance=2 dhcp-options=hostname,clientid disabled=no interface=ether1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=Beeline
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1

 

Изменено пользователем fartontm

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас