Рекомендованные сообщения

настройки по-умолчанию (ресет роутера с дефолтным конфигом), район с ipoe. телефон работает (меня слышно, я слышу). mikrotik rb9512n. прошивка 6.30.1

Охотно верю )

Но все в шапке написано про l2tp. Там, наверно, с маршрутами все еще надо шаманить...

Про ipoe как-то ну совсем нечего писать - включил, ресет и все работает.

 

Ну и телефонный траффик надо бы заQoSить по уму, чтобы торренты все не сожрали - а это тема отдельная и не такая очевидная.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@vysotsky, ну тогда мое сообщение оффтоп :) с ipoe шаманить только с iptv, работает только через так называемый тв-порт

Изменено пользователем  Ni©olas

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Приветствую всех!

Не являюсь продвинутым юзером, но тем не менее имею RB2011. (прошивка 6.30.2)

Инет работает благодаря данной теме, но вот IPTV не работает. Чуть подробнее....

Входной провод от Билайн в eth1, TV в eth4. Tv показывает примерно 3-5сек и застывает до переключения на другой канал и так далее. А вот если из Eth1 переключить в Eth3, то телевидение начинает работать, но соответственно пропадает инет.

Прошу помощи! Сорри если офтопик.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

надо установить пакет multicast, + настроить igmp-роутинг + настроить пару правил в firewall. тема по тв

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Подскажите плиз почему скорость напрямую с компа и с Mikrotik RB2011UiAS разница?

На ПК:

входящая = 92.06 Мбит/сек

исходящая = 93.02 Мбит/сек

 

На mikrotik:

входящая = 92.44 Мбит/сек

исходящая = 68.52 Мбит/сек

 

Больше интересует как исправить исходящую с mikrotik, нагрузка проца на mikrotik при отдаче ~45%

Вопрос снят, неверно показывают мерялки, TX в порядке при загрузке например на Я.Диск.

Изменено пользователем Black_Sun

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Помогите, заставить ТВ билайн работать на MikroTik.

 

 

MikroTik hAP lite подключил, ничего не настраивал, инет работает все ок!

Подключил ТВ приставку к микротику, переключаю канал, 5 СЕКУНД ПОКАЗЫВАЕТ И ОТРУБАЕТСЯ - "проверьте правильность подключения кабеля"

 

Помогите составить точную инструкцию для "одаренных" для решения проблемы.

Спасибо!

 

 

ТОЧНЫЙ АЛГОРИТМ ДЕЙСТВИЙ, ДЛЯ ТОГО, ЧТОБЫ ТВ РАБОТАЛО:

 

MikroTik hAP lite - RouterOS 6.30

Инет в ether1, ТВ в ether2

 

1. Отрубаю питание у роутера.

2. Нажимаю и удерживаю RES / включаю питание - лампочка ACT замигала - отпускаю RES.

Все инет есть! (никаких 2ltp соединений создовать не нужно)

А ТВ - 5 СЕКУНД ПОКАЗЫВАЕТ И ОТРУБАЕТСЯ - "проверьте правильность подключения кабеля"(((

 

3 .... просьба продолжить алгоритм действии, который решит проблему.

4

5

6

7

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@corbinatman, установите пакет мультикаст для своего роутера. пример установки пакета:

 

 

 

 

 

после этого возможно будет настроить igmp-роутинг, чтоб тв не фризило каждые 5 секунд

Изменено пользователем  Ni©olas

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@corbinatman, установите пакет мультикаст для своего роутера. пример установки пакета:

 

 

 

 

 

после этого возможно будет настроить igmp-роутинг, чтоб тв не фризило каждые 5 секунд

 

Спасибо большое, за то, что отклинулись!

давно уже установил, помогите настроить, пожалуйста.

ТОЧНЫЙ АЛГОРИТМ ДЕЙСТВИЙ НУЖЕН )

Иначе, писанина будет продолжаться месяц.

 

 

1. Отрубаю питание у роутера.

2. Нажимаю и удерживаю RES / включаю питание - лампочка ACT замигала - отпускаю RES.

3 установил пакет мультикаст

4 что дальше?... пример (Войти в "Routing" > "IGMP Proxy" > "+" выбрать "Interface" такой-то > нажать кнопку "Apply", нажать "OK")

5 что дальше?...

6 что дальше?...

7 что дальше?...

...

 

Спасибо!

 

-

-

-

-

-

 

 

post-861774-098242000 1439543923_thumb.png

по этой схеме та что не работает?

1-кабель билайна

2-пк

3-пустой

4-тв-приставка

5-тв-приставка

 

Спасибо большое, за то, что отклинулись!

Обычный пользователь не сможет понять то, что на картинке... )

Буду признателен Вам, если точно объясните что мне нужно сделать, что бы по Вашей схеме у меня все заработало.

Пример настройки пожалуйста для: MikroTik hAP lite - RouterOS 6.30 - Инет в ether1, ТВ в ether2

 

 

0. Подключаю кабель билайна в ether1, ТВ приставку билайна в ether2

1. Отрубаю питание у роутера.

2. сброс на Default

3 Войти в "Bridge" > .... просьба продолжить алгоритм действии, который решит проблему.

4

5

6

7

Изменено пользователем corbinatman

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@corbinatman, далее подключаетесь по ssh к своему роутеру и выполняете пару строк:

 

 

p.s. проверена работа на ipoe(не l2tp)

 

Настройка igmp-роутинга:

/routing igmp-proxy  
set query-interval=30s query-response-interval=20s quick-leave=no

 

/routing igmp-proxy interface  
add alternative-subnets=0.0.0.0/0 interface=ether1-gateway upstream=yes  
add interface=bridge-local

где,

interface=ether1-gateway - билайновский интерфейс

interface=bridge-local - домашняя локалка с тв-приставкой

 

 

настройка firewall'а

/ip firewall filter  
add chain=input comment="Allow IGMP" protocol=igmp  
add chain=input comment="Allow UDP" protocol=udp  
add chain=forward comment="Allow UDP" protocol=udp

после, следующие правила поднять вверх, над всем дропами

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@corbinatman, далее подключаетесь по ssh к своему роутеру и выполняете пару строк:

 

 

 

 

 

UM3x.jpg

 

5 секунд и проверьте кабель

фаервол выключил совсем, перезагружал.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@corbinatman, можете интерфейсы показать?

я могу показать что угодно скринами )

Только бы помогли :cray:

 

qSou.jpg

 

ether3 - ноут

ether4 - свободен

 

 

 

Экспорт конфига, может быть поможет...

# aug/14/2015 22:20:56 by RouterOS 6.30.2
# software id = 121212
#
/interface bridge
add admin-mac=D4:CA:11:F3:11:DF auto-mac=no name=bridge-local
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
   disabled=no distance=indoors frequency=auto l2mtu=1600 mode=ap-bridge \
   rx-chains=0,1 ssid=MikroTik-F338E2 tx-chains=0,1 wireless-protocol=802.11
/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] master-port=ether2-master-local name=\
   ether3-slave-local
set [ find default-name=ether4 ] master-port=ether2-master-local name=\
   ether4-slave-local
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge-local name=default
/interface bridge port
add bridge=bridge-local interface=ether2-master-local
add bridge=bridge-local interface=wlan1
/ip address
add address=192.168.88.1/24 comment="default configuration" interface=\
   ether2-master-local network=192.168.88.0
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid disabled=\
   no interface=ether1-gateway
/ip dhcp-server network
add address=192.168.88.0/24 comment="default configuration" gateway=\
   192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add action=fasttrack-connection chain=forward comment="default configuration" \
   connection-state=established,related
add chain=forward comment="default configuration" connection-state=\
   established,related
add action=drop chain=forward comment="default configuration" \
   connection-state=invalid
add action=drop chain=forward comment="default configuration" \
   connection-nat-state=!dstnat connection-state=new in-interface=\
   ether1-gateway
add chain=input comment="Allow IGMP" protocol=igmp
add chain=input comment="Allow UDP" protocol=udp
add chain=forward comment="Allow UDP" protocol=udp
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" \
   out-interface=ether1-gateway
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=bridge-local type=internal
add interface=ether1-gateway type=external
/routing igmp-proxy
set query-interval=30s query-response-interval=20s
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=ether1-gateway upstream=yes
add interface=bridge-local
/system clock
set time-zone-name=Europe/Moscow
/system routerboard settings
set cpu-frequency=650MHz protected-routerboot=disabled
/tool romon port
add

Изменено пользователем corbinatman

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@corbinatman, смотрите у вас правила:

/ip firewall filter
add action=fasttrack-connection chain=forward comment="default configuration" \
   connection-state=established,related
add chain=forward comment="default configuration" connection-state=\
   established,related
add action=drop chain=forward comment="default configuration" \
   connection-state=invalid
add action=drop chain=forward comment="default configuration" \
   connection-nat-state=!dstnat connection-state=new in-interface=\
   ether1-gateway
add chain=input comment="Allow IGMP" protocol=igmp
add chain=input comment="Allow UDP" protocol=udp
add chain=forward comment="Allow UDP" protocol=udp

что я ранее говорил три последних правила (add) перетащить над первым drop'ом, а лучше поставить вначале.

Изменено пользователем  Ni©olas

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

я же файевол вырубаю, получается в правилах толку нет

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@corbinatman, попробуйте перетащить! работает с правилами ниже:

 

 

ip firewall filter print 
Flags: X - disabled, I - invalid, D - dynamic 
0  D ;;; special dummy rule to show fasttrack counters
     chain=forward 

1    ;;; default configuration
     chain=input action=accept protocol=icmp log=no log-prefix="" 

2    ;;; default configuration
     chain=input action=accept connection-state=established,related log=no log-prefix="" 

3    ;;; Allow IGMP
     chain=input action=accept protocol=igmp in-interface=ether1-gateway log=no log-prefix="" 

4    ;;; Allow UDP
     chain=input action=accept protocol=udp log=no log-prefix="" 

5    ;;; Allow UDP
     chain=forward action=accept protocol=udp log=no log-prefix="" 

6    ;;; default configuration
     chain=input action=drop in-interface=ether1-gateway log=no log-prefix="" 

7    ;;; default configuration
     chain=forward action=fasttrack-connection connection-state=established,related log=no log-prefix="" 

8    ;;; default configuration
     chain=forward action=accept connection-state=established,related log=no log-prefix="" 

9    ;;; default configuration
     chain=forward action=drop connection-state=invalid log=no log-prefix="" 

10    ;;; default configuration
     chain=forward action=drop connection-state=new connection-nat-state=!dstnat in-interface=ether1-gateway log=no log-prefix="" 

 

 

Изменено пользователем  Ni©olas

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Mikrotik. FAQ - Настройка Интернета и Цифрового телевидения от Билайн.

Без всяких l2tp, а с помощью ipoe - подключил и пользуйся :)

Если ТВ приставки нет, то пункты: 3, 4, 5, 6 выполнять не нужно )

 

1. Подключаем кабель билайна в ether1, ТВ приставку билайна в ether2

2. System - Reset Configuration - Reset Configuration ...перезагружается

3 Установить пакет Multicast http://www.mikrotik.com/download

Скачать, распаковать архив, найти в нём файл multicast-xx-xxxx.npk нужно переместить его (Drag&Drop) в окно раздела меню Files.

Перегрузить маршрутизатор, System – Reboot

4. Копирум в буфер обмена код. (см. ниже)

5. New-Terminal - правый клик - Paste - Enter

6. IP - Firewall - переместить выделенные позиции (короче, сделать как на рисунке)

 

ВСЕ!

Инет работает, ТВ приставка работает!

 

Спасибо, Ni©olas!

 

P.S. Надеюсь, данный "алгоритм действий" поможет многим "одаренным" пользователям :D

 

MikroTik hAP lite - RouterOS 6.30

 

KkXBM98.png

 

/routing igmp-proxy  
set query-interval=30s query-response-interval=20s quick-leave=no

/routing igmp-proxy interface  
add alternative-subnets=0.0.0.0/0 interface=ether1-gateway upstream=yes  
add interface=bridge-local

/ip firewall filter  
add chain=input comment="Allow IGMP" protocol=igmp  
add chain=input comment="Allow UDP" protocol=udp  
add chain=forward comment="Allow UDP" protocol=udp

Изменено пользователем corbinatman

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@corbinatman, не за что! :)

Вопрос!

Какой все таки вариант лучше для работы приставки: через bridge или IGMP?

Вариант IGMP сильно потребляет ресурсы роутера?

И BRIDGE сильно потребляет ресурсы роутера?

Спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вопрос!

...

это не вопрос ;)

 

....

Какой все таки вариант лучше для работы приставки: через bridge или IGMP?

...

все зависит от схемы подключения! бывает, что и мост выгоден, а бывает, что лучше igmp

 

...

Вариант IGMP сильно потребляет ресурсы роутера?

И BRIDGE сильно потребляет ресурсы роутера?

....

не знаю! трудно сказать, думаю нет, на примере 951 девайса.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

мне вариант через igmp не подошел, потому что шел какой-то гигантский обьем трафика и каналы при переключении имели небольшую но паузу, кроме того не работал лк через приставу ну и некоторые другие опции.

поэтому как альтернативный вариант можно попробовать так:

1)жмем interfaces> выбираем порт приставки, вполне подойдут последние, например (ether4-slave-local или ether5-slave-local) и там выбираем Master port none post-861774-045181100 1439615853_thumb.png

2)после жмем вкладку Bridge, жмем +, и называем наш мост допустим tv post-861774-089899600 1439609693_thumb.png

3)после переходим на вкладку Bridge>Ports, жмем + и соединяем последовательно

порт куда кабель биллайна interface (ether1-gateway) и bridge(tv)

порт куда приставка interface (ether5-slave-local) и bridge(tv) post-861774-040250400 1439609950_thumb.png

Изменено пользователем romanekb

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@corbinatman, @romanekb, и всем остальным, выбор типа подключения остаётся только за вами. Каждый вариант имеет свои плюсы и минусы. Bridge более стабилен и менее затратен(условно, так как можно на…евертить по разному). IGMP пропускает пакеты внутрь домашней сети (в отличии от специально созданного bridge), в этом есть ряд преимуществ. Например:

 

1) Устройство, получающее multicast трафик, доступно из домашней сети. Яркий пример – xbox. Он должен быть доступен с домашнего пк, он должен достучаться до домашней медиа библиотеки, и при этом принимать тв.

 

2) Бывают видео семинары, вещающие в инете по multicast-у.

 

3) IGMP это отдельный протокол, и, вещание телевидения, это одна из его возможностей. Многие специфичные программу не прочь воспользоваться igmp. И вы, как пользователь об этом даже и не будете знать, а комфорту с той или иной программой добавится.

 

4) Возможности конфигурации – отсутствие возможности физической протяжки кабеля по квартире до приставки. IGMP позволяет передавать сигнал по штатной вафле, то есть не надо покупать дополнительную и строить отдельный мост.

 

Траблы, возникающие от непонимания технологий: четвёртого пункта, по возможности, надо избегать. Multicast трафик, в данном случае, очень сильно снижает пропускные возможности беспроводной сети, а также влияет на проводную домашнюю. В mikrotik, по умолчанию, wi-fi объединён в bridge, и multicast забивает канал. По этому, если вам не требуется передавать multicast в эфир то изолируйте wi-fi от этого трафика.

 

 

 

 

 

мне вариант через igmp не подошел, потому что шел какой-то гигантский обьем трафика и каналы при переключении имели небольшую но паузу, кроме того не работал лк через приставу ну и некоторые другие опции.

 

 

 

 

Здесь, только, ваши кривые руки.

 

 

  • Upvote 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

 

Спасибо за подробные пояснения!

 

Настроил через IGMP и забыл )

Все четко и быстро работает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Хелп!!!

Скорость WIFI - 1 мегабит в среднем, пинг под 250)

Как только отключаю кабель приставки от роутера - 50-75 мегабит в среднем, пинг 1-5 мс.

Что и где настроить, чтобы и тв-приставка работала и wifi на полную?

 

ps приставка работает через IGMP

 

Спасибо!

 

Решение:

/interface bridge filter add chain=output out-interface=wlan1 action=drop mac-protocol=ip packet-type=multicast

 

Ni©olas

 

Управление свитчом в Mikrotik

В микротике есть возможность сделать работу 2 портов, к примеру, как работу в свитче?

Можно сделать ether1 < > ether2 в режиме свитча?

и тогда бы отпали IGMP и правила в файервол, или я не прав.

Изменено пользователем corbinatman

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@corbinatman, если вы говорите про "тв-порт" (почти bridge), то да, igmp и firewall не надо заморачиваться. конечно, если железка позволит это сделать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сброс настроек

Все инструкции ниже написаны исходя из предположения, что у вас применены дефолтные настройки. Если вы уже начитались других советов/форумов/статей, попробовали все и вся, окончательно запутались, а все равно ничего не работает — сбросьте настройки на дефолтную конфигурацию.

system reset-configuration

Ломать - не строить? Это же не наш метод! Нужно всего лишь удалить костыли:

 

  • Удалить 4 маршрута (2 до dns, 2 до серверов vpn),
  • Удалить parameter_request_list. Заодно увеличить метрику, чтобы была больше, чем у l2tp (прощай локалка),
  • Удалить фейковый Remote Address.

Правила change MSS я оставил, потому что без них все равно пол интернета не открывается.

И для себя добавил маршрут 10.0.0.0/8 - здравствуй локалка.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@corbinatman, если вы говорите про "тв-порт" (почти bridge), то да, igmp и firewall не надо заморачиваться. конечно, если железка позволит это сделать.

MikroTik hAP lite - можно на нем второй порт сделать как свитч (1 и 2 порт в режиме свитча)?

 

KrsoI0y.png

Изменено пользователем corbinatman

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@corbinatman, тут вот есть информация

У меня Atheros8227

и там про коммутацию ничего нет (

предположим, что коммутация есть - и как ее настроить, помогите, если это возможно)

 

Ay9eAOX.png

 

на картинке показано то, что я хочу)

а здесь целая тема - http://mum.mikrotik.com/presentations/IT14/starnowski.pdf

Огромная просьба, подскажите, возможно ли на моем роутере сделать свитч как на картинке?

Спасибо!

Изменено пользователем corbinatman

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@corbinatman,

 

Во-первых, просите яснее – у hap lite четыре порта

 

Во-вторых, как правило аппаратное ограничение – один swich на чип

 

В-третьих, что мешает попробовать?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас