Архивировано

Эта тема находится в архиве и закрыта для публикации сообщений.

xSeagullx

xl2tpd есть DNS, CHAP успешен, нету соединения

Рекомендованные сообщения

[Проблема решена, см конец сообщения]

 

Доброго времени суток, уважаемые форумчане.

 

Уже пару дней не могу настроить l2tp соединение. Не могу понять проблему. Судя по логам, авторизация прошла успешно, и вроде как канал должен был подняться. Но нет, когда останавливаю службу xl2tpd пишет, что отправлено 0 байт. Пингуются все tp.internet.beeline.ru сервера, работает DNS. Но более ничего не пингуется. Например Яндекс, или Google. Хотя адреса определяются.

 

Подскажите пожалуйста, куда копать. Если что-то не приложил, пишите - будет.

 

Вырезано из syslog

 

 

Где-то на этапе запуска

Mar 10 23:45:51 seagull pppd[6934]: CHAP authentication succeeded

Повторяется что-то такое. Не пойму, что это.

...

Mar 10 23:45:58 seagull xl2tpd[6330]: Can not find tunnel 26428 (refhim=0)

Mar 10 23:45:58 seagull xl2tpd[6330]: network_thread: unable to find call or tunnel to handle packet. call = 0, tunnel = 26428 Dumping.

Mar 10 23:45:58 seagull xl2tpd[6330]: network_thread: recv packet from 78.107.1.171, size = 36, tunnel = 26428, call = 18929 ref=0 refhim=0

...

После остановки

Connect time 2.7 minutes.

Mar 10 23:48:31 seagull pppd[6934]: Sent 0 bytes, received 6610 bytes.

 

 

sudo route

 

[sudo] password for seagull:

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

default 10.57.64.1 0.0.0.0 UG 0 0 0 em1

10.57.64.0 * 255.255.248.0 U 0 0 0 em1

78.107.1.0 10.57.64.1 255.255.255.0 UG 0 0 0 em1

hdns2.corbina.n 10.57.64.1 255.255.255.255 UGH 0 0 0 em1

192.168.2.0 * 255.255.255.0 U 0 0 0 br0

hdns1.corbina.n 10.57.64.1 255.255.255.255 UGH 0 0 0 em1

 

 

Основные настройки:

 

 

[global]

access control = yes

port = 1701

auth file = /etc/ppp/chap-secrets

debug network = yes

debug tunnel = yes

 

[lac beeline]

lns = tp.internet.beeline.ru

require chap = yes

name = <мой логин>

ppp debug = yes

pppoptfile = /etc/ppp/options.xl2tpd

tx bps = 1000000000

redial = yes

redial timeout = 1

autodial = yes

 

Скрипт ниже запускается, лежит в ip-up.d/ Прописывает в таблицу пути к DNS и удаляет паразитный маршрут.

#!/bin/sh

# Скрипт для удаления паразитного маршрута

# env > /tmp/env.vpn

 

if [ $LINKNAME = "beeline-l2tp" ]; then

GW=10.57.64.1

# Delete parasite route

ip route del $5 dev $1

#add route to name servers

for i in $(grep "^nameserver" /etc/resolv.conf | awk '{print $2}') ; do

route add -host $i gw $GW

done

 

echo "Выполнен delroute" >> /var/log/syslog

echo "5 параметр:" $5 >> /var/log/syslog

echo "1 параметр:" $1 >> /var/log/syslog

else

echo "Не выполнен delroute" >> /var/log/syslog

fi

exit 0

 

 

# Beeline Интернет

unit 8

name <мой логин>

remotename l2tp

linkname beeline-l2tp

connect /bin/true

noauth

defaultroute

mtu 1460

mru 1460

 

 

Приложен полный syslog одной попытки подключения.

 

 

Проблема решилась после внимательного взгляда на таблицу маршрутов.

 

Шлюз по-умолчанию был выставлен неверно, им вообще должен заведовать pppd. Вручную надо было прописывать только маршруты до DNS и в подсеть tp.internet.beeline.ru серверов. На момент старта xl2tpd шлюза по-умолчанию стоять не должно было.

 

Досадно, что никто не откликнулся, на забугорных форумах такое бывает редко, отвык. Вероятно либо я плохо задал вопрос, либо тут никого разбирающегося не бывает(что странно и маловероятно).

В любом случае, проблема решена, тему можно закрывать.

syslog.txt

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость
Эта тема закрыта для публикации сообщений.