Архивировано

Эта тема находится в архиве и закрыта для публикации сообщений.

zotoz

openvpn --> putty --> top

Рекомендованные сообщения

Собственно столкнулся со следующей проблемой:

подключаюсь к серверу OpenVPN в интернете,

поднимаю сессию SSH2

логин пароль все нормально.

даже команда df работает =)

но как только я запускаю top. у меня черный экран перед глазами.

 

Вопрос: что делать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

попробуй другой клиент ? SecureCRT, к примеру... там всё гибко настраиваемо и есть табы...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

попробуй другой клиент ? SecureCRT, к примеру... там всё гибко настраиваемо и есть табы...

Спасибо за отклик, прям не ожидал что моя тема хоть кому-то будет интересна.

ssh клиент SecureCRT в самом деле хорошая программа, но боюсь мой проблемму она не решила.

 

С подобным я столкнулся в первые за свой 5 летний опыт интимных отношений с information technology.

До боли обидно что RDP работает как часы в этом же VPN, а *inux сервера остались без моего чуткого внимая.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

С подобным я столкнулся в первые за свой 5 летний опыт интимных отношений с information technology.

До боли обидно что RDP работает как часы в этом же VPN, а *inux сервера остались без моего чуткого внимая.

 

вопрос номер раз для человека, с "5 летним опытом": каким образом связаны тип соединения с сетью и внутренние данные внутри протокола подключения к удалённой машине ? программе, работающей с сетью, совершенно не важно, как система имеет эту сеть.

лично я за 21 год общения с ПК знаю, что когда не отправляются какие-то команды в SSH - следует изменить тип эмуляции клавиатуры... что примерно то же самое, что понюхать руки =)

 

ЗЫЖ мои руки до сих пор отдают некими запахами, так как до сих пор сам мучаюсь, то удаётся настроить введение кириллицы на удалённой машине, то нет... из разных мест при подключении к одному и тому же серверу - разные возможности =)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

проблема разрешись сама собой. Или мой танцы с бубном помогли. На данный момент могу констатировать что ПРОБЛЕМЫ НЕТ.

 

Да Я понимаю что соединения с сетью и внутренние данные внутри протокола ни как не соприкасаются это разные уровни модели OSI. Я больше рассчитывал на братскую помощь, =) которую вы мне и оказали. Большое спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ну и отличненько... обычно люди обижаются на мой стиль ответов, но я не стараюсь кого-то унизить, просто в таком ключе общение запоминается для дальнейшей эксплуатации полученных знаний =)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

=) Я решил проблему. Добавляем в конфиг OPENvpn клиента tun-mtu 1300 и будет нам счастье.

Подобная проблема есть и у других провайдеров вот на хабре

кто-то столкнулся

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

=) Я решил проблему. Добавляем в конфиг OPENvpn клиента tun-mtu 1300 и будет нам счастье.

Подобная проблема есть и у других провайдеров вот на хабре

кто-то столкнулся

 

Подтверждаю! Добавление в конфигурационный файл (*.ovpn) строки tun-mtu 1300 решает проблему!

 

У меня без этой строки openvpn работал со всеми провайдерами кроме домашнего интернет от Билайн (подключение L2TP), где н собственно говоря и был нужен прежде всего.

 

Симптомы были следующие: openvpn соединение с удалённым сервером устанавливал, winSCP при запуске проходил авторизацию, но не мог получить доступ к удалённому каталогу.

 

 

Спасибо за наводку! :-)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах