test0912

Рабочие настройки для IPTV на Mikrotik

Рекомендованные сообщения

@pepelxl,

 

Да, всё верно это и приходило, но видимо я что-то с НАТом нахимичил, т.к. 78.107.197.40 у меня доступен только через интернет добавил src-nat masquerade на ethernet перед аналогичным на l2tp и пакеты пошли через шлюз, странно всё это

 

 

И ещё надо ручками DNS (85.21.0.0/24, 213.234.192.0/24 и 85.21.192.0/24) всё таки добавлять, по dhcp они не приходят :)

Изменено пользователем Black_Sun

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всем привет!

Сорри, если оффтоп, но подходящей темы не нашел.

Проблема следующая:

Примерно раз в 5-7 мин изображение на тв "замерзает" примерно на секунду-полторы, рассыпается на квадраты, потом все нормально до следующего "цикла"

Прошу помощи, нужные конфиги готов скинуть.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здесь как на первой линии ТП. Подключаем кабель к приставке на прямую и смотрим результат. Так как в протоколе нет ничего с интервалом в 5 минут.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Привет еще раз! Проснувшись с утра получил радостное понимание того, что был переведен на 100.ххх адреса. Интернет поднять удалось, а вот тв приставка не заводится вообще. Прошу помощи, домашние воют, жизнь пошла прахом (((

Под спойлером экспорт из терминала.

 

 

may/22/2015 19:54:08 system,error,critical login failure for user root from 95.70.156.11 via telnet

may/22/2015 19:54:17 system,error,critical login failure for user root from 95.70.156.11 via telnet

may/22/2015 19:54:26 system,error,critical login failure for user tech from 95.70.156.11 via telnet

may/22/2015 19:54:35 system,error,critical login failure for user manager from 95.70.156.11 via telnet

may/22/2015 19:54:44 system,error,critical login failure for user from 95.70.156.11 via telnet

[EuKlement@MikroTik] > export

# may/22/2015 21:16:06 by RouterOS 6.28

# software id = RX1L-3ITE

#

/interface bridge

add admin-mac=4C:5E:0C:DE:5C:37 auto-mac=no mtu=1500 name=bridge-local

/interface wireless

set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode \

band=2ghz-b/g/n country=russia disabled=no distance=indoors frequency=\

2417 hw-protection-mode=rts-cts l2mtu=2290 mode=ap-bridge ssid=\

RastaFashion tx-power=20 tx-power-mode=all-rates-fixed wireless-protocol=\

802.11

/interface ethernet

set [ find default-name=ether1 ] name=ether1-gateway

set [ find default-name=ether2 ] name=ether2-master-local

set [ find default-name=ether3 ] master-port=ether2-master-local name=\

ether3-slave-local

set [ find default-name=ether4 ] master-port=ether2-master-local name=\

ether4-slave-local

set [ find default-name=ether5 ] name=ether5-slave-local

/ip neighbor discovery

set ether1-gateway discover=no

/interface ethernet switch port

set 3 vlan-mode=check

/interface wireless security-profiles

set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" \

group-ciphers=tkip,aes-ccm mode=dynamic-keys unicast-ciphers=tkip,aes-ccm \

wpa-pre-shared-key=xxx wpa2-pre-shared-key=xxx

/ip pool

add name=default-dhcp ranges=192.168.88.10-192.168.88.254

/ip dhcp-server

add address-pool=default-dhcp disabled=no interface=bridge-local name=default

/ppp profile

add name=Beeline remote-address=192.168.255.254 use-compression=no \

use-encryption=no use-vj-compression=no

/interface l2tp-client

add add-default-route=yes allow=chap connect-to=tp.internet.beeline.ru \

disabled=no max-mru=1500 max-mtu=1460 name=Beeline password=\

xxx profile=Beeline user=xxx

/interface bridge port

add bridge=bridge-local interface=ether2-master-local

add bridge=bridge-local interface=wlan1

/ip address

add address=192.168.88.1/24 comment="default configuration" interface=\

bridge-local network=192.168.88.0

/ip dhcp-client

add comment="default configuration" default-route-distance=2 dhcp-options=\

hostname,clientid disabled=no interface=ether1-gateway

/ip dhcp-server network

add address=192.168.88.0/24 comment="default configuration" dns-server=\

192.168.88.1 gateway=192.168.88.1

/ip dns

set allow-remote-requests=yes

/ip dns static

add address=192.168.88.1 name=router

/ip firewall filter

add chain=input comment="default configuration" protocol=icmp

add chain=input comment="default configuration" connection-state=established

add chain=input comment="default configuration" connection-state=related

add action=drop chain=input comment="default configuration" in-interface=\

ether1-gateway

add chain=forward comment="default configuration" connection-state=\

established

add chain=forward comment="default configuration" connection-state=related

add action=drop chain=forward comment="default configuration" \

connection-state=invalid

add chain=input comment="Allow IGMP"

add chain=input comment="Allow IGMP" protocol=igmp

add chain=input comment="Allow UDP" protocol=udp

add chain=forward comment="Allow UDP" protocol=udp

/ip firewall mangle

add action=change-mss chain=forward in-interface=Beeline new-mss=1416 \

protocol=tcp tcp-flags=syn tcp-mss=1417-65535

add action=change-mss chain=forward new-mss=1416 out-interface=Beeline \

protocol=tcp tcp-flags=syn tcp-mss=1417-65535

/ip firewall nat

add action=masquerade chain=srcnat comment="default configuration" \

out-interface=ether1-gateway

add action=masquerade chain=srcnat out-interface=Beeline to-addresses=0.0.0.0

/ip firewall service-port

set ftp disabled=yes

set tftp disabled=yes

/ip proxy

set cache-path=web-proxy1

/ip route

add comment="Beeline VPN server subnet" distance=1 dst-address=85.21.0.0/24 \

gateway=100.94.0.1

add comment="Beeline DNS server subnet" distance=1 dst-address=85.21.192.0/24 \

gateway=100.94.0.1

add comment="Beeline DNS server subnet" distance=1 dst-address=\

213.234.192.0/24 gateway=100.94.0.1

/ip service

set telnet disabled=yes

set ftp disabled=yes

set ssh disabled=yes

/romon port

add disabled=no

/routing igmp-proxy

set query-interval=30s query-response-interval=20s

/routing igmp-proxy interface

add alternative-subnets=78.107.196.0/22,10.0.0.0/8 interface=ether1-gateway \

upstream=yes

/system clock

set time-zone-name=Europe/Moscow

/system leds

set 0 interface=wlan1

/tool mac-server

set [ find default=yes ] disabled=yes

add interface=ether2-master-local

add interface=ether3-slave-local

add interface=ether4-slave-local

add interface=ether5-slave-local

add interface=wlan1

add interface=bridge-local

/tool mac-server mac-winbox

set [ find default=yes ] disabled=yes

add interface=ether2-master-local

add interface=ether3-slave-local

add interface=ether4-slave-local

add interface=ether5-slave-local

add interface=wlan1

add interface=bridge-local

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Rastafashion,

 

попробуйте для начала добавить в ip->DHCP-client->client options опцию:

name parameter_request_list

code 55

value 0x01F9032106

 

после естессно добавить опцию в текущий клиент, 3 строчкой, вот так http://s47.radikal.r...08b8e14dd83.png

ну и выкл/вкл его

 

и проверить работу, если не поможет, выкладывайте ip route print целиком

Изменено пользователем Black_Sun

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Black_Sun,

Не завелся телевизор (

 

 

 

ip route print

Flags: X - disabled, A - active, D - dynamic,

C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,

B - blackhole, U - unreachable, P - prohibit

# DST-ADDRESS PREF-SRC GATEWAY DISTANCE

0 ADS 0.0.0.0/0 192.168.255.254 1

1 ADS 10.25.0.0/26 100.94.0.1 2

2 ADS 78.107.52.0/26 100.94.0.1 2

3 ADS 78.107.125.161/32 100.94.0.1 2

4 DS 78.107.125.161/32 100.94.0.1 2

5 ADS 78.107.196.0/22 100.94.0.1 2

6 ADS 83.102.180.160/28 100.94.0.1 2

7 A S ;;; Beeline VPN server subnet

85.21.0.0/24 100.94.0.1 1

8 A S ;;; Beeline DNS server subnet

85.21.192.0/24 100.94.0.1 1

9 ADC 100.94.0.0/18 100.94.33.20 ether1-gateway 0

10 ADC 192.168.88.0/24 192.168.88.1 bridge-local 0

11 ADC 192.168.255.254/32 95.28.70.81 Beeline 0

12 A S ;;; Beeline DNS server subnet

213.234.192.0/24 100.94.0.1 1

 

 

 

Пока писал этот пост глянул еще раз в маршруты (ip>routes)

Весь блок адресов 78.xxxxxx исчез.

теперь лист выглядит так

 

 

 

Flags: X - disabled, A - active, D - dynamic,

C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,

B - blackhole, U - unreachable, P - prohibit

# DST-ADDRESS PREF-SRC GATEWAY DISTANCE

0 ADS 0.0.0.0/0 192.168.255.254 1

1 DS 0.0.0.0/0 100.94.0.1 2

2 A S ;;; Beeline VPN server subnet

85.21.0.0/24 100.94.0.1 1

3 A S ;;; Beeline DNS server subnet

85.21.192.0/24 100.94.0.1 1

4 ADC 100.94.0.0/18 100.94.33.20 ether1-gateway 0

5 ADC 192.168.88.0/24 192.168.88.1 bridge-local 0

6 ADC 192.168.255.254/32 95.28.70.81 Beeline 0

7 A S ;;; Beeline DNS server subnet

213.234.192.0/24 100.94.0.1 1

 

 

Изменено пользователем Rastafashion

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Black_Sun,

Не завелся телевизор (

 

 

 

ip route print

Flags: X - disabled, A - active, D - dynamic,

C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,

B - blackhole, U - unreachable, P - prohibit

# DST-ADDRESS PREF-SRC GATEWAY DISTANCE

0 ADS 0.0.0.0/0 192.168.255.254 1

1 ADS 10.25.0.0/26 100.94.0.1 2

2 ADS 78.107.52.0/26 100.94.0.1 2

3 ADS 78.107.125.161/32 100.94.0.1 2

4 DS 78.107.125.161/32 100.94.0.1 2

5 ADS 78.107.196.0/22 100.94.0.1 2

6 ADS 83.102.180.160/28 100.94.0.1 2

7 A S ;;; Beeline VPN server subnet

85.21.0.0/24 100.94.0.1 1

8 A S ;;; Beeline DNS server subnet

85.21.192.0/24 100.94.0.1 1

9 ADC 100.94.0.0/18 100.94.33.20 ether1-gateway 0

10 ADC 192.168.88.0/24 192.168.88.1 bridge-local 0

11 ADC 192.168.255.254/32 95.28.70.81 Beeline 0

12 A S ;;; Beeline DNS server subnet

213.234.192.0/24 100.94.0.1 1

 

 

 

Пока писал этот пост глянул еще раз в маршруты (ip>routes)

Весь блок адресов 78.xxxxxx исчез.

теперь лист выглядит так

 

 

 

Flags: X - disabled, A - active, D - dynamic,

C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,

B - blackhole, U - unreachable, P - prohibit

# DST-ADDRESS PREF-SRC GATEWAY DISTANCE

0 ADS 0.0.0.0/0 192.168.255.254 1

1 DS 0.0.0.0/0 100.94.0.1 2

2 A S ;;; Beeline VPN server subnet

85.21.0.0/24 100.94.0.1 1

3 A S ;;; Beeline DNS server subnet

85.21.192.0/24 100.94.0.1 1

4 ADC 100.94.0.0/18 100.94.33.20 ether1-gateway 0

5 ADC 192.168.88.0/24 192.168.88.1 bridge-local 0

6 ADC 192.168.255.254/32 95.28.70.81 Beeline 0

7 A S ;;; Beeline DNS server subnet

213.234.192.0/24 100.94.0.1 1

 

 

 

Ещё раз повторяю:

 

name parameter_request_list

code 55

value 0x01F9032106

 

В СОТКЕ НЕ РАБОТАЕТ (mikrotik теряет маршруты через пять минут(свинья от билайна)).

 

Вам сначала надо определится по какой схеме вы подключаете приставку через роутер – bridge, switch или igmp proxy.

 

Если вы пытаетесь настроить по моему посту(igmp), то теперь:

 

/routing igmp-proxy

set query-interval=30s query-response-interval=20s quick-leave=no

/routing igmp-proxy interface

add alternative-subnets=78.107.196.0/22,78.107.52.0/26 interface=ether1-gateway upstream=yes

add interface=bridge-local

/ip route

add distance=1 dst-address=233.0.0.0/8 gateway=ether1-gateway

add distance=1 dst-address=78.107.196.0/22 gateway=100.94.0.1

add distance=1 dst-address=78.107.52.0/26 gateway=100.94.0.1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@pepelxl,

О как, получается вручную всё надо будет в IPoE прописывать, зачем такая свинья не знаете?

Изменено пользователем Black_Sun

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В ipoe х.з., доживём, посмотрим. Скорее всего, всё равно понадобится:

 

/ip route

add distance=1 dst-address=233.0.0.0/8 gateway=ether1-gateway

 

А сейчас все маршруты ручками, как автоматизировать процесс пока размышляю, но ни чего путного в голову не приходит.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Black_Sun,

Видимо из-за того, что мои посты это по сути оффтоп, я ввел вас в заблуждение. Прошу меня ростить. Я пытаюсь завести тв-приставку. Каналы на компе мне не нужны (ну или пусть будут приятным бонусом)

 

@pepelxl,

Вам сначала надо определится по какой схеме вы подключаете приставку через роутер – bridge, switch или igmp proxy.

Ваши рекомендации?

Я ресетнул роутер в дефолт ибо как обезъяна писал, не понимая что конкретно я делаю. Сейчас его экспорт выглядит так

 

 

 

/interface bridge

add admin-mac=4C:5E:0C:DE:5C:37 auto-mac=no name=bridge-local

/interface wireless

set [ find default-name=wlan1 ] band=2ghz-b/g/n country=russia disabled=no \

distance=indoors frequency=2417 l2mtu=2290 mode=ap-bridge ssid=\

RastaFashion tx-power=20 tx-power-mode=all-rates-fixed wireless-protocol=\

802.11

/interface ethernet

set [ find default-name=ether1 ] name=ether1-gateway

set [ find default-name=ether2 ] name=ether2-master-local

set [ find default-name=ether3 ] master-port=ether2-master-local name=\

ether3-slave-local

set [ find default-name=ether4 ] name=ether4-slave-local

set [ find default-name=ether5 ] master-port=ether2-master-local name=\

ether5-slave-local

/ip neighbor discovery

set ether1-gateway discover=no

/interface wireless security-profiles

set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" \

group-ciphers=tkip,aes-ccm mode=dynamic-keys unicast-ciphers=tkip,aes-ccm \

wpa-pre-shared-key=xxxxxxx wpa2-pre-shared-key=xxxxxxx

/ip dhcp-client option

add code=55 name=parameter_request_list value=0x01F9032106

/ip pool

add name=default-dhcp ranges=192.168.88.10-192.168.88.254

/ip dhcp-server

add address-pool=default-dhcp disabled=no interface=bridge-local name=default

/ppp profile

add name=Beeline remote-address=192.168.255.254 use-compression=no \

use-encryption=no use-vj-compression=no

/interface l2tp-client

add add-default-route=yes allow=chap connect-to=tp.internet.beeline.ru \

disabled=no max-mru=1500 max-mtu=1460 name=Beeline password=\

хххх profile=Beeline user=ххххх

/interface bridge port

add bridge=bridge-local interface=ether2-master-local

add bridge=bridge-local interface=wlan1

/ip address

add address=192.168.88.1/24 comment="default configuration" interface=\

bridge-local network=192.168.88.0

/ip dhcp-client

add comment="default configuration" default-route-distance=2 dhcp-options=\

parameter_request_list,clientid disabled=no interface=ether1-gateway

/ip dhcp-server network

add address=192.168.88.0/24 comment="default configuration" gateway=\

192.168.88.1

/ip dns

set allow-remote-requests=yes

/ip dns static

add address=192.168.88.1 name=router

/ip firewall filter

add chain=input comment="default configuration" protocol=icmp

add chain=input comment="default configuration" connection-state=\

established,related

add action=drop chain=input comment="default configuration" in-interface=\

ether1-gateway

add chain=forward comment="default configuration" connection-state=\

established,related

add action=drop chain=forward comment="default configuration" \

connection-state=invalid

add action=drop chain=forward comment="default configuration" \

connection-nat-state=!dstnat connection-state=new in-interface=\

ether1-gateway

/ip firewall nat

add action=masquerade chain=srcnat comment="default configuration" \

out-interface=ether1-gateway

add action=masquerade chain=srcnat out-interface=Beeline

/ip route

add comment="Beeline VPN server subnet" distance=1 dst-address=85.21.0.0/24 \

gateway=100.94.0.1

add comment="Beeline DNS server subnet" distance=1 dst-address=85.21.192.0/24 \

gateway=100.94.0.1

add comment="Beeline DNS server subnet" distance=1 dst-address=\

213.234.192.0/24 gateway=100.94.0.1

/romon port

add disabled=no

/system clock

set time-zone-name=Europe/Moscow

/system leds

set 0 interface=wlan1

/system ntp client

set primary-ntp=194.190.168.1

/tool mac-server

set [ find default=yes ] disabled=yes

add interface=ether2-master-local

add interface=ether3-slave-local

add interface=ether4-slave-local

add interface=ether5-slave-local

add interface=wlan1

add interface=bridge-local

/tool mac-server mac-winbox

set [ find default=yes ] disabled=yes

add interface=ether2-master-local

add interface=ether3-slave-local

add interface=ether4-slave-local

 

 

Если не сложно, порекомендуйте алгоритм шагов, по-возможности с описанием того, что именно я должен сделать.

Пока жду ответа, пойду руками в винбоксе маршруты пропишу. Они, как я понял по любому прописываются вручную. А вот дальше, с протоколами и правилами файрвола мне нужна будет помощь, ибо тут я как обезъяна на минном поле.

Изменено пользователем Rastafashion

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

По быстродействию проще всего switch. Какая модель роутера? К какому порту подключена приставка?

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Дайте команду:

/interface ethernet

set [ find default-name=ether4 ] master-port=ether1-gateway name=TV

 

 

Перезагрузите приставку.

 

 

  • Upvote 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Дайте команду:

/interface ethernet

set [ find default-name=ether4 ] master-port=ether1-gateway name=TV

 

 

Перезагрузите приставку.

/interface ethernet> set [find default-name=ether4] master-port=ether1

-gateway name=TV

failure: only one master port in switch group allowed

[xxxxxxxxx@MikroTik] /interface ethernet>

интерфейсы

 

 

03841a94105b6879d99d2c5872e2b9f5.png

 

Изменено пользователем Rastafashion

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

failure: only one master port in switch group allowed

 

 

Зы: Ограничение чипа.

 

Тогда так:

 

Создайте ещё один Bridge и запихните в него порты 1и 4.

 

Возможно понадобится перестройка DHCP клиента и правил фаирвола.

 

Потом перезапустите приставку.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

failure: only one master port in switch group allowed

 

 

Зы: Ограничение чипа.

 

Тогда так:

 

Создайте ещё один Bridge и запихните в него порты 1и 4.

 

Возможно понадобится перестройка DHCP клиента и правил фаирвола.

 

Потом перезапустите приставку.

 

В картинках то, как ругается железка. При этом интернет падает

post-451031-092049200 1432371962_thumb.png

post-451031-044614300 1432371975_thumb.png

post-451031-009801600 1432371985_thumb.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Логично, т.к. правила надо указывать на вновь созданный bridge а не на ether1-gateway

 

Приставка при этом заработала?

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да, приставка завелась с полпинка

правила надо указывать на вновь созданный bridge а не на ether1-gateway

Можно вас попросить объяснить что и как?

Изменено пользователем Rastafashion

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Что тут объяснять, просматриваем свой конфиг, Меняем в правилах ether1-gateway на bridge, Начиная с DHCP client – firewall- nat и т.д.

 

 

 

Красные строчки вам подсказывают.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Что-то где-то поменял, приставка работает, на форум захожу, яндекс пингуется, страницы не открываются.

 

 

/interface bridge

add name=TV

add admin-mac=4C:5E:0C:DE:5C:37 auto-mac=no name=bridge-local

/interface wireless

set [ find default-name=wlan1 ] band=2ghz-b/g/n country=russia disabled=no \

distance=indoors frequency=2417 l2mtu=2290 mode=ap-bridge ssid=\

RastaFashion tx-power=20 tx-power-mode=all-rates-fixed wireless-protocol=\

802.11

/interface ethernet

set [ find default-name=ether1 ] name=ether1-gateway

set [ find default-name=ether2 ] name=ether2-master-local

set [ find default-name=ether3 ] master-port=ether2-master-local name=\

ether3-slave-local

set [ find default-name=ether4 ] name=ether4-slave-local

set [ find default-name=ether5 ] master-port=ether2-master-local name=\

ether5-slave-local

/ip neighbor discovery

set ether1-gateway discover=no

/interface wireless security-profiles

set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" \

group-ciphers=tkip,aes-ccm mode=dynamic-keys unicast-ciphers=tkip,aes-ccm \

wpa-pre-shared-key=xxxxxxxx wpa2-pre-shared-key=xxxxxxx

/ip dhcp-client option

add code=55 name=parameter_request_list value=0x01F9032106

/ip pool

add name=default-dhcp ranges=192.168.88.10-192.168.88.254

/ip dhcp-server

add address-pool=default-dhcp disabled=no interface=bridge-local name=default

/ppp profile

add name=Beeline remote-address=192.168.255.254 use-compression=no \

use-encryption=no use-vj-compression=no

/interface l2tp-client

add add-default-route=yes allow=chap connect-to=tp.internet.beeline.ru \

disabled=no max-mru=1500 max-mtu=1460 name=Beeline password=\

xxxxxxxxx profile=Beeline user=xxxxxxxxx

add bridge=bridge-local interface=ether2-master-local

add bridge=bridge-local interface=wlan1

add bridge=TV interface=ether4-slave-local

add bridge=TV interface=ether1-gateway

/ip address

add address=192.168.88.1/24 comment="default configuration" interface=\

bridge-local network=192.168.88.0

/ip dhcp-client

add comment="default configuration" default-route-distance=2 dhcp-options=\

parameter_request_list,clientid disabled=no interface=TV

/ip dhcp-server network

add address=192.168.88.0/24 comment="default configuration" gateway=\

192.168.88.1

/ip dns

set allow-remote-requests=yes

/ip dns static

add address=192.168.88.1 name=router

/ip firewall filter

add chain=input comment="default configuration" protocol=icmp

add chain=input comment="default configuration" connection-state=\

established,related

add action=drop chain=input comment="default configuration" in-interface=TV

add chain=forward comment="default configuration" connection-state=\

established,related

add action=drop chain=forward comment="default configuration" \

connection-state=invalid

add action=drop chain=forward comment="default configuration" \

connection-nat-state=!dstnat connection-state=new in-interface=TV

/ip firewall nat

add action=masquerade chain=srcnat comment="default configuration" \

out-interface=TV

add action=masquerade chain=srcnat out-interface=TV

/ip route

add distance=1 dst-address=78.107.52.0/26 gateway=100.94.0.1

add distance=1 dst-address=78.107.196.0/22 gateway=100.94.0.1

add comment="Beeline VPN server subnet" distance=1 dst-address=85.21.0.0/24 \

gateway=100.94.0.1

add comment="Beeline DNS server subnet" distance=1 dst-address=85.21.192.0/24 \

gateway=100.94.0.1

add comment="Beeline DNS server subnet" distance=1 dst-address=\

213.234.192.0/24 gateway=100.94.0.1

add distance=1 dst-address=233.0.0.0/8 gateway=ether1-gateway

/romon port

add disabled=no

/system clock

set time-zone-name=Europe/Moscow

/system leds

set 0 interface=wlan1

/system ntp client

set primary-ntp=194.190.168.1

/tool mac-server

set [ find default=yes ] disabled=yes

add interface=ether2-master-local

add interface=ether3-slave-local

add interface=ether4-slave-local

add interface=ether5-slave-local

add interface=wlan1

add interface=bridge-local

/tool mac-server mac-winbox

set [ find default=yes ] disabled=yes

add interface=ether2-master-local

add interface=ether3-slave-local

add interface=ether4-slave-local

add interface=ether5-slave-local

add interface=wlan1

add interface=bridge-local

 

post-451031-057696400 1432374274_thumb.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Rastafashion,

Да, я думал что нужны каналы на ПК, из-за фразы о "замерзании" каналов, не думал что для приставки это тоже актуально, а можно такой вопрос, если у вас все порты работают как свитч, зачем вы купили микротик, про микротик можно наверное даже сказать "шаг влево, шаг вправо и ничего не работает"? много же домашних роутеров которые намного упрощают все процессы. Для интернета по идее будет достаточно srcnat на ether1 masquerade

 

pepelxl про мастер порт зачётно, элегантное решение, без заморочек :)

Изменено пользователем Black_Sun

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Rastafashion,

а, да, там ж теперь бридж TV объединён, вот я об этом же, слишком много вопросов нужно задать что бы получить много ответов, например зачем вам l2tp, зачем vpn, dns маршуры (не уверен в их нужности на IPoE, хотя DNS всё таки может и нужен), зачем делать все мастер порты на ether1, если всего портов 5, зачем дублирование правил NAT, зачем, зачем, зачем... и где разрешающее правило для bridge-local в firewall?

DNS static тоже не нужен, ip-DNS это куда обращается микротик для разрешения имён, там надо либо динамически оставить (если есть), либо пусто (хотя можно ещё с 8.8.8.8 и 8.8.4.4 попробовать)

Изменено пользователем Black_Sun

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Black_Sun,

Да нету ещё ни какого ipoe, кроме тестовых городов.

 

Как был vpn, так он и остался.

 

 

 

@Rastafashion,

В нате как было два правила на vpn тунель, так и надо, зачем правили. Два правила на местную сеть, в принципе тоже надо (в вашем случае Bridge TV), но при такой конфигурации, они, как рыбке зонтик. Придёт ipoe, тогда и оставите только на bridge tv.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ребят, честно ни пса не понял. (увы, ламер я. микротик купил по совету какого-то знакомого ибо семья пожелала смотреть билайн-тв)

До того, как гейты были в блоке 10.ххх все худо бедно работало именно с мостами. После того, как поменялось на сотку-либо интернет, либо тв.

В итоге дотыркался до того, что роутер вывалился в кирпич. Пришлось делать хард ресет. В итоге сейчас конфиг с рабочим интернетом все.

Куда мне двигаться дальше?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Rastafashion,

Наверное в магазин за ASUS RT-N14U например.

Плохой тот знакомый.

Просто реально зачем мучатся, я не понимаю, я бы наверно остался на N56U если бы была возможность, хотя с моего микротика я фиг куда слезу.

 

pepelxl имеет ввиду что в посту #76 3 скрине слева всё было хорошо и надо было сменить ether1 на тот созданный мост TV, а билайн оставить как был.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Black_Sun,

Я правильно понимаю, что сейчас у вас микротик, провайдер билайн, и все работает?)

UPD. Мужчины, спасибо огромное, все заработало.

Собрал конфиг из трех постов и вуаля.

Не знаю, насколько актуально будет в этой ветке (все же тема про iptv на компе), но если необходимо, выложу пошаговый алгоритм.

Изменено пользователем Rastafashion

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Выложи, конечно.

 

По возможности, напиши очень подробно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Все, я запутался с этим разнообразием настроек. Все перепробывал. Отпишитесь у кого реально все работает без всяких глюков и тормозов. Я пока еще на l2tp, Братеево на iPoe не перевели. Роутер Mikrotik RB2011UiAS-2HnD-IN

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

с настройкой под спойлером (интернет по ipoe) тв воркает, но где-то через минуту фриз. переключение канала спасает на минуту, и т.д. прошивка 6.30.2

 

 

 

/routing igmp-proxy
set query-interval=30s query-response-interval=20s quick-leave=no
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=ether1-gateway upstream=yes
add interface=bridge-local

где:

ether1-gateway - сеть билайн

bridge-local - xbox360 (с билайновским iptv)

 

 

firewall:

ip firewall filter print 
Flags: X - disabled, I - invalid, D - dynamic 
0  D ;;; special dummy rule to show fasttrack counters
     chain=forward 

1    ;;; default configuration
     chain=input action=accept protocol=icmp log=no log-prefix="" 

2    ;;; default configuration
     chain=input action=accept connection-state=established,related 
     log=no log-prefix="" 

3 X  ;;; Allow IGMP
     chain=input action=accept protocol=igmp 
     in-interface=ether1-gateway log=no log-prefix="" 

4    ;;; default configuration
     chain=input action=drop in-interface=ether1-gateway log=no 
     log-prefix="" 

5    ;;; default configuration
     chain=forward action=fasttrack-connection 
     connection-state=established,related log=no log-prefix="" 

6    ;;; default configuration
     chain=forward action=accept 
     connection-state=established,related log=no log-prefix="" 

7    ;;; default configuration
     chain=forward action=drop connection-state=invalid log=no 
     log-prefix="" 

8    ;;; default configuration
     chain=forward action=drop connection-state=new 
     connection-nat-state=!dstnat in-interface=ether1-gateway 
     log=no log-prefix="" 

 

 

 

Изменено пользователем  Ni©olas

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас