test0912

Рабочие настройки для IPTV на Mikrotik

Рекомендованные сообщения

no

Изменено пользователем test0912

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Теперь еще 78.107.172.0/22 (по поводу макси не уверен) надо добавить в Upstream

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

чё это такое?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вопрос - все ли каналы работают, которые доступны на ТВ-приставке?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Не знаю как по регионам, а у нас в Красногорске (МО) пчелайн с некоторых пор ввел жесткую привязку к MAC адресу STB приставки, соответственно дабы смотреть дальше через IGMP proxy микротика надо на его wan интерфейс (смотрящий в сеть пчелайна) прописать MAC адрес приставки.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сегодня настраивал Mikrotik для подключения приставки за ним, а не через параллельный коммутатор.

Итог, все работает, включая просмотр каналов на компьютере через VLC/Simple TV, но пока непонятно что с PIN кодом блокировки каналов для взрослых на приставке.

 

Итак:

 

1. Маршрутизатор Mikrotik RB750GL из коробки шел без пакета multicast.

 

2. Настройка на работу с сетью Beeline была выполнена по документации на сайте htt_://minirouter.ru/routers/documentation/. Спасибо им за подробный мануал.

 

3. Был проведен апгрейд с 5.4 до 5.17

Апгрейд:

C сайта http://www.mikrotik.com/download

качаем образ для своей версии маршрутизатора

в winbox переносим NPK файл в закладку Files

перегружаем маршрутизатор

 

Установка дополнительных пакетов:

с сайта http://www.mikrotik-software.de/downloads/

скачиваем пакет со всеми модулями под текущую версию RouterOs

Распаковываем, переносим нужные NPK в закладку Files в winbox.

Перегружаем маршрутизатор.

 

 

4. Настройка igmp-proxy

Настройка проводилась по посту топикстартера, с добавлением второй multicast сети, т.е.:

 

/routing igmp-proxy interface add alternative-subnets=233.33.210.0/24,233.33.220.0/24,78.107.196.0/22 comment="Upstream" disabled=no interface=ether1-gw-beeline threshold=1 upstream=yes

/routing igmp-proxy interface add alternative-subnets="" comment="Downstream" disabled=no interface=ether2-master-local threshold=1 upstream=no

 

Тут нужно оговориться, на счет именования интерфейсов, в моем случае:

[admin@MikroTik] >> /interface print detail

Flags: D - dynamic, X - disabled, R - running, S - slave

0 R ;;; Beeline-Local

name="ether1-gw-beeline" type="ether" mtu=1500 l2mtu=1598

max-l2mtu=4074

1 R ;;; Internal Switch Master

name="ether2-master-local" type="ether" mtu=1500 l2mtu=1598

max-l2mtu=4074

2 R name="ether3-slave-local" type="ether" mtu=1500 l2mtu=1598

max-l2mtu=4074

3 name="ether4-slave-local" type="ether" mtu=1500 l2mtu=1598

max-l2mtu=4074

4 name="ether5-slave-local" type="ether" mtu=1500 l2mtu=1598

max-l2mtu=4074

5 R ;;; Beeline-l2tp

name="beeline-l2tp" type="l2tp-out" mtu=1420

 

5. Разрешаем IGMP трафик в брандмауэре

ip firewall filter add chain="input" action="accept" protocol="igmp" in-interface=ether1-gw-beeline comment="Allow IGMP"

Через winbox переносим правило выше блокирующего:

[admin@MikroTik] >> /ip firewall filter print d

5 ;;; Allow IGMP

chain=input action=accept protocol=igmp in-interface=ether1-gw-beeline

 

6 ;;; Drop All

chain=input action=drop in-interface=ether1-gw-beeline

 

Все

  • Upvote 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сегодня настраивал Mikrotik для подключения приставки за ним, а не через параллельный коммутатор.

Итог, все работает, включая просмотр каналов на компьютере через VLC/Simple TV, но пока непонятно что с PIN кодом блокировки каналов для взрослых на приставке.

 

 

 

 

Спасибо, что поделились.

 

Все сделал, как Вы описали, все работает, даже пин-код принимает, осталась одна проблема - все показывает примерно 8 секунд и замирает как стоп кадр и больше не оживает, при переключении на следующий канал все повторяется - 8 секунд и стоп-кадр.

 

Вы не сталкивались с такой проблемой?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

(IPTV IGMP Mikrotik Биллайн DNLA)

 

У меня Микротик 3.xx на базе ПК

IGMP прокся с Пчелайном не заработала. Пакеты нестандартные. (у этих пчел неправильный мед!)

Обошел проблему так:

1 поднял VLAN на шлюзе , обьеденил его c входящем интерфейсом Биллайна, через мост

2 поднял VLAN на ПК (в TCP-IP настройках задаем статический IP например: 223.1.2.3 ) все лишнее отключаем.

3 ПЕРЕЗАПУСКАЕМСЯ!!!

4 запускаем VLC плеер и смотрим IPTV от Пчел

Плейлист надеюсь найдете в соседней ветке, у каналов адреса 223.33.2xx.xxx

Про VLAN на Микротике читать тут, на сетевушке все индивидуально с настройками VLAN.

http://wiki.mikrotik.com/wiki/%D0%A0%D1%83%D0%BA%D0%BE%D0%B2%D0%BE%D0%B4%D1%81%D1%82%D0%B2%D0%B0:%D0%98%D0%BD%D1%82%D0%B5%D1%80%D1%84%D0%B5%D0%B9%D1%81/VLAN

http://xgu.ru/wiki/VLAN

 

P.S.завтра буду DNLA прикручивать

http://www.homemediaserver.ru/index.htm

post-725968-057231800 1347747121_thumb.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

a9b2, а можно подробнее, что нестандартного в IGMP-пакетах у Билайна? Или, хотя бы, откуда вывод/информация, что IGMP-proxy работать не должен/не будет?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сегодня настраивал Mikrotik для подключения приставки за ним, а не через параллельный коммутатор.

Итог, все работает, включая просмотр каналов на компьютере через VLC/Simple TV, но пока непонятно что с PIN кодом блокировки каналов для взрослых на приставке.

 

Итак:

 

1. Маршрутизатор Mikrotik RB750GL из коробки шел без пакета multicast.

 

2. Настройка на работу с сетью Beeline была выполнена по документации на сайте htt_://minirouter.ru/routers/documentation/. Спасибо им за подробный мануал.

 

3. Был проведен апгрейд с 5.4 до 5.17

Апгрейд:

C сайта http://www.mikrotik.com/download

качаем образ для своей версии маршрутизатора

в winbox переносим NPK файл в закладку Files

перегружаем маршрутизатор

 

Установка дополнительных пакетов:

с сайта http://www.mikrotik-software.de/downloads/

скачиваем пакет со всеми модулями под текущую версию RouterOs

Распаковываем, переносим нужные NPK в закладку Files в winbox.

Перегружаем маршрутизатор.

 

 

4. Настройка igmp-proxy

Настройка проводилась по посту топикстартера, с добавлением второй multicast сети, т.е.:

 

/routing igmp-proxy interface add alternative-subnets=233.33.210.0/24,233.33.220.0/24,78.107.196.0/22 comment="Upstream" disabled=no interface=ether1-gw-beeline threshold=1 upstream=yes

/routing igmp-proxy interface add alternative-subnets="" comment="Downstream" disabled=no interface=ether2-master-local threshold=1 upstream=no

 

Тут нужно оговориться, на счет именования интерфейсов, в моем случае:

[admin@MikroTik] >> /interface print detail

Flags: D - dynamic, X - disabled, R - running, S - slave

0 R ;;; Beeline-Local

name="ether1-gw-beeline" type="ether" mtu=1500 l2mtu=1598

max-l2mtu=4074

1 R ;;; Internal Switch Master

name="ether2-master-local" type="ether" mtu=1500 l2mtu=1598

max-l2mtu=4074

2 R name="ether3-slave-local" type="ether" mtu=1500 l2mtu=1598

max-l2mtu=4074

3 name="ether4-slave-local" type="ether" mtu=1500 l2mtu=1598

max-l2mtu=4074

4 name="ether5-slave-local" type="ether" mtu=1500 l2mtu=1598

max-l2mtu=4074

5 R ;;; Beeline-l2tp

name="beeline-l2tp" type="l2tp-out" mtu=1420

 

5. Разрешаем IGMP трафик в брандмауэре

ip firewall filter add chain="input" action="accept" protocol="igmp" in-interface=ether1-gw-beeline comment="Allow IGMP"

Через winbox переносим правило выше блокирующего:

[admin@MikroTik] >> /ip firewall filter print d

5 ;;; Allow IGMP

chain=input action=accept protocol=igmp in-interface=ether1-gw-beeline

 

6 ;;; Drop All

chain=input action=drop in-interface=ether1-gw-beeline

 

Все

 

Все работает проверил - спасибо - mikrotik 750 os 6.04

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сделал по инструкции - заработало. На следующий день включаю ТВ - половину каналов не показывает. Перезапускаю приставку - висит белый экран с логотипом билайна. Подключаю напрямую - приставка бутается, каналы показывает. На следующий день история повторяется. В результате объединил wan порт и порт с приставкой в мост. Только после этого пропал доступ к локальным ресурсам (да, на форум не зайти)

Изменено пользователем grooz

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Теперь еще 78.107.172.0/22 (по поводу макси не уверен) надо добавить в Upstream

Хотел добавить, точнее убрать лишнее.

Маршрутизацию до сетей 233.0.0.0/8 и вообще до мультикаст-групп прописывать не нужно. Принцип маршрутизации в мультикастовых сетях осуществляется иначе, чем традиционный юникаст. Тем более, маршрутизация до этих сетей не попадает в рамки механизма IgmpProxy, а больше для PIM-SM.

 

В "Alternative Subnets", также, лишнее прописывать всё что касается сетей 233.0.0.0/8, это просто широковещательная группа для запросов, а в этой опции должны быть указаны сети самих источников мультикаста (или, поправьте меня, точек встречи). Честно говоря, я несколько ограничен знаниями этого протокола и не могу точно сказать как именно можно вычислить эти источники. Думаю, хорошей идеей было бы выкладывать вместе со списками каналов адреса сетей источников мультикаста.

 

Таким образом, у меня получился такой рабочий конфиг

 

/routing igmp-proxy

set quick-leave=yes

/routing igmp-proxy interface

add alternative-subnets=78.107.196.0/24 interface=ether10 upstream=yes

add interface=bridge-local

Изменено пользователем Eugene_Lo
  • Upvote 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

опять проблема iptv через igmp proxy на микротике. Есть у меня RB493G, на ней igmp proxy ностроен и все прекрасно работает, но мощи этой железки перестало хватать и собрал я роутер на x86 платформе на базе Intel Atom D525 (Jetway NF99FL), настроил все аналогично как на RB493G, но IPTV работает криво, например первый канал показывает секунд 10 после чего картинка замерзает, помогает только переключение канала с пульта приставки, на других каналах поведение немного отличается, показывает пару минут, потом картинка замерзает, лечится либо переключением канала с пульта приставки либо само размораживается через секунд 30-минуту. Версии ROS (5.24) одинаковые, настройки одинаковые, на RB все зашибись, на x86 глюки. Может в сетевых адаптерах дело ? Ибо на RB это Atheros, а на x86 это Intel 82574L ? Тогда что с Intel не так и что там подкрутить ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Топикстартер удалил свой пост, и теперь цельной картины не складывается.

Я так понял, наиболее актуальный конфиг дает Eugene_Lo, но непонятно как вычислить адрес сети для прописывания в 4-ю строчку. И что такое Ether10 - интерфейс, смотрящий в Билайн?

Подскажите, кто в курсе.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Топикстартер удалил свой пост, и теперь цельной картины не складывается.

Я так понял, наиболее актуальный конфиг дает Eugene_Lo, но непонятно как вычислить адрес сети для прописывания в 4-ю строчку. И что такое Ether10 - интерфейс, смотрящий в Билайн?

Подскажите, кто в курсе.

ether10 - провод от Билайна

bridge-local - провод к приставке

Всё остальное оставляем без изменений (включая адрес сети)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Топикстартер удалил свой пост, и теперь цельной картины не складывается.

Я так понял, наиболее актуальный конфиг дает Eugene_Lo, но непонятно как вычислить адрес сети для прописывания в 4-ю строчку. И что такое Ether10 - интерфейс, смотрящий в Билайн?

Подскажите, кто в курсе.

ether10 - провод от Билайна

bridge-local - провод к приставке

Всё остальное оставляем без изменений (включая адрес сети)

 

ну вот мой конфиг

/routing igmp-proxy
set query-interval=1m query-response-interval=10s quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=78.107.196.0/24 disabled=no interface=ether1-gateway \
   threshold=1 upstream=yes
add alternative-subnets="" disabled=no interface=bridge-local threshold=1 \
   upstream=no

 

не работает :(

долгий показ заставки Билайн и потом "Ошибка инициализации клиента".

 

слушайте, но до мультикаста приставка ж должна загрузиться, интерфейс скачать откуда-то. Может роутинг какой-то нужен через шлюз ether1-gateway? А то ж сейчас все по дефолту в l2tp-интерфейс улетает, в интернет.

 

слушайте, но до мультикаста приставка ж должна загрузиться, интерфейс скачать откуда-то. Может роутинг какой-то нужен через шлюз ether1-gateway? А то ж сейчас все по дефолту в l2tp-интерфейс улетает, в интернет.

 

Отвечаю сам себе - я был прав. После добавления маршрута

add comment=IPTV disabled=no distance=1 dst-address=78.107.196.0/22 gateway=\
   10.48.176.1 scope=30 target-scope=10

IPTV заработало.

До этого в процессе поиска решения проблемы было добавлено еще 3 маршрута:

add comment=IPTV disabled=no distance=1 dst-address=85.21.91.0/24 gateway=\
   10.48.176.1 scope=30 target-scope=10
add comment=IPTV disabled=no distance=1 dst-address=85.21.100.0/24 gateway=\
   10.48.176.1 scope=30 target-scope=10
add comment=IPTV disabled=no distance=1 dst-address=172.16.16.0/24 gateway=\
   10.48.176.1 scope=30 target-scope=10

но после их добавления IPTV не заработало. Теперь непонятно - нужны ли они для работы IPTV или нет, но удалять и проверять мне влом. Итак много времени потратил на это IPTV. Может когда-нибудь в процессе уборки на роутере выясню и отпишусь.

PS. Да, ну и шлюз в вышеприведенных маршрутах может отличаться в разных местах подключения к сети. Смотрите у себя, какой шлюз по умолчанию выдается на интерфейсе, смотрящем в билайн, и его подставляйте в маршруты.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Заработать-то заработало, но... Как победить зависание картинки (прерывания потока)?

Показывает несколько минут или десятков минут, потом картинка останавливается, судя по загрузке интерфейсов - поток приходить перестаёт. Если ничего не делать - через минуту-две показ видео возобновляется. Ну или гарантированно возобновляется после смены канала.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Заработать-то заработало, но... Как победить зависание картинки (прерывания потока)?

Показывает несколько минут или десятков минут, потом картинка останавливается, судя по загрузке интерфейсов - поток приходить перестаёт. Если ничего не делать - через минуту-две показ видео возобновляется. Ну или гарантированно возобновляется после смены канала.

Снова отвечаю сам себе. Победил я "фризы" (остановки видео) через 6..9 секунда после переключения канала. Во-первых, добавил правило в файрволл

 

add action=accept chain=input disabled=no in-interface=ether1-gateway protocol=igmp

во-вторых, включил и настроил PIM

 

/routing pim

set switch-to-spt=yes switch-to-spt-bytes=0 switch-to-spt-interval=1m40s

/routing pim interface

add alternative-subnets=78.107.196.0/24 assert-override-interval=3s assert-time=3m disabled=no dr-priority=1 hello-holdtime=1m45s hello-period=30s hello-trigerred-delay=5s igmp-version=IGMPv2 interface=ether1-gateway join-prune-holdtime=3m30s \

join-prune-period=1m override-interval=250 preferred-source-address=0.0.0.0 propagation-delay=50 protocols=pim,igmp require-hello=yes tracking-support=yes

add alternative-subnets="" assert-override-interval=3s assert-time=3m disabled=no dr-priority=1 hello-holdtime=1m45s hello-period=30s hello-trigerred-delay=5s igmp-version=IGMPv2 interface=bridge-local join-prune-holdtime=3m30s join-prune-period=1m \

override-interval=250 preferred-source-address=0.0.0.0 propagation-delay=50 protocols=pim,igmp require-hello=yes tracking-support=y

 

итоговый конфиг (ether1-gateway - в билайн, bridge-local - локальный интерфейс, 10.48.176.1 - мой шлюз по умолчанию, выдаваемый Билайном по dhcp):

 

/ip firewall filter
add action=accept chain=input disabled=no in-interface=ether1-gateway protocol=igmp
/ip route
add comment=IPTV disabled=no distance=1 dst-address=78.107.196.0/22 gateway=10.48.176.1 scope=30 target-scope=10
add comment=IPTV disabled=no distance=1 dst-address=85.21.91.0/24 gateway=10.48.176.1 scope=30 target-scope=10
add comment=IPTV disabled=no distance=1 dst-address=85.21.100.0/24 gateway=10.48.176.1 scope=30 target-scope=10
add comment=IPTV disabled=no distance=1 dst-address=172.16.16.0/24 gateway=10.48.176.1 scope=30 target-scope=10
/routing igmp-proxy
set query-interval=1m query-response-interval=10s quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=78.107.196.0/24 disabled=no interface=ether1-gateway threshold=1 upstream=yes
add alternative-subnets="" disabled=no interface=bridge-local threshold=1 upstream=no
/routing pim
set switch-to-spt=yes switch-to-spt-bytes=0 switch-to-spt-interval=1m40s
/routing pim interface
add alternative-subnets=78.107.196.0/24 assert-override-interval=3s assert-time=3m disabled=no dr-priority=1 hello-holdtime=1m45s hello-period=30s hello-trigerred-delay=5s igmp-version=IGMPv2 interface=ether1-gateway join-prune-holdtime=3m30s \
   join-prune-period=1m override-interval=250 preferred-source-address=0.0.0.0 propagation-delay=50 protocols=pim,igmp require-hello=yes tracking-support=yes
add alternative-subnets="" assert-override-interval=3s assert-time=3m disabled=no dr-priority=1 hello-holdtime=1m45s hello-period=30s hello-trigerred-delay=5s igmp-version=IGMPv2 interface=bridge-local join-prune-holdtime=3m30s join-prune-period=1m \
   override-interval=250 preferred-source-address=0.0.0.0 propagation-delay=50 protocols=pim,igmp require-hello=yes tracking-support=yes

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В общем вся эта стенка настроек фигня.

 

Для работы достаточно прописать

/routing igmp-proxy

set query-interval=1m query-response-interval=10s quick-leave=yes

/routing igmp-proxy interface

add alternative-subnets=0.0.0.0/0 comment="Upstream" disabled=no interface=ether1-gateway threshold=1 upstream=yes

add alternative-subnets="" comment="Downstream" disabled=no interface=bridge-local threshold=1 upstream=no

 

Где ether1-gateway ваш порт с проводом от провайдера

bridge-local - ваш бридж или порт на комп

 

Ну можно для верности

/ip firewall filter

add action=accept chain=input disabled=no in-interface=ether1-gateway protocol=igmp (выше блокирующего)

/ip route

add comment="Beeline IPTV" disabled=no distance=1 dst-address=78.107.196.0/24 gateway=xxx scope=30 target-scope=10

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Цель создания документа - облегчение первоначальных настроек для новичков с инициализацией настройки маршрутизатора Mikrotik, для сети Билайн. Шаги настроек "из коробки" документировал. Версия документа 01 Initial.

По мере добавления конфигурации, документ буду дополнять.

 

Планируемые шаги настройки:

1. проброс портов на компьютер с торрент клиентом

2. изменение правил маршрутизации, для работы услуги телевидение на iPad.

3. запуск в работу приставок за маршрутизатором

 

Mikrotik+Beeline_01.06_v.01.pdf

 

Добавляем работоспособность IPTV на iPAD

Необходимо добавить маршрутизацию и NAT на подсеть 78.107.196.0/22

/ip route

add comment="Beeline TV" disabled=no distance=1 dst-address=78.107.196.0/22 \

gateway=ВАШ_ГЕЙТВЕЙ_СЕТЬ_БИЛАЙН_(10.XXX.XXX.XXX) scope=30 target-scope=10

 

/ip firewall nat

add action=masquerade chain=srcnat comment="Beeline TV" disabled=no \

dst-address=78.107.196.0/22 out-interface=ether1-gateway src-address=\

192.168.88.0/24

Работает только с поднятым L2TP.

Изменено пользователем arty_r

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В общем вся эта стенка настроек фигня.

 

Для работы достаточно прописать

....

У меня с такими настройками половина каналов не работает, а остальные виснут

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ОК спасти надо

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
У меня с такими настройками половина каналов не работает, а остальные виснут

Значит что-то криво настроено.

У меня при холодном старте приставка долго прочухивается, но потом работает отлично. Зависаний нет, каналы работают все из стандартного пакета.

Изменено пользователем Kuja Leonhart

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

просто вся эта стена настроек - не фигня. Есть какая-то индивидуальность, зависящая непонятно от чего. То ли от конкретного микротика, то ли от конкретной приставки, то ли от конкретного места подключения к билайну. У меня с твоими настройками не заработало. Но не заработало не так, как у grooz, а по своему. У меня все каналы работают, но все останавливаются.

С моими настройками у меня худо-бедно работает. Иногда начинаются фризы, лечатся выключением/включением приставки с пульта.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Версия OS 6?

Скорее всего с IPTV у Билайна все так же хитро как и с работой инета.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Версия OS 6?

Скорее всего с IPTV у Билайна все так же хитро как и с работой инета.

 

Не. 5.24, 5.25

с инетом у меня проблем не было, и с микротиком в том числе. с билайн тв тоже не было, микротик - первый, с кем случился геморрой. хотя все бывшие до этого роутеры были под билайн тем или иным способом подготовлены или хотя бы оттестированы.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Я на 6.0 RC и 6.0 все настройки производил.

 

хотя все бывшие до этого роутеры были под билайн тем или иным способом подготовлены или хотя бы оттестированы

Дело тут в в специфичной настройке и работе сети Билайн. С другими провайдерами проще в разы.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Цель создания документа - облегчение первоначальных настроек для новичков с инициализацией настройки маршрутизатора Mikrotik, для сети Билайн. Шаги настроек "из коробки" документировал. Версия документа 01 Initial.

По мере добавления конфигурации, документ буду дополнять.

 

Планируемые шаги настройки:

1. проброс портов на компьютер с торрент клиентом

2. изменение правил маршрутизации, для работы услуги телевидение на iPad.

3. запуск в работу приставок за маршрутизатором

 

Mikrotik+Beeline_01.06_v.01.pdf

У тебя неправильная настройка так как настройка зависит от сегмента сети так как в каждом городе и районе своя локальная сеть !

Перед тем как настраивать нужно узнать какая в районе сеть командой в Winbox New Terminal ip route print detail чтобы узнать vpn адрес командой nslookup tp.internet.beeline.ru в командной строке Windows и обязательно настроить refresh - обновление ip адреса чтобы каждый раз не выключать/включать роутер так как в Билайне ip адрес динамический тоисть меняется поэтому иногда нужно перезапускать некоторые роутеры типо mikrotik и Cisco .

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В общем вся эта стенка настроек фигня.

 

Для работы достаточно прописать

/routing igmp-proxy

set query-interval=1m query-response-interval=10s quick-leave=yes

/routing igmp-proxy interface

add alternative-subnets=0.0.0.0/0 comment="Upstream" disabled=no interface=ether1-gateway threshold=1 upstream=yes

add alternative-subnets="" comment="Downstream" disabled=no interface=bridge-local threshold=1 upstream=no

 

Где ether1-gateway ваш порт с проводом от провайдера

bridge-local - ваш бридж или порт на комп

 

Ну можно для верности

/ip firewall filter

add action=accept chain=input disabled=no in-interface=ether1-gateway protocol=igmp (выше блокирующего)

/ip route

add comment="Beeline IPTV" disabled=no distance=1 dst-address=78.107.196.0/24 gateway=xxx scope=30 target-scope=10

 

Упрощу задачу. Я так понимаю, 78.107.196.0/24 это адрес источников. А маршрутизация потоков производится по технологии PIM-SM. А это значит, что роуты тут не работают. Это "обратная" маршрутизация от источника к потребителю. У меня работает и вот так, причём, проверял уже в разных концах Москвы..

 

/routing igmp-proxy

set quick-leave=yes

/routing igmp-proxy interface

add alternative-subnets=78.107.196.0/24 interface=ether3 upstream=yes

add interface=bridge-local

 

Полагаю, расписыывать что к чему излишне..

 

Ну, как бы так :) Конечно, при условии, что фаервол настроен как надо.

Изменено пользователем Eugene_Lo
  • Upvote 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Имеется RB951G-2hnd, подключил билайн тв.

 

Было настроено как все советуют igmp-proxy, но через него эфир стал тормозным - появлялись лаги как со спутником + более долгое переключение каналов, а HD каналы вовсе "уходили" в постоянную буферизацию.

 

Было решено применить следующую схему, с учетом приоритета - максимальная скорость между ПК1 и ПК2:

 

Мои интерфейсы:

ether1-tv-beeline на POE (приставка IPTV) 
ether2-gw-beeline (провод провайдера) 
ether3-PC1
ether4-PC2
ether5-Не.исп.
wlan (wifi) 

l2tp

 

Действия (для уже настроенной конфигурации билайн l2tp):

 

  1. для ether4-PC2 назначаем Master port: ether4-PC1 (в мануале написано что такой способ имеет wired-speed)
    Так же если нужно задействовать еще локальный порт - назначаем тот же мастер порт для например "ether5-Не.исп."
  2. Порту ether1-tv-beeline назначаем Master port ether2-gw-beeline
  3. В DHCP-client'е интерфейс ether2-gw-beeline
  4. в существующий Bridge-local добавляем/изменяем порты чтобы было только: wlan и ether3-PC1

 

В итоге у меня приставка билайн тв соединена с подсетью билайна (получает IP 10.57.*.*) и l2tp соединение раздается на ПК1, ПК2, WiFi.

Приставка теперь работает так же шустро как если бы была подключена в свич с билайновским проводом.

 

Если Вам была полезна данная информация ставьте +1

Изменено пользователем KillerHT

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас