Davli

MikroTik RB/MRTG (miniROUTERG) Часть 1

Рекомендованные сообщения

но работает так же хреново, половина сайтов не открываются

 

У меня лечилось этим:

 

/ip firewall mangle

add action=change-mss chain=forward in-interface=Beeline new-mss=1420 protocol=\

tcp tcp-flags=syn tcp-mss=1421-65535

add action=change-mss chain=forward new-mss=1420 out-interface=Beeline \

protocol=tcp tcp-flags=syn tcp-mss=1421-65535

  • Upvote 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

но работает так же хреново, половина сайтов не открываются

 

У меня лечилось этим:

 

/ip firewall mangle

add action=change-mss chain=forward in-interface=Beeline new-mss=1420 protocol=\

tcp tcp-flags=syn tcp-mss=1421-65535

add action=change-mss chain=forward new-mss=1420 out-interface=Beeline \

protocol=tcp tcp-flags=syn tcp-mss=1421-65535

 

Пробовал, не помогает

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@chain1, Отличная новость! Только мне пришлось еще change-mss оставить для нормальной работы. А в новой прошивке руками маршруты колотить действительно не надо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@chain1, Отличная новость! Только мне пришлось еще change-mss оставить для нормальной работы. А в новой прошивке руками маршруты колотить действительно не надо.

 

А опцию DHCP убирали?

 

/ip dhcp-client option

add code=55 name=parameter_request_list value=0x01F90321062A

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Boson_Higgs, нет, не убирал. Да и причем здесь она? Работает и с ней, и без нее.

С момента перехода на 100-ую подсеть у Билайна маршруты приходят только с первым dhcp релизом. Дальше при продлении аренды остается только один дефолтный маршрут.

Т.к. я не пользую телефон/ТВ от билайна - мне до этих маршрутов все равно. Надеюсь, пофиксят.

Ну и локальные ресурсы (тот же retracker) после переходна на 100-ку канал в лету. Так что эта опция для меня теперь вообще без надобности. Уберу ее пожалуй.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Beeline перестал заглушку ставить в случае окончания средств.. сегодня бегал смотрел маршруты, гейты.. а оказалось ср-в нет.

чума.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Установил, не помогает, работает только если оставлять DHCP опцию:

/ip dhcp-client option

add code=55 name=parameter_request_list value=0x01F90321062A

но работает так же хреново, половина сайтов не открываются, если убрать опцию интернет не работает совсем.

 

Прошивка обновлена на 6.30?

 

Опцию в DNS не использовал ни в предыдущих прошивках, где прописывал два стат маршрута и одно routing rule. Коннект был по ip. Ни сейчас не использую.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Установил, не помогает, работает только если оставлять DHCP опцию:

/ip dhcp-client option

add code=55 name=parameter_request_list value=0x01F90321062A

но работает так же хреново, половина сайтов не открываются, если убрать опцию интернет не работает совсем.

 

Прошивка обновлена на 6.30?

 

Опцию в DNS не использовал ни в предыдущих прошивках, где прописывал два стат маршрута и одно routing rule. Коннект был по ip. Ни сейчас не использую.

 

Таки завел нормально, опцию DHCP убрал, стат маршруты убрал, поставил TCP MSS, и что-то еще крутил, если кому нужно могу выложить нормально работающий конфиг.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Разобрался с change mss: если в ppp профиле поставить change-tcp-mss=yes и в l2tp клиенте поставить max-mtu=1460 и max-mru=1460 - тогда соответствующие правила в /ip firewall mangle создаются корректно и автоматически.

 

Это что же теперь получается, с новой прошивкой танцев с бубном вокруг Билайна и Микротика вообще не надо? :o

 

Раньше жили не расслабляясь - то гейт Билайн поменяет, то маршруты пропадут или левые прилетят...и сразу вспоминаешь как команды в терминале набирать... романтика!

А сейчас? Пару очевидных кнопок жамкнул и спи спокойно... бяда... :D

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Разобрался с change mss: если в ppp профиле поставить change-tcp-mss=yes и в l2tp клиенте поставить max-mtu=1460 и max-mru=1460 - тогда соответствующие правила в /ip firewall mangle создаются корректно и автоматически.

 

Это что же теперь получается, с новой прошивкой танцев с бубном вокруг Билайна и Микротика вообще не надо? :o

 

Раньше жили не расслабляясь - то гейт Билайн поменяет, то маршруты пропадут или левые прилетят...и сразу вспоминаешь как команды в терминале набирать... романтика!

А сейчас? Пару очевидных кнопок жамкнул и спи спокойно... бяда... :D

 

Я не менял этих настроек, оставлял как оно по умолчанию было, отмечал только добавление маршрута по умолчанию в настройках l2tp и добавил запись nat для этого интерфейса и все

 

Удивляет еще отсутствие поддержки RouterOS функции WMM power saving, из-за чего мобильные клиенты - смартфоны, планшеты, при переходе в "спящий" режим отваливаются от wi-fi сети микротика.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Я не менял этих настроек, оставлял как оно по умолчанию было, отмечал только добавление маршрута по умолчанию в настройках l2tp и добавил запись nat для этого интерфейса и все

А я вот поменял на свою голову - повелся на инфу "настройки для опытных" на сайте Билайна. Там почему-то написано mru ставить 1500...

 

Удивляет еще отсутствие поддержки RouterOS функции WMM power saving, из-за чего мобильные клиенты - смартфоны, планшеты, при переходе в "спящий" режим отваливаются от wi-fi сети микротика.

Да, есть такое дело. Может допилят в очередной прошивке.

Хотя при просыпании они сеть быстро находят. Так что невелика беда. Только в логах мусора много оставляют. Я даже wireless info из логирования исключил из-за этого.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Может кому-то будет полезно.

Перевели на новую подсеть, пришлось менять маршруты. После ребута устройства инет присутствовал буквально пару минут.

Тут уже спрашивали про подобную ситуацию: "интернет пропадает через 5 минут"(в моем случае это было 1-2 минуты). Немого покрасноглазив выяснилось, что проблема появлялась поле того, как DHCP клиент получал шлюз по умолчанию от провайдера(100.х.х.х). Собсвенно проблема ушла после обновления железяки до версии 6.29.1 при чем средствами самой железки без шаманства("quick set"-"check for updates" и т.д., далее ребут). Шлюз по прежнему получается, но интет после этого не отваливается.

 

Заранее извиняюсь, если это уже описывалось(не видел).

Изменено пользователем kestlx

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

всем привет.

два дня пытаюсь настроить свой роутер rb2011

настроил локалку, wi-fi, l2tp, авторизация на сервере билайна происходит и все вроде бы ок.

но не пингуется ни один внешний домен.

видит ip ya.ru, но не открывает.

 

подскажите кто знает, куда копать.

днс-ы получает аатоматом, ip, gateway, mask тоже.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

всем привет.

два дня пытаюсь настроить свой роутер rb2011

настроил локалку, wi-fi, l2tp, авторизация на сервере билайна происходит и все вроде бы ок.

но не пингуется ни один внешний домен.

видит ip ya.ru, но не открывает.

 

подскажите кто знает, куда копать.

днс-ы получает аатоматом, ip, gateway, mask тоже.

маршруты пропиши. ip-routes нужны три штуки у меня четыре на всяк пажик.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

всем привет.

два дня пытаюсь настроить свой роутер rb2011

настроил локалку, wi-fi, l2tp, авторизация на сервере билайна происходит и все вроде бы ок.

но не пингуется ни один внешний домен.

видит ip ya.ru, но не открывает.

 

подскажите кто знает, куда копать.

днс-ы получает аатоматом, ip, gateway, mask тоже.

маршруты пропиши. ip-routes нужны три штуки у меня четыре на всяк пажик.

 

пример напишите пожалуйста..т.к. я уже мозг сломал))

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

пример напишите пожалуйста..т.к. я уже мозг сломал))

 

Рекомендую поставить бета прошивку 6.30rc* - не надо будет с маршрутами вообще геморроиться.

Если не заработает - конфиг в студию, поглядим...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ну вот пожалуйста..как настроен.

билайн сайт пашет, все остальное нет.

видит ip ya.ru и akernel.ru

post-938849-066026300 1434017098_thumb.png

post-938849-035083300 1434017099_thumb.png

post-938849-087113100 1434017099_thumb.png

post-938849-063511500 1434017299_thumb.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ну вот пожалуйста..как настроен.

билайн сайт пашет, все остальное нет.

видит ip ya.ru и akernel.ru

Все просто: у тебя два маршрута по-умолчанию с одинаковой метрикой. Сейчас все заворачивается в локалку и никакого тебе интернета.

Поставь метрику 2 для dhcp клиента и будет тебе счастье.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

И меня перевели на 100....

 

[admin@MikroTik] > /ip route print detail 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
0 ADS  dst-address=0.0.0.0/0 gateway=100.100.0.1 
       gateway-status=100.100.0.1 reachable via  Port2 distance=0 scope=30 
       target-scope=10 vrf-interface=Port2 

1   S  dst-address=78.107.1.0/24 gateway=10.29.72.1 
       gateway-status=10.29.72.1 unreachable distance=1 scope=30 
       target-scope=10 

2   S  dst-address=85.21.0.0/24 gateway=10.29.72.1 
       gateway-status=10.29.72.1 unreachable distance=1 scope=30 
       target-scope=10 

3   S  dst-address=85.21.192.3/32 gateway=10.29.72.1 
       gateway-status=10.29.72.1 unreachable distance=1 scope=30 
       target-scope=10 

4 ADC  dst-address=100.100.0.0/17 pref-src=100.100.40.169 gateway=Port2 
       gateway-status=Port2 reachable distance=0 scope=10 

5 ADC  dst-address=192.168.1.0/24 pref-src=192.168.1.1 gateway=bridge-lan 

 

Я тут почитал, но в голове бордак. какие именно маршруты надо поменять?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

И меня перевели на 100....

 

Я тут почитал, но в голове бордак. какие именно маршруты надо поменять?

Очевидно те, что у вас статиком прописаны. Как вариант - поставить ОС 6.30 и все статические маршруты нафиг удалить и забыть про них.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

И меня перевели на 100....

 

Я тут почитал, но в голове бордак. какие именно маршруты надо поменять?

Очевидно те, что у вас статиком прописаны. Как вариант - поставить ОС 6.30 и все статические маршруты нафиг удалить и забыть про них.

Под мою модель (951), только 6.29.1, надеюсь скоро и 6.30 выйдет

А в днс клиенте параметр_реквест_лист тоже надо будет удалить?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Под мою модель (951), только 6.29.1, надеюсь скоро и 6.30 выйдет

А в днс клиенте параметр_реквест_лист тоже надо будет удалить?

 

6.30 пока в статусе Release Candidate - надо качать с сайта руками и ставить. Автоматом не прилетает.

Доступна для всех моделей.

 

"параметр_реквест_лист" - для работы интернета не нужен, я у себя удалил. Если у вас еще есть телефония или ТВ от Билайна - может он и принесет нечто полезное.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Под мою модель (951), только 6.29.1, надеюсь скоро и 6.30 выйдет

А в днс клиенте параметр_реквест_лист тоже надо будет удалить?

 

6.30 пока в статусе Release Candidate - надо качать с сайта руками и ставить. Автоматом не прилетает.

Доступна для всех моделей.

 

"параметр_реквест_лист" - для работы интернета не нужен, я у себя удалил. Если у вас еще есть телефония или ТВ от Билайна - может он и принесет нечто полезное.

Обновился. л2тп подключается, но инета нет. Не пойму что делаю не так) Вечером конфиг скину, посмотришь?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Под мою модель (951), только 6.29.1, надеюсь скоро и 6.30 выйдет

А в днс клиенте параметр_реквест_лист тоже надо будет удалить?

 

6.30 пока в статусе Release Candidate - надо качать с сайта руками и ставить. Автоматом не прилетает.

Доступна для всех моделей.

 

"параметр_реквест_лист" - для работы интернета не нужен, я у себя удалил. Если у вас еще есть телефония или ТВ от Билайна - может он и принесет нечто полезное.

Обновился. л2тп подключается, но инета нет. Не пойму что делаю не так) Вечером конфиг скину, посмотришь?

 

Давайте коллективно писать на почту "internet@beeline.ru" о том, чтобы прекращали такой заниматься.

я долго вкуривал, что случилось. в итоге понял. поменяли все. ладно просто ip, так еще и подсети.

 

подключил tp-link, он мне выдает другие адреса. ну я их записал на всякий случай.

потом снова подрубаю микротик и вижу, что ДНС старые стоят, но они динамические, тогда почему не поменялись как у tp-link ?

в общем, добавил в ДНС вручную новые и прописал маршруты. подсети 100.100.0.1 тоже поменял вместо бывших 10.29.16.1

post-938849-042094700 1434701628_thumb.png

post-938849-084503300 1434701632_thumb.png

Изменено пользователем NikIv

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Обновился. л2тп подключается, но инета нет. Не пойму что делаю не так) Вечером конфиг скину, посмотришь?

 

Давай.

Вангую два дефолтных маршрута с одинаковой метрикой :rolleyes:

 

Давайте коллективно писать на почту "internet@beeline.ru" о том, чтобы прекращали такой заниматься.

Бесперспетиваня идея. Скажут "Ставь билайн смартбокс и все будет в шоколаде. А купил микротик - разбирайся сам с его тараканами."

Хотя тараканы скорее билайновские, чем микротиковские - но это их совершенно не волнует.

 

Всем истово рекомендую ставить на микротик ОС 6.30 - после этого проблемы с маршрутами от билайна прекращаются.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Давайте коллективно писать на почту "internet@beeline.ru" о том, чтобы прекращали такой заниматься.

Бесперспетиваня идея. Скажут "Ставь билайн смартбокс и все будет в шоколаде. А купил микротик - разбирайся сам с его тараканами."

Хотя тараканы скорее билайновские, чем микротиковские - но это их совершенно не волнует.

Поддержу, я пытался задать вопрос в поддержку – игра в одну сторону. Скажу больше: сам internet@beeline.ru – рассыпается, не то что поддержка. Они не могут починить свой почтовый ящик, не то что интернет.:lol:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@vysotsky,

# jan/02/1970 03:11:30 by RouterOS 6.30rc20
# software id = 0364-2WK1
#
/interface bridge
add mtu=1500 name=bridge-lan
/interface ethernet
set [ find default-name=ether1 ] comment=LAN name=Port1
set [ find default-name=ether2 ] comment=WAN name=Port2
set [ find default-name=ether3 ] name=Port3
set [ find default-name=ether4 ] disabled=yes name=Port4
set [ find default-name=ether5 ] disabled=yes name=Port5
/ip neighbor discovery
set Port1 comment=LAN
set Port2 comment=WAN
/interface wireless security-profiles
add authentication-types=wpa-psk,wpa2-psk eap-methods="" mode=dynamic-keys \
   name=profile1 supplicant-identity="" wpa-pre-shared-key=testwifi \
   wpa2-pre-shared-key=testwifi
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode \
   band=2ghz-b/g/n comment=WiFI country=russia disabled=no l2mtu=1600 mode=\
   ap-bridge rx-chains=0 security-profile=profile1 ssid=NETGEAR! tx-chains=0 \
   tx-power=15 tx-power-mode=all-rates-fixed wds-default-bridge=bridge-lan \
   wds-mode=dynamic wmm-support=enabled
/interface wireless manual-tx-power-table
set wlan1 comment=WiFI
/interface wireless nstreme
set wlan1 comment=WiFI
/ip neighbor discovery
set wlan1 comment=WiFI
/ip pool
add name=dhcp_pool1 ranges=192.168.1.100-192.168.1.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=bridge-lan lease-time=3d \
   name=dhcp1
/ppp profile
add name=beeline-l2tp remote-address=192.168.255.254 use-encryption=no \
   use-mpls=no
/interface l2tp-client
add add-default-route=yes allow=chap comment=VPN connect-to=\
   tp.internet.beeline.ru default-route-distance=1 disabled=no \
   keepalive-timeout=disabled mrru=1600 name=beeline-l2tp password=\
   ****** profile=beeline-l2tp user=******
/ip neighbor discovery
set beeline-l2tp comment=VPN
/interface bridge port
add bridge=bridge-lan interface=Port1
add bridge=bridge-lan interface=Port4
add bridge=bridge-lan interface=Port5
add bridge=bridge-lan interface=wlan1
/interface pptp-server server
set enabled=yes
/ip address
add address=192.168.1.1/24 interface=bridge-lan network=192.168.1.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid,clientid \
   disabled=no interface=Port2
/ip dhcp-server lease
add address=192.168.1.2 mac-address=00:23:54:38:84:6E server=dhcp1
/ip dhcp-server network
add address=192.168.1.0/24 gateway=192.168.1.1
/ip firewall filter
add chain=input dst-address=93.80.133.31 dst-port=1723 in-interface=\
   bridge-lan protocol=tcp
/ip firewall mangle
add action=change-mss chain=forward in-interface=beeline-l2tp new-mss=1420 \
   protocol=tcp tcp-flags=syn tcp-mss=1421-65535
add action=change-mss chain=forward new-mss=1420 out-interface=beeline-l2tp \
   protocol=tcp tcp-flags=syn tcp-mss=1421-65535
/ip firewall nat
add action=masquerade chain=srcnat out-interface=Port2 src-address=\
   192.168.1.0/24
add action=masquerade chain=srcnat out-interface=beeline-l2tp src-address=\
   192.168.1.0/24
/ip proxy
set cache-path=web-proxy1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www address=0.0.0.0/0 disabled=yes
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/ip smb
set domain=WORKGROUP
/ip smb shares
add directory=/usb1/files name=share1
/ppp secret
add local-address=192.168.1.1 name=user password=vpnpass remote-address=\
   192.168.1.5 service=pptp
/system clock
set time-zone-autodetect=no time-zone-name=Europe/Moscow
/system leds
set 0 interface=wlan1
/system ntp client
set enabled=yes primary-ntp=85.21.78.8 secondary-ntp=85.21.78.23
/tool graphing interface
add
/tool romon port
add

Изменено пользователем NikIv

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Vysotsky по поводу техподдержки прав. Вчера долго воевал с ними. Оказалось, что они решили перейти на "подключи кабель и все уже настроено", т.е. поднимать L2TP-тоннель больше не надо будет, но пока что только сменили оборудование для перехода на красивые ip-шники. Естественно, уведомлять об этом пользователей они не стали (правда, я не знаю с юридической точки зрения - должны ли?). Однако многократно я услышал следующее: "Оборудование не наше, помочь не можем". Очень и очень жаль, вчера убил весь вечер на ковыряние настроек. Кто-то может скинуть рабочий конфиг (или кидали ранее, а я слепня?)

Изменено пользователем HeroFromEarth

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Hacked,

Ну интернета у тебя нет потому, что

/ip dhcp-client add default-route-distance=0 dhcp-options=hostname,clientid,clientid disabled=no interface=Port2

Метрика дефолтного маршрутра на dchp клиенте должна быть больше, чем на l2tp клиенте. Поставь 2 сюда вместо 0 и интернет должен заработать.

 

В целом у тебя в конфиге много лишнего. Рекомендую почистить либо сбросить настройки и настроить заново.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот тут парень толково разживал, у меня получилось.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость
Эта тема закрыта для публикации сообщений.