Davli

MikroTik RB/MRTG (miniROUTERG) Часть 1

Рекомендованные сообщения

Меня поражают современные тенденции: всеобщая злоба в интернете, переходящая в живой мир; И такое впечатление, что современный пользователь инета научился клацкать по клавиатуре и не умеет читать. Здесь всего 33 страницы, правильный ответ дан добрую сотню раз, таким же людям, которые не помнят алфавит. Самое смешное, что правильная ссылка есть в первом посте данной темы.

 

Кстати, у вас есть ещё одна ошибка, но она также расписана в семи строчках.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ладно , и на том спасибо ! Правда , шерстил всю тему , перенастраивал полностью несколько раз по различным способам , но результат всегда один - ресет кнопкой и всё заново . "Будем искать"(с)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ладно , и на том спасибо ! Правда , шерстил всю тему , перенастраивал полностью несколько раз по различным способам , но результат всегда один - ресет кнопкой и всё заново . "Будем искать"(с)

Как вам правильно посоветовал pepelxl, необходимо поставить метрику для маршрута в локальной сети в /ip dhcp-client. А также указать там же параметр parameter_request_lst для получения маршрутов.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Add Default Route yes

Default Route Distance 2

 

а вот с параметром напряжёнка

Изменено пользователем ShurikG

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

По тому что «шерстите», а надо читать и повторять точь в точь каждый вариант.

хотябы это

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо за посильную помощь , вечером буду изучать дальше :)

Хочу довести этот свой конфиг до 100%ной правильности .

Изменено пользователем ShurikG

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Как вам правильно посоветовал pepelxl, необходимо поставить метрику для маршрута в локальной сети в /ip dhcp-client. А также указать там же параметр parameter_request_lst для получения маршрутов.

Как ни странно , но после включения этого параметра - ничего не изменилось , только на этот ресурс больше не удаётся зайти (

обидно, рабочий конфиг , осталось-то пару штрихов и всё .

Изменено пользователем ShurikG

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Интернет, вчера ночью отвалился. До сих пор не работает. Так у Всех??? Звонок в поддержку посылает что идут плановые работы, видимо по ипое... ДХЦП получил адрес, Л2ТП подключается и через 30 сек сбрасывается подключение, интернета нет. Локальные ресурсы работают при выключеном л2тп. ДХЦП месяц назад выдал новый адрес 100,.... с проблемой справился, а теперь ситуация опять возвращается.... Как быть что делать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Не , ну что за чертовщина !

По проводу от роутера скорость 10078466-1050499.png

По wifi - 2671188-6046996.png

Ну помогите кто-нибудь пожалуйста ! Отчего такой перекос на проводе ?

 

/interface bridge

add admin-mac=4C:5E:0C:09:56:33 auto-mac=no name=bridge-local

/interface wireless

set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \

country=russia disabled=no distance=indoors frequency=auto l2mtu=1600 \

mode=ap-bridge rx-chains=0,1 ssid=Sanchez tx-chains=0,1 \

wireless-protocol=802.11 wps-mode=disabled

/interface ethernet

set [ find default-name=ether1 ] comment=WAN name=ether1-gateway

set [ find default-name=ether2 ] comment=LAN name=ether2-master-local

set [ find default-name=ether3 ] master-port=ether2-master-local name=\

ether3-slave-local

set [ find default-name=ether4 ] master-port=ether2-master-local name=\

ether4-slave-local

/interface l2tp-client

add add-default-route=yes connect-to=tp.internet.beeline.ru dial-on-demand=\

yes disabled=no max-mru=1500 max-mtu=1460 name=l2tp-out1 password=\

xxxxxxx user=xxxxxxx

/ip neighbor discovery

set ether1-gateway comment=WAN discover=no

set ether2-master-local comment=LAN

/interface wireless security-profiles

set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys \

wpa-pre-shared-key=xxxxxxx wpa2-pre-shared-key=xxxxxxxx

add authentication-types=wpa2-psk group-ciphers=tkip management-protection=\

allowed mode=dynamic-keys name=ap_security unicast-ciphers=tkip \

wpa2-pre-shared-key=xxxxxxx

/ip pool

add name=dhcp ranges=192.168.88.10-192.168.88.254

/ip dhcp-server

add address-pool=dhcp disabled=no interface=bridge-local name=default

/interface bridge port

add bridge=bridge-local interface=ether2-master-local

add bridge=bridge-local interface=wlan1

/interface pptp-server server

set authentication=chap,mschap1,mschap2 enabled=yes

/ip address

add address=192.168.88.1/24 comment="default configuration" interface=\

ether2-master-local network=192.168.88.0

/ip dhcp-client

add comment="default configuration" default-route-distance=2 dhcp-options=\

hostname,clientid disabled=no interface=ether1-gateway

/ip dhcp-server network

add address=192.168.88.0/24 comment="default configuration" dns-server=\

192.168.88.1 gateway=192.168.88.1

/ip dns

set allow-remote-requests=yes

/ip dns static

add address=192.168.88.1 name=router

/ip firewall filter

add chain=forward comment="default configuration" connection-state=\

established,related

add action=drop chain=forward comment="default configuration" \

connection-state=invalid disabled=yes

add action=drop chain=forward comment="default configuration" \

connection-nat-state=!dstnat connection-state=new disabled=yes \

in-interface=ether1-gateway

add chain=input protocol=icmp

add chain=input connection-state=established

add chain=input connection-state=related

add action=drop chain=input disabled=yes in-interface=ether1-gateway

/ip firewall mangle

add chain=forward disabled=yes in-interface=all-ppp protocol=tcp

add chain=forward disabled=yes out-interface=all-ppp protocol=tcp

add action=change-mss chain=forward in-interface=l2tp-out1 new-mss=1416 \

protocol=tcp tcp-flags=syn tcp-mss=1417-65535

add action=change-mss chain=forward new-mss=1416 out-interface=l2tp-out1 \

protocol=tcp tcp-flags=syn tcp-mss=1417-65535

/ip firewall nat

add action=masquerade chain=srcnat comment="default configuration" \

out-interface=ether1-gateway

add action=masquerade chain=srcnat comment="default configuration" \

out-interface=l2tp-out1

/ip route

add distance=1 dst-address=78.107.1.0/24 gateway=10.252.48.1

add distance=1 dst-address=85.21.0.0/24 gateway=10.252.48.1

add distance=1 dst-address=85.21.192.3/32 gateway=10.252.48.1

add distance=1 dst-address=213.234.192.8/32 gateway=10.252.48.1

/ip service

set telnet disabled=yes

set ftp disabled=yes

set ssh disabled=yes

set api disabled=yes

set api-ssl disabled=yes

/system clock

set time-zone-autodetect=no

/system ntp client

set enabled=yes

/system routerboard settings

set cpu-frequency=650MHz protected-routerboot=disabled

/system upgrade upgrade-package-source

add user=admin

/tool mac-server

set [ find default=yes ] disabled=yes

add interface=ether2-master-local

add interface=wlan1

/tool mac-server mac-winbox

set [ find default=yes ] disabled=yes

add interface=ether2-master-local

add interface=wlan1

/tool romon port

add disabled=no

[admin@MikroTik] >

Изменено пользователем ShurikG

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Попробуй ip address 192.168.88.1 назначить не на порт, а на bridge

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

IP--Adress--Interface-- bridge-local ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Угу.

/ip dns static это те адреса у кого тик спрашивает. Сам у себя он ни чего не узнает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ничего не понимаю , вчера только сделал NAT открытым по рекомендации steam , и теперь у меня так :

/ip upnp

set allow-disable-external-interface=yes enabled=yes

/ip upnp interfaces

add interface=bridge-local type=internal

add interface=l2tp-out1 type=external

Потом начал искать , как по совету Pepelxl переназначить айпи с порта на мост , опять доигрался до того , что тик перестал коннектиться - ресет кнопкой и спать .

Сегодня с утра по проводу от роутера уже такая картинка

9919819-9988816.png

Думаю , что всё-таки помог ресет .

Изменено пользователем ShurikG

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Йеху. Теперь любая вражеская софтина может вырубить внешний интерфейс через upnp. allow-disable-external-interface ни о чем не говорит?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Нда... а вечером всё вернулось на круги своя - по wifi 34-36 , бридж ничего не изменил , провод опять

9461997-1161940.png

 

"allow-disable-external-interface ни о чем не говорит?"(с) - конечно , обычно дезактивирован , открываю только поиграть в сети .

Изменено пользователем ShurikG

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ShurikG, ни одной игре не нужно пробрасывать порт, а уж тем более разрешать выключать через upnp внешний интерфейс. Что бы не происходило ничего удивительного и волшебного - просто не нужно держать в кофиге мусор. Вот и все.

В идеале этот конфиг должен быть легкочитаем, все опции по умолчанию выставлены принудительно, т.к. от версии к версии умолчания у тиковцев могут измениться.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Проблема один в один, при этом техподдержка отказывается помогать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

 

l2tp, ppp, info corbina-l2tp: terminating... - session closed

669 Jan/02/1970 00:27:48 memory l2tp, ppp, info corbina-l2tp: disconnected

670 Jan/02/1970 00:27:48 memory l2tp, ppp, info corbina-l2tp: initializing...

671 Jan/02/1970 00:27:48 memory l2tp, ppp, info corbina-l2tp: dialing...

672 Jan/02/1970 00:27:48 memory l2tp, ppp, info corbina-l2tp: terminating... - old tunnel is not closed yet

673 Jan/02/1970 00:27:48 memory l2tp, ppp, info corbina-l2tp: disconnected

674 Jan/02/1970 00:27:48 memory l2tp, ppp, info corbina-l2tp: initializing...

675 Jan/02/1970 00:27:48 memory l2tp, ppp, info corbina-l2tp: dialing...

676 Jan/02/1970 00:27:48 memory l2tp, ppp, info corbina-l2tp: terminating... - old tunnel is not closed yet

677 Jan/02/1970 00:27:48 memory l2tp, ppp, info corbina-l2tp: disconnected

678 Jan/02/1970 00:27:49 memory l2tp, ppp, info corbina-l2tp: initializing...

679 Jan/02/1970 00:27:49 memory l2tp, ppp, info corbina-l2tp: dialing...

680 Jan/02/1970 00:28:13 memory l2tp, ppp, info corbina-l2tp: terminating... - session closed

681 Jan/02/1970 00:28:13 memory l2tp, ppp, info corbina-l2tp: disconnected

682 Jan/02/1970 00:28:13 memory l2tp, ppp, info corbina-l2tp: initializing...

683 Jan/02/1970 00:28:13 memory l2tp, ppp, info corbina-l2tp: dialing...

684 Jan/02/1970 00:28:30 memory l2tp, ppp, info corbina-l2tp: authenticated

 

 

И такая дребедень целый день..

Изменено пользователем NikIv

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Rampage1, попробуйте временно включить pap (в настройках L2TP).

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Rampage1, попробуйте временно включить pap (в настройках L2TP).

А у меня эта галка и была взведена..

Вообще роутер уже месяца 4 вообще не трогал.. Работал и работал.. И вот те на..

 

 

script, info VPN down. Refreshing

97 Jan/02/1970 00:02:08 memory script, info VPN down. Refreshing

98 Jan/02/1970 00:02:08 memory l2tp, ppp, info corbina-l2tp: terminating... - session closed

99 Jan/02/1970 00:02:08 memory l2tp, ppp, info corbina-l2tp: disconnected

100 Jan/02/1970 00:02:08 memory l2tp, ppp, info corbina-l2tp: initializing...

101 Jan/02/1970 00:02:08 memory l2tp, ppp, info corbina-l2tp: dialing...

102 Jan/02/1970 00:02:08 memory l2tp, ppp, info corbina-l2tp: terminating... - old tunnel is not closed yet

103 Jan/02/1970 00:02:08 memory l2tp, ppp, info corbina-l2tp: disconnected

104 Jan/02/1970 00:02:09 memory l2tp, ppp, info corbina-l2tp: initializing...

105 Jan/02/1970 00:02:09 memory l2tp, ppp, info corbina-l2tp: dialing...

106 Jan/02/1970 00:02:09 memory script, info VPN down. Refreshing

107 Jan/02/1970 00:02:10 memory script, info VPN down. Refreshing

108 Jan/02/1970 00:02:10 memory l2tp, ppp, info corbina-l2tp: authenticated

109 Jan/02/1970 00:02:10 memory l2tp, ppp, info corbina-l2tp: connected

110 Jan/02/1970 00:02:10 memory l2tp, ppp, info corbina-l2tp: terminating... - session closed

111 Jan/02/1970 00:02:10 memory l2tp, ppp, info corbina-l2tp: disconnected

112 Jan/02/1970 00:02:11 memory script, info VPN down. Refreshing

113 Jan/02/1970 00:02:11 memory l2tp, ppp, info corbina-l2tp: initializing...

114 Jan/02/1970 00:02:11 memory l2tp, ppp, info corbina-l2tp: dialing...

115 Jan/02/1970 00:02:12 memory script, info VPN down. Refreshing

116 Jan/02/1970 00:02:12 memory l2tp, ppp, info corbina-l2tp: terminating... - session closed

117 Jan/02/1970 00:02:12 memory l2tp, ppp, info corbina-l2tp: disconnected

118 Jan/02/1970 00:02:13 memory system, info, account user admin logged out from 192.168.88.253 via web

119 Jan/02/1970 00:02:13 memory script, info VPN down. Refreshing

120 Jan/02/1970 00:02:14 memory l2tp, ppp, info corbina-l2tp: initializing...

121 Jan/02/1970 00:02:14 memory l2tp, ppp, info corbina-l2tp: dialing...

122 Jan/02/1970 00:02:14 memory script, info VPN down. Refreshing

123 Jan/02/1970 00:02:15 memory script, info VPN down. Refreshing

124 Jan/02/1970 00:02:16 memory script, info VPN down. Refreshing

125 Jan/02/1970 00:02:17 memory

 

 

 

Билайн сапорт естественно сразу на роутер грешить начал

Изменено пользователем NikIv

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вообще роутер уже месяца 4 вообще не трогал.. Работал и работал.. И вот те на..

Почитайте эту ветку, начиная с 31 страницы, у других пользователей тоже внезапно отваливался Инет. Если вы ничего не делали, значит сделал кто...? Правильно, и почитайте об этом.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вообще роутер уже месяца 4 вообще не трогал.. Работал и работал.. И вот те на..

Почитайте эту ветку, начиная с 31 страницы, у других пользователей тоже внезапно отваливался Инет. Если вы ничего не делали, значит сделал кто...? Правильно, и почитайте об этом.

, вообщем да.. странно.

 

что сделал: подключил ноут к шнурку на прямую:

C:\Users\xxx> nslookup tp.internet.beeline.ru
Server:  hdns2.corbina.net
Address:  85.21.192.3

Name:    tp.internet.beeline.ru
Address:  85.21.0.218

 

После чего, в консоли микротика - /ip route print detail

результат (на скриншоте)

post-624651-065319200 1432036424_thumb.png

 

записал gateway в блокнотик...

 

после чего:

/ip route

add comment="Beeline VPN server subnet" distance=1 dst-address=85.21.0.0/24 gateway=10.227.56.1

 

и интернет сразу заработал. шайтан труба какая то...

Изменено пользователем Rampage1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да нет никакой шайтан трубы.

В Москве у Билайна несколько подсеток vpn серверов. Вас почему-то переключили на другую.

Скоро еще и 100-ая подсеть придет - придется опять маршруты править.

Билайн нас держит в тонусе, чтобы не забывали как команды в терминале набирать :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Самое обидное тут - нам ничего не говорят про изменения.

Я после произошедшего специально звонил в поддержку на случай ничего ли у вас не сломалось/менялось. Ответ был: нет, проблема на вашей стороне. И все.

И мы ваш роутер официально не поддерживаем.

Еслиб хоть какое-то письмишко мол переключаем.. Для информации.

 

Ну да ладно, как говорится, забыли до следующего изменения в корбине..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Переодически отваливается соединение на компе.

Начало происходит после переустановки винды или после того как сгорел блок питания роутера (работает по Poe), произашло это практически одновременно. Но все-таки грешу на сетевуху, из-за чего это может быть?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Hacked,у вас микротик роутер?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Hacked,у вас микротик роутер?

Да. Настраивал по видео с рутуба которео тут уже светилось и тут тоже советы спрашивал. Как выложить конфиг?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

/ip route

add comment="Beeline VPN server subnet" distance=1 dst-address=85.21.0.0/24 gateway=10.227.56.1

 

и интернет сразу заработал. шайтан труба какая то...

 

Большое спасибо за направление мысли в нужное русло. Действительно Билайн не предупреждая меняет подсети. Сегодня нас (Москва, район Аэропорт) после короткого отключения перевели на 100.x.x.x Техподдержка об этом молчит как рыба. "Напрямую работает? Настраивайте роутер" Но проблема только с Микротиком. Подключил старый Зухель -- сразу завелся. В Микротике пришлось с бубном. По методу Rampage1 выяснил новый шлюз и успешно поднял интернет.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Hacked,у вас микротик роутер?

Да. Настраивал по видео с рутуба которео тут уже светилось и тут тоже советы спрашивал. Как выложить конфиг?

Билайн подкинул нам свинью, настройки с рутуба в сотке больше не работают.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Hacked,у вас микротик роутер?

Да. Настраивал по видео с рутуба которео тут уже светилось и тут тоже советы спрашивал. Как выложить конфиг?

Билайн подкинул нам свинью, настройки с рутуба в сотке больше не работают.

Я как понял проблема с впн сервером?

Вот что у меня выдает /ip route print detail

[admin@MikroTik] > /ip route print detail 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
0 ADS  dst-address=0.0.0.0/0 gateway=192.168.255.255 
       gateway-status=192.168.255.255 reachable via  beeline-l2tp distance=1 
       scope=30 target-scope=10 

1 ADS  dst-address=10.0.0.0/8 gateway=10.29.72.1 
       gateway-status=10.29.72.1 reachable via  Port2 distance=0 scope=30 
       target-scope=10 vrf-interface=Port2 

2 ADC  dst-address=10.29.72.0/21 pref-src=10.29.73.34 gateway=Port2 
       gateway-status=Port2 reachable distance=0 scope=10 

3 A S  dst-address=78.107.1.0/24 gateway=10.29.72.1 
       gateway-status=10.29.72.1 reachable via  Port2 distance=1 scope=30 
       target-scope=10 

4 ADS  dst-address=78.107.23.0/24 gateway=10.29.72.1 
       gateway-status=10.29.72.1 reachable via  Port2 distance=0 scope=30 
       target-scope=10 vrf-interface=Port2 

5 ADS  dst-address=78.107.51.0/28 gateway=10.29.72.1 

Изменено пользователем Hacked

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость
Эта тема закрыта для публикации сообщений.