Davli

MikroTik RB/MRTG (miniROUTERG) Часть 1

Рекомендованные сообщения

[url="http://minirouter.ru/"]http://minirouter.ru/[/url]
Инструкция по настройке от [b][member="Kuja Leonhart "][/b] :
http://homenet.beeline.ru/index.php?showtopic=252615&st=180&p=1065169593&#entry1065169593

Раздел «Документация»
"Инструкция проверена на моделях роутеров Mikrotik RB750, RB750G, RB450, RB450G"

[url="http://homenet.beeline.ru/index.php?showtopic=252615&view=findpost&p=1064975383"][b]DDNS NO-IP.com на Mikrotik v5.x [Решение][/b][/url] Изменено пользователем  Ni©olas

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Апну топик. Интересны различные настройки для микротиков, сам пока только начал разбираться в местной OS, тем более что с никсами до этого дела не имел. Впн удалось поднять только каким-то мне самому пока неясным способом с другого форума, тем более что маршруты как оказалось в корбине выдаются не в соотв-вии с RFC. Если кто покажет свои настройки л2тп/пптп-клиента и его сопутствующих - буду благодарен -)

Для примера привожу настройки своего NAT:

[******@MikroTik] > ip firewall nat print
Flags: X - disabled, I - invalid, D - dynamic
0;;; default configuration
 chain=srcnat action=masquerade out-interface=ether1-gateway

1   chain=srcnat action=masquerade out-interface=l2tpcorb

2   chain=dstnat action=dst-nat to-addresses=192.168.88.3 to-ports=31870
 protocol=tcp dst-port=31870

3   chain=dstnat action=dst-nat to-addresses=192.168.88.3 to-ports=31870
 protocol=udp dst-port=31870

4   chain=dstnat action=dst-nat to-addresses=192.168.88.2 to-ports=11462
 protocol=udp dst-port=11462

5   chain=dstnat action=dst-nat to-addresses=192.168.88.2 to-ports=11462
 protocol=tcp dst-port=11462

6   chain=dstnat action=dst-nat to-addresses=192.168.88.2 to-ports=11464
 protocol=udp dst-port=11464

7   chain=dstnat action=dst-nat to-addresses=192.168.88.2 to-ports=11464
 protocol=tcp dst-port=11464

По нему также есть пара вопросов - пытался задавать порты группой - порт-мэппинг не работает, а также неясно можно ли задать в protocol несколько значений.

[******@MikroTik] > interface l2tp-client print
Flags: X - disabled, R - running
0  R name="l2tpcorb" max-mtu=1460 max-mru=1460 mrru=disabled
  connect-to=85.21.0.255 user="*******" password="****"
  profile=Corbina add-default-route=yes dial-on-demand=no
  allow=pap,chap,mschap1,mschap2

[******@MikroTik] > ppp profile print
Flags: * - default
0 * name="default" use-compression=default use-vj-compression=default
 use-encryption=default only-one=default change-tcp-mss=yes

1   name="Corbina" remote-address=192.168.88.1 use-compression=default
 use-vj-compression=no use-encryption=no only-one=yes change-tcp-mss=yes

2 * name="default-encryption" use-compression=default
 use-vj-compression=default use-encryption=yes only-one=default
 change-tcp-mss=yes

И вкупе к последнему - читал где-то о скрипте для получения адреса впн-сервера, пытался подставить вместо 85.21.0.255 [:resolve tp.corbina.net] - не принял.

Изменено пользователем Rivia

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Апну топик. Интересны различные настройки для микротиков, сам пока только начал разбираться в местной OS, тем более что с никсами до этого дела не имел. Впн удалось поднять только каким-то мне самому пока неясным способом с другого форума, тем более что маршруты как оказалось в корбине выдаются не в соотв-вии с RFC. Если кто покажет свои настройки л2тп/пптп-клиента и его сопутствующих - буду благодарен -)

Для примера привожу настройки своего NAT:

[******@MikroTik] > ip firewall nat print
Flags: X - disabled, I - invalid, D - dynamic
0;;; default configuration
 chain=srcnat action=masquerade out-interface=ether1-gateway

1   chain=srcnat action=masquerade out-interface=l2tpcorb

2   chain=dstnat action=dst-nat to-addresses=192.168.88.3 to-ports=31870
 protocol=tcp dst-port=31870

3   chain=dstnat action=dst-nat to-addresses=192.168.88.3 to-ports=31870
 protocol=udp dst-port=31870

4   chain=dstnat action=dst-nat to-addresses=192.168.88.2 to-ports=11462
 protocol=udp dst-port=11462

5   chain=dstnat action=dst-nat to-addresses=192.168.88.2 to-ports=11462
 protocol=tcp dst-port=11462

6   chain=dstnat action=dst-nat to-addresses=192.168.88.2 to-ports=11464
 protocol=udp dst-port=11464

7   chain=dstnat action=dst-nat to-addresses=192.168.88.2 to-ports=11464
 protocol=tcp dst-port=11464

В профиле виртуальный адрес (remote-address=85.21.0.254) может быть любым.

[admin@MikroTik] > interface l2tp-client print; ppp profile print
Flags: X - disabled, R - running 
0  R name="l2tp-corbina" max-mtu=1460 max-mru=1500 mrru=disabled connect-to=85.21.0.255 user="corbina" password="corbina" 
  profile=corbina add-default-route=yes dial-on-demand=no allow=chap

Flags: * - default 
0 * name="corbina" remote-address=85.21.0.254 use-compression=no use-vj-compression=no use-encryption=no only-one=yes 
 change-tcp-mss=yes

По нему также есть пара вопросов - пытался задавать порты группой - порт-мэппинг не работает, а также неясно можно ли задать в protocol несколько значений.

[******@MikroTik] > interface l2tp-client print
Flags: X - disabled, R - running
0  R name="l2tpcorb" max-mtu=1460 max-mru=1460 mrru=disabled
  connect-to=85.21.0.255 user="*******" password="****"
  profile=Corbina add-default-route=yes dial-on-demand=no
  allow=pap,chap,mschap1,mschap2

[******@MikroTik] > ppp profile print
Flags: * - default
0 * name="default" use-compression=default use-vj-compression=default
 use-encryption=default only-one=default change-tcp-mss=yes

1   name="Corbina" remote-address=192.168.88.1 use-compression=default
 use-vj-compression=no use-encryption=no only-one=yes change-tcp-mss=yes

2 * name="default-encryption" use-compression=default
 use-vj-compression=default use-encryption=yes only-one=default
 change-tcp-mss=yes

т.е. при вот такой форме записи трансляции не работают?

ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.1.2 to-ports=33343-33373 protocol=udp in-interface=l2tp-corbina dst-port=33343-33373

Задать protocol tcp&udp, imho, можно в двух разных правилах, в одном парсер не позволит. По крайней мере мне такой возможности не попалось.

 

И вкупе к последнему - читал где-то о скрипте для получения адреса впн-сервера, пытался подставить вместо 85.21.0.255 [:resolve tp.corbina.net] - не принял.
При использовании :resolve имя должно заключаться в ковычки (connect-to=[:resolve "tp.corbina.net"]) - адрес резольвится один раз и записывается в конфиг, но для этого должны быть доступны dns-сервера

Вот эту тему читали?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
т.е. при вот такой форме записи трансляции не работают?
ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.1.2 to-ports=33343-33373 protocol=udp in-interface=l2tp-corbina dst-port=33343-33373

Задать protocol tcp&udp, imho, можно в двух разных правилах, в одном парсер не позволит. По крайней мере мне такой возможности не попалось.

Странно, вчера точно создавал правило и не работало - сегодня создал еще раз - все нормально. in-interface не указываю, поскольку нужно и на l2tp и на локальное.

[******@MikroTik] > ip firewall nat add chain=dstnat action=dst-nat to-addresses=
192.168.88.2 to-ports=11472-11475 dst-port=11472-11475 protocol=tcp

Протокол пытался прописать с && - не воспринимает =)

По остальным пунктам - уже вечером попробую, спасибо за наводку. Тему кстати видел, но если честно пока не очень понимаю куда девать скрипт.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Тему кстати видел, но если честно пока не очень понимаю куда девать скрипт.

В смысле куда? Подозреваю, что именно туда :D

[admin@MikroTik] > system script print; system scheduler print
Flags: I - invalid 
0   name="l2tp-watcher" owner="admin" policy=read,write,policy,winbox,sensitive run-count=0 
 source=
   :if ([interface l2tp-client get l2tp-corbina running] = false) do={
   /ip dns cache flush
   :local CurrentL2TPIP [:resolve tp.corbina.net]
   :local TMPL2TPIP [/interface l2tp-client get [/interface l2tp-client find name="l2tp-corbina"] connect-to]
   :if ($CurrentL2TPIP != $TMPL2TPIP) do= {/interface l2tp-client set [/interface l2tp-client find name="l2tp-corbina"] connect-to=$CurrentL2TPIP}}

[art@MikroTik] > system scheduler print detail 
Flags: X - disabled 
0   name="l2tp-watcher" start-date=jan/01/2010 start-time=00:00:00 interval=1m on-event="" owner="admin" 
 policy=read,write,policy,winbox,sensitive run-count=1 next-run=12:00:00

 

Или куда в значении как?

Есть три пути простой, самый простой и возможный (наверное есть ещё и правильный, но я с ним не знаком :D)

Простой:

создаете тело скрипта

system script add name=pptp-watcher policy=read,write,policy,winbox,sensitive source=

во свтроенном редакторе создаете сам скрипт

system script edit pptp-watcher value-name=source;

:if ([interface pptp-clientget pptp-corbina running] = false) do={
/ip dns cache flush
:local CurrentVPNIP [:resolve vpn.corbina.net]
:local TMPVPNIP [/interface pptp-client get [/interface pptp-client find name=pptp-corbina] connect-to]
:if ($CurrentVPNIP != $TMPVPNIP) do= {/interface pptp-client set [/interface pptp-client find name="pptp-corbina"] connect-to=$CurrentVPNIP}
}

C-c quit C-o save&quit C-u undo C-k cut line C-y paste F5 repaint

Очень простой используя winbox

Возможный (пишете в одну строку "\r\n" - перевод строки):

system script add name=pptp-watcher policy=read,write,policy,winbox,sensitive source=":if ([interface pptp-clientge
t pptp-corbina running] = false) do={\r\n/ip dns cache flush\r\n:local CurrentVPNIP [:resolve vpn.corbina.net]\r\n:local TMPVPNIP [/
interface pptp-client get [/interface pptp-client find name=pptp-corbina] connect-to]\r\n:if ($CurrentVPNIP != $TMPVPNIP) do= {/interface pptp-client set [/interface pptp-client find name=pptp-corbina] connect-to=$CurrentVPNIP}}"

 

P.S. Поправил кое чего, попутал pptp с l2tp

Изменено пользователем roug

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

roug,

Да, именно как =) Благодарю.

Вообще стоит имхо поддерживать тему для не столь сведующих во всех этих делах людей, опять же уровень знаний у всех разный. Авось платформа популярность приобретет =)

ЗЫ Вот 1 вещь насторожила, можете назвать параноиком, но случайно обратил внимание на факт, что лановская сеть по молчанию 192.168.88.0/24 при изготовлении в Латвии =/ Я - совсем параноик?

Изменено пользователем Rivia

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
лановская сеть по молчанию 192.168.88.0/24 при изготовлении в Латвии =/

А что вас смущает? Ведь перед "88" нет "14".

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да так...

А вот кстати еще один вопрос - винбокс отказывается коннектиться к роутеру (сначала Logging on 192.168.88.1, а затем Router has been disconnected ). Никаких доп. настроек в роутере для него не нужно?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Да так...

А вот кстати еще один вопрос - винбокс отказывается коннектиться к роутеру (сначала Logging on 192.168.88.1, а затем Router has been disconnected ). Никаких доп. настроек в роутере для него не нужно?

Нет, никаких. Ему даже ip-адрес не нужен, но мешает подключиться скорее всего настройки файервола (по-умолчанию используется порт tcp 8291)

Изменено пользователем roug

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Да так...

А вот кстати еще один вопрос - винбокс отказывается коннектиться к роутеру (сначала Logging on 192.168.88.1, а затем Router has been disconnected ). Никаких доп. настроек в роутере для него не нужно?

Нет, никаких. Ему даже ip-адрес не нужен, но мешает подключиться скорее всего настройки файервола (по-умолчанию используется порт tcp 8291)

Да вот как раз фаервол я проверял - видно даже как проходит запрос на соединение и не блокируется. Отключал даже фаервол на всякий случай, все равно дисконнект =(

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Да вот как раз фаервол я проверял - видно даже как проходит запрос на соединение и не блокируется. Отключал даже фаервол на всякий случай, все равно дисконнект =(

Ну если исключить влияние ещё каких-нибудь файерволов, ошибку с вводом параметров аутентификации и пр., то попробуйте сохранить текущий конфиг (system backup save) и сбросить до "состояния поставки". Я поймал странный глюк с правилами ната, настраивая свеже установленный routeros и вылечилось только сбросом (system reset-configuration)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
[******@MikroTik] > system script print; system scheduler print det
Flags: I - invalid
0   name="l2tpwatch" owner="******" policy=read,write,policy,winbox,sensitive
 last-started=mar/26/2010 15:10:27 run-count=2
 source=
   :if ([interface l2tp-client get l2tpcorb running] = false) do={
   /ip dns cache flush
   :local CurrentL2TPIP [:resolve tp.corbina.net]
   :local TMPL2TPIP [/interface l2tp-client get [/interface l2tp-client find name="l2tpcorb"] connect-to]
   :if ($CurrentL2TPIP != $TMPL2TPIP) do= {/interface l2tp-client set [/interface l2tp-client find name="l2tpcorb"] connect-to=$CurrentL2TPIP}}

Flags: X - disabled
0   name="l2tpw" start-date=jan/01/2010 start-time=00:00:00 interval=1m
 on-event=l2tpwatch owner="******"
 policy=read,write,policy,winbox,sensitive run-count=107
 next-run=16:48:00

Понимаю, что звучит глупо, но не понимаю почему не запускается =( В шедулере l2tpwatch подсвечивается красным, видимо не опознается имя скрипта. Никто не сталкивался?

Изменено пользователем Rivia

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
[******@MikroTik] > system script print; system scheduler print det
Flags: I - invalid
0   name="l2tpwatch" owner="******" policy=read,write,policy,winbox,sensitive
 last-started=mar/26/2010 15:10:27 run-count=2
 source=
   :if ([interface l2tp-client get l2tpcorb running] = false) do={
   /ip dns cache flush
   :local CurrentL2TPIP [:resolve tp.corbina.net]
   :local TMPL2TPIP [/interface l2tp-client get [/interface l2tp-client find name="l2tpcorb"] connect-to]
   :if ($CurrentL2TPIP != $TMPL2TPIP) do= {/interface l2tp-client set [/interface l2tp-client find name="l2tpcorb"] connect-to=$CurrentL2TPIP}}

Flags: X - disabled
0   name="l2tpw" start-date=jan/01/2010 start-time=00:00:00 interval=1m
 on-event=l2tpwatch owner="******"
 policy=read,write,policy,winbox,sensitive run-count=107
 next-run=16:48:00

Понимаю, что звучит глупо, но не понимаю почему не запускается =( В шедулере l2tpwatch подсвечивается красным, видимо не опознается имя скрипта. Никто не сталкивался?

Не запускается - это как? log print что говорит? Вы, часом, не пытаетесь при активном интерфейсе l2tpcorb его запустить?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

roug,

большое спасибо за ваши ответы =)

l2tpcorb активен, но я так понимаю скрипт по шедулеру все равно должен запускаться, и уже в теле скрипта должно не выполняться условие :if ([interface l2tp-client get l2tpcorb running] = false) и соответственно счетчик кол-ва запусков скрипта должен увеличиваться параллельно со счетчиком шедулера. Или я не прав?

Изменено пользователем Rivia

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
roug,

большое спасибо за ваши ответы =)

l2tpcorb активен, но я так понимаю скрипт по шедулеру все равно должен запускаться, и уже в теле скрипта должно не выполняться условие :if ([interface l2tp-client get l2tpcorb running] = false) и соответственно счетчик кол-ва запусков скрипта должен увеличиваться параллельно со счетчиком шедулера. Или я не прав?

До тех пор пока l2tpcorb UP счетчик скрипта увеличиваться не будет, в отличие от счетчика попыток шедулера.

Наврал, оба счетчика синхронно увеличиваются

Изменено пользователем roug

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Тут мне на иксбт подсказали, что дело может быть в версии ОС, я начал копать и поплыл =) Уровень лицензии, версия прошивки, версия ОС, upgradable-to - я начинаю путаться =) Попробую сейчас поставить прошивку и ОС поновее, судя по всему лицензия позволяет (вопрос почему рутер поставляется с ОС значительно ниже возможной остается за кадром).

Upd: по всей видимости проблема действительно была в лицензии, обновил RouterOS с 3.31 до 4.6 - счетчик пошел.

Изменено пользователем Rivia

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Upd: по всей видимости проблема действительно была в лицензии, обновил RouterOS с 3.31 до 4.6 - счетчик пошел.

Скорее в версии. B) (Так как железку я так и не купил..., то routeros изначальной v 4.6 живет в виде PC-дистрибутива и с вопросами обновления пока не сталкивался)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Upd: по всей видимости проблема действительно была в лицензии, обновил RouterOS с 3.31 до 4.6 - счетчик пошел.

Скорее в версии. B) (Так как железку я так и не купил..., то routeros изначальной v 4.6 живет в виде PC-дистрибутива и с вопросами обновления пока не сталкивался)

Ну да, я и имел ввиду версию ОС, печатал уже на автомате =/

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Приветствую.

Полдня мучаюсь с новоиспеченным RB750G, толку почти ноль.

Добился стабильного поднятия vpn (не валится каждые 50 сек).

А дальше - полный завал.

Настройки аналогичны Rivia.

Только не работает=)))

Точнее максимум, что получается выжать - это пинг с роутера на поднятый корбиновский vpn-интерфейс. Все остальное не работает.

Вот мои настройки:

 

ppp профили.

Flags: * - default 
0 * name="default" use-compression=default use-vj-compression=default 
    use-encryption=default only-one=default change-tcp-mss=yes 

1   name="Corbina" remote-address=192.168.200.1 use-compression=no 
    use-vj-compression=no use-encryption=no only-one=yes change-tcp-mss=yes 

2 * name="default-encryption" use-compression=default use-vj-compression=no 
    use-encryption=no only-one=default change-tcp-mss=no 

 

Nat

 

Flags: X - disabled, I - invalid, D - dynamic 
0   ;;; default configuration
    chain=srcnat action=masquerade out-interface=ether1-gateway 

1   chain=srcnat action=masquerade out-interface=corbinapptp 

 

PPTP client:

 

Flags: X - disabled, R - running 
0  R name="corbinapptp" max-mtu=1460 max-mru=1500 mrru=disabled 
     connect-to=85.21.0.192 user="login" password="pass" 
     profile=Corbina add-default-route=yes dial-on-demand=no allow=chap

 

IP адреса, которые получаю.

 

Flags: X - disabled, I - invalid, D - dynamic 
#   ADDRESS            NETWORK         BROADCAST       INTERFACE              
0   ;;; default configuration
    192.168.88.1/24    192.168.88.0    192.168.88.255  ether2-local-master    
1 D 10.84.87.82/21     10.84.80.0      10.84.87.255    ether1-gateway         
2 D 95.25.116.97/32    192.168.200.1   0.0.0.0         corbinapptp            

 

И таблица маршрутизации.

 

Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
#      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
0 A S  0.0.0.0/0                          10.84.80.1         1       
1  DS  0.0.0.0/0                          192.168.200.1      1       
2 ADS  10.0.0.0/8                         10.84.80.1         0       
3 ADC  10.84.80.0/21      10.84.87.82     ether1-gateway     0       
4 ADS  78.107.23.0/24                     10.84.80.1         0       
5 ADS  78.107.51.0/28                     10.84.80.1         0       
6 ADS  78.107.196.0/22                    10.84.80.1         0       
7 ADS  78.107.235.4/30                    10.84.80.1         0       
8 ADS  83.102.146.96/27                   10.84.80.1         0       
9 ADS  83.102.231.32/28                   10.84.80.1         0       
10 ADS  85.21.72.80/28                     10.84.80.1         0       
11 ADS  85.21.79.0/24                      10.84.80.1         0       
12 ADS  85.21.90.0/24                      10.84.80.1         0       
13 ADS  85.21.108.16/28                    10.84.80.1         0       
14 ADS  85.21.138.208/28                   10.84.80.1         0       
15 ADC  192.168.88.0/24    192.168.88.1    ether2-local-ma... 0       
16 ADC  192.168.200.1/32   95.25.116.97    corbinapptp        0       
17 ADS  217.118.84.213/32                  10.84.80.1         0       
18 ADS  217.118.84.249/32                  10.84.80.1         0   

 

Если кому не лень, вышлете файл конфигурации, который точно будет работать у кобины...

Да, коробка как простой шлюз в сеть с натом работает....А вот при поднятии pptp клиента - отказывается работать...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

itoolsy,

попробуйте сначала увеличть метрику для

0 A S 0.0.0.0/0 10.84.80.1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
itoolsy,

попробуйте сначала увеличть метрику для

0 A S 0.0.0.0/0 10.84.80.1 1

Я бы даже сказал: попробуй убрать этот маршрут вообще.

ip route remove numbers=0;

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
itoolsy,

попробуйте сначала увеличть метрику для

0 A S 0.0.0.0/0 10.84.80.1 1

Я бы даже сказал: попробуй убрать этот маршрут вообще.

ip route remove numbers=0;

 

Без этого маршрута не пингуется vpn- сервер. Это маршрут по умолчанию, который должен получать хост вместе с IP адресом по dhcp от Корбины. Тока вот микротик не понимает, выдаваемый по dhcp default gateway... Приходится прописывать руками.

Попробую увеличить метрику.

Изменено пользователем itoolsy

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Приветствую Всех!

4-тые сутки бьюсь с настройкой интернета от Билайна с такой железкой как Mikrotik 750G с установленной RouterOS 4.8.

Прошу помощи.

 

Соединение используется vpn (Астрахань): vpn.internet.beeline.ru т.к. у нас кроме PPTP нет ничего даже L2TP sad.gif

 

Изначально у данного роутера имеется проблема с сопоставлением для имени vpn.internet.beeline.ru - IP адреса (он динамический для балансировки нагрузки на сеть). Но как я понял, данная проблема не решается (по крайней мере в существующих прошивках) и было решено не останавливаться и использовать ip-адрес (89.179.75.1-7, именно в этом диапазоне меняются адреса при трассировке в разное время суток).

После долгих танцев с бубном PPTP все же было установлено, но имеется две проблемы: 1. соединение не держится более 1 минуты, рвется и соединяется заново; 2. Даже при активном соединении до интернета добраться не представляется возможным, пинги не проходят. DNS при этом работает.

 

Подскажите пожалуйста на примерах как настроить это чудо техники.

Фото основных настроек прилагаю.

post-591645-1272612610_thumb.jpg

post-591645-1272612626_thumb.jpg

post-591645-1272612640_thumb.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

mark949,

точно не знаю как оно у вас там работает, однако проблема по-моему та же - с маршрутом 0.0.0.0/0 (решения - выше), кроме того у нас насколько я знаю аутентификация пользователей происходит по mschapv2, не знаю как у вас.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Кто знает какими правилами заставить Mikrotik определять адреса (заставить работать DNS) без поднятия соединения !?

Я выяснил проблемы отказа соединения по имени (tp.corbina.net либо vpn.internet.beeline.ru), все дело в том что DNS в нем работает только после поднятия соединения, в моем случае соединясь по ip 89.179.75.1-7

имя tp.corbina.net определяется как :

[admin@MikroTik] > ping tp.corbina.net

85.21.0.251 64 byte ping: ttl=247 time=31 ms

85.21.0.251 64 byte ping: ttl=247 time=31 ms

85.21.0.251 64 byte ping: ttl=247 time=31 ms

3 packets transmitted, 3 packets received, 0% packet loss

round-trip min/avg/max = 31/31.0/31 ms

 

а это не верно, этому имени должно соответствовать :

C:\Documents and Settings\Admin>ping tp.corbina.net

 

Обмен пакетами с tp.corbina.net [89.179.75.1] по 32 байт:

 

Ответ от 89.179.75.1: число байт=32 время<1мс TTL=249

Ответ от 89.179.75.1: число байт=32 время<1мс TTL=249

Ответ от 89.179.75.1: число байт=32 время<1мс TTL=249

(пример пинга по имени с компа без поднятого соединения, после поднятия ip меняется почемуто)

 

Только по данному адресу возможно соединение

 

Из-за этого получается когда мы вводим Mikrotik-у в "Server address" имя "tp.corbina.net":

1. без соединения - он не получает ничего совсем и дает сообщение об ошибке "сопоставления имени ip-адреса"

2. с соединением - (повторюсь с ручным вводом верного ip соединение проходит без проблем ) - он получает ip но не верное (85.21.0.251вместо 89.179.75.1) и записывает его в кеш своего DNS и соот-но ошибку об "сопоставлении имени ip-адреса" он больше выдает, но и соединение он поднять не может (ip адрес не верен). В логе в таком случае:

 

10:04:24 l2tp,ppp,info l2tpcorb: dialing...

10:04:25 system,info nat rule changed by admin

10:04:43 system,info nat rule removed by admin

10:04:48 l2tp,ppp,info l2tpcorb: terminating... - session closed

10:04:48 l2tp,ppp,info l2tpcorb: disconnected

10:04:55 l2tp,ppp,info l2tpcorb: initializing...

10:04:55 l2tp,ppp,info l2tpcorb: dialing...

10:05:03 l2tp,ppp,info l2tpcorb: terminating...

10:05:03 l2tp,ppp,info l2tpcorb: disconnected

10:05:03 l2tp,ppp,info l2tpcorb: initializing...

10:05:03 l2tp,ppp,info l2tpcorb: dialing...

10:05:03 system,info device changed by admin

10:05:04 l2tp,ppp,info l2tpcorb: authenticated

10:05:04 l2tp,ppp,info l2tpcorb: connected

10:22:58 l2tp,ppp,info l2tpcorb: terminating... - administrator request

10:22:58 l2tp,ppp,info l2tpcorb: disconnected

10:22:58 l2tp,ppp,info l2tpcorb: initializing...

10:22:58 system,info device changed by admin

10:22:58 l2tp,ppp,info l2tpcorb: dialing...

 

вот еще мой NAT :

 

[admin@MikroTik] > /ip firewall nat print

Flags: X - disabled, I - invalid, D - dynamic

0 ;;; NAT for Inet with Control "Inet_Users"

chain=srcnat action=masquerade src-address-list=Internet_Users out-interface=l2tpcorb

 

1 ;;; for DC++

chain=srcnat action=masquerade out-interface=ether1

 

2 chain=dstnat action=dst-nat to-addresses=192.168.11.5 to-ports=55555 protocol=tcp dst-port=55555

 

3 chain=dstnat action=dst-nat to-addresses=192.168.11.5 to-ports=55555 protocol=udp dst-port=55555

 

а вот мои маршруты:

[admin@MikroTik] /ip route> /ip route print

Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit

# DST-ADDRESS PREF-SRC GATEWAY DISTANCE

0 S 0.0.0.0/0 l2tpcorb 1

1 ADS 10.0.0.0/8 10.26.112.1 0

2 ADC 10.26.112.0/21 10.26.114.7 ether1 0

3 A S 89.179.75.0/24 10.26.112.1 1

4 ADC 192.168.11.0/24 192.168.11.100 ether2 0

 

вот такой вот косяк.

я думаю что это не проблема, но не могу сообразить как это сделать.

подскажите пожалуста.

Изменено пользователем mark949

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте! Помогите разобраться с таким вопросом:

Пытаюсь настроить скрипт из этой ветки под свои нужды. Открываю редактор, ввожу такие строки:

:if ([interface l2tp-client get "l2tp" running] = false) do={

/ip dns cache flush;

/log info "L2TP resolve";

:local CurrentVHNIP [:resolve "tp.corbina.net"]

:local TMPVHNIP [/interface l2tp-client get [/interface l2tp-client find name =\"l2tp\"] connect-to]

:if ($CurrentVHNIP != $TMPVHNIP) do= {/interface l2tp-client set [/interface l2tp-client find name=\"l2tp\"] connect-to=\$CurrentVHNIP}}\

 

Я так понимаю, что команды он распознает, выделяя их цветом. А вот несколько остаются "нераскрашенными".

Здесь не хотят распознаваться "running" , "connect-to" и "false"

Может у них формат какой другой?

Подключение Корбина с L2TP . Версия 4,9, железка RB750G

PS поправил скрипт, а то он почему-то не полностью сюда влез

Изменено пользователем Balzamalex

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Есть такой роутер MikroTik RB/MRTG (miniROUTERG) большая просьба (если можно с картинками) настройки для билайна этой машинки (интересно только настройка локалки, проброс портов для торрент-клиента и настройка внешки).

неужели никто не баловался с этим чудным агрегатом. в сравнительной таблице один из немногих полноценно держащих скорость канала. версия ОС 4.х.х

 

Вот тут народ наконец то сподобился написать на инструкцию для подключения Микротиков к корбине http://minirouter.ru/ Раздел «Документация»

"Инструкция проверена на моделях роутеров Mikrotik RB750, RB750G, RB450, RB450G"

Вроде всё расписано более менее понятно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте уважаемые.

Прошу вас помочь мне в настройке роутера RB/750G при подключении к Beeline по протоколу PPTP. Версия 5.0.5beta

Не смог настроить, руководствуясь вышеуказанной инструкцией... ничего не вышло.

Возможно виноваты неточности в инструкции? Например без, вручную указанного, адреса шлюза не проходит ping www.ru

Имя создаваемого профиля отличается от такового в создаваемом подключении...

Со скриптом вообще ничего не вышло...

Может быть кто-нибудь сможет доступно объяснить.

Положение на данный момент - vpn.internet.beeline.ru пингуется. Локалка провайдера есть. Интернета нет.

 

admin@MikroTik] > ip route print

Flags: X - disabled, A - active, D - dynamic,

C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,

B - blackhole, U - unreachable, P - prohibit

# DST-ADDRESS PREF-SRC GATEWAY DISTANCE

0 A S 0.0.0.0/0 10.242.26.1 1

1 DS 0.0.0.0/0 192.168.200.1 1

2 ADS 10.0.0.0/8 10.242.26.1 1

3 ADC 10.242.26.0/24 10.242.26.144 ether1-gateway 0

4 ADS 78.107.52.0/24 10.242.26.1 1

5 ADS 85.21.72.80/28 10.242.26.1 1

6 ADS 85.21.79.0/24 10.242.26.1 1

7 ADS 85.21.90.0/24 10.242.26.1 1

8 ADC 192.168.88.0/24 192.168.88.1 ether2-local-ma... 0

9 ADC 192.168.200.1/32 95.31.128.3 pptp-corbina 0

10 ADS 217.118.84.0/24 10.242.26.1 1

11 DS 233.33.210.0/24 10.242.26.144 1

 

[admin@MikroTik] > ip firewall nat print

Flags: X - disabled, I - invalid, D - dynamic

0 ;;; default configuration

chain=srcnat action=masquerade out-interface=ether1-gateway

 

1 chain=srcnat action=masquerade out-interface=pptp-corbina

 

2 I chain=srcnat action=masquerade out-interface=corbina-l2tp

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость
Эта тема закрыта для публикации сообщений.