Архивировано

Эта тема находится в архиве и закрыта для публикации сообщений.

eXcessive

Quake 3 для Linux

Рекомендованные сообщения

Недавно переехал с винды на линукс. Все круто и т.д., но сильно нехватает одной штуки - q3 :P Я знаю, что q3 для линукса есть, но нигде не могу найти. :P Если кто знает, где скачать, напишите ссылку или хэш, плз :beer2: Заранее спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Недавно переехал с винды на линукс. Все круто и т.д., но сильно нехватает одной штуки - q3 :D Я знаю, что q3 для линукса есть, но нигде не могу найти. :o Если кто знает, где скачать, напишите ссылку или хэш, плз :( Заранее спасибо.

 

Береш кваку виндову удаляеш оттуда все кроме baseq3 сохраняя при этом разбивку деректорий в папке baseq3 удалаеш все кроме официальных паков pak0, pak1, pak2,pak3, pak4, pak5,pak6, pak7, pak8 качаеш линуховый патч для версии 1.32, инсталиш его незабудь на линухе должны стоять иксы, я просто без них не пробовал но вроде он ругается если их нет. Ну вроде и все запускать надо файлом quake3.x86, незабудь он должен быть исполняемым (просто проверь на всякий случай) вот и все. Патч лудше ставить под рутом а потом на всю деректорию с квакой дать юзерские права.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Оригинально :o:( В самом деле, в паках ведь только исходники лежат, должно пойти :D

 

А без X-сервера он, конечно, не пойдет, ведь X управляет и режимами экрана, и OpenGL'ом

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

при попытке запустить выводит следующую хрень:

 

Q3 1.32 linux-i386 Oct 7 2002

----- FS_Startup -----

Current search path:

/home/andrey/.q3a/baseq3

/home/andrey/quake3/baseq3/pro-q3tourney7.pk3 (10 files)

/home/andrey/quake3/baseq3/pak8.pk3 (9 files)

/home/andrey/quake3/baseq3/pak7.pk3 (4 files)

/home/andrey/quake3/baseq3/pak6.pk3 (64 files)

/home/andrey/quake3/baseq3/pak5.pk3 (7 files)

/home/andrey/quake3/baseq3/pak4.pk3 (272 files)

/home/andrey/quake3/baseq3/pak3.pk3 (4 files)

/home/andrey/quake3/baseq3/pak2.pk3 (148 files)

/home/andrey/quake3/baseq3/pak1.pk3 (26 files)

/home/andrey/quake3/baseq3/pak0.pk3 (3539 files)

/home/andrey/quake3/baseq3

./quake3.x86/baseq3

 

----------------------

4083 files in pk3 files

execing default.cfg

execing q3config.cfg

couldn't exec autoexec.cfg

Hunk_Clear: reset the hunk ok

 

------- Input Initialization -------

Joystick is not active.

------------------------------------

----- Client Initialization -----

----- Initializing Renderer ----

-------------------------------

----- Client Initialization Complete -----

----- R_Init -----

...loading opengl32: QGL_Init: Can't load opengl32 from /etc/ld.so.conf or current dir: /home/andrey/quake3/opengl32: cannot open shared object file: No such file or directory

failed

...loading libGL.so.1: Initializing OpenGL display

...setting mode 4: 800 600

Using XFree86-VidModeExtension Version 2.2

XF86DGA Mouse (Version 2.0) initialized

XFree86-VidModeExtension Activated at 800x600

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Couldn't get a visual

...WARNING: could not set the given mode (4)

Initializing OpenGL display

...setting mode 3: 640 480

Using XFree86-VidModeExtension Version 2.2

XF86DGA Mouse (Version 2.0) initialized

XFree86-VidModeExtension Activated at 640x480

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Couldn't get a visual

...WARNING: could not set the given mode (3)

----- CL_Shutdown -----

RE_Shutdown( 1 )

-----------------------

----- CL_Shutdown -----

-----------------------

Sys_Error: GLimp_Init() - could not load OpenGL subsystem

 

 

Очевидно, проблема в OpenGL. Как это исправить? дистрибутив Ubuntu 5.10; видюха Riva TNT2 32Mb

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Дрова надо вроде поставить для видюхи, вот только где их найти. С дровами и идет опенгл.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А вот где бы достать обновление Q3 (все - Osp, Mappackets и т.д.) для MACINTOSH...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А вот где бы достать обновление Q3 (все - Osp, Mappackets и т.д.) для MACINTOSH...

 

Принцып тот же самый, принцыпиально можеш всю папку ку3 скопироватьь на мак а потом установить патчь 1.32 для макинтоша и все должно работать, меняется только запускающий файл а все остальное остается тем же самым.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Дрова надо вроде поставить для видюхи, вот только где их найти. С дровами и идет опенгл.

 

дрова-то стоят... а все равно не пашет

 

Какой линух, какая версия ядра, какой glib откуда дрова брал, и есть ли там подержка опенгл 1.8

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

если у кого-то проблемы с q3 под linux, то я под линуксом почти всегда и играю(fps выше),если что то могу подсказать,

кроме нативного q3 есть еще ioquake3 - www.ioquake3.org - немного доработанный вариант кваки,появившийся когда открыли сорцы кваки,кстати есть версия и под Mac

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

> я под линуксом почти всегда и играю(fps выше)

 

Я вот тоже... просто потому что других ОС не держу

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Недавно переехал с винды на линукс. Все круто и т.д., но сильно нехватает одной штуки - q3 :) Я знаю, что q3 для линукса есть, но нигде не могу найти. ;) Если кто знает, где скачать, напишите ссылку или хэш, плз :rolleyes: Заранее спасибо.

у миня всё работает на линуксе а какой у тебя линукс

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах