Архивировано

Эта тема находится в архиве и закрыта для публикации сообщений.

Ston4ik

Как настроить ArmA 2 чтобы не блокировали интернет

Рекомендованные сообщения

Помогите пожалуйста с ArmA 2 как настроить firewoll чтобы не банили меня за спамы!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Может, дело в вирусах, а не в фаерволах?

 

Попробуй почистить комп от вирусов - я уверен, это из-за этого.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Почистил 5 вирусов обнаружилось всё удалил! позвонил потом в корбину проверяли вместе с техником по телефону,и всё ровно захожу в игру и опять спам то есть и в большом количестве то раз и нету!Не понятно в чём дело даже!Помогите!600 рублей отдал за лиц диск!вот ссылка обсуждали первую часть игры с такой же проблемой ArmA: Armed Assault но там нормального решения нету!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В игре проблема скорее всего.

Посмотри в настройках.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Чтобы не блокировали сеть, нужно запретить процессу arma2.exe при поиске серверов флудить в нашу сеть. Для этого (см. похожую тему по Left 4 Dead) нужно фаерволлом запретить исходящие UDP-пакеты на адрес 255.255.255.255. Прилагаю скрины, как это сделать с помощью KIS (на примере KIS 2010):

 

1. в списке приложений, выбираем процесс arma2.exe -> правила для программы

ns2pTiRdTe.jpg

 

2. на вкладке "правила" выбираем сетевые правила и нажимаем "добавить" (на скрине результат)

PD1561yy4j.jpg

 

3. в списке сервисов выбираем "any outgoing UDP stream", выбираем "заблокировать" и на всякий случай для уверенности отмечаем галочку "записать в отчет".

в поле адресов выбираем "адреса из группы" и нажимаем "добавить" (на скрине результат)

61L89no7R9.jpg

 

4. имя можно выбрать любое, в поле адреса вбиваем 255.255.255.255/8 ("/8" - маска, специфично для KIS)

IjYEM3wEq1.jpg

 

---

применяем настройки, заходим в Арму, выбираем "сетевая игра", обновляем список серверов, выходим.

в отчетах KIS (если до этого была отмечена галочка "записать в отчет") видим:

kfA0RvXwRp.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

либо скачать из раздела л4д специальную прогу весом в 60 кб для блока

играю с ней в л4д уже полгода и все супер

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

поставил заплатку, которая была в теме л4д... теперь загрузка игры доходит до полной, после этого начинается загрузка данных и на этом всё кончается- ждал минут 10, а "закачка данных" так и не закончилась... чего делать-то? <_<

 

ЗЫ. На сервера с оригинальными кампаниями заходит, а вот на ВарФару и Эволюшин не хочет

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
поставил заплатку, которая была в теме л4д... теперь загрузка игры доходит до полной, после этого начинается загрузка данных и на этом всё кончается- ждал минут 10, а "закачка данных" так и не закончилась... чего делать-то? :rolleyes:

 

ЗЫ. На сервера с оригинальными кампаниями заходит, а вот на ВарФару и Эволюшин не хочет

 

 

Разобрался я в этой проблеме...конечно немного гемора это доставит, но всё же...

Вобщем надо делать так- нужно скачать миссию из интернета самому и установить её в папку MPMissions. После этого никаких проблем с заходом на сервер с данной миссией не будет.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
поставил заплатку, которая была в теме л4д... теперь загрузка игры доходит до полной, после этого начинается загрузка данных и на этом всё кончается- ждал минут 10, а "закачка данных" так и не закончилась... чего делать-то? :)

 

ЗЫ. На сервера с оригинальными кампаниями заходит, а вот на ВарФару и Эволюшин не хочет

 

 

Разобрался я в этой проблеме...конечно немного гемора это доставит, но всё же...

Вобщем надо делать так- нужно скачать миссию из интернета самому и установить её в папку MPMissions. После этого никаких проблем с заходом на сервер с данной миссией не будет.

 

 

У меня таже самая проблема. Скачал все что толко нашел в сети по сетевым миссиям залил все в папку Mpmission и........... хрен мне с палочкой B)

Теперь при попытке подключения к какому либо среваку игра просто вылетает.

Я удалил все миссии и стал заливать по одной, игра нормально вопринимает толко red evolution 93f3 и War 3 front rus 1.0

 

Скажи, как правильно заливать карты: если допустим у меня имеется более поздняя версия и я заливаю новую версию той же карты, надо ли удалять предыдущую? Файлы с миссиями обязательно класть в корень папки mpmission ил можно все рассортировать по папкам?

Так и не нашел нигде Доминации

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

У меня тоже проблемы с Arma2 и с остальными играми этой серии от Bohemia Interactive Studios (Operation Flashpoint и Armed Assault).

Во всех трёх играх семейства наблюдаются проблемы с сетью. Показывается либо желтый и затем красный значок разорванной цепочки, и надписи о не полученных сообщениях (видимо из-за бана), либо, как в Arma2 - просто вылет игры на рабочий стол во время игры по интернет в миссии с большим трафиком (Warfare, прочие CTI).

 

Вначале грешил на рутер, попробовал без рутера - та же фигня. Менял провайдер на стрим, на стриме всё летало, хоть и на медленной скорости инета...

 

Попробую запретить исходящий broadband (255.255.255.255) по UDP через фаервол.... посмотрим, поможет ли...

 

P.S. И БЕЗ, и С скачанной ранее картой и пложенной в MPMissions все-равно получаю висящее окошечко "Закачка данных"... причем на загруженных игроками серверах входящий трафик армы тикает очень медленно, а на русских серверах с малым количеством народа скачивает сразу несклько метров трафика и затем еле ползёт , судя по сетевой активности в Outpos Pro 2009.... а окошечко висит. .... и потом Арма вылетает на рабочий стол с ошибкой.... мдауж......

 

Разрабы писали, что они пофиксили баг с этим окошечком, но баг всё ещё остаётся... Говорят, что это связано с тем, что сервер больше выдаёт трафика уже соединившимся и находящимся в игре клиентам, чем новичкам. Только почму-то как-то криво всё это сделано.... И не понятно, кто же тут виноват...

 

Возможно, виноваты кривые руки миссиесторителей, потому как миссии, отличные от самопальных warfare и cti, такие фокусы не показывают.....

Один только баг с невзможносью русской стороны строить защитные сооружения разработчик миссии пофиксил только хрен знает когда.... что уж про остальное говорить))

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
У меня тоже проблемы с Arma2 и с остальными играми этой серии от Bohemia Interactive Studios (Operation Flashpoint и Armed Assault).

Во всех трёх играх семейства наблюдаются проблемы с сетью. Показывается либо желтый и затем красный значок разорванной цепочки, и надписи о не полученных сообщениях (видимо из-за бана), либо, как в Arma2 - просто вылет игры на рабочий стол во время игры по интернет в миссии с большим трафиком (Warfare, прочие CTI).

 

Вначале грешил на рутер, попробовал без рутера - та же фигня. Менял провайдер на стрим, на стриме всё летало, хоть и на медленной скорости инета...

 

Попробую запретить исходящий broadband (255.255.255.255) по UDP через фаервол.... посмотрим, поможет ли...

 

P.S. И БЕЗ, и С скачанной ранее картой и пложенной в MPMissions все-равно получаю висящее окошечко "Закачка данных"... причем на загруженных игроками серверах входящий трафик армы тикает очень медленно, а на русских серверах с малым количеством народа скачивает сразу несклько метров трафика и затем еле ползёт , судя по сетевой активности в Outpos Pro 2009.... а окошечко висит. .... и потом Арма вылетает на рабочий стол с ошибкой.... мдауж......

 

Разрабы писали, что они пофиксили баг с этим окошечком, но баг всё ещё остаётся... Говорят, что это связано с тем, что сервер больше выдаёт трафика уже соединившимся и находящимся в игре клиентам, чем новичкам. Только почму-то как-то криво всё это сделано.... И не понятно, кто же тут виноват...

 

Возможно, виноваты кривые руки миссиесторителей, потому как миссии, отличные от самопальных warfare и cti, такие фокусы не показывают.....

Один только баг с невзможносью русской стороны строить защитные сооружения разработчик миссии пофиксил только хрен знает когда.... что уж про остальное говорить))

 

Да что тут говорить: меня не проходит закачка данных даже на мой собственный сервер армы 2 :thanx: ( так я борюсь с проблемой заказчки данных, создал свой сервак) Оборону у русских умельцы уже сделали, когда же разрабы устранят эту проблему хрен знает. Игра полна багов как сингл, так и сетовом режиме. Возможна когда нибудь с патчем 1.127 они наконец то уберут все баги

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

в новых версиях Warfare BE 2.027 уже 100% работает защита у русских.

 

попробовал сегодня присоединиться к серверам с warfare без рутера.

результат - закачка данных происходит (после загрузки миссии), затем медленно доползает до конца и появляется желтая цепочка снизу справа. мигает немного, потом просто горит , а потом горит красная цепочка и пишется, что нет соединений 5 секунд..10....40..60.... короче потом меня с сервера выкидывают...

 

вот такая вот Корбина... рутер тут не причем оказался......

 

щас еще раз попробую для верности, со всеми отключенными ферволами и без рутера...

 

на форуме BIS мне написали , что провайдер блокирует ICMP трафик, и поэтому такое происходит.... вот уроды..... блин.... как же теперь играть в арму любимую.... я для этого апгрейд делал..... разгонял железо крутое.... а тут засада таилась в самом неожиданном месте... слов нету просто....

 

попробовал подрубить услугу статического IP и вырубилфаервол на соединение в панели управления (на сайте корбины). Странно, я же давно его отключал, а он там вдру был включён опять. Кто же его назад включал??.... админы чтоли?? ну да ладно...

 

решил еще раз поиграть без рутера... вдруг, за те деньги, которые просят за стат. IP мой кабель из квартиры подрубят на какую нибудь супер железку нетормозящую.....

 

вобщем....оно запахало.... мда...... поиграл в warfare.... правда потом нужно было обратно возвращать рутер, т.к. инет понадобился окружающим тоже. и тут D-Link опять показал свои выкрутасы.. игра с ним не запахала.... конект зависал на последней стадии, уже после окошечка закачки данных...

 

подскажите нормальный рутер который выдержит арму2 в корбине....с D-Link DI-604 чтото не так.....

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну так кто нибудь может дать внятный ответ? Прога из темы LFD2 не помогла.

В посте 5 картинки померли (((

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Многие абоненты Корбины испытывают проблемы при подключении к некоторым ArmA II серверам из-за размера MTU (хоть лично у меня никаких проблем нет, подключаюсь абсолютно к любому серверу без стороннего ПО).

На форумах некоторых серверов об этом уже писали.

У кого проблема в роутере - посмотрите в нем настройки MTU, либо попробуйте сменить протокол с PPPoE на L2TP например.

Хотя большинство проблем именно в авторизации. Многие роутеры (не говоря уже о D-Link) недостаточно мощные чтобы работать с PPPoE или L2TP - отсюда потери пакетов => обрывы связи и огромное время отклика.

В моем случае - роль роутера выполняет отдельная "машинка" на Win 2008 R2 с 2-мя сетевыми картами - проблемы с потерей пакетов сразу же разрешились. До этого стоял роутер ASUS RT-G32 - не тянул.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спустя полгода решил опять поиграть в Арму, опять на сутки заблокировали порт, сегодня попробую старый способ...

 

Рассказываю как я решал это проблему в те времена:

 

1) Ставил KIS (тогда поставил пиратку только для армы, сейчас хорошо есть лицензия)

2) Настраивал по инструкции из поста выше (ylemsoul) (тогда были картинки, было проще, но и без картинок описание вполне понятно, если KIS под рукой)

3) Заходим в Арму, ищем сервера, подключаемся

4) Выбираем сторону/слот и жмем запуск игры когда ползунок доходит до конца "загрузка данных" замирает...

5) Сворачиваем Арму (ALT-TAB), ВЫКЛЮЧАЕМ защиту у KIS (на рабочем столе, внизу-справа около часов красная буква К, правой кнопкой - выключить защиту)

6) Разворачиваем Арму, видим, что "загрузка данных" пробило и игра запускается

7) (по желанию, не обязательно) - повторяем пункт 5)-6) только ВКЛЮЧАЕМ защиту

 

 

Путём многомесячных экспериментов могу сделать следующий вывод:

Все широковещательные запросы идут именно во время поиска серверов. И вся эта лабуда с блокированием трафика требуется только для пункта 3), который длится 5-10 секунд. Однако этого достаточно, для того чтобы "робот" корбины определил это как атака на сеть с забиванием трафика (мне по телефону говорили, что не должно идти больше 15 широковещательных пакетов в секунду, другим провайдерам видимо пофиг).

 

Так что ставим фаерволы, настраиваем и играем :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах