wanderer_mg

Настройка vpn-подключения в Gentoo. "Официальный" способ.

Рекомендованные сообщения

loopa

vim предлагать новичкам - жестоко :blink:

10.XXX.0.17 - это не единственный возможный вариант, в Бирюлево-Восточном шлюз, например, 10.57.15.15. Так что не стоит вводить людей в заблуждение.

 

Какой смысл добавлять по одному хосту? Снова введут новые сервера и опять править?

При маршрутизации vpn-серверов через указывание подсети у меня возникали иногда проблемы с соединением. Добавил твой вариант, как основной, но старый удалять не стал: кому надо - просто раскоментят нужные строки, а ненужные - закоментят.

 

Маршрутизаторы корбины пользуются правилами для подсетей, а не конкретных хостов, так почему ты игнорируешь сети и упрямо прописываешь хосты?

Вообще не понял, что ты хотел этим сказать. Поясни.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

loopa, вариант с указанием подсети не прошел - после поднятия pptp-тоннеля дефолтовый маршрут к конкретному ip-адресу vnp-сервера оказывается приоритетнее и все пакеты безуспешно пытаюся попасть туда напрямую, так что закоментил твой вариант на время разбирательств :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Интересно, а за счёт чего происходит автоматическое восстановление соединения? Или этого в таком способе подключения не предусмотрено?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Интересно, а за счёт чего происходит автоматическое восстановление соединения? Или этого в таком способе подключения не предусмотрено?

 

Предусмотрено, но фиг знает, каким образом ;) Либо сам pppd перезапускает соенидение, либо это делает скриптовая "обвеска" Gentoo :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо за инструкции, заработало сразу без дополнительных правок.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Думаю, теперь стоит настраивать так:

 

http://homenet.corbina.net/index.php?automodule=blog&req=showblog&blogid=410&st=#

 

(правда, пути там не все прописаны)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Гм, я вчера как раз обновил baselayout и ppp, всё работает так же.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Гм, я вчера как раз обновил baselayout и ppp, всё работает так же.

 

Просто я использовал ещё более официальный способ с /etc/conf.d/net.ppp0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

чисто для статистики: у меня по-прежнему работает vpn-скрипт от loop'ы с теми же настройками (версия baselayout - 1.12.0), только в net добавила строчку

config_ppp0=( "ppp" )

, иначе он жалуется, что конфигурации для ппп нету и подымает его по dhcp, с дикой скоростью в 20 м/б в сек. :unsure::king:

кроме того, с сегодняшнего дня (17 авг.) dhcp подхватывается (у меня, по крайней мере) только через dhclient, а dhcpcd пахать отказывается, так что если у кого стоят оба (dhcp и dhcpcd), как у меня, выкидывайте его, потому что по дефолту запускается как раз dhcpcd

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

rsc, А чем твой вариант от моего отличается? Если можно, то объясни по пунктам :)

 

способ с /etc/conf.d/net.ppp0 был официальным когда-то (сам его использовал), но с некоторых пор в нестабильной ветке перешли на другую организацию сетевых init-скриптов и все конфиги переместились в /etc/conf.d/net.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Пожалуй тем, что я слишком давно читал первый пост (в апреле). Из существенного: я удаляю лишний route.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

чего-то мудрят у нас в Измайлово... :)

то нормально подключение проходит, то вот такую фигню выдаёт:

Oct 26 21:44:58 Spica pppd[10690]: pppd 2.4.3 started by root, uid 0											  
Oct 26 21:44:58 Spica pppd[10690]: Using interface ppp0														   
Oct 26 21:44:58 Spica pppd[10690]: Connect: ppp0 <--> /dev/pts/3												  
Oct 26 21:45:00 Spica pppd[10690]: Unknown MS-CHAP authentication failure: E=691 R=0							  
Oct 26 21:45:00 Spica pppd[10690]: CHAP authentication failed													 
Oct 26 21:45:00 Spica pppd[10690]: Connection terminated.														 
Oct 26 21:45:01 Spica pppd[10690]: Exit.   

потом через некоторое время (долгое или не очень) - подключка нормально проходит...

ничего не меняла я в настройках

может это как-то можно обхитрить с моей стороны? ;)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ЕМНИП, снова поменялись кое-какие адреса vpn-серверов. Сейчас поправлю таблицу маршрутизации.

 

UPDATE: Поправил, так что "обновляйтесь"! ;)

 

routes_eth0=(				# Прописываем роутинги
	"10.0.0.0/8 via <шлюз>"

	"195.14.50.1 via <шлюз>"
	"195.14.50.16 via <шлюз>"
	"195.14.50.21 via <шлюз>"
	"195.14.50.26 via <шлюз>"

	"195.14.38.1 via <шлюз>"	# новый
	"195.14.38.2 via <шлюз>"	# новый
#		"195.14.40.6 via <шлюз>"	#убрали
#		"195.14.40.7 via <шлюз>"	#убрали
	"195.14.40.8 via <шлюз>"
	"195.14.40.9 via <шлюз>"
	"195.14.40.13 via <шлюз>"
	"195.14.40.14 via <шлюз>"
	"195.14.40.15 via <шлюз>"
	"195.14.40.16 via <шлюз>" #новый
	"195.14.40.17 via <шлюз>" # новый
	"195.14.40.18 via <шлюз>" # новый

	"85.21.79.0/24 via <шлюз>"
	"85.21.90.0/24 via <шлюз>"
	"85.21.52.254 via <шлюз>"
	"62.205.179.146 via <шлюз>"
	"83.102.146.96/27 via <шлюз>"
)

Изменено пользователем wanderer_mg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

спасиб за быстрый ответ :)

пропинговала, подставила новый ip сервера - вроде завелось

тьфу-тьфу-тьфу ;)

Изменено пользователем Нюра

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

localhost init.d # /etc/init.d/net.ppp0 restart
* Starting ppp0
*   Bringing up ppp0
*	 ppp
*	   Running pppd ...

 

И все так и висит. Что делать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

wanderer_mg, так и будете при каждом изменении править?

 

Я уже читал вашу методу, просто руки никак не доходили ее попробовать. Сейчас буду смотреть...

 

update:

Посмотрел этот пост еще раз, сделал кое-какие изменения в туториале:

- изменились строки, прописывающие маршруты до vpn-серверов

- после 5-го пункта добавился еще один, соотв-но, все следующие съехали на единицу вниз по номеру.

 

Обновляйтесь! :)

Изменено пользователем wanderer_mg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Исрпавьте, пожалуйста, строчку с echo ... $5. Bash при виде символа $ воспринимает его и все идущее после него до ближайшего пробела, как переменную и пытется ее интерпретировать, но так как в шелле этой

Так, например echo "route del $5 dev ppp0" >> /etc/ppp/ip-up.local

 

Исправьте, пожалуйста, строчку с echo ... $5. Bash при виде символа $ воспринимает его и все идущее после него до ближайшего пробела, как переменную и пытется ее интерпретировать, но так как в шелле этой переменной не объявлено, то bash просто возвращает нулевое значение.

Так, например команда

echo "route del $5 dev ppp0route del $5 dev ppp0" >> /etc/ppp/ip-up.local

запишет в конец файла /etc/ppp/ip-up.local

route del  dev ppp0

Чтобы этого не случилось, в примерах надо указывать \$5 там, где используется дозапись в файл при помощи echo.

Изменено пользователем Gmarapet

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Исправьте, пожалуйста, строчку с echo ... $5. Bash при виде символа $ воспринимает его и все идущее после него до ближайшего пробела, как переменную и пытется ее интерпретировать, но так как в шелле этой переменной не объявлено, то bash просто возвращает нулевое значение.

Так, например команда

echo "route del $5 dev ppp0route del $5 dev ppp0" >> /etc/ppp/ip-up.local

запишет в конец файла /etc/ppp/ip-up.local

route del  dev ppp0

Чтобы этого не случилось, в примерах надо указывать \$5 там, где используется дозапись в файл при помощи echo.

 

Блин, точно! Спасибо огромное!

 

Исправил :angry:)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

после обнавления до sys-apps/baselayout-1.12.7 vpn перестал подниматься. :)

откатился пока на sys-apps/baselayout-1.12.6 разбираться некогда.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

злостный OFF

а у меня сегодня с утра каждая сессия ppp0 длится ровно 11 минут 52 секунды

веселуха :)

лишь бы на новый год у них не заглючило, хосподи пронеси <_<

/злостный OFF

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

злостный OFF

а у меня сегодня с утра каждая сессия ppp0 длится ровно 11 минут 52 секунды

веселуха :lol:

лишь бы на новый год у них не заглючило, хосподи пронеси :blink:

/злостный OFF

 

Может где-то у тебя в конфигах закралась цифра 720 (секунд)? :D

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

поправочка только - не у меня, а у Корбины, дай ей бог здоровья! :blink:

Изменено пользователем Нюра

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

поправочка только - не у меня, а у Корбины, дай ей бог здоровья! :huh:

 

Уверена?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Уверена?

зачэм абижаэш, а? я свою женту знаю, ни с того ни с сего не бывает "чего", от святаго духа штоли? :unsure:

надо бы позвонить всё-таки, а то праздники на носу... :P

/OFF

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

зачэм абижаэш, а? я свою женту знаю, ни с того ни с сего не бывает "чего", от святаго духа штоли? corbina.gif

надо бы позвонить всё-таки, а то праздники на носу...

/OFF

у меня нормально. ты baselayout не обновляла? :spiteful:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Измайлово у меня Северное... не обновляла, с новым baselayout'ом разобралась тогда ещё, когда в этой темке спрашивала.

ладно, чего уж тему засорять будем, крик души высказала - и будет :D

разберусь :huh:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

в общем получается, что aMule каким-то образом мне весь ppp покоцал ;)

то есть до его запуска всё ок, держится долго и всё отлично

запускаешь ослика - какое-то время держится нормально - потом начинается как раз маразм этот самый

и самое главное и поганое - даже после отключения ослика всё это так и остаётся - 10 минут, падает, 10 минут - падает...

где порыться-то? в каких конфигах он может чего писать? ;) или это вообще Корбина эти порты режет, а потом и получается?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

после обнавления до sys-apps/baselayout-1.12.7 vpn перестал подниматься. ;)

откатился пока на sys-apps/baselayout-1.12.6 разбираться некогда.

 

Сейчас в ~x86 появилась следующая версия baselayout, в которой все снова работает (только кое-что поменялось в синтаксисе конфига, так что загляните в /etc/conf.d/net.example, но старый конфиг должен продолжать работать). Так что emerge --sync и можно смело обновляться.

 

в общем получается, что aMule каким-то образом мне весь ppp покоцал ;)

то есть до его запуска всё ок, держится долго и всё отлично

запускаешь ослика - какое-то время держится нормально - потом начинается как раз маразм этот самый

и самое главное и поганое - даже после отключения ослика всё это так и остаётся - 10 минут, падает, 10 минут - падает...

где порыться-то? в каких конфигах он может чего писать? ;) или это вообще Корбина эти порты режет, а потом и получается?

 

Может, у ослика утечки памяти, которые валят ppp/pptp?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас