Custler

Скрипт полностью автоматического создания роутера для корбины на FreeBSD (Custler).

Рекомендованные сообщения

Гость ^_^Smile

Беда какая-то.

По ссылке такого плана

http://retracker.local/announce.php?size=8...B1080p%5D+BDRip

 

 

выдает d14:failure reason80:Your client forgot to send your torrent's info_hash. Please upgrade your client.e

 

куда копать ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Беда какая-то.

По ссылке такого плана

http://retracker.local/announce.php?size=8...B1080p%5D+BDRip

 

 

выдает d14:failure reason80:Your client forgot to send your torrent's info_hash. Please upgrade your client.e

 

куда копать ?

Так он и пишет - в анонсе нет хеша. А откуда взялся такой урл?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость ^_^Smile
Беда какая-то.

По ссылке такого плана

http://retracker.local/announce.php?size=8...B1080p%5D+BDRip

 

 

выдает d14:failure reason80:Your client forgot to send your torrent's info_hash. Please upgrade your client.e

 

куда копать ?

Так он и пишет - в анонсе нет хеша. А откуда взялся такой урл?

в свойстве торрент файла ) который качется

 

Хотя вроде все работает.
Ваш IP-адрес: 10.227.129.188
Ваш префикс: [lub]
Ваш район/город: Мск: Люблино
Ваш оператор: Corbina

Доступ к центральным ресурсам: без NAT (прямой)
Доступ к Центральному хабу p2p.corbina.net: ЕСТЬ
Доступ к Центральному ретрекеру: ЕСТЬ

Изменено пользователем ^_^Smile

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Беда какая-то.

По ссылке такого плана

http://retracker.local/announce.php?size=8...B1080p%5D+BDRip

 

 

выдает d14:failure reason80:Your client forgot to send your torrent's info_hash. Please upgrade your client.e

 

куда копать ?

Так он и пишет - в анонсе нет хеша. А откуда взялся такой урл?

в свойстве торрент файла ) который качется

А что за клиент?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость ^_^Smile

мюторрент 1.8.5

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
мюторрент 1.8.5

Я уже какое-то время не сижу на винде и проверить не могу, но у меня в торрент-клиентах в списке трекеров только http://retracker.local/announce. Или это не там показывается такой урл? )

Изменено пользователем GroboiD

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость ^_^Smile
мюторрент 1.8.5

Я уже какое-то время не сижу на винде и проверить не могу, но у меня в торрент-клиентах в списке трекеров только http://retracker.local/announce. Или это не там показывается такой урл? )

Понятно, ладно помучаюсь, может что и получится.

 

Вообще скорости отдачи ни какой ;( беда беда.

Изменено пользователем ^_^Smile

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
мюторрент 1.8.5

Я уже какое-то время не сижу на винде и проверить не могу, но у меня в торрент-клиентах в списке трекеров только http://retracker.local/announce. Или это не там показывается такой урл? )

Понятно, ладно помучаюсь, может что и получится.

 

Вообще скорости отдачи ни какой ;( беда беда.

Может у тебя патчеры на ретрекеры какие-то стоят? )

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость ^_^Smile

Ни понятно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

странная штука

пользовался фряхой, созданной этим скриптом,без каких либо проблем уже больше полугода. вдруг решил подредактировать настройки pf, чтоб открыть порт на вновь собранном компе, полез - ввожу пароль, а он не жрет! ни непосредственно с клавиатуры, ни через secureCRT. пароль длинный, достаточно взломостойкий, да и кому его нужно было ломать? раньше я его вводил много раз, все было ок, потом в общем-то он не нужен был, и вдруг сунулся - и пароль инкоррект. Что бы это быть могло и как с этим бороться?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Кто нить поможет где грабли спрятаны.

Запускаю скрипт ./SetUp_Router.sh

Выдает.

Found static interface: rl0

Found static interface: vr0

#### ERROR: Must be exactly ONE STATIC interface. Dont know how to process it. Sorry

 

Check network configuration in /etc/rs.conf or run sysinstall to configure network interfaces

 

Внешняя карта rl1 rl0 и vr0 смотрят внут.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

sherasman, зачем 2 карты внутрь? 2 подсети?

 

41 строка скрипта:

### Check interfaces. Must be: one static and one DHCP, otherwise - error.

 

Видимо у автора на то были веские причины.

 

Как вариант, отключите 1 внутренний интерфейс на момент установки, затем пропишите для него правила pf вручную.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Прошу прощения за длительное молчание.

 

Ни понятно.

Возможно, дело просто в том, что сейчас сидов на порядок больше чем личей - "сиды: 7,133,917 личи: 766,176" (rutracker) и похоже nnm имеет ввиду какой-то другой ретрекер, а наш такого не поддерживает.

 

странная штука

пользовался фряхой, созданной этим скриптом,без каких либо проблем уже больше полугода. вдруг решил подредактировать настройки pf, чтоб открыть порт на вновь собранном компе, полез - ввожу пароль, а он не жрет! ни непосредственно с клавиатуры, ни через secureCRT. пароль длинный, достаточно взломостойкий, да и кому его нужно было ломать? раньше я его вводил много раз, все было ок, потом в общем-то он не нужен был, и вдруг сунулся - и пароль инкоррект. Что бы это быть могло и как с этим бороться?

Чудес не бывает! Проверяй регистр (рус/лат), CapsLock и т.д.

 

Кто нить поможет где грабли спрятаны.

Запускаю скрипт ./SetUp_Router.sh

Выдает.

Found static interface: rl0

Found static interface: vr0

#### ERROR: Must be exactly ONE STATIC interface. Dont know how to process it. Sorry

 

Check network configuration in /etc/rs.conf or run sysinstall to configure network interfaces

 

Внешняя карта rl1 rl0 и vr0 смотрят внут.

Для определения какой интерфейс смотрит наружу, скрипт берет тот, который получает настройки по DHCP.

А для определения какой интерфейс внутренний и какой назначить default gateway'ем - берет тот, который со статическим адресом и именно этот адрес использует при дальнейшем конфигурировании. Двух default gateway'ев быть не может! Так как у тебя два статических интерфейса, как скрипт может догадаться какой выбрать для default gateway?!

Вот это и есть веская причина. Поэтому совершенно правильно написал Blood Angel:

Отключай перед запуском скрипта тот интерфейс, который НЕ будет default gateway'ем для внутренней сети.

Изменено пользователем Custler

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо blood angel и custler за совет отключил и все заработал.

 

А как вручную включить вторую карту vr0(с адресском 192,168,2,1)

Первая карта rl1 смотрит в корбину

Вторая карта rl0 (192,168,1,1) внутренняя сеть

 

:(

 

Прописал правило как было описано выше что то никак.

 

 

int_if="rl0"

wint_if="vr0"

 

nat on $ext_if proto { tcp udp icmp } from $int_if:network to any -> ($ext_if)

nat on $vpn_if proto { tcp udp icmp } from $int_if:network to any -> ($vpn_if)

 

nat on $ext_if proto { tcp udp icmp } from $wint_if:network to any -> ($ext_if)

nat on $vpn_if proto { tcp udp icmp } from $wint_if:network to any -> ($vpn_if)

Изменено пользователем sherasman

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
А как вручную включить вторую карту vr0(с адресском 192,168,2,1)

 

Я рекомендовал бы бридж сделать.

 

Добавляешь в /boot/loader.conf:

bridge_load="YES"

 

Потом в /etc/rc.conf:

## Internal wired 1

ifconfig_vr0="up"

## Internal wired 2

ifconfig_rl0="up"

## Bridge for internal

cloned_interfaces="bridge0"

ifconfig_bridge0="inet 192.168.1.1 netmask 255.255.255.0 addm vr0 addm rl0"

## External

ifconfig_rl1="DHCP"

 

В /etc/pf.conf меняешь

int_if="rl0"

на

int_if="bridge0"
Изменено пользователем stgib

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Чудес не бывает! Проверяй регистр (рус/лат), CapsLock и т.д.

 

да у меня пароль чисто цифровой, но довольно длинный. не вводится ни с ноута фряшного, ни через secureCRT ...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
да у меня пароль чисто цифровой, но довольно длинный. не вводится ни с ноута фряшного, ни через secureCRT ...

 

Тогда загрузись в single mode, перемонтируй корень в rw, после чего командой passwd root меняй пароль.

 

И поищи в гугле - сброс пароля freebsd :)

Там дофига понаписано на эту тему.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость ^_^Smile

Да проблема вообще в другом.. Скорость в инет имею 100мб =)

А скачивает и раздает не выше 3-4 мб. Раньше было 10-12, походу по локалке цеплял. Локальные пиры вообще не цепляет и не хочет. Что рутрекер, что остальное.

 

Я уже начинаю грешить на фряху 8й версии. Нади будет сегодня 7.2 поставить наверно, скриптом все подцепить и не париться.

Изменено пользователем ^_^Smile

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
А как вручную включить вторую карту vr0(с адресском 192,168,2,1)

 

Я рекомендовал бы бридж сделать.

 

Добавляешь в /boot/loader.conf:

bridge_load="YES"

 

Потом в /etc/rc.conf:

## Internal wired 1

ifconfig_vr0="up"

## Internal wired 2

ifconfig_rl0="up"

## Bridge for internal

cloned_interfaces="bridge0"

ifconfig_bridge0="inet 192.168.1.1 netmask 255.255.255.0 addm vr0 addm rl0"

## External

ifconfig_rl1="DHCP"

 

В /etc/pf.conf меняешь

int_if="rl0"

на

int_if="bridge0"

 

 

ОГРОМНОЕ СПАСИБО Все заработало.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Да проблема вообще в другом.. Скорость в инет имею 100мб =)

А скачивает и раздает не выше 3-4 мб. Раньше было 10-12, походу по локалке цеплял. Локальные пиры вообще не цепляет и не хочет. Что рутрекер, что остальное.

 

Я уже начинаю грешить на фряху 8й версии. Нади будет сегодня 7.2 поставить наверно, скриптом все подцепить и не париться.

Ну такие скорости проверить не могу, у меня 10Мбит тариф).

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость ^_^Smile
Да проблема вообще в другом.. Скорость в инет имею 100мб =)

А скачивает и раздает не выше 3-4 мб. Раньше было 10-12, походу по локалке цеплял. Локальные пиры вообще не цепляет и не хочет. Что рутрекер, что остальное.

 

Я уже начинаю грешить на фряху 8й версии. Нади будет сегодня 7.2 поставить наверно, скриптом все подцепить и не париться.

Ну такие скорости проверить не могу, у меня 10Мбит тариф).

Да понятно ;(((

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
А как вручную включить вторую карту vr0(с адресском 192,168,2,1)

 

Я рекомендовал бы бридж сделать.

 

Добавляешь в /boot/loader.conf:

bridge_load="YES"

 

Потом в /etc/rc.conf:

## Internal wired 1

ifconfig_vr0="up"

## Internal wired 2

ifconfig_rl0="up"

## Bridge for internal

cloned_interfaces="bridge0"

ifconfig_bridge0="inet 192.168.1.1 netmask 255.255.255.0 addm vr0 addm rl0"

## External

ifconfig_rl1="DHCP"

 

В /etc/pf.conf меняешь

int_if="rl0"

на

int_if="bridge0"

 

Спасибо за совет. Все отлично.

 

Поставил Все работает нормально. Но них зависает через час или полтора иногда каждый полчасика. Ничего не реагирует через клавиатурки буквы пишется и все. помогает кнопочка резет. Думал проблемки в железке. Снес весь них установил виндХР прогнал все тесты проверил всю железку все ок. никаких проблем работают как часы. Поставил обратно них. Проблемки те же самые. В чем проблема. Может них не все железки поддерживает.

UNIX FREEBSD 7.2

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Спасибо за совет. Все отлично.

 

Поставил Все работает нормально. Но них зависает через час или полтора иногда каждый полчасика. Ничего не реагирует через клавиатурки буквы пишется и все. помогает кнопочка резет. Думал проблемки в железке. Снес весь них установил виндХР прогнал все тесты проверил всю железку все ок. никаких проблем работают как часы. Поставил обратно них. Проблемки те же самые. В чем проблема. Может них не все железки поддерживает.

UNIX FREEBSD 7.2

 

Надо после перезагрузки посмотреть записи в /var/log/messages за то время, когда зависает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Так повисло или все-таки пишется что-то? Команды какие-нить можно подать? И да, посмотреть лог надо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Дошли руки до iptv.

 

pf.conf

mcast_ll="224.0.0.0/24"
mcast_as="233.33.210.0/24"
mcast_ssm="239.255.255.0/24"

 

igmpproxy.conf

quickleave

phyint xl0 upstream ratelimit 0  threshold 1
       altnet 233.33.210.0/24
       altnet 239.255.255.0/24
       altnet 78.107.196.0/24

phyint rl0 downstream  ratelimit 0  threshold 1
       altnet 192.168.90.0/24

phyint ng0 disabled

 

Соответственно в upstream и downstream подставляете свои интерфейсы и altnet в downstream ваша внутренняя сеть.

 

Так же можно использовать переменные $int_if и $ext_if

Изменено пользователем Blood Angel

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

С клавиатуры пишет то пишет нажимаю ентер тишина буквы пишется а вот команды не реагирует.

Может кто нить лог посмотрит и подскажет где собака зарыта.

 

Вот лог.

messages.txt

Изменено пользователем sherasman

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость ^_^Smile
Дошли руки до iptv.

 

pf.conf

mcast_ll="224.0.0.0/24"
mcast_as="233.33.210.0/24"
mcast_ssm="239.255.255.0/24"

 

igmpproxy.conf

quickleave

phyint xl0 upstream ratelimit 0  threshold 1
       altnet 233.33.210.0/24
       altnet 239.255.255.0/24
       altnet 78.107.196.0/24

phyint rl0 downstream  ratelimit 0  threshold 1
       altnet 192.168.90.0/24

phyint ng0 disabled

 

Соответственно в upstream и downstream подставляете свои интерфейсы и altnet в downstream ваша внутренняя сеть.

 

Так же можно использовать переменные $int_if и $ext_if

 

 

а Фря какая ?

 

 

 

 

 

Дошли руки до сервера, подсказали.. Включил polling.

 

image.png

 

Раздача без локальных пиров. =)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
а Фря какая ?

 

7.2 но это не важно. Прекрасно работает и под 6.3 и под 8.0

Проверено лично ради спортивного интереса :blink:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость ^_^Smile
а Фря какая ?

 

7.2 но это не важно. Прекрасно работает и под 6.3 и под 8.0

Проверено лично ради спортивного интереса :rolleyes:

Так так а патчить ничего не нужно было на 8рке ?

 

 

Попозже погляжу.

 

Что-то как-то глухо как в танке ;( не фурычит. Может что не то сделал ;(

 

 

phyint xl0 upstream ratelimit 0 threshold 1

altnet 233.33.210.0/24

altnet 239.255.255.0/24

altnet 78.107.196.0/24

 

 

сюда внешний интерфейс вбивать

 

 

phyint rl0 downstream ratelimit 0 threshold 1

altnet 192.168.90.0/24

 

 

сюда внутренний.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

quickleave

 

phyint (iface смотрящий в билайн) upstream ratelimit 0 threshold 1

altnet 233.33.210.0/24

altnet 239.255.255.0/24

altnet 78.107.196.0/24

 

phyint (iface смотрящий в домашнюю сетку) downstream ratelimit 0 threshold 1

altnet х.х.х.0/24 (домашняя подсеть)

 

phyint ng0 disabled

 

Соответственно, ядро должно быть собрано с функцией mrouting

 

А что пишет igmpproxy при запуске в интерактивном режиме?

igmpproxy -d <путь к igmpproxy.conf>

 

Так же рекомендую убрать из вещания все мосты, бриджи и туннели, а так же исключить петлю. У меня igmpproxy начинает судорожно колбасить от них.

Мой конец конфига выглядит так:

 

phyint ng0 disabled

phyint lo0 disabled

phyint gre0 disabled

phyint tun0 disabled

phyint tun1 disabled

phyint tun5 disabled

Изменено пользователем Blood angel

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас