user-login

Маршрутизаторы Cisco Systems, Inc.

Рекомендованные сообщения

Коллеги,

 

есть вопрос по следующему фрагменту конфигурации, которую приводили, как рабочую:

 

ip nat inside source route-map LOCAL interface FastEthernet0 overload

ip nat inside source route-map PUBLIC interface Virtual-PPP1 overload

!

access-list 100 deny ip any host 85.21.0.255

access-list 100 permit 192.168.0.0 0.0.0.255 any

!

!

route-map PUBLIC permit 10

match ip address 100

match interface Virtual-PPP1

!

route-map LOCAL permit 10

match ip address 100

match interface FastEthernet0

 

Я хочу разобраться, что здесь и почему. Зачем нужно объявлять "ip nat inside sourceroute-map LOCAL interface FastEthernet0" для NAT? Не будет ли достататочно только одного объявления для Virtual-PPP?

 

Как я интерпретирую эту конфиругацию, трансляция в Virtual-PPP нужна для выхода в Интернет, а трансляция в FastEthernet0 - для выхода на внутренние ресурсы сети Билайн, чтобы транслироваться туда из сети 192.168. Но если мне на внутренние ресурсы не нужны, то как будто трансляцию на FastEthernet0 можно бы и убрать. Поправьте, если не прав.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@krulfa, если я правильно понял вопрос - что бы поднять L2TP на tp.internet.beeline.ru, до, собственно, поднятия, трафик идет по внутренним ресурсам, по локалке провайдера то есть.

 

Другими словами, Virtual-PPP поднимается на физическом FastEthernet0, и в случае запрета выхода на физический, виртуальный на нем поднять никак не получится.

 

Это ИМХО, но, думаю, не ошибся

Изменено пользователем tishin99

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

C NAT как будто бы стало понятно - я обошелся:

 

ip nat inside source list 101 interface Virtual-PPP1 overload

 

access-list 101 deny ip any host 85.21.230.86

access-list 101 deny ip 10.0.0.0 0.255.255.255 10.0.0.0 0.255.255.255

access-list 101 permit ip 10.0.0.0 0.255.255.255 any

 

Соответственно на Virtual-PPP1 стоит ip nat outside а на vlan1 ip nat inside. Здесь 85.21.230.86 это IP L2TP сервера.

 

То есть, если пакет направляектся в Virtual-PPP1, то он нормально транслируется через NAT и уходит в Интернет. Но оказывается, что далеко не все пакеты и не всегда уходят туда, куда предсказывает теория маршрутизации из учебников.

 

Проблему с выходом в Интернет с внутренней VLAN1 я решил с помошью маршрутизации по политике:

 

access-list 130 deny ip 10.0.0.0 0.255.255.255 10.0.0.0 0.255.255.255

access-list 130 deny ip 10.0.0.0 0.255.255.255 172.16.0.0 0.15.255.255

access-list 130 permit ip 10.189.184.0 0.0.0.127 any

 

route-map CORBINA permit 10

match ip address 130

set interface Virtual-PPP1

 

interface vlan1

ip policy route-map CORBINA

 

Но что касается трафика с других интерфейсов, я не могу понять, почему трафик идет "не туда".

 

ping 23.209.73.116 source Virtual-PPP1 - работает напрямую (а куда ж ему деться)

ping 23.209.73.116 source VLAN1 - работает, через политику маршрутизации

ping 23.209.73.116 source FastEthernet4 - не работает!!!

 

Debug показывает, что пакет с адресом отправителя 10.99.69.220 и адресом получателя 23.209.73.116 напрявляется прямиком шлюзу 10.99.64.1 !!! И видел он маршрут к Virtual-PPP с NAT трансляцией в гробу и белых тапочках!!!!!

 

Маршруты у меня такие:

 

ip route 0.0.0.0 0.0.0.0 Virtual-PPP1

ip route 85.21.230.86 255.255.255.255 10.99.64.1

ip route 0.0.0.0 0.0.0.0 dhcp

 

Последняя строчка не удаляется.

 

Здесь 10.99.69.220 - это IP по DHCP на FastEthernet 4 от провайдера, а 10.99.64.1 это шлюз провайдера, через который идет выход на сервер l2tp.

 

show ip route

S* 0.0.0.0/0 [1/0] via 195.239.77.114

[1/0] via 10.99.64.1

is directly connected, Virtual-PPP1

10.0.0.0/8 is variably subnetted, 5 subnets, 4 masks

D EX 10.0.0.0/8 [170/2803200] via 172.20.37.1, 01:46:05, Tunnel37

C 10.99.64.0/21 is directly connected, FastEthernet4

L 10.99.69.220/32 is directly connected, FastEthernet4

C 10.189.184.0/25 is directly connected, Vlan1

L 10.189.184.1/32 is directly connected, Vlan1

79.0.0.0/32 is subnetted, 1 subnets

C 79.104.56.125 is directly connected, Virtual-PPP1

85.0.0.0/32 is subnetted, 3 subnets

S 85.21.78.93 [254/0] via 10.99.64.1

S 85.21.78.139 [254/0] via 10.99.64.1

S 85.21.230.86 [1/0] via 10.99.64.1

89.0.0.0/32 is subnetted, 1 subnets

S 89.179.231.150 [254/0] via 10.99.64.1, FastEthernet4

172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 172.20.37.0/24 is directly connected, Tunnel37

L 172.20.37.43/32 is directly connected, Tunnel37

195.239.77.0/32 is subnetted, 1 subnets

C 195.239.77.114 is directly connected, Virtual-PPP1

Изменено пользователем krulfa

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

а у вас вот это:

access-list 130 deny ip 10.0.0.0 0.255.255.255 10.0.0.0 0.255.255.255
access-list 130 deny ip 10.0.0.0 0.255.255.255 172.16.0.0 0.15.255.255
access-list 130 permit ip 10.189.184.0 0.0.0.127 any

route-map CORBINA permit 10
match ip address 130
set interface Virtual-PPP1

interface vlan1
ip policy route-map CORBINA

зачем?

 

И почему должно работать

ping 23.209.73.116 source FastEthernet4

?

Изменено пользователем _dm

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Порописав IP 10.99.69.220 на интерфейс FA4 статически - эффект пропадает, ping 23.209.73.116 source FastEthernet4 начинает проходить нормально.

Всего-то исчезает второй интерфейс под default route.

Это "баг" или "фича"???

 

а у вас вот это: (route map)

зачем?

А потому, что Интернет не работал нормально - некоторые IP соединения и PING работают, но большинство сайтов не грузилось.

 

Думаю, что маршрутизацию по политике теперь можно и убрать.

 

И почему должно работать

ping 23.209.73.116 source FastEthernet4

?

А почему нет, собственно??? Source означает только, куда нужно вернуть пакет. А не куда его посылать.

Интерфейс 10.99.69.220 тоже должен транслироваться через NAT и уходить в Virtual-PPP1.

 

Хотя вы правы в том, что это не очевидно. В моем случае, на FastEthernet 4 нет определения ip nat outside.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ip route 0.0.0.0 0.0.0.0 Virtual-PPP1
ip route 0.0.0.0 0.0.0.0 dhcp

при наличии двух равноценных маршрутов трафик между ними балансируется, пинг с fa4 и должен был улетать на локальный шлюз, половина сайтов не должна была открываться, ибо пакеты уходили не в инет, а в локалку.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ip route 0.0.0.0 0.0.0.0 Virtual-PPP1
ip route 0.0.0.0 0.0.0.0 dhcp

при наличии двух равноценных маршрутов трафик между ними балансируется, пинг с fa4 и должен был улетать на локальный шлюз, половина сайтов не должна была открываться, ибо пакеты уходили не в инет, а в локалку.

Спасибо за подсказку, просто у меня команда

 

ip route 0.0.0.0 0.0.0.0 dhcp

 

из конфига не убиралась, хотя no ip route 0.0.0.0 0.0.0.0 dhcp ошибок не создавала. Я поэтому думал, что она там навсегда прописана, по умолчанию.

 

Сейчас только убралась. Возможно, что-то ее "держало", либо отсуствие второго определения ip route 0.0.0.0..., либо ip address dhcp на интерфейсе.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Братцы, приветствую. Нужна помощь...

Имеется Cisco 881

Sh ver: Version 15.3(3)M2

Что касается L2TP выкладываю.

sh run:

l2tp-class pw-beeline

 

pseudowire-class beeline

encapsulation l2tpv2

protocol l2tpv2 pw-beeline

ip local interface FastEthernet4

 

interface Virtual-PPP1

ip address negotiated

no ip redirects

no ip proxy-arp

ip mtu 1460

ip nat outside

ip virtual-reassembly in max-fragments 64 max-reassemblies 1024

ip tcp adjust-mss 1420

load-interval 30

shutdown

no peer neighbor-route

ppp authentication chap callin

ppp chap hostname хххххх

ppp chap password 0 ххххххххххх

no cdp enable

pseudowire 10.255.0.2 17 encapsulation l2tpv2 pw-class beeline

 

 

 

ip route 0.0.0.0 0.0.0.0 Virtual-PPP1 10 ------------------(так как резервный канал)

ip route 89.179.75.197 255.255.255.255 dhcp

ip route 10.255.0.2 255.255.255.255 dhcp

ip route 79.104.32.160 255.255.255.255 dhcp

ip route 194.67.2.114 255.255.255.255 dhcp

ip route 194.67.1.154 255.255.255.255 dhcp

 

 

interface FastEthernet4

description # L2TP Beeline #

ip address dhcp

no ip unreachables

no ip proxy-arp

no ip route-cache

duplex auto

speed auto

no cdp enable

 

****************ОШИБКА**********************

 

 

Apr 9 16:06:43.433: PPP: Alloc Context [899EBDAC]

Apr 9 16:06:43.433: ppp0 PPP: Phase is ESTABLISHING

Apr 9 16:06:43.433: Vp1 PPP: Using default call direction

Apr 9 16:06:43.433: Vp1 PPP: Treating connection as a dedicated line

Apr 9 16:06:43.433: Vp1 PPP: Session handle[5C000037] Session id[0]

Apr 9 16:06:43.433: Vp1 LCP: Event[OPEN] State[initial to Starting]

Apr 9 16:06:43.433: Vp1 LCP: O CONFREQ [starting] id 1 len 15

Apr 9 16:06:43.433: Vp1 LCP: AuthProto CHAP (0x0305C22305)

Apr 9 16:06:43.433: Vp1 LCP: MagicNumber 0x09993562 (0x050609993562)

Apr 9 16:06:43.433: Vp1 LCP: Event[uP] State[starting to REQsent]

BRYANSK.DO8.881(config-if)#

Apr 9 16:06:45.425: Vp1 LCP: O CONFREQ [REQsent] id 2 len 15

Apr 9 16:06:45.425: Vp1 LCP: AuthProto CHAP (0x0305C22305)

Apr 9 16:06:45.425: Vp1 LCP: MagicNumber 0x09993562 (0x050609993562)

Apr 9 16:06:45.425: Vp1 LCP: Event[Timeout+] State[REQsent to REQsent]

Apr 9 16:06:45.425: Vp1 LCP: I CONFREQ [REQsent] id 1 len 14

Apr 9 16:06:45.425: Vp1 LCP: AuthProto PAP (0x0304C023)

Apr 9 16:06:45.425: Vp1 LCP: MagicNumber 0xF9745DFA (0x0506F9745DFA)

Apr 9 16:06:45.425: Vp1 LCP: O CONFNAK [REQsent] id 1 len 9

Apr 9 16:06:45.425: Vp1 LCP: AuthProto CHAP (0x0305C22305)

Apr 9 16:06:45.425: Vp1 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]

Apr 9 16:06:45.425: Vp1 LCP: I CONFACK [REQsent] id 2 len 15

Apr 9 16:06:45.425: Vp1 LCP: AuthProto CHAP (0x0305C22305)

Apr 9 16:06:45.425: Vp1 LCP: MagicNumber 0x09993562 (0x050609993562)

Apr 9 16:06:45.425: Vp1 LCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]

Apr 9 16:06:45.429: Vp1 LCP: I CONFREQ [ACKrcvd] id 2 len 15

Apr 9 16:06:45.429: Vp1 LCP: AuthProto CHAP (0x0305C22305)

Apr 9 16:06:45.429: Vp1 LCP: MagicNumber 0xF9745DFA (0x0506F9745DFA)

Apr 9 16:06:45.429: Vp1 LCP: O CONFACK [ACKrcvd] id 2 len 15

Apr 9 16:06:45.429: Vp1 LCP: AuthProto CHAP (0x0305C22305)

Apr 9 16:06:45.429: Vp1 LCP: MagicNumber 0xF9745DFA (0x0506F9745DFA)

Apr 9 16:06:45.429: Vp1 LCP: Event[Receive ConfReq+] State[ACKrcvd to Open]

Apr 9 16:06:45.453: Vp1 PPP: Queue CHAP code[1] id[1]

Apr 9 16:06:45.457: Vp1 PPP: Phase is AUTHENTICATING, by both

Apr 9 16:06:45.457: Vp1 CHAP: O CHALLENGE id 1 len 41 from "3452369@bry.fttb.b2b"

Apr 9 16:06:45.457: Vp1 CHAP: Redirect packet to Vp1

Apr 9 16:06:45.457: Vp1 CHAP: I CHALLENGE id 1 len 40 from "ccr-corbina.Bryansk"

Apr 9 16:06:45.457: Vp1 PPP: Sent CHAP SENDAUTH Request

Apr 9 16:06:45.457: Vp1 LCP: State is Open

Apr 9 16:06:45.457: Vp1 PPP: Received SENDAUTH Response FAIL

Apr 9 16:06:45.457: Vp1 CHAP: Using hostname from interface CHAP

Apr 9 16:06:45.457: Vp1 CHAP: Using password from interface CHAP

Apr 9 16:06:45.457: Vp1 CHAP: O RESPONSE id 1 len 41 from "3452369@bry.fttb.b2b"

Apr 9 16:06:45.493: Vp1 CHAP: I SUCCESS id 1 len 4

Apr 9 16:06:45.493: Vp1 LCP: I TERMREQ [Open] id 3 len 4

Apr 9 16:06:45.493: Vp1 PPP DISC: Received LCP TERMREQ from peer

Apr 9 16:06:45.493: Vp1 PPP: Sending Acct Event[Down] id[61]

Apr 9 16:06:45.493: PPP: NET STOP send to AAA.

Apr 9 16:06:45.493: Vp1 PPP: Phase is TERMINATING

Apr 9 16:06:45.497: Vp1 LCP: O TERMACK [Open] id 3 len 4

Apr 9 16:06:45.497: Vp1 LCP: Event[Receive TermReq] State[Open to Stopping]

BRYANSK.DO8.881(config-if)#

Apr 9 16:06:45.505: Vp1 LCP: Event[CLOSE] State[stopping to Closing]

Apr 9 16:06:45.505: Vp1 LCP: Event[DOWN] State[Closing to Initial]

Apr 9 16:06:45.505: Vp1 PPP: Phase is DOWN

BRYANSK.DO8.881(config-if)#

Apr 9 16:06:49.953: PPP: Alloc Context [899EBDAC]

Apr 9 16:06:49.953: ppp0 PPP: Phase is ESTABLISHING

Apr 9 16:06:49.953: Vp1 PPP: Using default call direction

Apr 9 16:06:49.953: Vp1 PPP: Treating connection as a dedicated line

Apr 9 16:06:49.953: Vp1 PPP: Session handle[70000038] Session id[0]

Apr 9 16:06:49.953: Vp1 LCP: Event[OPEN] State[initial to Starting]

Apr 9 16:06:49.953: Vp1 LCP: O CONFREQ [starting] id 1 len 15

Apr 9 16:06:49.953: Vp1 LCP: AuthProto CHAP (0x0305C22305)

Apr 9 16:06:49.953: Vp1 LCP: MagicNumber 0x09994EE1 (0x050609994EE1)

Apr 9 16:06:49.953: Vp1 LCP: Event[uP] State[starting to REQsent]

BRYANSK.DO8.881(config-if)#

Apr 9 16:06:51.949: Vp1 LCP: I CONFREQ [REQsent] id 1 len 14

Apr 9 16:06:51.949: Vp1 LCP: AuthProto PAP (0x0304C023)

Apr 9 16:06:51.949: Vp1 LCP: MagicNumber 0xF9747F3B (0x0506F9747F3B)

Apr 9 16:06:51.949: Vp1 LCP: O CONFNAK [REQsent] id 1 len 9

Apr 9 16:06:51.949: Vp1 LCP: AuthProto CHAP (0x0305C22305)

Apr 9 16:06:51.949: Vp1 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]

Apr 9 16:06:51.949: Vp1 LCP: I CONFREQ [REQsent] id 2 len 15

Apr 9 16:06:51.949: Vp1 LCP: AuthProto CHAP (0x0305C22305)

Apr 9 16:06:51.949: Vp1 LCP: MagicNumber 0xF9747F3B (0x0506F9747F3B)

Apr 9 16:06:51.949: Vp1 LCP: O CONFACK [REQsent] id 2 len 15

Apr 9 16:06:51.949: Vp1 LCP: AuthProto CHAP (0x0305C22305)

Apr 9 16:06:51.949: Vp1 LCP: MagicNumber 0xF9747F3B (0x0506F9747F3B)

Apr 9 16:06:51.949: Vp1 LCP: Event[Receive ConfReq+] State[REQsent to ACKsent]

Apr 9 16:06:51.953: Vp1 LCP: O CONFREQ [ACKsent] id 2 len 15

Apr 9 16:06:51.953: Vp1 LCP: AuthProto CHAP (0x0305C22305)

Apr 9 16:06:51.953: Vp1 LCP: MagicNumber 0x09994EE1 (0x050609994EE1)

Apr 9 16:06:51.953: Vp1 LCP: Event[Timeout+] State[ACKsent to ACKsent]

Apr 9 16:06:51.953: Vp1 LCP: I CONFACK [ACKsent] id 2 len 15

Apr 9 16:06:51.953: Vp1 LCP: AuthProto CHAP (0x0305C22305)

Apr 9 16:06:51.953: Vp1 LCP: MagicNumber 0x09994EE1 (0x050609994EE1)

Apr 9 16:06:51.953: Vp1 LCP: Event[Receive ConfAck] State[ACKsent to Open]

Apr 9 16:06:51.981: Vp1 PPP: Queue CHAP code[1] id[1]

Apr 9 16:06:51.985: Vp1 PPP: Phase is AUTHENTICATING, by both

Apr 9 16:06:51.985: Vp1 CHAP: O CHALLENGE id 1 len 41 from "3452369@bry.fttb.b2b"

Apr 9 16:06:51.985: Vp1 CHAP: Redirect packet to Vp1

Apr 9 16:06:51.985: Vp1 CHAP: I CHALLENGE id 1 len 40 from "ccr-corbina.Bryansk"

Apr 9 16:06:51.985: Vp1 PPP: Sent CHAP SENDAUTH Request

Apr 9 16:06:51.985: Vp1 LCP: State is Open

Apr 9 16:06:51.985: Vp1 PPP: Received SENDAUTH Response FAIL

Apr 9 16:06:51.985: Vp1 CHAP: Using hostname from interface CHAP

Apr 9 16:06:51.985: Vp1 CHAP: Using password from interface CHAP

Apr 9 16:06:51.985: Vp1 CHAP: O RESPONSE id 1 len 41 from "My_login"

Apr 9 16:06:52.021: Vp1 CHAP: I SUCCESS id 1 len 4

Apr 9 16:06:52.025: Vp1 LCP: I TERMREQ [Open] id 3 len 4

Apr 9 16:06:52.025: Vp1 PPP DISC: Received LCP TERMREQ from peer

Apr 9 16:06:52.025: Vp1 PPP: Sending Acct Event[Down] id[62]

Apr 9 16:06:52.025: PPP: NET STOP send to AAA.

Apr 9 16:06:52.025: Vp1 PPP: Phase is TERMINATING

Apr 9 16:06:52.025: Vp1 LCP: O TERMACK [Open] id 3 len 4

BRYANSK.DO8.881(config-if)#

Apr 9 16:06:52.025: Vp1 LCP: Event[Receive TermReq] State[Open to Stopping]

Apr 9 16:06:52.033: Vp1 LCP: Event[CLOSE] State[stopping to Closing]

Apr 9 16:06:52.033: Vp1 LCP: Event[DOWN] State[Closing to Initial]

Apr 9 16:06:52.037: Vp1 PPP: Phase is DOWN

 

 

 

Подскажите пожалуйста что тут не так?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Братцы, приветствую. Нужна помощь...

Имеется Cisco 881

...

Подскажите пожалуйста что тут не так?

То, что на поверхности:

 

interface Virtual-PPP1

no shutdown

no ppp authentication chap callin

 

Я пока не докопался, почему строчка про ppp authentication не нужна, но в моем случае она мешала работать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А маршрутизация, которая есть, её хватает?

У вас несколько маршрутов по маске 255.255.255.255 на хосты провайдера через DHCP, но в принципе, чтобы поднять канал, достаточного единственного маршрута на 10.255.0.2, который есть сервер L2TP.

 

Остальное может cпокойно уходить по ip route 0.0.0.0 0.0.0.0 Virtual-PPP1

 

Если другие ресурсы из внутренней сети провайдера не нужны (DNS, SMTP и др.), то и маршруты прописывать необязательно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо большое за помощь.

В тех поддержке говорят авторизация успешна, сессия запущена. НО внешний IP не пингуется снаружи. Что это может быть???

Вот мне выдает такое сообщение.

Apr 10 13:02:05.632: %LINK-3-UPDOWN: Interface Virtual-PPP1, changed state to up

Apr 10 13:02:10.340: PPP: Alloc Context [8A3EEAAC]

Apr 10 13:02:10.340: ppp0 PPP: Phase is ESTABLISHING

Apr 10 13:02:10.340: Vp1 PPP: Using default call direction

Apr 10 13:02:10.340: Vp1 PPP: Treating connection as a dedicated line

Apr 10 13:02:10.340: Vp1 PPP: Session handle[C4000001] Session id[0]

Apr 10 13:02:10.340: Vp1 LCP: Event[OPEN] State[initial to Starting]

Apr 10 13:02:10.340: Vp1 LCP: O CONFREQ [starting] id 1 len 10

Apr 10 13:02:10.340: Vp1 LCP: MagicNumber 0x090AF821 (0x0506090AF821)

Apr 10 13:02:10.340: Vp1 LCP: Event[uP] State[starting to REQsent]

Apr 10 13:02:12.349: Vp1 LCP: O CONFREQ [REQsent] id 2 len 10

Apr 10 13:02:12.349: Vp1 LCP: MagicNumber 0x090AF821 (0x0506090AF821)

Apr 10 13:02:12.349: Vp1 LCP: Event[Timeout+] State[REQsent to REQsent]

Apr 10 13:02:12.349: Vp1 LCP: I CONFREQ [REQsent] id 1 len 14

Apr 10 13:02:12.349: Vp1 LCP: AuthProto PAP (0x0304C023)

Apr 10 13:02:12.349: Vp1 LCP: MagicNumber 0xFDF1E94B (0x0506FDF1E94B)

Apr 10 13:02:12.349: Vp1 LCP: O CONFNAK [REQsent] id 1 len 9

Apr 10 13:02:12.349: Vp1 LCP: AuthProto CHAP (0x0305C22305)

Apr 10 13:02:12.349: Vp1 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]

Apr 10 13:02:12.349: Vp1 LCP: I CONFACK [REQsent] id 2 len 10

Apr 10 13:02:12.349: Vp1 LCP: MagicNumber 0x090AF821 (0x0506090AF821)

Apr 10 13:02:12.349: Vp1 LCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]

Apr 10 13:02:12.353: Vp1 LCP: I CONFREQ [ACKrcvd] id 2 len 15

Apr 10 13:02:12.353: Vp1 LCP: AuthProto CHAP (0x0305C22305)

Apr 10 13:02:12.353: Vp1 LCP: MagicNumber 0xFDF1E94B (0x0506FDF1E94B)

Apr 10 13:02:12.353: Vp1 LCP: O CONFACK [ACKrcvd] id 2 len 15

Apr 10 13:02:12.353: Vp1 LCP: AuthProto CHAP (0x0305C22305)

Apr 10 13:02:12.353: Vp1 LCP: MagicNumber 0xFDF1E94B (0x0506FDF1E94B)

Apr 10 13:02:12.353: Vp1 LCP: Event[Receive ConfReq+] State[ACKrcvd to Open]

Apr 10 13:02:12.381: Vp1 PPP: Phase is AUTHENTICATING, by the peer

Apr 10 13:02:12.381: Vp1 LCP: State is Open

Apr 10 13:02:12.385: Vp1 CHAP: I CHALLENGE id 1 len 40 from "ccr-corbina.Bryansk"

Apr 10 13:02:12.385: Vp1 PPP: Sent CHAP SENDAUTH Request

Apr 10 13:02:12.385: Vp1 PPP: Received SENDAUTH Response FAIL

Apr 10 13:02:12.385: Vp1 CHAP: Using hostname from interface CHAP

Apr 10 13:02:12.385: Vp1 CHAP: Using password from interface CHAP

Apr 10 13:02:12.385: Vp1 CHAP: O RESPONSE id 1 len 41 from "MY_LOGIN"

Apr 10 13:02:12.421: Vp1 CHAP: I SUCCESS id 1 len 4

Apr 10 13:02:12.425: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-PPP1, changed state to up

Apr 10 13:02:12.425: Vp1 PPP: No AAA accounting method list

Apr 10 13:02:12.425: Vp1 PPP: Phase is UP

Apr 10 13:02:12.425: Vp1 IPCP: Protocol configured, start CP. state[initial]

Apr 10 13:02:12.425: Vp1 IPCP: Event[OPEN] State[initial to Starting]

Apr 10 13:02:12.425: Vp1 IPCP: O CONFREQ [starting] id 1 len 10

Apr 10 13:02:12.425: Vp1 IPCP: Address 0.0.0.0 (0x030600000000)

Apr 10 13:02:12.425: Vp1 IPCP: Event[uP] State[starting to REQsent]

Apr 10 13:02:12.425: Vp1 IPCP: I CONFREQ [REQsent] id 1 len 10

Apr 10 13:02:12.425: Vp1 IPCP: Address 79.104.32.160 (0x03064F6820A0)

Apr 10 13:02:12.429: Vp1 IPCP: O CONFACK [REQsent] id 1 len 10

Apr 10 13:02:12.429: Vp1 IPCP: Address 79.104.32.160 (0x03064F6820A0)

Apr 10 13:02:12.429: Vp1 IPCP: Event[Receive ConfReq+] State[REQsent to ACKsent]

Apr 10 13:02:12.433: Vp1 IPCP: I CONFNAK [ACKsent] id 1 len 10

Apr 10 13:02:12.433: Vp1 IPCP: Address 194.67.36.113 (0x0306C2432471)

Apr 10 13:02:12.433: Vp1 IPCP: O CONFREQ [ACKsent] id 2 len 10

Apr 10 13:02:12.433: Vp1 IPCP: Address 194.67.36.113 (0x0306C2432471)

Apr 10 13:02:12.433: Vp1 IPCP: Event[Receive ConfNak/Rej] State[ACKsent to ACKsent]

Apr 10 13:02:12.433: Vp1 IPCP: I CONFACK [ACKsent] id 2 len 10

Apr 10 13:02:12.433: Vp1 IPCP: Address 194.67.36.113 (0x0306C2432471)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Есть Cisco 871w работает уже несколько лет проблем никаких никогда не было. Перешел на тариф Элит40мб L2TP, все продолжало работать отлично, потом где-то через месяц инет помер. Начал смотреть внутрянка вся работает, канал подымается и не падает, внешний адрес присваивается, но инета нет ничего вообще не пингуется. Если положить канал Virtual-PPP1, то любой комп из внутренней сети, если создать соединение в Винде по L2TP без проблем подсоединяется и все работает. Уже голову сломал куда копать :((( Помогите пожалуйста !!!

Изменено пользователем LuckyM

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Прошивки от проекта Мир Wi-Fi (mirwifi.org) можно найти тут http://berk-s.ru/linksys/

В наличии следующие прошивки EA4500, E4200, E4200v2, EA3500, E900, E1000, E1200, E2500, E3000, E3200, WRT320N, WRT610N

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Способы настройки L2TP на свежекупленном роутере Cisco Linksys ea2700

 

1) Тип L2TP

IP4 - 78.107.1.255 (Московский шлюз)

Имя пользователя - Ваш_логин@tp.internet.beeline.ru

Пароль - ****

MTU - 1400

 

Если вы делаете замену то лучше склонировать МАС от старого

Для проверки залезаем в Диагностику и смотрим получен ли внешний IP (если да то все ок и должен быть инет)

 

2) Скачиваем прошивку тут, прошиваем... после прошивки вместо IP можно будет указать tp.internet.beeline.ru

 

LuckyM - Проблема имеенно с одним из шлюзов билайна. Попробуй использовать IP шлюза который я написал.

 

Jack456 - Внешний IP не пингуется тк включена скорее всего блокировка ICMP

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

@Tero, в отрыве от всего остального - "московского шлюза" не существует. В каждом районе свой. 78.107.1.255 - это вероятно БРАС, их много

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

может кому пригодится , вот рабочий конфиг для Cisco 3845

версия IOS :

 

3845#sh ver

Cisco IOS Software, 3800 Software (C3845-ADVENTERPRISEK9-M), Version 12.4(25g), RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright © 1986-2012 by Cisco Systems, Inc.

Compiled Wed 22-Aug-12 08:58 by prod_rel_team

 

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

 

3845 uptime is 7 minutes

System returned to ROM by power-on

System image file is "flash:c3845-adventerprisek9-mz.124-25g.bin"

 

 

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

 

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

 

If you require further assistance please contact us by sending email to

export@cisco.com.

 

Cisco 3845 (revision 1.0) with 222208K/39936K bytes of memory.

Processor board ID FCZ1108731W

2 Gigabit Ethernet interfaces

1 Virtual Private Network (VPN) Module

DRAM configuration is 64 bits wide with parity enabled.

479K bytes of NVRAM.

62720K bytes of ATA System CompactFlash (Read/Write)

 

Configuration register is 0x2102

 

и собственно , сам конфиг ))

 

3845#sh start

Using 3985 out of 491512 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 3845

!

boot-start-marker

boot-end-marker

!

enable secret 5 ххх

enable password ххх

!

no aaa new-model

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.0.120

!

ip dhcp pool ccp-pool

import all

network 192.168.0.0 255.255.0.0

default-router 192.168.0.120

dns-server 85.21.192.5 213.234.192.7

lease 0 2

!

!

no ip domain lookup

ip name-server 85.21.192.5

ip name-server 213.234.192.7

ip multicast-routing

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

l2tp-class corbina

!

!

voice-card 0

no dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

pseudowire-class class-1

encapsulation l2tpv2

protocol l2tpv2 corbina

ip local interface GigabitEthernet0/1

!

!

!

!

!

!

interface GigabitEthernet0/0

ip address 192.168.0.120 255.255.0.0

no ip redirects

no ip proxy-arp

ip pim dense-mode

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

ip igmp helper-address 10.177.56.1

ip igmp mroute-proxy GigabitEthernet0/1

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

description ISP

ip address dhcp

no ip redirects

no ip proxy-arp

ip pim neighbor-filter 2

ip pim dense-mode

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

media-type rj45

!

interface Virtual-PPP1

description WAN; Corbina internet

ip address negotiated

no ip redirects

no ip proxy-arp

ip mtu 1460

ip nat outside

ip virtual-reassembly max-fragments 64 max-reassemblies 1024

ip tcp adjust-mss 1420

no peer neighbor-route

no cdp enable

ppp chap hostname (имя)

ppp chap password 0 (пароль)

pseudowire 85.21.0.255 10 pw-class class-1

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Virtual-PPP1

ip route 10.0.0.0 255.0.0.0 dhcp

ip route 83.102.146.96 255.255.255.224 dhcp

ip route 85.21.29.242 255.255.255.255 dhcp

ip route 85.21.79.0 255.255.255.0 dhcp

ip route 85.21.90.0 255.255.255.0 dhcp

ip route 195.14.50.16 255.255.255.255 dhcp

ip route 85.21.17.253 255.255.255.255 dhcp

ip route 89.179.135.67 255.255.255.255 dhcp

ip route 195.14.50.21 255.255.255.255 dhcp

ip route 195.14.50.1 255.255.255.255 dhcp

ip route 85.21.0.251 255.255.255.255 dhcp

ip route 85.21.0.253 255.255.255.255 dhcp

ip route 172.16.16.0 255.255.255.0 dhcp

ip route 85.21.108.19 255.255.255.255 dhcp

ip route 195.14.50.26 255.255.255.255 dhcp

ip route 85.21.72.83 255.255.255.255 dhcp

ip route 85.21.0.255 255.255.255.255 dhcp

ip route 78.107.23.0 255.255.255.0 dhcp

ip route 78.107.69.98 255.255.255.255 dhcp

ip route 83.102.231.32 255.255.255.240 dhcp

ip route 85.21.90.0 255.255.254.0 dhcp

ip route 85.21.108.16 255.255.255.240 dhcp

ip route 85.21.88.130 255.255.255.255 dhcp

ip route 85.21.138.208 255.255.255.240 dhcp

ip route 85.21.52.254 255.255.255.255 dhcp

ip route 85.21.72.80 255.255.255.240 dhcp

ip route 195.14.50.93 255.255.255.255 dhcp

ip route 213.234.192.8 255.255.255.255 dhcp

ip route 85.21.192.3 255.255.255.255 dhcp

ip route 83.102.254.255 255.255.255.255 dhcp

ip route 78.107.196.0 255.255.255.0 dhcp

!

!

no ip http server

no ip http secure-server

ip mroute 85.21.91.0 255.255.255.0 10.82.48.1

ip mroute 172.16.16.0 255.255.255.0 10.82.48.1

ip mroute 78.107.196.0 255.255.255.0 10.82.48.1

ip nat inside source route-map LOCAL interface GigabitEthernet0/1 overload

ip nat inside source route-map PUBLIC interface Virtual-PPP1 overload

!

access-list 100 deny ip any host 85.21.0.255

access-list 100 permit ip 192.168.0.0 0.0.255.255 any

no cdp run

!

route-map PUBLIC permit 10

match ip address 100

match interface Virtual-PPP1

!

route-map LOCAL permit 10

match ip address 100

match interface GigabitEthernet0/1

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

password ххх

login

!

scheduler allocate 20000 1000

no process cpu extended

no process cpu autoprofile hog

!

end

 

соединение держит уверенно , производительности хватает , только вот в акустическом плане это агрегат явно на любителя ))

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

...соединение держит уверенно , производительности хватает , только вот в акустическом плане это агрегат явно на любителя ))

IPTV проверяли? В вашем конфиге смущает строка ip pim dense-mode, при данном режиме наличие некоторого количества потребителей iptv в локалке роутера приведет к засорению сети мультикастом, особенно это "почувствуют" потребители у которых будет стоять 100Мбитное конечное оборудование.

Изменено пользователем noox

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

...соединение держит уверенно , производительности хватает , только вот в акустическом плане это агрегат явно на любителя ))

IPTV проверяли? В вашем конфиге смущает строка ip pim dense-mode, при данном режиме наличие некоторого количества потребителей iptv в локалке роутера приведет к засорению сети мультикастом, особенно это "почувствуют" потребители у которых будет стоять 100Мбитное конечное оборудование.

 

к сожалению , iptv не довелось испытать в этой связке , ибо приставки не имею , и этой услугой не пользуюсь .. )

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

к сожалению , iptv не довелось испытать в этой связке , ибо приставки не имею , и этой услугой не пользуюсь .. )

Понятно, значит все строки конфига, включающие в себя такие термины как; multicast, pim, igmp можно смело удалять, ну или допиливать конфиг под IPTV, чтоб был полноценный. Но это так небольшое уточнение. :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Коллеги добрый день, подскажите, настраиваю DMVPN, туннель поднимается приходят маршруты, но затем начинает флаппать OSPF

%OSPF-5-ADJCHG: Process 10, Nbr 172.16.1.1 on Tunnel0 from FULL to DOWN, Neighbor Down: Dead timer expired. в дебаге на пять отправленных Hello один ответ...

в схеме уже есть HUB и один SPOKE оба на Ростелеке, работают стабильно, новый SPOKE подключается через Билайн, локалка и инет работают хорошо, в чем может быть причина такого поведения(и еще вопрос подключена услуга белый IP но почему-то не могу завалиться телнетом, посмотрите по листингу конфига в чем может быть причина). Спасибо!

 

Конфиг SPOKE на билайне:

 

Building configuration...

 

Current configuration : 4117 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname x.x.x.x

!

boot-start-marker

boot-end-marker

!

enable secret

!

aaa new-model

!

!

!

aaa session-id common

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no ip source-route

no ip gratuitous-arps

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.2.1 192.168.2.128

!

ip dhcp pool LOCAL

network 192.168.2.0 255.255.255.0

default-router 192.168.2.1

dns-server 213.132.75.24 213.132.75.23

!

!

ip cef

no ip domain lookup

ip domain name dyndns.org

ip multicast-routing

vpdn enable

vpdn session-limit 100

!

vpdn-group 1

!

l2tp-class beeline

!

!

username x.x.x.x privilege 15 password x.x.x.x

!

!

pseudowire-class pw-beeline

encapsulation l2tpv2

protocol l2tpv2 beeline

ip local interface FastEthernet0

!

!

!

interface Loopback1

description ### ROUTER-ID ###

ip address 10.1.1.3 255.255.255.255

!

interface Tunnel0

description ### mGRE SPOKE ###

ip address 172.16.1.3 255.255.255.0

no ip redirects

ip mtu 1400

ip nhrp map 172.16.1.1 белый_iP_Huba

ip nhrp map multicast белый_iP_Huba

ip nhrp network-id 9

ip nhrp nhs 172.16.1.1

ip nhrp registration no-unique

ip nhrp registration timeout 60

ip ospf network broadcast

ip ospf priority 0

load-interval 30

cdp enable

tunnel source Virtual-PPP5

tunnel mode gre multipoint

!

interface FastEthernet0

description ### Local WAN ###

ip address dhcp

no ip redirects

no ip proxy-arp

ip nat outside

ip virtual-reassembly

load-interval 30

speed auto

full-duplex

no cdp enable

!

interface FastEthernet1

description ### Local Access ###

switchport access vlan 10

!

interface FastEthernet2

description ### Local Access ###

switchport access vlan 10

!

interface FastEthernet3

description ### Local Access ###

switchport access vlan 10

spanning-tree portfast

!

interface FastEthernet4

description ### Local Access ###

switchport access vlan 10

!

interface Virtual-PPP5

description ### Global WAN ###

ip address negotiated

ip verify unicast reverse-path allow-self-ping

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1460

ip nat outside

ip virtual-reassembly max-fragments 64 max-reassemblies 1024

ip tcp adjust-mss 1420

load-interval 30

no peer neighbor-route

no cdp enable

ppp chap hostname ччч

ppp chap password ччч

ppp ipcp route default

pseudowire 10.255.255.237 10 pw-class pw-beeline

!

interface Vlan10

description ### LOCAL-LAN ###

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

!

router ospf 100

router-id 10.1.1.3

log-adjacency-changes

redistribute connected subnets

network 10.1.1.3 0.0.0.0 area 0

network 172.16.1.0 0.0.0.255 area 0

network 192.168.2.0 0.0.0.255 area 1

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Virtual-PPP5

ip route 10.255.255.237 255.255.255.255 dhcp

ip route 10.255.255.238 255.255.255.255 dhcp

ip route 10.255.255.239 255.255.255.255 dhcp

ip route 10.255.255.240 255.255.255.255 dhcp

ip route 10.0.0.0 255.0.0.0 dhcp

ip route 213.132.75.23 255.255.255.255 dhcp

ip route 213.132.75.24 255.255.255.255 dhcp

ip route 78.107.196.0 255.255.252.0 dhcp

no ip http server

!

ip nat inside source route-map global interface Virtual-PPP5 overload

ip nat inside source route-map local interface FastEthernet0 overload

!

!

access-list 100 permit ip 192.168.0.0 0.0.255.255 host 213.132.75.23

access-list 100 permit ip 192.168.0.0 0.0.255.255 host 213.132.75.24

access-list 100 permit ip 192.168.0.0 0.0.255.255 78.107.196.0 0.0.3.255

access-list 100 permit ip 192.168.0.0 0.0.255.255 10.0.0.0 0.255.255.255

access-list 110 permit ip 192.168.0.0 0.0.255.255 any

!

route-map global permit 10

match ip address 110

match interface Virtual-PPP5

!

route-map local permit 10

match ip address 100

match interface FastEthernet0

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

password x.x.x.x

line vty 5 15

password x.x.x.x

!

ntp server 80.93.56.210

end

 

 

Конфиг HUB на РТК:

 

____________________

 

interface Tunnel0

description ### mGRE HUB ###

ip address 172.16.1.1 255.255.255.0

no ip redirects

ip mtu 1400

ip pim sparse-mode

ip nat inside

ip nhrp map multicast dynamic

ip nhrp network-id 9

ip nhrp holdtime 600

no ip split-horizon

ip ospf network broadcast

ip ospf priority 200

ip ospf mtu-ignore

qos pre-classify

cdp enable

tunnel source Dialer1

tunnel mode gre multipoint

tunnel path-mtu-discovery

 

 

router ospf 100

router-id 10.1.1.1

log-adjacency-changes

redistribute connected

redistribute static subnets

network 10.1.1.1 0.0.0.0 area 0

network 172.16.1.0 0.0.0.255 area 0

network 192.168.0.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 1

 

UPD 11:02 / видимо надо eigrp переходить

Nikolay Shopik30 June, 2011 21:06

 

What best solution if you running DMVPN and one of your spoke are running on MTU lower then 1500, lowering MTU on spoke? Well this is only solution I see, but other spokes will suffer lower MTU too, thus less effective usage of bandwidth.

Reply

Ivan Pepelnjak01 July, 2011 19:12

 

Best solution? Don't run OSPF over DMVPN ;)

 

By definition, all hosts/routers connected to the same shared subnet must have the same MTU. Any workaround will eventually bite you.

Изменено пользователем green_krd

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Коллеги добрый день, подскажите, настраиваю DMVPN, туннель поднимается приходят маршруты, но затем начинает флаппать OSPF

%OSPF-5-ADJCHG: Process 10, Nbr 172.16.1.1 on Tunnel0 from FULL to DOWN, Neighbor Down: Dead timer expired. в дебаге на пять отправленных Hello один ответ...

в схеме уже есть HUB и один SPOKE оба на Ростелеке, работают стабильно, новый SPOKE подключается через Билайн, локалка и инет работают хорошо, в чем может быть причина такого поведения(и еще вопрос подключена услуга белый IP но почему-то не могу завалиться телнетом, посмотрите по листингу конфига в чем может быть причина). Спасибо!

Можно попробовать подкрутить таймеры на всех участниках в сторону увеличения, но если все узлы на Сиськах, то, действительно, лучше EIGRP.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Коллеги добрый день, подскажите, настраиваю DMVPN, туннель поднимается приходят маршруты, но затем начинает флаппать OSPF

%OSPF-5-ADJCHG: Process 10, Nbr 172.16.1.1 on Tunnel0 from FULL to DOWN, Neighbor Down: Dead timer expired. в дебаге на пять отправленных Hello один ответ...

в схеме уже есть HUB и один SPOKE оба на Ростелеке, работают стабильно, новый SPOKE подключается через Билайн, локалка и инет работают хорошо, в чем может быть причина такого поведения(и еще вопрос подключена услуга белый IP но почему-то не могу завалиться телнетом, посмотрите по листингу конфига в чем может быть причина). Спасибо!

Можно попробовать подкрутить таймеры на всех участниках в сторону увеличения, но если все узлы на Сиськах, то, действительно, лучше EIGRP.

 

Спасибо за совет, привел настройку OSPF к виду описанному в статье:

http://www.fryguy.net/2011/08/04/dmvpn-and-routing-protocols-ospf/

и все заработало на ура. Пока поюзаем OSPF.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Добрый день, прошу помощи у знающих...

 

С cisco знаком очень плохо, первый раз достал из коробки 1921/к9.

 

Кое как с помощью манулов настроил интернет Билайн. Работает, но постоянно рвется соединение.

 

Посмотрите мой конфиг знатоки, ткните носом что не так.

 

Building configuration...

Current configuration : 3940 bytes
!
! Last configuration change at 19:50:40 UTC Wed Oct 8 2014 by XXXXXX
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
enable secret 5 XXXXX
enable password XXXXX
!
no aaa new-model
!
ip cef
!
!
!
!


!
!
!
!
ip name-server 85.21.192.3
ip name-server 213.234.192.8
ip name-server 85.21.192.5
l2tp-class DEFAULT-L2TP-CLASS
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
crypto pki trustpoint TP-self-signed-1121161266
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1121161266
revocation-check none
rsakeypair TP-self-signed-1121161266
!
!
crypto pki certificate chain TP-self-signed-1121161266
certificate self-signed 01
 3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030 
 31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
 69666963 6174652D 31313231 31363132 3636301E 170D3134 31303036 31393437 
 30355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
 4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 31323131 
 36313236 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
 8100C25A EC353CE3 2F9FF145 11CDD205 43FBCC5D 5CA3CAB9 1E106287 D0E79806 
 9B6AAAC5 C222C477 CF2D1057 9D4E0D06 7B48C222 727260E7 630D2EB5 EC7DD3B9 
 88DFE943 C6E3830E 09541B85 79EEC015 D8851E76 01084136 931AFECA F02057EA 
 DDF4CB5F 12672325 F9CCCE2F A488F42E 34B10739 4CA2873F 1188AFBF A133599A 
 D2030203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603 
 551D2304 18301680 14F82D79 95D7E638 D30D190C C4A739F1 FE73E519 DA301D06 
 03551D0E 04160414 F82D7995 D7E638D3 0D190CC4 A739F1FE 73E519DA 300D0609 
 2A864886 F70D0101 05050003 818100B3 01AC82FA 2362DAB8 2E78204C AA15C188 
 B9450599 4CFAC115 46AD3BF0 48E4649B DC42DC02 6B51AFBB 8A3D452E 3F7F5775 
 754C51A6 138EE589 1EBE39A0 85164360 1B195533 23F24251 E39979DE 2372BDB6 
 3EC60E84 A1264295 16AAE02D E1B6E350 A4D330A4 33F1E01B 379C093C E4B646EA 
 85C735A5 BADFCF87 E773B1DB FE372C
 	quit
license udi pid CISCO1921/K9 sn XXXXXXX
license boot module c1900 technology-package securityk9
license boot module c1900 technology-package datak9
!
!
username XXXXXX privilege 15 password 0 XXXXX
!
redundancy
!
!
!
!
!
pseudowire-class PW-L2TP-GigabitEthernet0/0
encapsulation l2tpv2
protocol l2tpv2 DEFAULT-L2TP-CLASS
ip local interface GigabitEthernet0/0
!
! 
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description ISP
ip address dhcp
ip nat outside
ip virtual-reassembly in
load-interval 30
duplex auto
speed auto
!
interface GigabitEthernet0/1
description Localnet
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
no mop enabled
!
interface Virtual-PPP1
description WAN; Beeline internet
ip address negotiated
ip mtu 1460
ip nat outside
ip virtual-reassembly in
ip tcp adjust-mss 1420
ppp chap hostname XXXXX
ppp chap password 0 XXXXXX
no cdp enable
pseudowire 85.21.0.241 10 encapsulation l2tpv2 pw-class PW-L2TP-GigabitEthernet0/0
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
!
ip nat inside source list 1 interface Virtual-PPP1 overload
!
!
!
snmp-server community public RO
snmp-server enable traps entity-sensor threshold
access-list 1 permit 192.168.1.0 0.0.0.255
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
privilege level 15
password XXXXXXX
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp server ru.pool.ntp.org
ntp server ntp.corbina.net
!
end

Изменено пользователем yungo

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

enable secret 5 XXXXX
enable password XXXXX
username XXXXXX privilege 15 password 0 XXXXX

Как хорошо все начиналось...

interface Virtual-PPP1
ppp chap hostname 0894623673
ppp chap password 0 0894623673
line vty 0 4
privilege level 15
password admin12345

 

А вот тут что-то пошло не так.. :)

 

Пробуйте:

no ip nat inside source list 1 interface Virtual-PPP1 overload

access-list 100 deny   ip any host 85.21.0.241
access-list 100 permit ip 192.168.1.0 0.0.0.255 any

route-map Internet permit 10
match ip address 100
match interface Virtual-PPP1

route-map Local permit 10
match ip address 100
match interface GigabitEthernet0/1

ip nat inside source route-map Internet interface Virtual-PPP1 overload
ip nat inside source route-map Local interface GigabitEthernet0/1 overload
service password-encryption

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

... Работает, но постоянно рвется соединение...

Мне кажется у вас просто не хватает маршрутов. Как минимум двух основных:

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Virtual-PPP1

ip route 85.21.0.241 255.255.255.255 dhcp

Остальные по желанию.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Разрывы прекратились после добавления no peer neighbor-route к интерфейсу interface Virtual-PPP1, но половина сайтов не работает. ya.ru пингуется нормально...

 

Прописать маршруты?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Разрывы прекратились после добавления no peer neighbor-route к интерфейсу interface Virtual-PPP1, но половина сайтов не работает. ya.ru пингуется нормально...

 

Прописать маршруты?

Да, что вам мешает? Если делаете удаленно, подстрахуйтесь, найдите того, кто перезагрузит.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Разрывы прекратились после добавления no peer neighbor-route к интерфейсу interface Virtual-PPP1, но половина сайтов не работает. ya.ru пингуется нормально...

 

Прописать маршруты?

Да, что вам мешает? Если делаете удаленно, подстрахуйтесь, найдите того, кто перезагрузит.

или команда reload in х (время в минутах до перезагрузки) , чтобы отменить - reload cancel . очень выручает!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

2noox

 

Действительно, дело было в маршрутах, добавил, все сайты стали грузиться.

 

Но разрывы прекратились после добавления no peer neighbor-route, повлияет ли как то эта команда на маршруты?

Где можно посмотреть полный список маршрутов?

Как увидеть локалку?

 

 

2 yellow.card

 

После ваших команд, упала скорость аплода

Раньше была 92/70 мбит

Стала 92/20 мбит

С чем это может быть связано?

 

И еще, пришлось на компе в свойствах сетевухи прописать DNS, нормально ли это? Не должен ли роутер выполнять эту работу?

 

ЗЫ: Спасибо за помощь)))

Изменено пользователем yungo

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас