Архивировано

Эта тема находится в архиве и закрыта для публикации сообщений.

bts24

Cisco 1841

Рекомендованные сообщения

Доброго дня!

 

 

Очень долго мучился с поиском и настройкой с1841. В итоге, собрал конфиг. Думаю пригодиться кому нить. Всё работает, трафик тянет. :(

 

!

version 12.4

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service sequence-numbers

!

hostname gauss-msk-GW

!

boot-start-marker

boot-end-marker

!

security authentication failure rate 3 log

security passwords min-length 6

logging buffered 51200 warnings

logging console critical

enable secret 5 $1$5PJE$etGYuAKg8i/dJbFUFdl.B0

!

aaa new-model

!

!

aaa authentication ppp default local

aaa authorization network default none

!

!

aaa session-id common

memory-size iomem 50

clock timezone MSK 3

clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1 192.168.1.19

ip dhcp excluded-address 192.168.1.250 192.168.1.254

!

ip dhcp pool home

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 213.234.192.8 85.21.192.3 213.234.192.7

lease 8

!

!

ip cef

no ip bootp server

ip domain name corbina.ru

ip name-server 85.21.192.3

ip name-server 213.234.192.8

ip name-server 213.234.192.7

!

no ipv6 cef

l2tp-class corbina

!

!

multilink bundle-name authenticated

!

!

!

!

!

ip tcp synwait-time 10

ip ssh time-out 60

ip ssh authentication-retries 2

!

!

!

!

!

!

pseudowire-class class1

encapsulation l2tpv2

protocol l2tpv2 corbina

ip local interface FastEthernet0/1

!

!

!

!

interface FastEthernet0/0 <------------- Inside int to PC

ip address 192.168.1.1 255.255.255.0

ip broadcast-address 192.168.1.0

ip mtu 1452

ip nat inside

ip virtual-reassembly

speed auto

full-duplex

no mop enabled

!

interface FastEthernet0/1 <------------- Outside interface to Corbina

ip address dhcp

ip access-group 111 out

ip mtu 1452

ip nat outside

ip virtual-reassembly

speed auto

full-duplex

no mop enabled

!

interface FastEthernet0/1/0

!

interface FastEthernet0/1/1

!

interface FastEthernet0/1/2

!

interface FastEthernet0/1/3

!

interface ATM0/0/0 <-----------------------------------можно выкинуть, у кого нету

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/0/0.1 point-to-point <-----------------------------------можно выкинуть, у кого нету

pvc 0/100

pppoe-client dial-pool-number 1

!

!

interface Virtual-PPP1

ip address negotiated

no ip proxy-arp

ip mtu 1452

ip nat outside

ip virtual-reassembly

no cdp enable

ppp authentication chap callin

ppp chap hostname <----------------------------------------- user name

ppp chap password <----------------------------------------- pass

pseudowire 85.21.x.x 10 pw-class class1 <----------------- ip L2TP servera

!

!

interface Vlan1 <-----------------------------------можно выкинуть, у кого нету

ip address 192.168.2.1 255.255.255.0

ip broadcast-address 192.168.2.0

ip mtu 1452

ip nat inside

ip virtual-reassembly

!

interface Dialer0 <-----------------------------------можно выкинуть, у кого нету

ip address 10.100.100.10 255.255.255.0

ip mtu 1452

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname ####

ppp chap password ####

!

ip route 0.0.0.0 0.0.0.0 Virtual-PPP1 <--------------- Default Route

ip route 10.0.0.0 255.0.0.0 10.57.16.1

ip route 83.102.146.96 255.255.255.224 10.57.16.1

ip route 85.21.0.0 255.255.0.0 10.57.16.1

ip route 89.179.135.67 255.255.255.255 10.57.16.1

ip route 195.14.0.0 255.255.0.0 10.57.16.1

!

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list lan interface FastEthernet0/1 overload

ip nat inside source list wan interface Virtual-PPP1 overload

ip nat inside source static tcp 192.168.1.22 21 interface Virtual-PPP1 21

ip nat inside source static tcp 192.168.2.21 5060 interface Virtual-PPP1 5060 <------- проброс портов

ip nat inside source static tcp 192.168.1.22 23780 interface Virtual-PPP1 23780

ip nat inside source static udp 192.168.1.22 23780 interface Virtual-PPP1 23780

ip nat inside source static tcp 192.168.1.22 16590 interface Virtual-PPP1 16590

ip nat inside source static udp 192.168.1.22 16605 interface Virtual-PPP1 16605

ip nat inside source static tcp 192.168.1.22 25563 interface FastEthernet0/1 25563

ip nat inside source static udp 192.168.1.22 19005 interface FastEthernet0/1 19005

!

ip access-list extended lan <------------------------------------ inside (local) Lan subnets

permit ip 192.168.1.0 0.0.0.255 195.14.0.0 0.0.255.255

permit ip 192.168.1.0 0.0.0.255 10.0.0.0 0.255.255.255

permit ip 192.168.1.0 0.0.0.255 85.21.0.0 0.0.255.255

permit ip 192.168.1.0 0.0.0.255 83.102.146.0 0.0.0.31

permit ip 192.168.2.0 0.0.0.255 195.14.0.0 0.0.255.255

permit ip 192.168.2.0 0.0.0.255 10.0.0.0 0.255.255.255

permit ip 192.168.2.0 0.0.0.255 85.21.0.0 0.0.255.255

permit ip 192.168.2.0 0.0.0.255 83.102.146.0 0.0.0.31

permit ip 192.168.9.0 0.0.0.255 195.14.0.0 0.0.255.255

permit ip 192.168.9.0 0.0.0.255 10.0.0.0 0.255.255.255

permit ip 192.168.9.0 0.0.0.255 85.21.0.0 0.0.255.255

permit ip 192.168.9.0 0.0.0.255 83.102.146.0 0.0.0.31

ip access-list extended wan

permit ip 192.168.1.0 0.0.0.255 any

permit ip 192.168.2.0 0.0.0.255 any

permit ip 192.168.9.0 0.0.0.255 any

!

access-list 111 permit ip any any <------------ Ну а это, что бы всё работало правильно :-)

access-list 111 permit udp any any

access-list 111 permit gre any any

access-list 111 permit tcp any any

access-list 111 permit icmp any any

access-list 111 permit pcp any any

access-list 111 permit esp any any

access-list 111 permit igmp any any

access-list 111 permit ipinip any any

access-list 111 permit nos any any

access-list 111 permit tcp any any eq domain

access-list 111 deny tcp any eq 139 any

access-list 111 deny udp any eq netbios-ns any eq netbios-ns

access-list 111 deny udp any eq netbios-dgm any eq netbios-dgm

access-list 111 deny udp any eq netbios-ss any eq netbios-ss

access-list 111 deny udp any any range snmp snmptrap

access-list 111 deny tcp any any eq 3128

access-list 111 deny ip 192.168.1.0 0.0.0.255 any

access-list 111 deny ip 172.16.0.0 0.15.255.255 any

access-list 111 deny ip 127.0.0.0 0.0.0.255 any

access-list 111 deny udp any any range 130 140

access-list 111 deny tcp any any range 130 140

access-list 111 deny tcp any any eq 8080

access-list 111 deny ip 192.168.2.0 0.0.0.255 any

access-list 111 deny ip 192.168.9.0 0.0.0.255 any

no cdp run

!

!

!

!

!

!

control-plane

!

!

line con 0

transport output telnet

speed 57600

line aux 0

line vty 0 4

!

scheduler allocate 20000 1000

!

end

 

 

 

Вроде всё. Те интерфейсы, что ненужно, соответственно можно убрать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Доброго дня!

Приветствую.

Конфиг потенциально рабочий, думаю тебе следует обратить на него внимание модераторов с просьбой прикрепить в разделе примеров настройки роутеров.

Только необходимы некоторые пояснения сделать:

- с корбиной может работать любой маршрутизатор cisco имеющий хотя бы один ethernet интерфейс, и ios которого поддерживает след. фитчи

 

 L2TP Client Initiated Tunneling
L2TP Dial-Out
L2TP Layer 2 Tunneling Protocol
Selective Virtual-Access Interface Creation 

- базовая конфигурация заключается в: настройке трех интерфейсов (или двух в отдельных случаях) , ethernet - в локальную сеть, ethernet - в интрасеть сеть корбины и Virtual-Access Interface (virtual-ppp) виртуальный интерфейс - в интернет; настройке правил трансляции трафика из локальной сети в корбину и интернет; настройке маршрутизации; написании списков доступа.

- расширенная включает в себя настройку iptv, трансляции портов для eMule, torrent и д.р. клиентов и т.д.

 

P.S. Если версия иоса 124-15.Т и выше, разумнее использовать route-map для трансляции трафика и не зависить от изменений в адресации К.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А IPTV не пробовали настраивать на 1841?

Приветствую.

ip multicast-routing
!
ip mroute 85.21.91.0 255.255.255.0 10.х.х.х  ! адрес локального шлюза К.
ip mroute 172.16.16.0 255.255.255.0 10.х.х.х  ! адрес локального шлюза К.
!
access-list 66 deny   any ! Опционально.
!
interface FastEthernet0/0.1 ! "Смотрящий" на Корбину
ip pim neighbor-filter 66
ip pim dense-mode
!
interface Vlan 1 ! Твоя локальная сеть
ip pim dense-mode
ip igmp helper-address 10.х.х.х ! адрес локального шлюза К.
ip igmp mroute-proxy FastEthernet0/0.1 ! Интерфейс, "смотрящий" на Корбину 

 

Какой-то из маршрутов уже не нужен.

В acl надо сделать дырку для udp на порту 5050 от 172.16.16.0/24

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

:) Все же жаль, что модеры до сих пор игнорируют цискарей. Неплохо бы было вверху сделать общую ветку по циске. Ведь нет-нет да и всплывет что-то новое, или появится сочуствующий-интересующийся :)

 

То: user-login Собственно оффтопик :D ты iptv пользуешь? Как качество картинки? Я вот все думаю, подключить или нет. И как это буит выглядить на 32 дюймах.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А какая прошивка используется на роутере ?

Я попробовал поднять L2TP, тунель поднимается и через минуту падает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
А какая прошивка используется на роутере ?

Я попробовал поднять L2TP, тунель поднимается и через минуту падает.

Какой l2tp-сервер используется для авторизации?

Смени l2tp-сервер на:

Официальный:

85.21.0.255

 

 

Не совсем официальные, но работающие:

85.21.17.1 
85.21.17.3 
85.21.17.5 
85.21.17.7 
85.21.17.9 
85.21.17.11 
85.21.17.13 Этот особенно рекомендуют 
85.21.17.15 
85.21.17.17 
85.21.17.19 
85.21.17.21 
и т.д.

А проблема не работоспособности интернета и падения интерфейса заключается в том, что выдаваемый пиром адрес дефолтного гейтвея совпадает с адресом самого пира.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Какой l2tp-сервер используется для авторизации?

 

пробовал несколько из тех, что разрешаются из vpn.corbina.net

85.21.0.17, 85.21.0.18, 85.21.0.21, 85.21.0.15, 85.21.0.16

 

а проблема действительно в том, что выдаваемый пиром адрес дефолтного гейтвея совпадает с адресом самого пира. Когда туннель поднимается, дефолтный гейтвей перестает пинговаться. Как это побороть - не знаю. Может кто подскажет ? :ok:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
пробовал несколько из тех, что разрешаются из vpn.corbina.net

85.21.0.17, 85.21.0.18, 85.21.0.21, 85.21.0.15, 85.21.0.16

 

а проблема действительно в том, что выдаваемый пиром адрес дефолтного гейтвея совпадает с адресом самого пира. Когда туннель поднимается, дефолтный гейтвей перестает пинговаться. Как это побороть - не знаю. Может кто подскажет ? <_<

Мне доступен пока только один способ решения этой проблемы - использовать адреса l2tp-пиров из поста выше... Либо использовать pptp-инкапсуляцию, но там свои непонятки

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Мне доступен пока только один способ решения этой проблемы - использовать адреса l2tp-пиров из поста выше... Либо использовать pptp-инкапсуляцию, но там свои непонятки

Спасибо, попробую. Уже не первый раз слышу, что vpn сервера корбины "ведут себя" по-разному и меют свои особенности. Интересно, с чем это связано ....

 

Какой l2tp-сервер используется для авторизации?

Использовал 85.21.17.13 - все отлично заработало. Спасибо за помощь.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А какие значения mtu кто использует ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
А какие значения mtu кто использует ?

Если использовать официальный peer 85.21.0.255, то можно никакие значения mtu не задавать. PMTU - Path MTU Discovery - сам все сделает (главное в acl не на мудрить с запретами icmp-unreachable и icmp-packet-too-big). А если какие-то другие, то это определяется эмпирически.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Не получается заставить работать все это в vrf (без vrf все работает). На текущий момент измененные/добавленные части (никаких ACL/NAT нет):

 

 

no ip gratuitous-arps

ip cef

!

!

!

!

ip vrf isp30

description beeline

rd 65000:30

route-target export 65000:30

route-target import 65000:30

!

ip multicast-routing

ip multicast-routing vrf isp30

!

multilink bundle-name authenticated

vpdn enable

!

vpdn-group 1

request-dialin

protocol pptp

rotary-group 0

vpn vrf isp30

initiate-to ip 172.29.192.7 priority 1

initiate-to ip 172.29.192.8 priority 2

l2tp tunnel receive-window 1024

!

 

interface FastEthernet0/1.30

description beeline

encapsulation dot1Q 30

ip vrf forwarding isp30

ip address dhcp

ip pim neighbor-filter 2

ip virtual-reassembly

no cdp enable

!

interface Dialer0

ip vrf forwarding isp30

ip address negotiated

no ip proxy-arp

ip mtu 1460

ip pim neighbor-filter 2

ip pim dense-mode

ip virtual-reassembly

encapsulation ppp

dialer in-band

dialer idle-timeout 0

dialer string 123

dialer vpdn

dialer-group 1

no keepalive

no cdp enable

ppp pfc local request

ppp pfc remote apply

ppp encrypt mppe auto

ppp chap hostname XXX

ppp chap password 0 XXX

!

ip route vrf isp30 0.0.0.0 0.0.0.0 Dialer0

ip route vrf isp30 10.0.0.0 255.0.0.0 dhcp

ip route vrf isp30 172.29.192.7 255.255.255.255 dhcp

ip route vrf isp30 172.29.192.8 255.255.255.255 dhcp

 

 

totoro#sh ip route vrf isp30

 

Routing Table: isp30

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

 

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

 

172.29.0.0/32 is subnetted, 2 subnets

S 172.29.192.7 [1/0] via 10.13.40.1

S 172.29.192.8 [1/0] via 10.13.40.1

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

S 10.0.0.0/8 [1/0] via 10.13.40.1

C 10.13.40.0/21 is directly connected, FastEthernet0/1.30

212.119.249.0/32 is subnetted, 1 subnets

S 212.119.249.227 [254/0] via 10.13.40.1, FastEthernet0/1.30

S* 0.0.0.0/0 is directly connected, Dialer0

totoro#

 

totoro#sh deb

PPP:

PPP detailed event debugging is on

PPP authentication debugging is on

MPPE Events debugging is on

PPP protocol errors debugging is on

PPP protocol negotiation debugging is on

PPP forwarding events debugging is on

VPN:

L2X protocol events debugging is on

L2X data packets debugging is on

L2X control packets debugging is on

L2X protocol errors debugging is on

VPDN call event debugging is on

VPDN call FSM debugging is on

VPDN message debugging is on

VPDN events debugging is on

VPDN errors debugging is on

VPDN packet debugging is on

 

 

dot11:

dot11 Syslog debugging is on

 

 

Отладочный вывод (часть между строк **************** повторяется бесконечно):

 

 

*Jul 14 22:20:49.919: VPDN CALL [25]: Event client disc, state changed from connecting to disconnecting

*Jul 14 22:20:49.919: VPDN CALL [25]: Client requested disconnectionUnexpected event!!! VPDN Subblock destroy called

*Jul 14 22:20:49.919: VPDN MGR: Received message, client disconnect request

*Jul 14 22:20:49.919: VPDN MGR [25]: Event client disconnect, state changed from connecting to disconnected

*Jul 14 22:20:49.923: VPDN MGR [25]: Abort to forward unknown

*Jul 14 22:20:49.923: VPDN Vi1 vpdn shutdown session, result=2, error=7, vendor_err=0

*Jul 14 22:20:49.923: VPDN Vi1 Unbinding session from idb

*Jul 14 22:20:49.923: L2TUN APP: handle/106521Destroying app session

*Jul 14 22:20:49.923: VPDN CALL [25]: Received client message client disconnect ok

*Jul 14 22:20:49.923: VPDN CALL [25]: Event client disc ok, state changed from disconnecting to disconnected

*Jul 14 22:20:49.923: VPDN CALL [25]: Event free req, state changed from disconnected to terminal

*Jul 14 22:20:49.923: VPDN CALL [25]: Free request

*Jul 14 22:20:49.923: PPTP _____:_____: L2X DB: no id

*Jul 14 22:20:49.923: PPTP _____:106521:_____: close -> state change wt-tun to terminal

*Jul 14 22:20:49.923: PPTP _____:106521:_____: Destroying session

*Jul 14 22:20:49.923: L2X _____:_____: Cannot remove invalid application context 0x65CF155C from socket

*Jul 14 22:20:49.927: PPTP _____:_____: DB: no remote id

*Jul 14 22:20:49.927: L2X _____:_____: PROTO DB: removed session with id 27 (total 0)

*Jul 14 22:20:49.927: PPTP tnl 106521:_____: no-sess -> state change wt-cnnct to terminal

*Jul 14 22:20:49.927: PPTP tnl 106521:_____: Destroy tunnel

*Jul 14 22:20:49.927: PPTP _____:_____: No l2x in cc

*Jul 14 22:20:49.927: L2X _____:_____: PROTO DB: removed cc with id 27 (total 1)

*Jul 14 22:20:49.927: VPDN Received L2TUN socket message <CDN - Session Disconnected>

 

***************************************************

 

*Jul 14 22:21:18.671: Vi1 PPP: Phase is DOWN, Setup

*Jul 14 22:21:18.675: VPDN CALL [26]: Event connect req, state changed from idle to connecting

*Jul 14 22:21:18.675: VPDN CALL [26]: Requesting connection

*Jul 14 22:21:18.675: VPDN CALL [26]: Call request sent

*Jul 14 22:21:18.675: VPDN MGR: Received message, client voluntary request

*Jul 14 22:21:18.675: VPDN MGR [26]: Event client connect, state changed from idle to connecting

*Jul 14 22:21:18.675: VPDN MGR [26]: Initiating voluntary connection to 172.29.192.7

*Jul 14 22:21:18.675: VPDN Vi1 L2TUN socket session connect requested

*Jul 14 22:21:18.675: VPDN Vi1 Setting up dataplane for L2-L3, Vi1

*Jul 14 22:21:18.679: L2X _____:_____: PROTO DB: added cc with id 28 (total 2)

*Jul 14 22:21:18.679: PPTP tnl 110618:_____: Tunnel created; we initiated

*Jul 14 22:21:18.679: L2X _____:_____: PROTO DB: added session (cc id 28, sess id 28) (total 1)

*Jul 14 22:21:18.679: PPTP tnl 110618:_____: new-sess -> state change idle to wt-cnnct

*Jul 14 22:21:18.679: PPTP tnl 110618:_____: TCP active opening to 172.29.192.7

*Jul 14 22:21:18.679: PPTP _____:_____: L2X DB: no id

*Jul 14 22:21:48.671: VPDN CALL [26]: Event client disc, state changed from connecting to disconnecting

*Jul 14 22:21:48.671: VPDN CALL [26]: Client requested disconnectionUnexpected event!!! VPDN Subblock destroy called

*Jul 14 22:21:48.671: VPDN MGR: Received message, client disconnect request

*Jul 14 22:21:48.671: VPDN MGR [26]: Event client disconnect, state changed from connecting to disconnected

*Jul 14 22:21:48.675: VPDN MGR [26]: Abort to forward unknown

*Jul 14 22:21:48.675: VPDN Vi1 vpdn shutdown session, result=2, error=7, vendor_err=0

*Jul 14 22:21:48.675: VPDN Vi1 Unbinding session from idb

*Jul 14 22:21:48.675: L2TUN APP: handle/110618Destroying app session

*Jul 14 22:21:48.675: VPDN CALL [26]: Received client message client disconnect

ok

*Jul 14 22:21:48.675: VPDN CALL [26]: Event client disc ok, state changed from disconnecting to disconnected

*Jul 14 22:21:48.675: VPDN CALL [26]: Event free req, state changed from disconnected to terminal

*Jul 14 22:21:48.675: VPDN CALL [26]: Free request

*Jul 14 22:21:48.675: PPTP _____:_____: L2X DB: no id

*Jul 14 22:21:48.675: PPTP _____:110618:_____: close -> state change wt-tun to terminal

*Jul 14 22:21:48.675: PPTP _____:110618:_____: Destroying session

*Jul 14 22:21:48.675: L2X _____:_____: Cannot remove invalid application context 0x65CF155C from socket

*Jul 14 22:21:48.679: PPTP _____:_____: DB: no remote id

*Jul 14 22:21:48.679: L2X _____:_____: PROTO DB: removed session with id

28 (total 0)

*Jul 14 22:21:48.679: PPTP tnl 110618:_____: no-sess -> state change wt-cnnct to terminal

*Jul 14 22:21:48.679: PPTP tnl 110618:_____: Destroy tunnel

*Jul 14 22:21:48.679: PPTP _____:_____: No l2x in cc

*Jul 14 22:21:48.679: L2X _____:_____: PROTO DB: removed cc with id 28 (total 1)

*Jul 14 22:21:48.679: VPDN Received L2TUN socket message <CDN - Session Disconnected>

 

*********************************************

 

Туннель поднимается и затем падает:

 

totoro#sh vpdn

 

%No active L2TP tunnels

 

PPTP Tunnel and Session Information Total tunnels 1 sessions 1

 

LocID Remote Name State Remote Address Port Sessions VPDN Group

46 172.29.192.7 wt-cnnct 172.29.192.7 1723 1 1

 

LocID RemID TunID Intf Username State Last Chg Uniq ID

46 0 46 Vi1 wt-tun never 0

totoro#

 

 

Dialer так и не может получить адрес. В общем не пойму в чем дело.

Можно ли вообще это сделать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Не получается заставить работать все это в vrf (без vrf все работает).

А можно вопрос не в тему? Какой смысл этой затеи? Теоретические изыски или какое-то практическое применение?

Покажите вывод show ip route и show ip route vrf isp30, какие маршруты у вас передаются в глобальную таблицу?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Не получается заставить работать все это в vrf (без vrf все работает).

А можно вопрос не в тему? Какой смысл этой затеи? Теоретические изыски или какое-то практическое применение?

Покажите вывод show ip route и show ip route vrf isp30, какие маршруты у вас передаются в глобальную таблицу?

 

Не заметил, что тема оказывается закрыта.

 

totoro#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

C 192.168.1.0/24 is directly connected, FastEthernet0/1.10

totoro#

 

Этот адрес для связи с tftp-сервером, не более.

 

totoro#sh ip route vrf isp30

 

Routing Table: isp30

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

 

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

 

172.29.0.0/32 is subnetted, 2 subnets

S 172.29.192.7 [1/0] via 10.13.40.1

S 172.29.192.8 [1/0] via 10.13.40.1

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

S 10.0.0.0/8 [1/0] via 10.13.40.1

C 10.13.40.0/21 is directly connected, FastEthernet0/1.30

212.119.249.0/32 is subnetted, 1 subnets

S 212.119.249.227 [254/0] via 10.13.40.1, FastEthernet0/1.30

S* 0.0.0.0/0 is directly connected, Dialer0

totoro#

 

Смысл затеи? Было у меня два интернета (adsl pppoe и статический). Загнал каждый в свой vrf и при помощи "vrf selection using PBR" (начитался теории) в зависимости от ip-адреса компьютера выбирал нужный канал. Все работало. Потом поменял статический канал на Билайн с его pptp и не могу загнать его в vrf. Может идея и не выполнимая? В простой конфигурации все работает, не жалуюсь, но хочется сделать через vrf.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Смысл затеи? Было у меня два интернета (adsl pppoe и статический). Загнал каждый в свой vrf и при помощи "vrf selection using PBR" (начитался теории) в зависимости от ip-адреса компьютера выбирал нужный канал. Все работало. Потом поменял статический канал на Билайн с его pptp и не могу загнать его в vrf. Может идея и не выполнимая? В простой конфигурации все работает, не жалуюсь, но хочется сделать через vrf.

Сейчас мне категорически не когда разбираться, но покажите вывод deb ppp auth и deb ppp neg (онли). Была какая-то давняя тема с ограничениями на диалере, но сейчас подробностей не вспомню.

А ваша идея реализуема посредством PBR и без vrf

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Смысл затеи? Было у меня два интернета (adsl pppoe и статический). Загнал каждый в свой vrf и при помощи "vrf selection using PBR" (начитался теории) в зависимости от ip-адреса компьютера выбирал нужный канал. Все работало. Потом поменял статический канал на Билайн с его pptp и не могу загнать его в vrf. Может идея и не выполнимая? В простой конфигурации все работает, не жалуюсь, но хочется сделать через vrf.

Сейчас мне категорически не когда разбираться, но покажите вывод deb ppp auth и deb ppp neg (онли). Была какая-то давняя тема с ограничениями на диалере, но сейчас подробностей не вспомню.

А ваша идея реализуема посредством PBR и без vrf

 

Не густо с ppp:

 

*Jul 15 21:26:10.932: Vi1 PPP: Phase is DOWN, Setup

*Jul 15 21:27:09.584: Vi1 PPP: Phase is DOWN, Setup

*Jul 15 21:28:09.184: Vi1 PPP: Phase is DOWN, Setup

*Jul 15 21:29:08.232: Vi1 PPP: Phase is DOWN, Setup

 

Собственно вот разница между неуспешным соединением:

 

*Jul 14 22:23:17.571: Vi1 PPP: Phase is DOWN, Setup

*Jul 14 22:23:17.575: VPDN CALL [28]: Event connect req, state changed from idle to connecting

*Jul 14 22:23:17.575: VPDN CALL [28]: Requesting connection

*Jul 14 22:23:17.575: VPDN CALL [28]: Call request sent

*Jul 14 22:23:17.575: VPDN MGR: Received message, client voluntary request

*Jul 14 22:23:17.575: VPDN MGR [28]: Event client connect, state changed from idle to connecting

*Jul 14 22:23:17.575: VPDN MGR [28]: Initiating voluntary connection to 172.29.192.7

*Jul 14 22:23:17.575: VPDN Vi1 L2TUN socket session connect requested

*Jul 14 22:23:17.575: VPDN Vi1 Setting up dataplane for L2-L3, Vi1

*Jul 14 22:23:17.575: L2X _____:_____: PROTO DB: added cc with id 30 (total 2)

*Jul 14 22:23:17.579: PPTP tnl 118812:_____: Tunnel created; we initiated

*Jul 14 22:23:17.579: L2X _____:_____: PROTO DB: added session (cc id 30, sess id 30) (total 1)

*Jul 14 22:23:17.579: PPTP tnl 118812:_____: new-sess -> state change idle to wt-cnnct

*Jul 14 22:23:17.579: PPTP tnl 118812:_____: TCP active opening to 172.29.192.7

 

Вот здесь все и помирает:

 

*Jul 14 22:23:17.579: PPTP _____:_____: L2X DB: no id

*Jul 14 22:23:47.571: VPDN CALL [28]: Event client disc, state changed from connecting to disconnecting

*Jul 14 22:23:47.571: VPDN CALL [28]: Client requested disconnectionUnexpected event!!! VPDN Subblock destroy called

 

 

и успешным соединением (без vrf):

 

 

*Jul 14 01:19:53.427: Vi1 PPP: Phase is DOWN, Setup

*Jul 14 01:19:53.427: VPDN CALL [3]: Requesting connection

*Jul 14 01:19:53.427: VPDN CALL [3]: Call request sent

*Jul 14 01:19:53.431: VPDN MGR: Received message, client voluntary request

*Jul 14 01:19:53.431: VPDN MGR [3]: Initiating voluntary connection to 172.29.192.7

*Jul 14 01:19:53.431: Tnl 5 PPTP: Tunnel created; we initiated

*Jul 14 01:19:53.431: Tnl/Sn 5/5 PPTP: Created PNS voluntary session

*Jul 14 01:19:53.431: Tnl 5 PPTP: new-sess -> state change idle to wt-cnnct

*Jul 14 01:19:53.431: Tnl 5 PPTP: TCP active opening to 172.29.192.7

 

и далее все хорошо:

 

*Jul 14 01:19:53.435: Tnl 5 PPTP: tcp-conn -> state change wt-cnnct to wt-sccrp

*Jul 14 01:19:53.435: Tnl 5 PPTP: O SCCRQ

*Jul 14 01:19:53.435: Tnl 5 PPTP: I 009C00011A2B3C4D0002000001000100000000030000...

*Jul 14 01:19:53.435: Tnl 5 PPTP: I SCCRP from vpn1.Vladivostok

*Jul 14 01:19:53.435: Tnl 5 PPTP: protocol version 100

*Jul 14 01:19:53.435: Tnl 5 PPTP: result code 1

*Jul 14 01:19:53.435: Tnl 5 PPTP: error code 0

*Jul 14 01:19:53.435: Tnl 5 PPTP: framing caps 3

*Jul 14 01:19:53.435: Tnl 5 PPTP: bearer caps 3

*Jul 14 01:19:53.439: Tnl 5 PPTP: max channels 0

*Jul 14 01:19:53.439: Tnl 5 PPTP: firmware rev 1200

*Jul 14 01:19:53.439: Tnl 5 PPTP: hostname "vpn1.Vladivostok"

*Jul 14 01:19:53.439: Tnl 5 PPTP: vendor "Cisco Systems, Inc."

*Jul 14 01:19:53.439: Tnl 5 PPTP: SCCRP-ok -> state change wt-sccrp to estabd

*Jul 14 01:19:53.439: Vi1 Tnl/Sn 5/5 PPTP: tnl-up -> state change wt-tun to wt-ocrp

*Jul 14 01:19:53.439: Vi1 Tnl/Sn 5/5 PPTP: CC O OCRQ

*Jul 14 01:19:53.439: Tnl 5 PPTP: I 002000011A2B3C4D0008000022980005010000000000...

*Jul 14 01:19:53.439: Vi1 Tnl/Sn 5/5 PPTP: CC I OCRP

*Jul 14 01:19:53.439: Vi1 Tnl/Sn 5/5 PPTP: call id 8856

*Jul 14 01:19:53.439: Vi1 Tnl/Sn 5/5 PPTP: result code 1

*Jul 14 01:19:53.439: Vi1 Tnl/Sn 5/5 PPTP: error code 0

*Jul 14 01:19:53.439: Vi1 Tnl/Sn 5/5 PPTP: cause code 0

*Jul 14 01:19:53.443: Vi1 Tnl/Sn 5/5 PPTP: connect speed 64000

*Jul 14 01:19:53.443: Vi1 Tnl/Sn 5/5 PPTP: recv win size 16

*Jul 14 01:19:53.443: Vi1 Tnl/Sn 5/5 PPTP: ppd 0

*Jul 14 01:19:53.443: Vi1 Tnl/Sn 5/5 PPTP: physical channel id 0

*Jul 14 01:19:53.443: Vi1 Tnl/Sn 5/5 PPTP: OCRP-ok -> state change wt-ocrp to estabd

*Jul 14 01:19:53.443: Vi1 Tnl/Sn 5/5 PPTP: VPDN session up

*Jul 14 01:19:53.443: VPDN MGR [3]: Succeed to forward unknown

*Jul 14 01:19:53.443: VPDN CALL [3]: Received client message client connect ok

*Jul 14 01:19:53.443: VPDN CALL [3]: Connection succeeded

 

Конечно это можно реализовать и без vrf, но хочется понять в чем косяк.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Конечно это можно реализовать и без vrf, но хочется понять в чем косяк.

В качестве эксперимента попробуйте выключить cef командой в глобальном режиме no ip cef. Единственное что вспомнилось из ограничений:

The Dialer CEF feature is not supported when a static route is pointing to the Dialer without specifying a next hop IP address. When using the Cisco IOS Release 12.3(11)T and higher, the ppp ipcp default route command may be used in Dialer interface configuration mode to work around this restriction.
но это пока не ваш случай...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Для тех, у кого тоннел отваливается через минуту, нужно добавить одну команду.

На интерфейсе будут следующие настройки:

 

interface Virtual-PPP1

description $FW_OUTSIDE$

ip address negotiated

ip access-group 111 out

no ip proxy-arp

ip nat outside

ip virtual-reassembly

ip route-cache flow

no peer neighbor-route

no cdp enable

ppp encrypt mppe auto

ppp authentication ms-chap chap callin

ppp chap hostname логин

ppp chap password пароль

no ppp chap wait

pseudowire 85.21.0.243 10 pw-class class1

 

 

и не забываем про ip tcp path-mtu-discovery

что бы мту линейкой не мерить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всем привет!

 

хотел настроить cisco 1841

залил конфиг ваш и больше она не грузиться (подозреваю что проблема с прошивкой)

вот ошибки:

Cisco 1841 (revision 7.0) with 64512K/66560K bytes of memory.
Processor board ID FCZ120992S5
2 FastEthernet interfaces
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
125184K bytes of ATA CompactFlash (Read/Write)

SYSTEM INIT: INSUFFICIENT MEMORY TO BOOT THE IMAGE!



%Software-forced reload


03:01:03 MSK Thu Jan 1 1970: Breakpoint exception, CPU signal 23, PC = 0x6051799C



--------------------------------------------------------------------
  Possible software fault. Upon reccurence,  please collect
  crashinfo, "show tech" and contact Cisco Technical Support.
--------------------------------------------------------------------


-Traceback= 0x6051799C 0x60515F50 0x601E318C 0x601E45BC 0x601EE598 0x601EDD04 0x610770E8 0x610750A8 0x61024D30 0x61028A10 0x60A81878 0x60A9B490 0x60A9B65C 0x60A9B7D4 0x60A9B880 0x60E48FA4
$0 : 00000000, AT : 62F10000, v0 : 00000000, v1 : 00000000
a0 : 00000000, a1 : 00003968, a2 : 00000000, a3 : 62230000
t0 : 62FC2EE8, t1 : 63110000, t2 : 6051CE30, t3 : 62F14D44
t4 : 00000002, t5 : 00000001, t6 : 00000002, t7 : 00000000
s0 : 00000000, s1 : 00000000, s2 : 62CB0000, s3 : 62C30000
s4 : 601EE590, s5 : 00000000, s6 : 620FF01C, s7 : 00000000
t8 : 63110000, t9 : 00000000, k0 : 3041E801, k1 : 00100000
gp : 62F1CB00, sp : 63336E90, s8 : 00000000, ra : 60515F50
EPC  : 6051799C, ErrorEPC : 00100008, SREG     : 3401FF03
MDLO : 0000001E, MDHI     : 00000000, BadVaddr : BE9EFDEF
DATA_START : 0x61F84380
Cause 00000024 (Code 0x9): Breakpoint exception

Writing crashinfo to flash:crashinfo_19700101-000103

03:01:03 MSK Thu Jan 1 1970: Breakpoint exception, CPU signal 23, PC = 0x6051799C



--------------------------------------------------------------------
  Possible software fault. Upon reccurence,  please collect
  crashinfo, "show tech" and contact Cisco Technical Support.
--------------------------------------------------------------------


-Traceback= 0x6051799C 0x60515F50 0x601E318C 0x601E45BC 0x601EE598 0x601EDD04 0x610770E8 0x610750A8 0x61024D30 0x61028A10 0x60A81878 0x60A9B490 0x60A9B65C 0x60A9B7D4 0x60A9B880 0x60E48FA4
$0 : 00000000, AT : 62F10000, v0 : 00000000, v1 : 00000000
a0 : 00000000, a1 : 00003968, a2 : 00000000, a3 : 62230000
t0 : 62FC2EE8, t1 : 63110000, t2 : 6051CE30, t3 : 62F14D44
t4 : 00000002, t5 : 00000001, t6 : 00000002, t7 : 00000000
s0 : 00000000, s1 : 00000000, s2 : 62CB0000, s3 : 62C30000
s4 : 601EE590, s5 : 00000000, s6 : 620FF01C, s7 : 00000000
t8 : 63110000, t9 : 00000000, k0 : 3041E801, k1 : 00100000
gp : 62F1CB00, sp : 63336E90, s8 : 00000000, ra : 60515F50
EPC  : 6051799C, ErrorEPC : 00100008, SREG     : 3401FF03
MDLO : 0000001E, MDHI     : 00000000, BadVaddr : BE9EFDEF
DATA_START : 0x61F84380
Cause 00000024 (Code 0x9): Breakpoint exception

-Traceback= 0x6051799C 0x60515F50 0x601E318C 0x601E45BC 0x601EE598 0x601EDD04 0x610770E8 0x610750A8 0x61024D30 0x61028A10 0x60A81878 0x60A9B490 0x60A9B65C 0x60A9B7D4 0x60A9B880 0x60E48FA4


=== Flushing messages (03:01:06 MSK Thu Jan 1 1970) ===

Buffered messages:
Queued messages:
000008: *Jan  1 00:01:06.547: %SYS-3-LOGGER_FLUSHING: System pausing to ensure console debugging output.

*Mar  1 00:00:02.471: %ENVMON-4-RTC: The Real Time Clock may have battery problem or it has not been set to the current timesslinit fn

*Jan  1 00:00:59.939: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State changed to: Initialized
*Jan  1 00:00:59.939: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0  State changed to: Enabled
000005: *Jan  1 00:01:02.803: %SYS-6-CLOCKUPDATE: System clock has been updated from 00:01:02 UTC Thu Jan 1 1970 to 03:01:02 MSK Thu Jan 1 1970, configured from console by console.
000006: *Jan  1 00:01:02.803: %SYS-6-CLOCKUPDATE: System clock has been updated from 03:01:02 MSK Thu Jan 1 1970 to 03:01:02 MSK Thu Jan 1 1970, configured from console by console.
000007: *Jan  1 00:01:03.043: %SYS-2-MALLOCFAIL: Memory allocation of 65536 bytes failed from 0x601EE590, alignment 8
Pool: Processor  Free: 61136  Cause: Not enough free memory
Alternate Pool: None  Free: 0  Cause: No Alternate pool
-Process= "Init", ipl= 0, pid= 3 -Traceback= 0x60A40914 0x601DE3D8 0x601E318C 0x601E45BC 0x601EE598 0x601EDD04 0x610770E8 0x610750A8 0x61024D30 0x61028A10 0x60A81878 0x60A9B490 0x60A9B65C 0x60A9B7D4 0x60A9B880 0x60E48FA4

помогите исправить......

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всем привет!

 

хотел настроить cisco 1841

залил конфиг ваш и больше она не грузиться (подозреваю что проблема с прошивкой)

вот ошибки:

Cisco 1841 (revision 7.0) with 64512K/66560K bytes of memory.
Processor board ID FCZ120992S5
2 FastEthernet interfaces
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
125184K bytes of ATA CompactFlash (Read/Write)

SYSTEM INIT: INSUFFICIENT MEMORY TO BOOT THE IMAGE!



%Software-forced reload

 

Вы объясните где вы взяли 1841 с 64Мб памяти да ещё и все выделены под iomem? Таких в дикой природе не бывает. Внутрь лазили?

Залейте ей какой-нибудь ipbase ios и посмотрите, поднимется ли она вообще.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всем привет!

 

хотел настроить cisco 1841

залил конфиг ваш и больше она не грузиться (подозреваю что проблема с прошивкой)

вот ошибки:

Cisco 1841 (revision 7.0) with 64512K/66560K bytes of memory.
Processor board ID FCZ120992S5
2 FastEthernet interfaces
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
125184K bytes of ATA CompactFlash (Read/Write)

SYSTEM INIT: INSUFFICIENT MEMORY TO BOOT THE IMAGE!



%Software-forced reload

 

Вы объясните где вы взяли 1841 с 64Мб памяти да ещё и все выделены под iomem? Таких в дикой природе не бывает. Внутрь лазили?

Залейте ей какой-нибудь ipbase ios и посмотрите, поднимется ли она вообще.

немогли бы помоч с прошивочкой?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

немогли бы помоч с прошивочкой?

Попробуйте хотя бы с этим загрузиться

c1841-ipbase-mz.124-15.T7.bin

незаработало... нашел другой версии прошивку c1841-ipbase-mz.124-12c.bin

загружается но начинает ругаться на это:

 

pseudowire-class class1
encapsulation l2tpv2
protocol l2tpv2 corbina
ip local interface FastEthernet0/1

 

также нельзя создать виртуальный пптр

железко умер?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

незаработало... нашел другой версии прошивку c1841-ipbase-mz.124-12c.bin

загружается но начинает ругаться на это:

 

pseudowire-class class1
encapsulation l2tpv2
protocol l2tpv2 corbina
ip local interface FastEthernet0/1

 

также нельзя создать виртуальный пптр

железко умер?

Хоть с каким-то иосом она загрузилась? Покажите вывод show plat и show diag

У вас проблема не в том, что вы не можете создать virtual-ppp, это естественно так как прошивки ipbase это не поддерживают. Проблема в том, что вас маршрутизатор, которого не бывает в дикой природе: у линейки 1841 - 128МБ памяти, распаянной на плате и меньше не бывает. Бывает больше, если до установить SO-DIMM SDRAM 128-256MB. Соответственно нужно понять, куда пропала память. И если она не найдется, то тогда на искать вот такую Cisco MEM1841-256D планку и если после модернизации в системе будет хотя бы 192МБ, то уже тогда можно пробовать залить иос c1841-adventerprisek9-mz.124-22.T5.bin или вот такой c1841-adventerprisek9-mz.124-24.T3.bin и настраивать l2tp

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

незаработало... нашел другой версии прошивку c1841-ipbase-mz.124-12c.bin

загружается но начинает ругаться на это:

 

pseudowire-class class1
encapsulation l2tpv2
protocol l2tpv2 corbina
ip local interface FastEthernet0/1

 

также нельзя создать виртуальный пптр

железко умер?

Хоть с каким-то иосом она загрузилась? Покажите вывод show plat и show diag

У вас проблема не в том, что вы не можете создать virtual-ppp, это естественно так как прошивки ipbase это не поддерживают. Проблема в том, что вас маршрутизатор, которого не бывает в дикой природе: у линейки 1841 - 128МБ памяти, распаянной на плате и меньше не бывает. Бывает больше, если до установить SO-DIMM SDRAM 128-256MB. Соответственно нужно понять, куда пропала память. И если она не найдется, то тогда на искать вот такую Cisco MEM1841-256D планку и если после модернизации в системе будет хотя бы 192МБ, то уже тогда можно пробовать залить иос c1841-adventerprisek9-mz.124-22.T5.bin или вот такой c1841-adventerprisek9-mz.124-24.T3.bin и настраивать l2tp

как я вижу в ней стоит флешка на 128 неродная...

так же спросил у знакомых которые отдали мне эту циску, что наней стоит еще cisco sdm он помоему тоже на флешку ставиться..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

День добрый.

Кто может подсказать, что исправить в конфиге для циски 1801

 

ios c180x-advipservicesk9-mz.124-15.T3.bin

не работают локальные ресурсы Билайна.

 

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service internal

!

hostname maximum

!

boot-start-marker

boot-end-marker

!

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication ppp default local

aaa authorization config-commands

aaa authorization exec default local

!

!

aaa session-id common

clock timezone MSK/MSD 3

clock summer-time MSK/MDD recurring last Sun Mar 2:00 last Sun Oct 3:00

!

!

no ip gratuitous-arps

!

!

ip cef

!

!

ip name-server 85.175.46.130

ip name-server 85.175.46.122

ip multicast-routing

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

multilink bundle-name authenticated

vpdn enable

!

vpdn-group 1

request-dialin

protocol pptp

rotary-group 0

initiate-to ip 10.255.255.254

!

!

!

username diso privilege 5 secret 5

!

!

archive

log config

hidekeys

!

!

!

!

!

interface FastEthernet0

ip address dhcp

duplex auto

speed auto

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface FastEthernet1

switchport access vlan 2

duplex full

speed 100

!

interface FastEthernet2

switchport access vlan 2

!

interface FastEthernet3

switchport access vlan 2

!

interface FastEthernet4

switchport access vlan 2

!

interface FastEthernet5

switchport access vlan 3

!

interface FastEthernet6

switchport access vlan 3

!

interface FastEthernet7

switchport access vlan 3

!

interface FastEthernet8

switchport access vlan 3

!

interface ATM0

no ip address

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto

dsl bitswap both

!

interface ATM0.1 point-to-point

ip address zz.zzz.zz.zzz 255.255.255.252

ip nat outside

ip virtual-reassembly

atm route-bridged ip

pvc 0/35

encapsulation aal5snap

!

!

interface Vlan1

ip address 192.168.a.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan2

description UTK

ip address 192.168.yy.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip policy route-map UTK

!

interface Vlan3

description BEELINE

ip address 192.168.x.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Dialer0

mtu 1460

ip address negotiated

ip pim dense-mode

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1420

dialer in-band

dialer idle-timeout 0

dialer string 123

dialer vpdn

dialer-group 1

no cdp enable

ppp pfc local request

ppp pfc remote apply

ppp encrypt mppe auto

ppp chap hostname qqqqqqqqqqqqq@internet.beeline.ru

ppp chap password 0 qqqqqqqqqqqqq

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 10.0.0.0 255.0.0.0 dhcp

!

!

no ip http server

no ip http secure-server

ip nat inside source list 1 interface ATM0.1 overload

ip nat inside source list 2 interface Dialer0 overload

 

!

ip access-list extended BEELINE-ACL

deny ip any 10.0.0.0 0.255.255.255

permit ip 192.168.x.0 0.0.0.255 any

ip access-list extended NAT

permit ip host 192.168.a.a any

ip access-list extended UTK-ACL

deny ip any 10.0.0.0 0.255.255.255

permit ip 192.168.yy.0 0.0.0.255 any

!

access-list 1 permit 192.168.yy.0 0.0.0.255

access-list 2 permit 192.168.x.0 0.0.0.255

dialer-list 1 protocol ip permit

!

!

!

route-map UTK permit 10

match ip address UTK-ACL

set ip next-hop zz.zzz.zz.zzz

!

route-map BEELINE permit 2

match ip address BEELINE-ACL

!

!

!

!

control-plane

!

alias exec c conf t

alias exec s sh run

alias exec b sh ip int br

alias exec v sh ver

alias exec d sh int descr

!

line con 0

transport output all

stopbits 1

line aux 0

transport output all

stopbits 1

line vty 0 4

session-timeout 30

access-class 10 in

exec-timeout 30 0

transport input telnet ssh

transport output all

line vty 5 15

access-class 10 in

transport input telnet ssh

transport output all

!

end

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Цискари ау, подскажите плз )

добавь ip route на все локальный ресурсы

типа

ip route 85.21.0.0 255.255.0.0 dhcp

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

это очень широкая маска и в ней буду не только локальные ресурсы, но и куча инет-сайтов, хостящихся в этом диапазоне...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах