Gmarapet

Автоматический l2tp / xl2tpd

Рекомендованные сообщения

Сначала надо настроить локальную сеть и как минимум выйти на этот сайт без VPN.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

как лог найти и выложить его? как прогу через термминал запуститьь и все выложить сюда?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Не надо никакого терминала, там кнопка есть тестового запуска. Но сначала надо выйти сюда локально, только потом поднимать VPN.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Приветствую!

 

Требуется помощь. Не работает интернет. OC - Debian. Пол логам:

CHAP authentication succeeded
local  IP address XX.31.XX.139
remote IP address 85.21.XX.XX
Script /etc/ppp/ip-up started (pid 2617)
Script /etc/ppp/ip-up finished (pid 2617), status = 0x0

 

tp.internet.beeline.ru пингует

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Приветствую!

 

Требуется помощь. Не работает интернет. OC - Debian. Пол логам:

CHAP authentication succeeded
local  IP address XX.31.XX.139
remote IP address 85.21.XX.XX
Script /etc/ppp/ip-up started (pid 2617)
Script /etc/ppp/ip-up finished (pid 2617), status = 0x0

 

tp.internet.beeline.ru пингует

-Доктор, у меня "это"

-Что "это"

-Ну "это"

Вам доктор поможет?

 

Напишите больше инфы. Как всё началось? Всё по новому делаете или было, но пропало. Способ подключения. Десктоп или сервер. Выложите конфиги.

/etc/xl2tpd/xl2tpd.conf

/etc/ppp/options.beeline

 

route -n до поднятия xl2tp, и после.

 

Под спойлером для примера работающие конфиги на сервере

http://homenet.beeline.ru/index.php?showtopic=165811&view=findpost&p=1065206357

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Приветствую!

 

Требуется помощь. Не работает интернет. OC - Debian. Пол логам:

CHAP authentication succeeded
local  IP address XX.31.XX.139
remote IP address 85.21.XX.XX
Script /etc/ppp/ip-up started (pid 2617)
Script /etc/ppp/ip-up finished (pid 2617), status = 0x0

 

tp.internet.beeline.ru пингует

Если вы из Москвы или Подмосковья, то возможно ваши проблемы связаны с переходом на ipoe. Необходимо, чтобы debian получил новый айпишник на порту, начинающийся на 100.хх.хх.хх(раньше было 10.хх.хх.хх) и изменить маршруты до VPN и DNS серверов. Но это только предположение, необходимо проверять. А так конечно, jelt прав, вы не дали никакой информации исходя из которой можно было бы сделать выводы о причине проблем.

Изменено пользователем noox

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Напишите больше инфы. Как всё началось? Всё по новому делаете или было, но пропало. Способ подключения. Десктоп или сервер. Выложите конфиги.

/etc/xl2tpd/xl2tpd.conf

/etc/ppp/options.beeline

 

route -n до поднятия xl2tp, и после.

Здравствуйте,

route -n до включения сервиса xl2tpd (стоит версия 1.3.1)

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.158.56.1     0.0.0.0         UG    0      0        0 eth0
лок. подсеть    0.0.0.0         255.255.255.0   U     0      0        0 eth1
10.158.56.0     0.0.0.0         255.255.248.0   U     0      0        0 eth0

route -n после включения

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 ppp0
лок. подсеть    0.0.0.0         255.255.255.0   U     0      0        0 eth1
10.158.56.0     0.0.0.0         255.255.248.0   U     0      0        0 eth0
85.21.0.163     0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
85.21.192.3     10.158.56.1     255.255.255.255 UGH   0      0        0 eth0

eth0 - смотрит в интернет (iface eth0 iten dhcp)

eth1 - в локальную сеть

 

Делаю все по новому. Сервер Debian. Кроме xl2tpd на сервере больше ничего нет. Конфиги переписал на те, что Вы скинули. В /etc/xl2tpd/xl2tpd.conf использую tp.internet.beeline.ru только. А в /etc/ppp/ip-up "route add 85.21.192.3 gw 10.158.56.1".

 

Вот некоторые логи из /var/log/syslog:

CHAP authentication succeeded: CHAP authentication success, unit 4659
CHAP authentication succeeded
replacing old default route to eth0 [10.158.56.1]
local  IP address МОЙ ВНЕШНИЙ IP
remote IP address 85.21.0.163
primary   DNS address 85.21.192.5
secondary DNS address 213.234.192.7

Это последний кусок логов. Пинги не проходят.

 

И еще /etc/resolv.conf

nameserver 85.21.192.5
nameserver 213.234.192.7
domain beeline
search beeline

Изменено пользователем freeg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Делаю все по новому. Сервер Debian. Кроме xl2tpd на сервере больше ничего нет. Конфиги переписал на те, что Вы скинули. В /etc/xl2tpd/xl2tpd.conf использую tp.internet.beeline.ru только. А в /etc/ppp/ip-up "route add 85.21.192.3 gw 10.158.56.1".

Так делать не надо. Если в /etc/xl2tpd/xl2tpd.conf использовать tp.internet.beeline.ru, тогда в /etc/ppp/ip-up и /etc/ppp/ip-down следует добавлять переменные http://homenet.beeline.ru/index.php?showtopic=267122&view=findpost&p=1065050497

Это работало в Debian6

В Debian7 почему то перестало http://homenet.beeline.ru/index.php?showtopic=165811&view=findpost&p=1065177835

У Вас локальный интерфейс eth0 не знает как ему проходить через шлюз до VPN сервера, то есть ему надо рассказать.

 

До поднятия туннеля узнаём адрес шлюза

ipconfig

и vpn сервера

nslookup tp.internet.beeline.ru

host -t A tp.internet.beeline.ru

Их будет несколько, выбираем любой.

адрес vpn сервера добавляем в файл конфигурации /etc/xl2tpd/xl2tpd.conf, параметр lns

так же правим /etc/ppp/ip-up, добавляем в конец файла перед exit0

route del default
route add адрес VPN сервера  gw адрес шлюза
ip route del default dev eth0
route add default dev ppp0

 

и в /etc/ppp/ip-down

route del default
route del default dev ppp0

 

после поднятия vpn

 

> route -n

Kernel IP routing table

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 ppp0
10.0.0.0        10.63.224.1     255.0.0.0       UG    0      0        0 eth0
10.8.0.0        0.0.0.0         255.255.255.0   U     0      0        0 br0
10.63.224.0     0.0.0.0         255.255.248.0   U     0      0        0 eth0
78.107.196.0    10.63.224.1     255.255.252.0   UG    0      0        0 eth0
85.21.66.202    10.63.224.1     255.255.255.255 UGH   0      0        0 eth0
85.21.78.93     10.63.224.1     255.255.255.255 UGH   0      0        0 eth0
93.81.0.1       0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
233.32.240.0    10.63.230.*     255.255.255.0   UG    0      0        0 eth0

 

10.63.230.* локальный адрес

10.63.224.1 адрес шлюза

85.21.66.202 адрес VPN сервера

Изменено пользователем jelt

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

> route -n

Kernel IP routing table

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 ppp0
10.0.0.0        10.63.224.1     255.0.0.0       UG    0      0        0 eth0
10.8.0.0        0.0.0.0         255.255.255.0   U     0      0        0 br0
10.63.224.0     0.0.0.0         255.255.248.0   U     0      0        0 eth0
78.107.196.0    10.63.224.1     255.255.252.0   UG    0      0        0 eth0
85.21.66.202    10.63.224.1     255.255.255.255 UGH   0      0        0 eth0
85.21.78.93     10.63.224.1     255.255.255.255 UGH   0      0        0 eth0
93.81.0.1       0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
233.32.240.0    10.63.230.*     255.255.255.0   UG    0      0        0 eth0

 

Здравствуйте,

Подключил провод к винде, чтобы посмотреть ipconfig и nslookup. Взял первый VPN сервер и вписал его в lns и route add. В итоге tp.internet.beeline.ru снова пингует, а остальные сайты до сих пор нет. Зато nslookup на гугле и яндексе работает.

 

route -n почему-то стал такой

0.0.0.0         10.158.56.1     0.0.0.0         UG    0      0        0 eth0
10.158.56.0     0.0.0.0         255.255.248.0   U     0      0        0 eth0

то есть по всем ip-шникам ходит через мой основной шлюз.

 

А в логах

Connecting to host 85.21.192.3, port 1701
Maximum retries exceeded for tunnel 25980.  Closing.
Connection 0 closed to 85.21.192.3, port 1701 (Timeout)
Unable to deliver closing message for tunnel 25980. Destroying anyway.
Will redial in 10 seconds

Изменено пользователем freeg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Покажи лог xl2tp и pppd от начала подключения

Неправильно прописал IP VPN сервера, поэтому он и не коннектился к нему, сейчас данный пункт заработал, но интернета до сих пор нет. Опишу более подробно.

 

nslookup tp.internet.beeline.ru
Server:         85.21.192.3
Address:        85.21.192.3#53

Name:   tp.internet.beeline.ru
Address: 85.21.0.165

Сначала я вбил в VPN адрес 85.21.192.3 (к нему не коннектил), сейчас поставил 85.21.0.165 и вроде соединилось.

 

host -t A tp.internet.beeline.ru
tp.internet.beeline.ru has address 85.21.0.163

Это я так понимаю второй адрес.

 

А вот со шлюзом не очень понял. ipconfig-а в debian-е нет, поэтому открыл ifconfig.

 

ifconfig
eth0      inet addr:10.158.57.206  

Это локальный адрес сетевой карты, как я понял. Его нужно вписывать в шлюз? Когда делал ipconfig с windows, то показывало другой ip в графе основной шлюз. Ни с тем, ни с тем не работало.

 

Что касается логов:

 

pppd[2566]: CHAP authentication succeeded
pppd[2566]: replacing old default route to eth0 [10.158.56.1]
pppd[2566]: local  IP address МОЙ ВНЕШНИЙ
pppd[2566]: remote IP address 85.21.0.165
pppd[2566]: primary   DNS address 85.21.192.5
pppd[2566]: secondary DNS address 213.234.192.7
/USR/SBIN/CRON[2597]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)

xl2tpd, как я понял, он прошел успешно и pppd тоже все присвоило, но интернета до сих пор нет.

 

route -n после изменении VPN сервера на правильный

 

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 ppp0
10.158.56.0     0.0.0.0         255.255.248.0   U     0      0        0 eth0
85.21.0.165     0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
85.21.192.3     10.158.56.1     255.255.255.255 UGH   0      0        0 eth0

10.158.56.1 - шлюз, который я получил на windows

85.21.0.165 - мой VPN сервер

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Это локальный адрес сетевой карты, как я понял. Его нужно вписывать в шлюз? Когда делал ipconfig с windows, то показывало другой ip в графе основной шлюз. Ни с тем, ни с тем не работало.

Локальный адрес (eth0) никуда вбивать не надо. При подключении разных компов этот адрес будет меняться.

Проверь /etc/network/interfaces

 

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo eth0
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Локальный адрес (eth0) никуда вбивать не надо. При подключении разных компов этот адрес будет меняться.

Небольшое уточнение. Адрес локальной сети действительно никуда вбивать не нужно. Адрес статически вбивать нельзя только потому, что в локальной сети Билайн работает DHCP сервер и существует время аренды адреса. Если предположить, что кто-то вбил адрес статически, то в какой-то момент времени аренда адреса истечет, а от клиента не будет подтверждения аренды и этот адрес DHCP сервер выдаст кому-то другому. Получится конфликт ip-адресов, того адреса, что выдан автоматически и того адреса, что статически прописан у абонента. Вот в чем проблема.

 

В принципе правильнее использовать вместо отдельного айпишника VPN сервера запись вида tp.internet.beeline.ru. Но для этого необходимо прописать маршруты через локальный шлюз не для отдельного адреса, а для целых сетей VPN серверов, а также до DNS серверов в локальной сети. Например, для вас jelt, для Иваново, это будут следующие сети VPN серверов 85.21.66.0/24 и 213.234.199.0/24. А также два DNS сервера 213.234.192.8 и 85.21.192.3.

P.S. Кстати, сейчас freeg настроит свой debian, а через некоторое время его ждет новое переконфигурирование, т.к. его район, Солнцево, будут также готовить к переходу на ipoe.

Изменено пользователем noox

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В принципе правильнее использовать вместо отдельного айпишника VPN сервера запись вида tp.internet.beeline.ru. Но для этого необходимо прописать маршруты через локальный шлюз не для отдельного адреса, а для целых сетей VPN серверов, а также до DNS серверов в локальной сети.

Подскажите, пожалуйста, как это сделать - может статью похожую или сообщение в данной теме.

 

Все остальное работает, но перед загрузкой самой страницы замечаю задержки. С чем это может быть связано?

Изменено пользователем freeg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Я так понимаю без команды нат работать не будет?

iptables -t mangle -A FORWARD -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu

Изменено пользователем VovaSolncelikiy

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

доброго времени суток. что здесь может быть? manjaro, конфиги все как указано (за исключением lns = tp.internet.beeline.ru), chap-secrets тоже. версия пакета xl2tpd 1.3.6

 

 

xl2tpd[1865]: setsockopt recvref[30]: Protocol not available

xl2tpd[1865]: Using l2tp kernel support.

xl2tpd[1865]: xl2tpd version xl2tpd-1.3.6 started on lab PID:1865

xl2tpd[1865]: Written by Mark Spencer, Copyright © 1998, Adtran, Inc.

xl2tpd[1865]: Forked by Scott Balmos and David Stipp, © 2001

xl2tpd[1865]: Inherited by Jeff McAdams, © 2002

xl2tpd[1865]: Forked again by Xelerance (www.xelerance.com) © 2006

xl2tpd[1865]: Listening on IP address 0.0.0.0, port 1701

xl2tpd[1865]: Connecting to host tp.internet.beeline.ru, port 1701

xl2tpd[1865]: Connection established to 172.18.48.174, 1701. Local: 3363, Remote: 4493 (ref=0/0).

xl2tpd[1865]: Calling on tunnel 3363

xl2tpd[1865]: Call established with 172.18.48.174, Local: 53656, Remote: 26350, Serial: 1 (ref=0/0)

xl2tpd[1865]: start_pppd: I'm running:

xl2tpd[1865]: "/usr/sbin/pppd"

xl2tpd[1865]: "passive"

xl2tpd[1865]: "nodetach"

xl2tpd[1865]: ":"

xl2tpd[1865]: "name"

xl2tpd[1865]: <юзернейм>

xl2tpd[1865]: "debug"

xl2tpd[1865]: "file"

xl2tpd[1865]: "/etc/ppp/options.xl2tpd"

xl2tpd[1865]: "plugin"

xl2tpd[1865]: "pppol2tp.so"

xl2tpd[1865]: "pppol2tp"

xl2tpd[1865]: "7"

/usr/sbin/pppd: The remote system (l2tp) is required to authenticate itself

/usr/sbin/pppd: but I couldn't find any suitable secret (password) for it to use to do so.

xl2tpd[1865]: child_handler : pppd exited for call 26350 with code 1

 

Изменено пользователем roaming_round

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

chap-secrets делать

Они уже были сделаны, отсюда и вопрос =) Всё равно спасибо, я уже разобрался.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте.

Я настраивал подключение по l2tp без IP-sec, по инструкции приведенной в первом сообщении.

Во-первых благодарю за указанный легкий путь, ведь соединение настроено)

Но инструкция отчести неполная, и где-то нерабочая. Что излишне усложнило настройку.

Ээээх, короче пункт №1(совет):

- Желательно модифицировать первое сообщение добавив в него команды запуска и рестарта сети, на всякий случай:

#sudo service xl2tpd start

Это команда запуска демона xl2tpd

 

#sudo killall pppd

#sudo service xl2tpd restart

Это перезапуск демона, на случай некорректной настройки

Пункт №2:

- Вообще то эта тема поднималась на 2-ой странице, опять же на всякий случай, в файл /etc/ppp/options.xl2tpd

добавить пункт:

noauth

Потомучто, на Linux Mint 18 KDE без него не стартует.

Пункт №3:

- Эм, не знаю почему но в указанных настройках пропущен пункт об установке шлюза по умолчанию, поэтому даже

если настраивающему и повезет, у него будет корректно работающий pppd, и все указано правильно, к интернету он не

приконнектится. Точне соединение будет установлено, xl2tpd и pptpd сообщают об успешном соединении,но внешние сайты

пинговаться не будут.

Короче есть несколько путей решения проблемы(зависят от версии pptpd)

 

3.1 Поменять шлюз по умолчанию в ручную из командной строки:

#sudo route add default dev ppp0

Достоинство метода - работает всегда, не зависимо от версии pptpd, годится, чтобы поднять интернет кое-как,

и обновиться до актуальных версий пакетов. А там уже либо использовать принципиально другой метод, либо допиливать

до ума уже этот...

 

3.2 Добавить в файл /etc/ppp/options.xl2tpd строку:

replacedefaultroute

Собственно так сейчас у меня и работат, но у меня уже последние обновления пакетов, так что на более ранних версих

может и не стартануть. Не знаю не проверял, я вообще эту натсройку только вчера поставил.

 

3.3 Это, собственно, автоматизация пункта 3.1. Суть: оформить команду в виде автоматического скрипта после заврешения

подъема соединения.

Здесь все зависит от вашей версии пакета pptpd. Хаа. Напишу как определял я.

Если файл ip-up выглядит обычныи скриптом, следовательно pptpd, старый (так, например, в Linux Mint 18) и можно

в конец ip-up дописать команду из 3.1 (естественно без sudo);

Если файл ip-up выглядит уже как код программы (видно рабиение на функции и exit 0 в конце), то pptpd новый и

(в принципе можно почитать, там в файле очевидно, что он пытается запустить соодержимое папок ip-up.d и ip-down.d)

(такой у меня сейчас на openSUSE 42.1 Leap)

следовательно надо создать собственный файл скрипта с произвольным именем, исполняемый, и с обязательной шапкой.

Пример моего старого файла(вчера удалил, т.к. пользуюсь пунктом 3.2)

---------------------------------------------------------------------------------------------------------------------------

Файл: /etc/ppp/ip-up.d/beeline.sh

#!/bin/bash

#

PATH=/bin:/sbin:/usr/bin:/usr/sbin

 

route add default dev ppp0

---------------------------------------------------------------------------------------------------------------------------

 

 

Вообще-то я подключался к интернету всеми тремя способами. Рассматривал и другие, но т.к. испугался компилить непонятные

мне пакеты на новой системе, не получилось.

Немного отвлекусь: я настраивал L2tp, без Ip-sec, на нескольких дистрибутивах(ну смотрел, какой подойдет мне) по-этому,

на всякий случай дам небольшой совет. Итак, если Вы выбрали openSUSE 42.1, Linux Mint 18 или Debian, то самый простой и

надежный способ настройки показан здесь, через файлы. Для смеха: а вот Rosa Fresh R8, настроился сразу из коробки через

стандарный network-manger.

 

В заключении приведу файлы настроек, которые у меня сейчас, вдруг, кому поможет. И да я из Красноярска, поэтому

никакого IP-sec.

Итак для начала качаем из онлайн репозитория выбранного дистрибутива свежий xl2tpd (для opnSUSE 41.1 еще и во время

установки отметим ставить pptpd - по дефолту он не устанавливается, но можно потом в качестве репа добавить установочный

диск и установить от туда). Далее изменяем(создаем) файлы, заменяя ВАШ_ПАРОЛЬ и ВАШ_ЛОГИН соответсвенно:

---------------------------------------------------------------------------------------------------------------------------

Файл /etc/xl2tpd/xl2tpd.conf

[global]

access control = yes

 

[lac beeline]

lns = tp.internet.beeline.ru

autodial = yes

redial = yes

redial timeout = 3

max redials = 10000

require authentication = no

require pap = no

require chap = yes

name = ВАШ_ЛОГИН

ppp debug = yes

pppoptfile = /etc/ppp/options.xl2tpd

---------------------------------------------------------------------------------------------------------------------------

Файл /etc/ppp/options.xl2tpd

name ВАШ_ЛОГИН

remotename l2tp

ipparam beeline

connect /bin/true

noauth

nodeflate

nobsdcomp

nopcomp

noaccomp

persist

defaultroute

replacedefaultroute

mtu 1460

---------------------------------------------------------------------------------------------------------------------------

Файл /etc/ppp/chap-secrets

ВАШ_ПАРОЛЬ * ВАШ_ЛОГИН

---------------------------------------------------------------------------------------------------------------------------

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Уже второй раз интернет поднимается, но в браузере редирект на веб-авторизацию билайн

 

Первый раз прошло само примерно за пару дней

Сейчас обратил внимание, что по dhcp на ethernet не приходят маршруты. Точнее, адреса l2tp серверов доступны через default gateway

 

В результате, xl2tp после подключения не заменяет дефолтный маршрут. Если явно приказать ( replacedefaultroute в /etc/ppp/options.xl2tpd.beeline ), теряет доступ к l2tp серверу. Похоже, у билайна какие-то косяки с настройками время от времени всплывают.

 

Есть ли готовый workaround? Пока думаю добавить скрипт в post-up к ethernet интерфейсу, но можно ли его воткнуть куда-нибудь в xl2tp ?

 

update. Или я что-то настроил неправильно и маршруты таки должны прилетать?


 

update. Или я что-то настроил неправильно и маршруты таки должны прилетать?

 

Нашёл. Маршруты теперь приходят. Но к сожалению не те что нужно. До l2tp серверов все равно через default gateway

 

https://www.opennet.ru/tips/2539_l2tp_vpn_debian_linux_beeline_pptp.shtml

> В связи с увлеченностью Beeline технологиями от MS придется подправить dhclient.conf, заменяем >    option rfc3442-classless-static-routes code 121 = array of unsigned integer 8;> на>    option rfc3442-classless-static-routes code 249 = array of unsigned integer 8;
Изменено пользователем madrouter

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В общем, фиг его знает, что там сетевики пчелайна колхозят. Решил проблему добавлением маршрутов к dns и l2tp серверам

 

/usr/local/sbin/l2tp_routes.sh:


#!/bin/bash
export PATH=/bin:/usr/bin:/sbin:/usr/sbin
IFACE=eth1

eth_gw=$(ip r l | awk '/^default.*eth[0-9]*/{ print $3;}')
l2tp_servers=$(dig -t A tp.internet.beeline.ru +short)
dns_servers=$(cat /etc/resolv.conf | awk '/^nameserver/{ print $2; }')

for server in $l2tp_servers; do
    net=$(echo $server | sed -e 's/\.[0-9]*$/\.0\/24/' )
    ip r a $net via $eth_gw dev $IFACE 2>/dev/null
done
for server in $dns_servers; do
    ip r a $server via $eth_gw dev $IFACE
done

/etc/network/interfaces:

iface eth1 inet dhcp
        post-up /usr/local/sbin/l2tp_routes.sh

В /etc/ppp/options.xl2tpd.pcheline добавил

defaultroute
replacedefaultroute

Пока работает. Посмотрим, что будет дальше

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
On 18.10.2016 at 13:49, Const=512 писал:

Файл /etc/ppp/options.xl2tpd
 

connect /bin/true

---------------------------------------------------------------------------------------------------------------------------

Файл /etc/ppp/chap-secrets

ВАШ_ПАРОЛЬ * ВАШ_ЛОГИН

---------------------------------------------------------------------------------------------------------------------------

на Debian 8 работает кроме: "connect /bin/true"- вообще не понимает, логин-пасс должен быть в формате

логин_интернета * пароль_интернета *

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Приветствую.

Просьба помочь с настройкой для Fedora 29. Нет подключения к Интернету.

Конфигурация как здесь: https://homenet.beeline.ru/index.php?/topic/320882-установка-l2tp-в-rhel7-centos7-fedora20/

В  логах примерно такое повторяется в цикле (local IP каждый раз новый):

Dec 13 22:07:28 localhost pppd[3898]: CHAP authentication succeeded
Dec 13 22:07:28 localhost pppd[3898]: CHAP authentication succeeded
Dec 13 22:07:30 localhost pppd[3898]: local  IP address 2.93.139.162
Dec 13 22:07:30 localhost NetworkManager[886]: <info>  [1544717250.8252] device (ppp0): state change: unmanaged -> unavailable (reason 'connection-assumed', sys-iface-state: 'external')
Dec 13 22:07:30 localhost pppd[3898]: remote IP address 85.21.59.57
Dec 13 22:07:30 localhost NetworkManager[886]: <info>  [1544717250.8299] device (ppp0): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'external')
Dec 13 22:07:38 localhost kernel: ppp0: recursion detected
Dec 13 22:07:48 localhost kernel: ppp0: recursion detected
Dec 13 22:07:58 localhost kernel: ppp0: recursion detected
Dec 13 22:08:08 localhost kernel: ppp0: recursion detected
Dec 13 22:08:18 localhost kernel: ppp0: recursion detected
Dec 13 22:08:28 localhost pppd[3898]: LCP terminated by peer
Dec 13 22:08:28 localhost pppd[3898]: Connect time 1.0 minutes.

Маршруты в моменты, когда пингуется tp.internet.beeline.ru, но нет ppp:

ip route show
default via 10.174.88.1 dev eno1 proto dhcp metric 20100
10.0.0.0/8 via 10.174.88.1 dev eno1 proto dhcp metric 100
10.174.88.0/21 dev eno1 proto kernel scope link src 10.174.89.127 metric 100
78.107.196.0/22 via 10.174.88.1 dev eno1 proto dhcp metric 100
233.32.240.0/24 via 10.174.89.127 dev eno1 proto dhcp metric 100

Маршруты, когда НЕ пингуется tp.internet.beeline.ru, но есть ppp:

default via 128.73.44.219 dev ppp0
default via 10.174.88.1 dev eno1 proto dhcp metric 20100
10.0.0.0/8 via 10.174.88.1 dev eno1 proto dhcp metric 100
10.174.88.0/21 dev eno1 proto kernel scope link src 10.174.89.127 metric 100
78.107.196.0/22 via 10.174.88.1 dev eno1 proto dhcp metric 100
85.21.59.57 dev ppp0 proto kernel scope link src 128.73.44.219
233.32.240.0/24 via 10.174.89.127 dev eno1 proto dhcp metric 100

 

(эти 2 состояния чередуются циклически примерно каждую минуту)

8.8.8.8 не пингуется никогда.

Пробовал на Fedora 28, затем после апдейта на Fedora 29, отдельно пробовал на чистой Fedora 29 с LiveCD (прописав конфиги), результат всегда одинаковый.

Изменено пользователем vr-s

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте,

пытаюсь настроить l2tp с Дебиан, но не хватает какой-то детали. Подключение устанавливается нормально, вот лог:

Jan  7 01:18:51  pppd[1822]: CHAP authentication succeeded: CHAP authentication success, unit 1885
Jan  7 01:18:51 pppd[1822]: CHAP authentication succeeded
Jan  7 01:18:51 pppd[1822]: local  IP address 10.12.74.240
Jan  7 01:18:51 pppd[1822]: remote IP address 10.12.64.1
Jan  7 01:18:51 pppd[1822]: primary   DNS address 85.21.192.5
Jan  7 01:18:51 pppd[1822]: secondary DNS address 213.234.192.7

Также tp.internet.beeline.ru нормально пингуется, но в интернет не проходит. Думаю что какой-то маршрут или лишний или отсутствующий:

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         10.43.40.1      0.0.0.0         UG    0      0        0 eth0
default         0.0.0.0         0.0.0.0         U     0      0        0 eth0
vpn241-l0.msk.c 10.43.40.1      255.255.255.255 UGH   0      0        0 eth0
85.21.52.254    10.43.40.1      255.255.255.254 UG    202    0        0 eth0
lk.corbina.net  10.43.40.1      255.255.255.255 UGH   202    0        0 eth0
85.21.88.130    10.43.40.1      255.255.255.254 UG    202    0        0 eth0
hdns2.corbina.n 10.43.40.1      255.255.255.255 UGH   0      0        0 eth0
ns4.corbina.net 10.43.40.1      255.255.255.255 UGH   0      0        0 eth0
95-24-48-1.broa 0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
195.14.50.16    10.43.40.1      255.255.255.240 UG    202    0        0 eth0
sip.corbina.net 10.43.40.1      255.255.255.255 UGH   202    0        0 eth0
ns3.corbina.net 10.43.40.1      255.255.255.255 UGH   0      0        0 eth0
hdns1.corbina.n 10.43.40.1      255.255.255.255 UGH   0      0        0 eth0

Подскажите пожалуйста что подправить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
13.12.2018 в 20:15, vr-s сказал:

Dec 13 22:08:08 localhost kernel: ppp0: recursion detected

8.8.8.8 не пингуется никогда.

Пробовал на Fedora 28, затем после апдейта на Fedora 29, отдельно пробовал на чистой Fedora 29 с LiveCD (прописав конфиги), результат всегда одинаковый.

http://skleroz.blogspot.com/2016/09/xl2tpd.html
Можно попробовать понизить MTU ppp-соединения до уровня локалки (у меня например 576)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас