Архивировано

Эта тема находится в архиве и закрыта для публикации сообщений.

A_Petrenko

Cisco871WK9 + Corbina L2TP

Рекомендованные сообщения

Гы, а какже назначенные по dhcp сервера

Тут ты прав, без них никак.

ip dns server

Команда включает в ios режим работы dns-server (работает вместе с ip domein lookup и ip name servers), т.е. если клиенту в качестве адреса dns выдать адрес такого маршрутизатора, то резолвить имена будет роутер и одной дырой в локалку будет меньше (не надо будет во внешнем аксесс-листе разрешать прохождение dns-запросов к/от локальной подсети)

у меня почемуто получилось только 1 dns сервер назначить, второй ну никак не воспринимался.

Где назначить?

В настройках dhcp-сервера?

router(dhcp-config)#dns-server 195.14.50.1 195.14.50.21 213.234.192.7

Или вручную назначать самому роутеру?

ip name-server 195.14.50.1
ip name-server 195.14.50.21
ip name-server 213.234.192.7

Или я опять не про то понял? :blink:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Тут ты прав, без них никак.

ip dns server

Команда включает в ios режим работы dns-server (работает вместе с ip domein lookup и ip name servers), т.е. если клиенту в качестве адреса dns выдать адрес такого маршрутизатора, то резолвить имена будет роутер и одной дырой в локалку будет меньше (не надо будет во внешнем аксесс-листе разрешать прохождение dns-запросов к/от локальной подсети)

Где назначить?

В настройках dhcp-сервера?

router(dhcp-config)#dns-server 195.14.50.1 195.14.50.21 213.234.192.7

Или вручную назначать самому роутеру?

ip name-server 195.14.50.1
ip name-server 195.14.50.21
ip name-server 213.234.192.7

Или я опять не про то понял? ;)

 

:) Все, теперь окончательно во всем разобрался, я не включил днс сервер командой

ip dns server

поэтому и не заработало. А вот командой

ip name-server 195.14.50.1

Действительно назначался только один сервер, вводил второй, но rh run его не показывал. Правда все это пробовалось на дефолтном ИОСе, а потом после перепрошивки я уже к этому не возвращался.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

господа помогите.....туннель подымается но только на минуту , при этом ip адрес получает ... вариации с мту ничего не дал ..попытаюсь иос обновить

сейчас

home#sho ver
Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.4(15)T5, RELEASE SOFTWARE (fc4)

 

вот конфиг мож чё забыл

 

home#sho run
Building configuration...

Current configuration : 3850 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime localtime
service password-encryption
!
hostname home
!
boot-start-marker
boot-end-marker
!
logging buffered 20000
enable secret 5 $1$HBu1$ipn.to8Xzeuo42p.S/GI5/
!
no aaa new-model
!
!
dot11 syslog
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.9.0 172.16.9.30
!
ip dhcp pool HOME
  import all
  network 172.16.9.0 255.255.255.0
  default-router 172.16.9.1
  dns-server 213.234.192.8 85.21.192.3
!
!
ip cef
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip domain name corbina.net
ip multicast-routing
l2tp-class corbina
!
!
!
!
username cisco password хххххх
!
archive
log config
 hidekeys
!
!
ip tftp source-interface Vlan1
pseudowire-class class1
encapsulation l2tpv2
protocol l2tpv2 corbina
ip local interface FastEthernet4
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
mac-address ххххххххх
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 
station-role root
!
interface Virtual-PPP1
ip address negotiated
ip access-group 111 in
ip mtu 1272
ip nat outside
ip virtual-reassembly
no cdp enable
ppp authentication chap callin
ppp chap hostname юзер
ppp chap password пасворд
pseudowire 85.21.0.255 1 pw-class class1
!
interface Vlan1
ip address 172.16.9.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Virtual-PPP1
ip route 10.0.0.0 255.0.0.0 dhcp
ip route 83.102.146.96 255.255.255.224 dhcp
ip route 85.21.29.242 255.255.255.255 dhcp
ip route 85.21.79.0 255.255.255.0 dhcp
ip route 85.21.90.0 255.255.255.0 dhcp
ip route 195.14.50.16 255.255.255.255 dhcp
ip route 195.14.50.26 255.255.255.255 dhcp
ip route 85.21.0.176 255.255.255.255 dhcp
!
no ip http server
no ip http secure-server
ip nat inside source list LAN interface FastEthernet4 overload
ip nat inside source list WAN interface Virtual-PPP1 overload
!
ip access-list extended LAN
permit ip 172.16.9.0 0.0.0.255 10.0.0.0 0.255.255.255
permit ip 172.16.9.0 0.0.0.255 83.102.146.0 0.0.0.231
permit ip 172.16.9.0 0.0.0.255 host 85.21.29.242
permit ip 172.16.9.0 0.0.0.255 85.21.79.0 0.0.0.255
permit ip 172.16.9.0 0.0.0.255 85.21.90.0 0.0.0.255
permit ip 172.16.9.0 0.0.0.255 host 195.14.50.16
permit ip 172.16.9.0 0.0.0.255 host 195.14.50.26
ip access-list extended WAN
permit ip 172.16.9.0 0.0.0.255 any
!
access-list 111 deny   tcp any eq 139 any
access-list 111 deny   udp any eq netbios-ns any eq netbios-ns
access-list 111 deny   udp any eq netbios-dgm any eq netbios-dgm
access-list 111 deny   udp any eq netbios-ss any eq netbios-ss
access-list 111 deny   udp any any range snmp snmptrap
access-list 111 deny   tcp any any eq 3128
access-list 111 deny   ip 172.16.0.0 0.15.255.255 any
access-list 111 deny   ip 127.0.0.0 0.0.0.255 any
access-list 111 deny   udp any any range 130 140
access-list 111 deny   tcp any any range 130 140
access-list 111 deny   tcp any any eq 8080
access-list 111 permit ip any any
access-list 111 permit udp any any
access-list 111 permit gre any any
access-list 111 permit tcp any any
access-list 111 permit icmp any any
access-list 111 permit pcp any any
access-list 111 permit esp any any
access-list 111 permit igmp any any
access-list 111 permit ipinip any any
access-list 111 permit nos any any
no cdp run
!
control-plane
!
!
line con 0
exec-timeout 0 0
no modem enable
line aux 0
line vty 0 4
privilege level 15
login
transport input telnet ssh
transport output all
!
scheduler max-task-time 5000
sntp server 195.170.62.130
end

home#

 

 

заранее благодарю

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

заменил иос на более позднюю и вроде всё нормально....ща

Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.4(9)T3, RELEASE SOFTWARE (fc3)

 

вот только одна проблема.....некоторые сайты не открываются, хотя пинги до них идут ...

вот конф

home#sho run
Building configuration...

Current configuration : 2216 bytes
!
! Last configuration change at 14:04:35 UTC Sat Nov 8 2008
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime localtime
service password-encryption
!
hostname home
!
boot-start-marker
boot-end-marker
!
logging buffered 20000 debugging
enable secret 5 $1$HBu1$ipn.to8Xzeuo42p.S/GI5/
!
no aaa new-model
!
resource policy
!
no ip dhcp use vrf connected
ip dhcp excluded-address 172.16.9.0 172.16.9.30
!
ip dhcp pool HOME
  import all
  network 172.16.9.0 255.255.255.0
  default-router 172.16.9.1
  dns-server 213.234.192.8 85.21.192.3
!
!
ip cef
ip tftp source-interface Vlan1
ip domain name corbina.net
ip multicast-routing
l2tp-class corbina
receive-window 128
!
!
!
!
username cisco password 7 060506324F41
archive
log config
 hidekeys
!
pseudowire-class class1
encapsulation l2tpv2
protocol l2tpv2 corbina
ip local interface FastEthernet4
!
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
mac-address 001d.70ce.98b6
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Virtual-PPP1
ip address negotiated
ip mtu 1400
ip nat outside
ip virtual-reassembly
no cdp enable
ppp authentication chap callin
ppp chap hostname хххх
ppp chap password ххххххххх
pseudowire 85.21.0.255 1 pw-class class1
!
interface Vlan1
ip address 172.16.9.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 Virtual-PPP1
ip route 85.21.0.255 255.255.255.255 dhcp
!
no ip http server
no ip http secure-server
ip nat inside source list WAN interface Virtual-PPP1 overload
!
ip access-list extended WAN
permit ip 172.16.9.0 0.0.0.255 any
permit tcp 172.16.9.0 0.0.0.255 any
permit udp any any
!
no cdp run
!
control-plane
!
!
line con 0
exec-timeout 0 0
no modem enable
line aux 0
line vty 0 4
privilege level 15
login
transport input telnet ssh
transport output all
!
scheduler max-task-time 5000
sntp server 195.170.62.130
end

home#

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
заменил иос на более позднюю и вроде всё нормально....ща

Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.4(9)T3, RELEASE SOFTWARE (fc3)

 

вот только одна проблема.....некоторые сайты не открываются, хотя пинги до них идут ...

вот конф

...

 

Попробуйте пинги до этих сайтов с размером пакетов равным Вашему MTU - 1400.

Если пакеты не пойдут - уменьшите значение MTU.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

хм... ну так пинги то идут....не понимю зачам изменять размер мту......попробую хотя не понимаю чем это может помочь!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Пинги ничем и не помогут! :blum:

Попробуйте выставить MTU и MSS как в моём посте. Если любите кошерное советую убрать "chap callin и хзнахнужен-class'ы", опять же как в моём посте... :umnik:

Cisco. Разрыв соединения с l2tp сервером через 50 сек.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Пинги ничем и не помогут! :cray:

Попробуйте выставить MTU и MSS как в моём посте. Если любите кошерное советую убрать "chap callin и хзнахнужен-class'ы", опять же как в моём посте... :rolleyes:

Cisco. Разрыв соединения с l2tp сервером через 50 сек.

 

 

Ежели пинги, с размером пакета = mtu, не проходят до проблемных сайтов - время "крутить" mtu...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Ежели пинги, с размером пакета = mtu, не проходят до проблемных сайтов - время "крутить" mtu...
дело в том, что у корбины везде MTU 1460 (насколько я знаю из этого форума, ресурса help.corbina.ru и своего опыта).

К стати не "размером пакета = mtu", а (размером пакета + 28) = mtu, RTFM любезнейший.

У вопрошающего MTU 1400, если внимательно читать, симптом:

...некоторые сайты не открываются, хотя пинги до них идут
Если он сам не знает, что делать - то "пинги", именно ему, не помогут. Конструктив заключается в том, что бы попробовать вот так и вот эдак, что я и предложил. :rolleyes:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
дело в том, что у корбины везде MTU 1460 (насколько я знаю из этого форума, ресурса help.corbina.ru и своего опыта).

К стати не "размером пакета = mtu", а (размером пакета + 28) = mtu, RTFM любезнейший.

У вопрошающего MTU 1400, если внимательно читать, симптом:Если он сам не знает, что делать - то "пинги", именно ему, не помогут. Конструктив заключается в том, что бы попробовать вот так и вот эдак, что я и предложил. :closedeyes:

 

По размеру пакета + 28 - не понял откуда взялась эта цифра. Что вы понимаете под размером пакета?

На мой взгляд, пакет = данные + заголовок.

Заголовок для L2TP - 4 байта, 20 байт на заголовок IP + данные.

Откуда берется цифра 28?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

не будем размусоливать. The IP header takes 20 bytes. the ICMP header takes 8 bytes. L2TP тут ВАЩЕ не при делах.

Это Linux:

Usage: ping ... [-s packetsize] ...

 

ping -c 2 -s 1432 ya.ru

PING ya.ru (213.180.204.8) 1432(1460) bytes of data.

1440 bytes from ya.ru (213.180.204.8): icmp_seq=1 ttl=56 time=11.1 ms

...

http://en.wikipedia.org/wiki/Internet_Cont...ol#Padding_data

 

Относительно вашей теории:

In the case of L2TP over UDP, the overhead of all the protocols includes an additional set of IP, UDP and L2TP headers. The IP header is 20 bytes, the UDP header is 8 bytes, and the L2TP header is generally 12 bytes. The 12 bytes of the L2TP header include:

* the version and flag fields (2 bytes)

* the tunnel id and session id fields (2 bytes each)

* 2 bytes of padding offset

* 4 bytes of Point-to-Point Protocol (PPP) encapsulation

И так далее, далеко не так просто как Вы пишите. http://www.cisco.com/en/US/tech/tk801/tk70...080094c4f.shtml

IP - 20

UDP - 8

L2TP - 12

Собственно -40 байт и набегает, именно поэтому 1460 а не 1500.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
не будем размусоливать. The IP header takes 20 bytes. the ICMP header takes 8 bytes. L2TP тут ВАЩЕ не при делах.

Это Linux:

Usage: ping ... [-s packetsize] ...

 

ping -c 2 -s 1432 ya.ru

PING ya.ru (213.180.204.8) 1432(1460) bytes of data.

1440 bytes from ya.ru (213.180.204.8): icmp_seq=1 ttl=56 time=11.1 ms

...

http://en.wikipedia.org/wiki/Internet_Cont...ol#Padding_data

 

Относительно вашей теории:

In the case of L2TP over UDP, the overhead of all the protocols includes an additional set of IP, UDP and L2TP headers. The IP header is 20 bytes, the UDP header is 8 bytes, and the L2TP header is generally 12 bytes. The 12 bytes of the L2TP header include:

* the version and flag fields (2 bytes)

* the tunnel id and session id fields (2 bytes each)

* 2 bytes of padding offset

* 4 bytes of Point-to-Point Protocol (PPP) encapsulation

И так далее, далеко не так просто как Вы пишите. http://www.cisco.com/en/US/tech/tk801/tk70...080094c4f.shtml

IP - 20

UDP - 8

L2TP - 12

Собственно -40 байт и набегает, именно поэтому 1460 а не 1500.

 

Ок. Возможно мы рассуждали о разных вещах. По RFC 2661 - заголовок L2TP 4 байта.

По ICMP - понял, спасибо за объяснение.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну и развели вы тут калькулятор :))

 

Чтобы все сайты нормально работали в контексте диалап-интерфейса надо задать

ip tcp adjust-mss 1420

(в случае если mtu на интерфейсе задано 1460)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

У меня в последнее время скорость выросла

pWnWgzi2v0.jpg

eMule стабильно качает 1Мбайт/сек при тарифе 8000. Сам факт отрадный, но где-то есть подвох... Тарифы не менялись на сколько я знаю.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот мой конфиг с настоенным мультикастом

может кому пригодится для IPTV

 

R1#sh ru

Building configuration...

 

Current configuration : 5879 bytes

!

version 12.4

no service timestamps debug uptime

no service timestamps log uptime

no service password-encryption

!

hostname R1

!

boot-start-marker

boot system flash:/c181x-advipservicesk9-mz.124-20.T1.bin

boot-end-marker

!

logging message-counter syslog

logging buffered 4096

!

aaa new-model

!

!

aaa authentication ppp default local

aaa authorization network default none

!

!

aaa session-id common

!

!

dot11 syslog

no ip source-route

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.5

!

!

ip dhcp pool vlan1

import all

network 192.168.1.0 255.255.255.248

default-router 192.168.1.5

dns-server 192.168.1.5 195.14.50.1 213.234.192.7 85.21.192.3 213.234.192.8

!

!

ip cef

ip multicast-routing

ip multicast cache-headers

ip inspect name FWall icmp timeout 60

ip inspect name FWall tcp timeout 900

ip inspect name FWall udp

ip inspect name FWall ftp

vlan ifdescr detail

l2tp-class corbina

!

!

no ipv6 cef

multilink bundle-name authenticated

!

vpdn enable

!

vpdn-group 1

ip pmtu

ip mtu adjust

!

!

!

!

no spanning-tree vlan 1

no spanning-tree vlan 3

!

!

!

archive

log config

hidekeys

!

!

pseudowire-class class1

encapsulation l2tpv2

protocol l2tpv2 corbina

ip local interface FastEthernet0

ip pmtu max 1260

!

bridge irb

!

!

!

!

interface FastEthernet0

description Corbina LAN

ip address dhcp

ip access-group in_corbina in

ip pim neighbor-filter 10

ip pim sparse-dense-mode

ip nat outside

ip virtual-reassembly

duplex auto

speed 10

no cdp enable

!

interface FastEthernet1

no ip address

shutdown

duplex auto

speed auto

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface FastEthernet2

switchport access vlan 3

duplex half

speed 10

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface FastEthernet9

!

interface Virtual-PPP1

ip address negotiated

ip access-group in_public in

ip mtu 1260

ip nat outside

ip virtual-reassembly

ip tcp adjust-mss 1220

pulse-time 60

no cdp enable

ppp authentication chap callin

ppp chap hostname xxxxxxxxxxxxxxxxxxxxxxxx

ppp chap password 0 yyyyyyyyyyyyyyyyyyyyyyyy

ppp ipcp dns request

pseudowire 85.21.0.253 10 pw-class class1

!

interface Vlan1

description Home LAN

ip address 192.168.1.5 255.255.255.248

ip pim sparse-dense-mode

ip nat inside

ip inspect FWall in

ip virtual-reassembly

ip igmp helper-address 10.237.24.1

!

interface Vlan3

description Corbina LAN

no ip address

!

interface Dialer1

no ip address

no cdp enable

!

no ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Virtual-PPP1

ip route 0.0.0.0 0.0.0.0 FastEthernet0 dhcp 20

ip route 85.21.0.255 255.255.255.255 FastEthernet0 dhcp 10

ip route 85.21.192.3 255.255.255.255 FastEthernet0 dhcp

ip route 213.234.192.8 255.255.255.255 FastEthernet0 dhcp

ip route 85.21.0.253 255.255.255.255 FastEthernet0 dhcp 10

ip route 172.16.0.0 255.255.0.0 FastEthernet0 dhcp

ip route 85.21.0.0 255.255.0.0 FastEthernet0 dhcp

no ip http server

no ip http secure-server

!

!

ip dns server

ip nat inside source route-map local interface FastEthernet0 overload

ip nat inside source route-map public interface Virtual-PPP1 overload

!

ip access-list extended in_corbina

permit udp 85.21.0.0 0.0.255.255 any eq 1701

permit udp 172.16.0.0 0.0.255.255 any eq 5050

permit udp any eq domain any

permit igmp any any

permit icmp any any echo

permit icmp any any echo-reply

permit icmp any any unreachable

permit icmp any any packet-too-big

permit icmp any any administratively-prohibited

permit icmp any any source-quench

permit icmp any any ttl-exceeded

permit udp any eq bootps any

permit udp any eq bootpc any

ip access-list extended in_public

permit udp any eq domain any

permit icmp any any echo

permit icmp any any echo-reply

permit icmp any any unreachable

permit icmp any any packet-too-big

permit icmp any any administratively-prohibited

permit icmp any any source-quench

permit icmp any any ttl-exceeded

!

access-list 10 deny any

access-list 101 permit ip 192.168.0.0 0.0.255.255 any

no cdp run

 

!

!

!

!

route-map public permit 10

match ip address 101

match interface Virtual-PPP1

!

route-map local permit 10

match ip address 101

match interface FastEthernet0

!

!

!

!

control-plane

!

!

line con 0

exec-timeout 0 0

no exec

transport output all

line aux 0

session-timeout 20

transport preferred telnet

transport input all

speed 38400

flowcontrol hardware

line vty 0 4

session-timeout 20

access-class MGT in

transport input telnet ssh

!

end

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Вот мой конфиг с настоенным мультикастом

может кому пригодится для IPTV

 

R1#sh ru

!

interface Virtual-PPP1

ip address negotiated

ip access-group in_public in

ip mtu 1260

ip nat outside

ip virtual-reassembly

ip tcp adjust-mss 1220

pulse-time 60

no cdp enable

ppp authentication chap callin

ppp chap hostname xxxxxxxxxxxxxxxxxxxxxxxx

ppp chap password 0 yyyyyyyyyyyyyyyyyyyyyyyy

ppp ipcp dns request

pseudowire 85.21.0.253 10 pw-class class1

!

 

end

 

На interface Virtual-PPP1 поднимите ip mtu и ip tcp adjust-mss до 14xx...

Можно посмотреть информацию по sh proc cpu hi и sh inter summary ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
На interface Virtual-PPP1 поднимите ip mtu и ip tcp adjust-mss до 14xx...

 

Некоторое время назад, когда перестал работать инет б дебаггом выяснилось

что L2TP предлагал mtu = 1260, вот и поставил чтоб работало :unsure:

Ну а щас просто лень менять.

 

а ip mtu для Virtual-PPP* "заработала" только с 12.4(20)T1 (по крайней мере для 18хх)

под "заработала" я имею в виду что в sh ip int virtual-ppp 1 теперь mtu то

которое прописанно в конфиге. Но я не проверял работает фича на самом деле

или только притворяется.

Только при установке L2TP тунеля Virtual-PPP* всеравно плевать хотел на

предлогаемый сервером MRU. так что пока от выставления ручками

ip tcp adjust-mss не избавится <_<

 

 

Можно посмотреть информацию по sh proc cpu hi и sh inter summary ?

 

Вот:

 

R1#sh proc cpu hi

R1   08:29:27 PM Monday Nov 24 2008 UTC


   333332222222222333332222222222222222222222222222222222222222
   000009999988888888887777766666333332222233333555555555533333
100                                                             
90                                                             
80                                                             
70                                                             
60                                                             
50                                                             
40                *****                                        
30 ******************************               **********     
20 ************************************************************
10 ************************************************************
  0....5....1....1....2....2....3....3....4....4....5....5....6
            0    5    0    5    0    5    0    5    0    5    0
              CPU% per second (last 60 seconds)


   232322222222422222222222211112222232221 1  1111111111111  1 
   741244693022328361248336496870110210165339902210021202318818
100                                                             
90                                                             
80                                                             
70                                                             
60                                                             
50                                                             
40             *                                               
30 ** *  **    * * *   *  *          *  *                      
20 ##*######***######***#**#**********#*#*                     
10 ####################################### ********************
  0....5....1....1....2....2....3....3....4....4....5....5....6
            0    5    0    5    0    5    0    5    0    5    0
              CPU% per minute (last 60 minutes)
             * = maximum CPU%   # = average CPU%


   923422221232122312322222322322221232133222332343322222322242223224232332
   755026266507456076411982093121764714512453083311457045429612483791311203
100 *                                                                       
90 *                                                                       
80 *                                                                       
70 *                                                                       
60 *                                                                       
50 *                                                                       
40 * **                                       *  *           *      *      
30 **** * * *** *** **  ** ** *  ** **  ** * ** ******  ** ***  ***** * ** 
20 ************ ******************* **************#************************
10 ***********#******************#***#*******######************************
  0....5....1....1....2....2....3....3....4....4....5....5....6....6....7..
            0    5    0    5    0    5    0    5    0    5    0    5    0  
                  CPU% per hour (last 72 hours)
                 * = maximum CPU%   # = average CPU%


R1#sh int summary  

*: interface is up
IHQ: pkts in input hold queue     IQD: pkts dropped from input queue
OHQ: pkts in output hold queue    OQD: pkts dropped from output queue
RXBS: rx rate (bits/sec)          RXPS: rx rate (pkts/sec)
TXBS: tx rate (bits/sec)          TXPS: tx rate (pkts/sec)
TRTL: throttle count

 Interface              IHQ   IQD  OHQ   OQD  RXBS RXPS  TXBS TXPS TRTL
------------------------------------------------------------------------
* FastEthernet0            0     0    0    49 13530000  1318 372000  430    0
 FastEthernet1            0     0    0     0     0    0     0    0    0
 BRI0                     0     0    0     0     0    0     0    0    0
 BRI0:1                   0     0    0     0     0    0     0    0    0
 BRI0:2                   0     0    0     0     0    0     0    0    0
 FastEthernet2            0     0    0     0     0    0     0    0    0
 FastEthernet3            0     0    0     0     0    0     0    0    0
 FastEthernet4            0     0    0     0     0    0     0    0    0
 FastEthernet5            0     0    0     0     0    0     0    0    0
* FastEthernet6            0     0    0     1  2000    0 7036000  641    0
 FastEthernet7            0     0    0     0     0    0     0    0    0
* FastEthernet8            0     0    0     0  5000    6 583000   39    0
* FastEthernet9            0     0    0     0 843000  476 6329000  684    0
* SSLVPN-VIF0              0     0    0     0     0    0     0    0    0
* Vlan1                    0     0    0     0 255000  431 13315000  1314    0
* Loopback1                0     0    0     0     0    0     0    0    0
* NVI0                     0     0    0     0     0    0     0    0    0
* Virtual-PPP1             0     0    1     0 6241000  672 204000  430    0
 Vlan3                    0     0    0     0     0    0     0    0    0
* Dialer1                  0     0    0     0     0    0     0    0    0
R1#sh ip mrou    
R1#sh ip mroute active
Active IP Multicast Sources - sending >= 4 kbps
a negative (-) Rate counts pps being fast-dropped

Group: 233.32.240.232, (?)
  Source: 172.16.16.68 (?)
    Rate: 641 pps/6949 kbps(1sec), 6928 kbps(last 50 secs), 1612 kbps(life avg)
R1#

 

FastEthernet6 это интерфейс к приставке

на кошку льется поток Luxe TV HD и в нагрузку торрент ~870КБ/с

 

По началу когда подымается интерфейс начинают сыпаться сразу несколько

потоков потом не нужные постепенно отваливаются. (так было когда у корбины

кошка в мою сторону смотрела, щас dlink поставили а выяснять ка он мне поток

сливвает dense или sparse уже не охота. и так все работает)

 

sh proc cpu hi - касательно вашего интереса к нагрузке могу сказать что

2620XM - не справилась. продал.

2651XM - врать не буду не помню, но довольно сильно была нагружена, и шумела сильно. продал.

а вот 1812 вполне подошла.

 

PS:

Тут ктото писал что Asus sucks.

На моем Asus 500GP + openwrt (pptp) максимум скорости наблюдался в районе 500КБ/с

и это без wifi и мультикаста. Правда с ядерным L2TP чуть чуть пошустрее было.

pppd на железке в проц упирался.

 

PS2:

На полке валяется лишняя 1811, если кого интересует.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Некоторое время назад, когда перестал работать инет б дебаггом выяснилось

что L2TP предлагал mtu = 1260, вот и поставил чтоб работало ;)

Ну а щас просто лень менять.

 

sh proc cpu hi - касательно вашего интереса к нагрузке могу сказать что

2620XM - не справилась. продал.

2651XM - врать не буду не помню, но довольно сильно была нагружена, и шумела сильно. продал.

а вот 1812 вполне подошла.

 

PS:

Тут ктото писал что Asus sucks.

На моем Asus 500GP + openwrt (pptp) максимум скорости наблюдался в районе 500КБ/с

и это без wifi и мультикаста. Правда с ядерным L2TP чуть чуть пошустрее было.

pppd на железке в проц упирался.

 

PS2:

На полке валяется лишняя 1811, если кого интересует.

 

Спасибо! Хотел со своим 881 сравнить.

 

Асус нормальные бюджетные железки клепает (особенно с прошивкой от Олега).

 

1811 слабовата. Если только 1841 с Wi Fi на тест взять :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот загрузка 2801 при работающем торрент клиенте

 

cs2801   11:41:44 PM Friday Dec 5 2008 MSK


   455555555555555555555555555555555555555555555555555666666666
   988888555550000077777333339999966666777777777788888333331111
100
90
80
70
60  **********     *****     **********************************
50 ************************************************************
40 ************************************************************
30 ************************************************************
20 ************************************************************
10 ************************************************************
  0....5....1....1....2....2....3....3....4....4....5....5....6
            0    5    0    5    0    5    0    5    0    5    0
              CPU% per second (last 60 seconds)


   667766666776766666767778988888889777769877777776766787787776
   413002641012019748271347035254613674260156598416079328013388
100
90                        ** * * * *     *
80                        ########****   #******       ** *  *
70   **  *  ** * ** *****##############**########*****########*
60 ####*#**####################################################
50 ############################################################
40 ############################################################
30 ############################################################
20 ############################################################
10 ############################################################
  0....5....1....1....2....2....3....3....4....4....5....5....6
            0    5    0    5    0    5    0    5    0    5    0
              CPU% per minute (last 60 minutes)
             * = maximum CPU%   # = average CPU%


   9877976899999989999999994645451
   9611192799989149271559987140767
100 *       *****  * * *****
90 **  *  ******* *********
80 **  ** ****#************
70 ****** **###*********##*
60 ##*******#####****#####* *   *
50 ##*****########*#######*** ***
40 #######################*******
30 #######################*******
20 ########################*******
10 ###############################
  0....5....1....1....2....2....3....3....4....4....5....5....6....6....7..
            0    5    0    5    0    5    0    5    0    5    0    5    0
                  CPU% per hour (last 72 hours)
                 * = maximum CPU%   # = average CPU%


cs2801>sh int sum

*: interface is up
IHQ: pkts in input hold queue     IQD: pkts dropped from input queue
OHQ: pkts in output hold queue    OQD: pkts dropped from output queue
RXBS: rx rate (bits/sec)          RXPS: rx rate (pkts/sec)
TXBS: tx rate (bits/sec)          TXPS: tx rate (pkts/sec)
TRTL: throttle count

 Interface              IHQ   IQD  OHQ   OQD  RXBS RXPS  TXBS TXPS TRTL
------------------------------------------------------------------------
* FastEthernet0/0          0     3    0     0 724000  837 14922000  1448    0
* FastEthernet0/1          0     0    0     0 14459000  1451 451000  831    0
 Serial0/2/0              0     0    0     0     0    0     0    0    0
 NVI0                     0     0    0     0     0    0     0    0    0
* SSLVPN-VIF0              0     0    0     0     0    0     0    0    0
* Virtual-PPP1             0     0    1     0 371000  831 14339000  1448    0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Вот загрузка 2801 при работающем торрент клиенте

 

Чтото хреново твоей кошке.

Что кажут sh int switching и sh int stats

 

ЗЫ:

1812 с моим конфигом качает торентом со скоростью 700-900Kб/c + IPTV кажет, (тариф 8000)

вот такая нагрузка:

R1#sh processes cpu history   

R1   10:29:42 AM Sunday Dec 21 2008 UTC


   222222333332222222222222222222222222222222222222222222222222
   100000333332222200000111112222222222222223333322222222221111
100                                                             
90                                                             
80                                                             
70                                                             
60                                                             
50                                                             
40                                                             
30       *****                                                 
20 ************************************************************
10 ************************************************************
  0....5....1....1....2....2....3....3....4....4....5....5....6
            0    5    0    5    0    5    0    5    0    5    0
              CPU% per second (last 60 seconds)


   233323332333323333233233223332333223333222225333322233333222
   612062109222151201412800670217021793000926642103479300110877
100                                                             
90                                                             
80                                                             
70                                                             
60                                                             
50                                             *               
40                                             *               
30 ****************** ********************* ** ******* ********
20 ############################################################
10 ############################################################
  0....5....1....1....2....2....3....3....4....4....5....5....6
            0    5    0    5    0    5    0    5    0    5    0
              CPU% per minute (last 60 minutes)
             * = maximum CPU%   # = average CPU%


   422223232222221223322123312221232122212222133222332312222333132222332322
   403740703359199635994640092604127573396183907047405186523422992823108368
100                                                                         
90                                                                         
80                                                                         
70                                                                         
60                                                                         
50                                                                         
40 *                **                         *                *          
30 *  * ***  ** * * ***   **  *   ** *   * *  **  ***** **  *** * *  ******
20 ***************************** ******************************************
10 #***************************************************##******************
  0....5....1....1....2....2....3....3....4....4....5....5....6....6....7..
            0    5    0    5    0    5    0    5    0    5    0    5    0  
                  CPU% per hour (last 72 hours)
                 * = maximum CPU%   # = average CPU%

 

 

 

 

Асус нормальные бюджетные железки клепает (особенно с прошивкой от Олега).

 

1811 слабовата. Если только 1841 с Wi Fi на тест взять :(

 

У меня на тарифе 8000 анлим 1812 почти бездельничает,

хотя от такой же но с wifi я бы не отказался :thanx:

 

а пока для wifi я юзаю asus wl500gp, благо портов в кошке достаточно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Та же фигня на асусе 500GP с Олеговской прошивкой :blum: Пинг на вайвай улетает к двум секундам :huh:

Думаю, что нужно на торенте апетиты ослабить :lol:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Та же фигня на асусе 500GP с Олеговской прошивкой :D Пинг на вайвай улетает к двум секундам ;)

Думаю, что нужно на торенте апетиты ослабить :)

 

Про пинг - рекомендую настройки на другой стороне глянуть.

У меня при установке "максимальное энергосбережение" для ноутбучной Wi Fi карты, пинг тоже к двум секундам улетает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Про пинг - рекомендую настройки на другой стороне глянуть.

У меня при установке "максимальное энергосбережение" для ноутбучной Wi Fi карты, пинг тоже к двум секундам улетает.

 

Пасиб.

Дельный совет.

Нужно попробовать...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Чтото хреново твоей кошке.

Что кажут sh int switching и sh int stats

 

ЗЫ:

1812 с моим конфигом качает торентом со скоростью 700-900Kб/c + IPTV кажет, (тариф 8000)

 

sh int switching

cs2801#sh interfaces fastEthernet 0/0 switching
FastEthernet0/0
         Throttle count          0
                  Drops         RP         25         SP          0
            SPD Flushes       Fast          0        SSE          0
            SPD Aggress       Fast          0
           SPD Priority     Inputs     324166      Drops          0

   Protocol  IP
         Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                Process     276314   32692462      47145   18718856
           Cache misses          0          -          -          -
                   Fast   49543365   24473987   45896207 3164858197
              Auton/SSE          0          0          0          0

   Protocol  DEC MOP
         Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                Process          0          0        175      13475
           Cache misses          0          -          -          -
                   Fast          0          0          0          0
              Auton/SSE          0          0          0          0

   Protocol  ARP
         Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                Process     322270   19350506        112       6720
           Cache misses          0          -          -          -
                   Fast          0          0          0          0
              Auton/SSE          0          0          0          0

   Protocol  Other
         Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                Process       5676     552298      10485     629100
           Cache misses          0          -          -          -
                   Fast          0          0          0          0
              Auton/SSE          0          0          0          0

   NOTE: all counts are cumulative and reset only after a reload.

cs2801#sh interfaces fastEthernet 0/1 switching
FastEthernet0/1
         Throttle count          0
                  Drops         RP          0         SP          0
            SPD Flushes       Fast          0        SSE          0
            SPD Aggress       Fast          0
           SPD Priority     Inputs       2261      Drops          0

   Protocol  IP
         Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                Process     101185   21151743     170631   13191451
           Cache misses          0          -          -          -
                   Fast   46092688 1618763984   49418624 2320334570
              Auton/SSE          0          0          0          0

   Protocol  DEC MOP
         Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                Process          0          0        176      13552
           Cache misses          0          -          -          -
                   Fast          0          0          0          0
              Auton/SSE          0          0          0          0

   Protocol  ARP
         Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                Process        553      33180       7234     434040
           Cache misses          0          -          -          -
                   Fast          0          0          0          0
              Auton/SSE          0          0          0          0

   Protocol  CDP
         Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                Process       1764     698544       1754     666478
           Cache misses          0          -          -          -
                   Fast          0          0          0          0
              Auton/SSE          0          0          0          0

   Protocol  Other
         Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                Process          3       1188      10509     630540
           Cache misses          0          -          -          -
                   Fast          0          0          0          0
              Auton/SSE          0          0          0          0

   NOTE: all counts are cumulative and reset only after a reload.

cs2801#sh interfaces virtual-ppp1 switching
Virtual-PPP1 WAN; Corbina internet
         Throttle count          0
                  Drops         RP          0         SP          0
            SPD Flushes       Fast          0        SSE          0
            SPD Aggress       Fast          0
           SPD Priority     Inputs      12260      Drops          0

   Protocol  IP
         Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                Process     186552   20021082      30832   16078987
           Cache misses          0          -          -          -
                   Fast   49442410 1727104303          0          0
              Auton/SSE          0          0          0          0

   Protocol  Other
         Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                Process          0          0      10278     164447
           Cache misses          0          -          -          -
                   Fast      11976     167664   46061870 1096206326
              Auton/SSE          0          0          0          0

   NOTE: all counts are cumulative and reset only after a reload.

 

sh int stats

cs2801#sh interfaces fastEthernet 0/0 stat
FastEthernet0/0
         Switching path    Pkts In   Chars In   Pkts Out  Chars Out
              Processor     606255   52777539      58052   19379365
            Route cache   49677917   39232616   46114845 3465259461
                  Total   50284172   92010155   46172897 3484638826

cs2801#sh interfaces fastEthernet 0/1 stat
FastEthernet0/1
         Switching path    Pkts In   Chars In   Pkts Out  Chars Out
              Processor     103823   21907374     190712   14976028
            Route cache   46172902 1725156618   49467845 2323722498
                  Total   46276725 1747063992   49658557 2338698526

cs2801#sh interfaces virtual-PPP1 stat
Virtual-PPP1
         Switching path    Pkts In   Chars In   Pkts Out  Chars Out
              Processor     186719   19939814      41134   16244198
            Route cache   49498039 1729845309   46132641 1189219127
                  Total   49684758 1749785123   46173775 1205463325

 

У меня тариф 26000, торрент качает на скорости до 3 Мб/сек

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
У меня тариф 26000, торрент качает на скорости до 3 Мб/сек

 

Тоже подключил этот тариф из научного интереса

получилось что при скорости 3Мб/с загрузка 60%

 

R1#sh proc cpu hi

R1   06:00:33 PM Saturday Jan 17 2009 UTC


   663333355555666665555555555555554444455555555555555555555555
   113333333333333334444466666777779999977777555550000022222333
100                                                             
90                                                             
80                                                             
70                                                             
60 **          *****     **********     **********             
50 **     *****************************************************
40 **     *****************************************************
30 ************************************************************
20 ************************************************************
10 ************************************************************
  0....5....1....1....2....2....3....3....4....4....5....5....6
            0    5    0    5    0    5    0    5    0    5    0
              CPU% per second (last 60 seconds)


   666767665666634334344433433333111  11 111111111 1111  121111
   321010047132061964211065853701310761181021122118211183173121
100                                                             
90                                                             
80                                                             
70    * *                                                      
60 *************                                               
50 #############           *                                   
40 #############***** ******* *                                
30 #############*#****#******#***                         *    
20 ##############################                         *    
10 ###############################********************** ******
  0....5....1....1....2....2....3....3....4....4....5....5....6
            0    5    0    5    0    5    0    5    0    5    0
              CPU% per minute (last 60 minutes)
             * = maximum CPU%   # = average CPU%


   726767882252324456676262222321223353123222324221234224222322222222142132
   023044219839763754445674607265012311994412106638322380427154565005903797
100                                                                         
90                                                                         
80       **                                                                
70 *  * ***           ** *                                                 
60 * ******        ***** *                                                 
50 * ****#*  *    ****** *           *         *                           
40 * ***###  * * ****### *           *         *     *  *             *  * 
30 * *#####*********####** * ***   **** **   * **   ** **  *** ***  * *  **
20 #*######*******######***************************************************
10 #*#########*#########***************************************************
  0....5....1....1....2....2....3....3....4....4....5....5....6....6....7..
            0    5    0    5    0    5    0    5    0    5    0    5    0  
                  CPU% per hour (last 72 hours)
                 * = maximum CPU%   # = average CPU%

 

R1#sh int sum

*: interface is up
IHQ: pkts in input hold queue     IQD: pkts dropped from input queue
OHQ: pkts in output hold queue    OQD: pkts dropped from output queue
RXBS: rx rate (bits/sec)          RXPS: rx rate (pkts/sec)
TXBS: tx rate (bits/sec)          TXPS: tx rate (pkts/sec)
TRTL: throttle count

 Interface              IHQ   IQD  OHQ   OQD  RXBS RXPS  TXBS TXPS TRTL
------------------------------------------------------------------------
* Virtual-PPP1             0     0    2     2 24414000  2504 3384000  1661    0

 

А я думал что 2801 помощнее должа была быть. :mellow:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
А я думал что 2801 помощнее должа была быть. :huh:

 

У меня на ней стоит C2801-ADVENTERPRISEK9-M, думаю если поставить что-нить попроще, то процессор должен разгрузиться.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Возникла проблема, корбиновцы подкрутили, что-то на DHCP, в результате после глобалки в моем сегменте рутер не получает адрес.

Саппорт стандартно отписался, у всех все работает, а циску мы не поддерживаем. Рутер ругается на маску /32 приходящую от сервака.

 

 

*Jan 21 19:53:38.901: DHCP: SDiscover attempt # 1 for entry:
*Jan 21 19:53:38.901: Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet0
*Jan 21 19:53:38.901: Temp  sub net mask: 0.0.0.0
*Jan 21 19:53:38.901:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
*Jan 21 19:53:38.901:    DHCP transaction id: 2222
*Jan 21 19:53:38.901:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*Jan 21 19:53:38.901:    Next timer fires after: 00:00:04
*Jan 21 19:53:38.901:    Retry count: 1   Client-ID: cisco-0007.0e41.6516-Fa0
*Jan 21 19:53:38.901:    Client-ID hex dump: 636973636F2D303030372E306534312E
*Jan 21 19:53:38.901:                        363531362D466130
*Jan 21 19:53:38.901:    Hostname: XXXXXXXX
*Jan 21 19:53:38.901: DHCP: SDiscover: sending 295 byte length DHCP packet
*Jan 21 19:53:38.901: DHCP: SDiscover 295 bytes 
*Jan 21 19:53:38.901:             B'cast on FastEthernet0 interface from 0.0.0.0
*Jan 21 19:53:38.933: DHCP: Received a BOOTREP pkt
*Jan 21 19:53:38.933: DHCP: Scan: Message type: DHCP Offer
*Jan 21 19:53:38.933: DHCP: Scan: Server ID Option: 83.102.233.200 = 5366E9C8
*Jan 21 19:53:38.933: DHCP: Scan: Lease Time: 604800
*Jan 21 19:53:38.933: DHCP: Scan: Subnet Address Option: 255.255.248.0
*Jan 21 19:53:38.933: DHCP: Scan: DNS Name Server Option: 213.234.192.8, 85.21.192.3
*Jan 21 19:53:38.933: DHCP: Scan: Router Option: 10.29.16.1
*Jan 21 19:53:38.933: DHCP: Scan: Static Route Option: 89.179.135.67 10.29.16.1
*Jan 21 19:53:38.933: DHCP: Scan: Static Route Option: 195.14.50.26 10.29.16.1, &195.14.50.16&, &10.29.16.1&, &85.21.52.254&, &10.29.16.1&, &85.21.88.130&, &10.29.16.1&, &195.14.50.93&, &10.29.16.1&, &195.14.50.21&, &10.29.16.1&, &194.67.1.130&
*Jan 21 19:53:38.933: DHCP: Scan: bad Subnet mask Option len 255
*Jan 21 19:53:38.933: DHCP: Error in pkt. puntingno

 

И так бесконечно.... Видимо изменения произошли в период с 15-го по 20-ое января. 20-го в 6:13 случилась глобалка из-за которой разорвалось соединение и возникла данная проблема. Саппорт корбины уверяет, что для устранения глобалки просто перезагрузили оборудование. На самом деле странно, так как Сегмент сидел без инетас 6:13 до девяти вечера примерно. Винда напрямую нормально получает адрес и поднимает VPN

У кого-нибудь была такая проблема?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Рутер ругается на маску /32 приходящую от сервака.

Честно посмотрел лог и не увидел, где он так ругается?

Приведите листинг настройки интерфейса, подключенного к К., acl (если есть).

Пробовали настроить статикой?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Честно посмотрел лог и не увидел, где он так ругается?

Приведите листинг настройки интерфейса, подключенного к К., acl (если есть).

Пробовали настроить статикой?

 

 

Последние две строчки дебага...

Статикой пробовал разумеется, дальше шлюза пинги не идут... (

 

 

Update: Проблема решилась добавлением, на WAN интерфейсе, команды no ip dhcp client request static-route

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах