Архивировано

Эта тема находится в архиве и закрыта для публикации сообщений.

StarWoofy

CISCO851-K9

Рекомендованные сообщения

;)Привет!

 

Оригинальное сообщение:

Есть ли информация об успешной работе роутера CISCO851-K9 WIFI

в сети Корбины?

 

Использовать роутеры типа Zyxel 330EE или Asus 500

не очень хочется в связи с проблемностью настройки (поиск новых бета-версий прошивок, итп).

;)

 

Ссылки на cisco.com и sysadmins.ru удалены (неактуально).

 

Но всё равно было бы приятно услышать комментарии....

 

Полезная информация:

 

Мой "не самый правильный", но работоспособный текущий конфиг для 851 W K-9 на

прошивке c850-advsecurityk9-mz.124-9.T3.bin

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2008.08.22 09:34:32 =~=~=~=~=~=~=~=~=~=~=~=

SWRouter#
SWRouter#sh ru
Building configuration...

Current configuration : 5663 bytes
!
! Last configuration change at 20:46:09 MSD Wed Aug 6 2008 by starwoofy
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime localtime
service password-encryption
!
hostname SWRouter
!
boot-start-marker
boot system flash c850-advsecurityk9-mz.124-9.T3.bin
boot-end-marker
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication ppp default local
aaa authorization network default none
!
aaa session-id common
!
resource policy
!
clock timezone moscow 3
clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00
clock save interval 8
no ip dhcp use vrf connected
!
ip dhcp pool HOME
  import all
  network 192.168.0.0 255.255.255.0
  default-router 192.168.0.1
  dns-server 195.14.50.21 195.14.50.1
  lease infinite
!
ip dhcp pool guest_lan
  import all
  network 192.168.10.0 255.255.255.0
  default-router 192.168.10.1
  dns-server 195.14.50.21 195.14.50.1
  lease infinite
!
!
ip cef
ip domain name corbina.net
l2tp-class corbina
!
!
!
!
username xxxxxxxxxx privilege 15 secret 5 xxxxxxxxxxxxxxxxxxxxxxxxx
!
pseudowire-class class1
encapsulation l2tpv2
protocol l2tpv2 corbina
ip local interface FastEthernet4
!
!
!
!
!
!
interface FastEthernet0
speed 100
no cdp enable
!
interface FastEthernet1
shutdown
speed 100
no cdp enable
!
interface FastEthernet2
shutdown
speed 100
no cdp enable
!
interface FastEthernet3
shutdown
speed 100
no cdp enable
!
interface FastEthernet4
mac-address xxxx.xxxx.xxxx
ip address dhcp
ip nat outside
no ip virtual-reassembly
speed auto
full-duplex
no cdp enable
!
interface Dot11Radio0
no ip address
!
encryption vlan 10 mode ciphers tkip
!
ssid SW-WIFI
vlan 10
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 7 xxxxxxxxxxxxxxxxxxxxxxxxx
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 54.0
channel 2437
station-role root
no dot11 extension aironet
no cdp enable
!
interface Dot11Radio0.10
bandwidth 8
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
ip nat inside
no ip virtual-reassembly
no cdp enable
!
interface Virtual-PPP1
ip address negotiated
ip access-group 111 in
ip nat outside
no ip virtual-reassembly
no peer neighbor-route 
no cdp enable
ppp authentication chap callin
ppp chap hostname xxxxxxxxxxxxx
ppp chap password 7 xxxxxxxxxxxxxxxxxxxxxxxxx
pseudowire 85.21.17.13 10 pw-class class1
!
interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
no ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 Virtual-PPP1
ip route 192.168.10.0 255.255.255.0 Dot11Radio0.10
ip route 10.0.0.0 255.0.0.0 dhcp
ip route 85.21.79.38 255.255.255.255 dhcp
ip route 85.21.88.130 255.255.255.255 dhcp
ip route 195.14.50.1 255.255.255.255 dhcp
ip route 195.14.50.21 255.255.255.255 dhcp
ip route 85.21.17.13 255.255.255.255 dhcp
!
no ip http server
no ip http secure-server
ip nat inside source list lan interface FastEthernet4 overload
ip nat inside source list wan interface Virtual-PPP1 overload
ip nat inside source static tcp 192.168.10.2 28169 interface FastEthernet4 28169
ip nat inside source static udp 192.168.10.2 7557 interface FastEthernet4 7557
!
ip access-list extended lan
permit ip 192.168.0.0 0.0.0.255 195.14.50.0 0.0.0.255
permit ip 192.168.0.0 0.0.0.255 10.0.0.0 0.255.255.255
permit ip 192.168.0.0 0.0.0.255 85.21.151.0 0.0.0.255
permit ip 192.168.0.0 0.0.0.255 85.21.79.0 0.0.0.255
permit ip 192.168.0.0 0.0.0.255 83.102.146.96 0.0.0.31
permit ip 192.168.0.0 0.0.0.255 host 85.21.52.254
permit ip 192.168.0.0 0.0.0.255 host 85.21.88.130
permit ip 192.168.0.0 0.0.0.255 85.21.90.0 0.0.1.255
permit ip 192.168.0.0 0.0.0.255 host 85.21.138.211
permit ip 192.168.0.0 0.0.0.255 host 85.21.138.212
permit ip 192.168.10.0 0.0.0.255 195.14.50.0 0.0.0.255
permit ip 192.168.10.0 0.0.0.255 10.0.0.0 0.255.255.255
permit ip 192.168.10.0 0.0.0.255 85.21.151.0 0.0.0.255
permit ip 192.168.10.0 0.0.0.255 85.21.79.0 0.0.0.255
permit ip 192.168.10.0 0.0.0.255 83.102.146.96 0.0.0.31
permit ip 192.168.10.0 0.0.0.255 host 85.21.52.254
permit ip 192.168.10.0 0.0.0.255 host 85.21.88.130
permit ip 192.168.10.0 0.0.0.255 85.21.90.0 0.0.1.255
permit ip 192.168.10.0 0.0.0.255 host 85.21.138.211
permit ip 192.168.10.0 0.0.0.255 host 85.21.138.212
ip access-list extended wan
permit ip 192.168.0.0 0.0.0.255 any
permit ip 192.168.10.0 0.0.0.255 any
!
access-list 111 deny   tcp any eq 139 any
access-list 111 deny   udp any eq netbios-ns any eq netbios-ns
access-list 111 deny   udp any eq netbios-dgm any eq netbios-dgm
access-list 111 deny   udp any eq netbios-ss any eq netbios-ss
access-list 111 deny   udp any any range snmp snmptrap
access-list 111 deny   tcp any any eq 3128
access-list 111 deny   ip 192.168.0.0 0.0.255.255 any
access-list 111 deny   ip 172.16.0.0 0.15.255.255 any
access-list 111 deny   ip 127.0.0.0 0.0.0.255 any
access-list 111 deny   udp any any range 130 140
access-list 111 deny   tcp any any range 130 140
access-list 111 deny   tcp any any eq 8080
access-list 111 permit ip any any
access-list 111 permit udp any any
access-list 111 permit gre any any
access-list 111 permit tcp any any
access-list 111 permit icmp any any
access-list 111 permit pcp any any
access-list 111 permit esp any any
access-list 111 permit igmp any any
access-list 111 permit ipinip any any
access-list 111 permit nos any any
no cdp run
!
control-plane
!
!
line con 0
privilege level 15
no modem enable
transport output all
line aux 0
transport output all
line vty 0 4
privilege level 15
transport input ssh
transport output all
!
scheduler max-task-time 5000
sntp server 195.170.62.130
end

SWRouter#

 

По поводу подкручивания MTU/tcp mss (как вариант необходимо подбирать значения индивидуально, см. сообщения в этой ветке):

interface Virtual-PPP1
...
ip mtu 1400
...
ip tcp adjust-mss 1360
...

 

 

Как выглядит роутер :P

post-78567-1219680889_thumb.jpg

 

Пошаговая инструкция по настройке роутеров от user-login

Настройка маршрутизаторов Cisco для работы в сети Корбина.

 

Ветка по поводу 871 W K9 от A_Petrenko

Cisco871WK9 + Corbina L2TP

 

Дока по прошивке 800й серии (pdf 128K)

cisco univercd

 

Если не идет авторизация/падает vpdn - проверьте сервер авторизации

Изменения от 24.09.2008 вероятно не последние :-)

почти наверняка не пингуется сервер авторизации

85.21.17.13

 

 

Если так - измени параметры:

Например

я пинганул l2tp.corbina.net

получил адрес 85.21.0.253

 

Изменения:

 

conf t

interface Virtual-PPP1

pseudowire 85.21.0.253 10 pw-class class1

 

exit

no ip route 85.21.17.13 255.255.255.255 dhcp

ip route 85.21.0.253 255.255.255.255 dhcp

exit

exit

 

sh vpdn

 

ping www.ya.ru

 

если всё ок -

copy running-config startup-config

 

Изменения от 07.10.2009

в связи с непонятными падениями туннеля

потребовалось добавить

no peer neighbor-route

на интерфейсе Virtual-ppp1

 

Оригинальный пост

Маршрутизаторы Cisco Systems, Inc.

 

Изменения от 18.01.2010

в связи с перегрузкой браса 253 подкрутить мту

 

добавить

 

interface virtual-ppp1

ip mtu 1380

необязательно ip virtual-reassembly

ip tcp adjust-mss 1320

 

необязательно

interface fastEthernet 4

ip virtual-reassembly

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Хм. В данный момент борюсь с невозможностью поднять l2tpv2 туннель...

Для интересующихся - конфиг:1.txt

 

Вылезает ошибка:

 

L2X: l2tun session [2187205508], event [client request], old state [open], new state [open]
Tnl/Sn 22362/26 L2TP: Session state change from idle to wait-for-tunnel
uid:1 Tnl/Sn 22362/26 L2TP: Create session
Tnl 22362 L2TP: SM State idle
Tnl 22362 L2TP: O SCCRQ
Tnl 22362 L2TP: Control channel retransmit delay set to 1 seconds
Tnl 22362 L2TP: Tunnel state change from idle to wait-ctl-reply
Tnl 22362 L2TP: SM State wait-ctl-reply
Tnl 22362 L2TP: O Resend SCCRQ, flg TLS, ver 2, len 115,tnl 0, ns 0, nr 0
Tnl 22362 L2TP: Control channel retransmit delay set to 2 seconds
Tnl 22362 L2TP: Tunnel state shutting-down while destroying session

 

*Sep 15 00:15:42.247: %LINK-3-UPDOWN: Interface Virtual-PPP1, changed state to up
*Sep 15 00:15:42.247: Vp1 PPP: Using default call direction
*Sep 15 00:15:42.247: Vp1 PPP: Treating connection as a dedicated line
*Sep 15 00:15:42.247: Vp1 PPP: Session handle[13000015] Session id[13]
*Sep 15 00:15:42.247: Vp1 PPP: Phase is ESTABLISHING, Active Open
*Sep 15 00:15:42.247: Vop1 PPP: Authorization NOT required
*Sep 15 00:15:42.247: Vp1 LCP: O CONFREQ [Closed] id 49 len 15
*Sep 15 00:15:42.247: Vp1 LCP:	AuthProto CHAP (0x0305C22305)
*Sep 15 00:15:42.247: Vp1 LCP:	MagicNumber 0x1BE344CE (0x05061BE344CE)
*Sep 15 00:15:44.251: Vp1 LCP: I CONFREQ [REQsent] id 1 len 19
*Sep 15 00:15:44.251: Vp1 LCP:	MRU 1464 (0x010405B8)
*Sep 15 00:15:44.251: Vp1 LCP:	AuthProto CHAP (0x0305C22305)
*Sep 15 00:15:44.251: Vp1 LCP:	MagicNumber 0x7BEFE05A (0x05067BEFE05A)
*Sep 15 00:15:44.251: Vp1 LCP: O CONFNAK [REQsent] id 1 len 8
*Sep 15 00:15:44.251: Vp1 LCP:	MRU 1500 (0x010405DC)
*Sep 15 00:15:44.255: Vp1 LCP: TIMEout: State REQsent
*Sep 15 00:15:44.255: Vp1 LCP: O CONFREQ [REQsent] id 50 len 15
*Sep 15 00:15:44.255: Vp1 LCP:	AuthProto CHAP (0x0305C22305)
*Sep 15 00:15:44.255: Vp1 LCP:	MagicNumber 0x1BE344CE (0x05061BE344CE)
*Sep 15 00:15:44.255: Vp1 LCP: I CONFREQ [REQsent] id 2 len 19
*Sep 15 00:15:44.255: Vp1 LCP:	MRU 1500 (0x010405DC)
*Sep 15 00:15:44.255no : Vp1 LCP:	AuthProto CHAP (0x0305C22305)
*Sep 15 00:15:44.255: Vp1 LCP:	MagicNumber 0x7BEFE05A (0x05067BEFE05A)
*Sep 15 00:15:44.255: Vp1 LCP: O CONFACK [REQsent] id 2 len 19
*Sep 15 00:15:44.255: Vp1 LCP:	MRU 1500 (0x010405DC)
*Sep 15 00:15:44.255: Vp1 LCP:	AuthProto CHAP (0x0305C22305)
*Sep 15 00:15:44.255: Vp1 LCP:	MagicNumber 0x7BEFE05A (0x05067BEFE05A)
*Sep 15 00:15:44.259: Vp1 LCP: I CONFACK [ACKsent] id 50 len 15
*Sep 15 00:15:44.259: Vp1 LCP:	AuthProto CHAP (0x0305C22305)
*Sep 15 00:15:44.259: Vp1 LCP:	MagicNumber 0x1BE344CE (0x05061BE344CE)
*Sep 15 00:15:44.259: Vp1 LCP: State is Open
*Sep 15 00:15:44.259: Vp1 PPP: Phase is AUTHENTICATING, by both
*Sep 15 00:15:44.259: Vp1 CHAP: O CHALLENGE id 21 len 30 from "starwoofy"
*Sep 15 00:15:44.283: Vp1 CHAP: I CHALLENGE id 1 len 26 from "bras2"
*Sep 15 00:15:44.283: Vp1 CHAP: Using hostname from interface CHAP
*Sep 15 00:15:44.283: Vp1 CHAP: Using password from interface CHAP
*Sep 15 00:15:44.283: Vp1 CHAP: O RESPONSE ipp ad 1 len 30 from "starwoofy"
*Sep 15 00:15:44.599: Vp1 CHAP: I SUCCESS id 1 len 4
*Sep 15 00:15:44.599: Vp1 LCP: I TERMREQ [Open] id 3 len 4
*Sep 15 00:15:44.599: Vp1 LCP: O TERMACK [Open] id 3 len 4
*Sep 15 00:15:44.599: Vp1 PPP: Sending Acct Event[Down] id[27]
*Sep 15 00:15:44.599: Vp1 PPP: Phase is TERMINATING
*Sep 15 00:15:44.639: %LINK-3-UPDOWN: Interface Virtual-PPP1, changed state to down
*Sep 15 00:15:44.639: Vp1 LCP: State is Closed
*Sep 15 00:15:44.639: Vp1 PPP: Phase is DOWN

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Привет!

 

Есть ли информация об успешной работе роутера CISCO851-K9 WIFI

в сети Корбины?

 

Использовать роутеры типа Zyxel 330EE или Asus 500

не очень хочется в связи с проблемностью настройки (поиск новых бета-версий прошивок, итп).

wink.gif

 

Брошюра

http://www.cisco.com/application/pdf/en/us...ecd8019dc1f.pdf

 

 

upd. Похоже что работает без проблем

http://forum.sysadmins.ru/32/176772/?postd...1833216df1e5f14

 

Но всё равно было бы приятно услышать комментарии....

 

Там же я выкладывал готовый конфиг и здесь где-то пробегал почти рабочий вариант.

 

Если интересно, то:

 

router#sh ver
Cisco IOS Software, C870 Software (C870-ADVIPSERVICESK9-M), Version 12.4(4)T7, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Wed 29-Nov-06 00:43 by kellythw

ROM: System Bootstrap, Version 12.3(8r)YI3, RELEASE SOFTWARE

871_router uptime is 2 weeks, 2 days, 5 hours, 35 minutes
System returned to ROM by power-on
System restarted at 15:49:59 gmt Sun Sep 2 2007
System image file is "flash:c870-advipservicesk9-mz.124-4.T7.bin"

Cisco 871 (MPC8272) processor (revision 0x200) with 118784K/12288K bytes of memory.
Processor board ID FCZ111541EE
MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10
5 FastEthernet interfaces
128K bytes of non-volatile configuration memory.
24576K bytes of processor board System flash (Intel Strataflash)

Configuration register is 0x2102

 

851-я почти полная аналогия.

 

И сам конфиг:

 

router#sh run
Building configuration...

Current configuration : 5181 bytes
!
! Last configuration change at 21:01:13 gmt Tue Sep 18 2007
! NVRAM config last updated at 07:36:27 gmt Mon Sep 17 2007
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log uptime
service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
enable secret 5 ***********
!
no aaa new-model
!
resource policy
!
clock timezone gmt 3
clock summer-time gmt recurring 4 Sun Mar 0:00 4 Sun Oct 0:00
ip subnet-zero
ip cef
!
!
!
!
ip domain lookup source-interface FastEthernet4
ip name-server 195.14.50.1
ip name-server 195.14.50.21
!
password encryption aes
!
!
!
! 
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description Corbina intranet
ip address 10.84.*.* 255.255.0.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Virtual-PPP1
description Corbina internet
ip address negotiated
ip access-group in_filt in
ip access-group out_filt out
ip nat outside
ip virtual-reassembly
no cdp enable
ppp chap hostname ***********
ppp chap password 7 ***********
ppp direction callout
ppp timeout retry 1
pseudowire 85.21.17.17 5 encapsulation l2tpv2
!
interface Vlan1
description LAN
ip address 192.168.71.254 255.255.255.248
ip nat inside
ip virtual-reassembly
!
ip classless
ip route 0.0.0.0 0.0.0.0 Virtual-PPP1
ip route 10.0.0.0 255.0.0.0 10.84.0.17
ip route 83.102.146.96 255.255.255.224 10.84.0.17
ip route 85.21.17.17 255.255.255.255 10.84.0.17
ip route 85.21.52.254 255.255.255.255 10.84.0.17
ip route 85.21.79.0 255.255.255.0 10.84.0.17
ip route 85.21.88.130 255.255.255.255 10.84.0.17
ip route 85.21.90.0 255.255.254.0 10.84.0.17
ip route 85.21.121.50 255.255.255.255 10.84.0.17
ip route 85.21.138.208 255.255.255.248 10.84.0.17
ip route 85.21.151.122 255.255.255.255 10.84.0.17
ip route 85.21.151.138 255.255.255.255 10.84.0.17
ip route 89.179.144.102 255.255.255.255 10.84.0.17
ip route 195.14.40.141 255.255.255.255 10.84.0.17
ip route 195.14.50.0 255.255.255.0 10.84.0.17
!
!
no ip http server
no ip http secure-server
ip nat inside source list lan interface FastEthernet4 overload
ip nat inside source list wan interface Virtual-PPP1 overload
ip nat inside source static tcp 192.168.71.250 63530 interface Virtual-PPP1 63530
ip nat inside source static udp 192.168.71.250 63540 interface Virtual-PPP1 63540
!
ip access-list extended in_filt
permit icmp any any
permit tcp host *********** any eq telnet
permit tcp host *********** any eq telnet
permit tcp any any eq 63530
permit tcp any eq www ftp ftp-data 443 8080 any established
permit udp any eq ntp any eq ntp
permit udp any any eq 63540
permit udp any any eq isakmp
permit udp any eq domain any eq domain
permit esp any any
evaluate traffic 
deny   ip any any
ip access-list extended lan
permit ip 192.168.71.248 0.0.0.7 195.14.50.0 0.0.0.255
permit ip 192.168.71.248 0.0.0.7 10.0.0.0 0.255.255.255
permit ip 192.168.71.248 0.0.0.7 85.21.151.0 0.0.0.255
permit ip 192.168.71.248 0.0.0.7 85.21.79.0 0.0.0.255
permit ip 192.168.71.248 0.0.0.7 83.102.146.96 0.0.0.31
permit ip 192.168.71.248 0.0.0.7 host 85.21.52.254
permit ip 192.168.71.248 0.0.0.7 host 85.21.88.130
permit ip 192.168.71.248 0.0.0.7 85.21.90.0 0.0.1.255
permit ip 192.168.71.248 0.0.0.7 host 85.21.138.211
permit ip 192.168.71.248 0.0.0.7 host 85.21.138.212
permit ip 192.168.71.248 0.0.0.7 host 89.179.144.102
permit udp 192.168.71.248 0.0.0.7 eq ntp host 195.14.40.141
ip access-list extended out_filt
permit tcp any any reflect traffic
permit esp any any reflect traffic
permit udp any any reflect traffic
permit icmp any any reflect traffic
deny   ip any any log-input
ip access-list extended wan
deny   ip 192.168.71.248 0.0.0.7 172.16.31.0 0.0.0.255
permit ip 192.168.71.248 0.0.0.7 any
!
access-list 23 permit ***********
access-list 23 permit ***********
access-list 23 permit ***********
access-list 23 permit ***********
!
!
control-plane
!
!
line con 0
password 7 ************
no modem enable
line aux 0
line vty 0 4
access-class 23 in
password 7 ************
login
!
scheduler max-task-time 5000
ntp clock-period 17174955
ntp server 195.14.40.141 source FastEthernet4
ntp server 138.96.64.10 source Virtual-PPP1 prefer
end

 

Я его почистил немного, если удалил чего лишнего, то извиняй. :D На портах tcp 63530 и udp 63540 у меня живет eMule

 

Да и вот ещё что, корбина вчера переселила почти все l2tp сервера в одну подсеть 85.21.17.0.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо за инфо, я сохранил на всякий случай!

:)

 

 

Я уже настроил (с чужой помощью)

Как выяснилось, я про***хался из-за глюка (или фичи)

что если на FE4 адрес по dhcp - то роутинг нифига не работает :(

 

Сейчас сижу по воздуху,

тестирую скорость....

 

ps. форум sysadmins.ru рулит!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

У меня на 871W L2TP заработало только после замены дефолтового IOS на advanced ip services ver. 12.4(15)T1

 

P.S. Для работы multicast IPTV необходимо настроить PIM на интерфейсах и ip igmp helper-adress на VLAN1.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

P.S. Для работы multicast IPTV необходимо настроить PIM на интерфейсах и ip igmp helper-adress на VLAN1.

 

 

Сорри, можно с этого места поподробнее? :D

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ниже минимальная конфигурация "типо" igmp proxy, которого собственно нет в IOS. чтобы не извращаться с конфигурацией IP PIMа.

 

interface FastEthernet4
ip pim neighbor-filter 4
ip pim dense-mode

interface Vlan1
ip pim dense-mode
ip igmp helper-address <GW IP recieved via DHCP>

access-list 4 deny   any

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ниже минимальная конфигурация "типо" igmp proxy, которого собственно нет в IOS. чтобы не извращаться с конфигурацией IP PIMа.

 

 

 

А в случае если igmp proxy присутствует?

 

У меня 1811 - 12.4.15T1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

я же написал выше - в обывательском понимании igmp proxy в Cisco IOS отсутствует как класс. Есть просто набор команд которые заставят маршрутизатор форвардить igmp джойны и ливы.

 

Да, совсем забыл, для корректной отработки RPF абсолютно необхоим статический mroute до источников вещания стримов:

 

ip mroute 85.21.91.0 255.255.255.0 <GW IP recieved via DHCP>

 

ip mroute 172.16.16.0 255.255.255.0 <GW IP recieved via DHCP>

 

ну и ессно не забыть про ip multicast-routing ;)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

я же написал выше - в обывательском понимании igmp proxy в Cisco IOS отсутствует как класс. Есть просто набор команд которые заставят маршрутизатор форвардить igmp джойны и ливы.

 

 

Спасибо. Заработало..

Только при прямом подключении приставки все идеально, через рутер картинка рассыпается, затыкается звук, прочие гадости и на приставке, и на компе :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Возможно проблема в связана с параметрами speed и duplex порта к которому подключена ТВ приставка. Попробуйте поиграть с ними.

 

Покажете конфигурацию интерфейса и sh int

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Возможно проблема в связана с параметрами speed и duplex порта к которому подключена ТВ приставка. Попробуйте поиграть с ними.

 

Покажете конфигурацию интерфейса и sh int

 

 

interface FastEthernet8
no cdp enable
spanning-tree portfast


FastEthernet8 is up, line protocol is up 
 Hardware is FastEthernet, address is 0007.0e41.651e (bia 0007.0e41.651e)
 MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 
 reliability 255/255, txload 5/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive set (10 sec)
 Full-duplex, 100Mb/s
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input never, output never, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 3000 bits/sec, 1 packets/sec
 5 minute output rate 2277000 bits/sec, 204 packets/sec
 78651 packets input, 33082130 bytes, 0 no buffer
 Received 166 broadcasts, 0 runts, 0 giants, 0 throttles
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
 0 input packets with dribble condition detected
 18686159 packets output, 3972584071 bytes, 0 underruns
 0 output errors, 0 collisions, 1 interface resets
 0 babbles, 0 late collision, 0 deferred
 0 lost carrier, 0 no carrier
 0 output buffer failures, 0 output buffers swapped out

 

Проблема с дерганьем и кваканьем по всей видимости была от перегруженного магистрального канала. После его расширения стало существенно лучше. Но, переодически возникают замерзания картинки или же ее дерганья с кваканьем. Повторюсь, такое возникает крайне редко.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да, бывает, только до конца пока не ясно с чем связаны эти замирания. Либо действительно магистрали колбасит, либо саму платформу MS IPTV.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да, бывает, только до конца пока не ясно с чем связаны эти замирания. Либо действительно магистрали колбасит, либо саму платформу MS IPTV.

Корбина уверяет, что проблема с подпиской на IGMP группы.

 

У меня другая беда. Есть телевизор, умеет видеть шары с медиа контентом. Так при включенной приставке, он не видит ни одной шары. Стоит выключить приставку, как он тут же снова видит все...

Придется его в другой VLAN перебрасывать...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В мысле проблемы с подпиской? IGMP-таймеры срабатывают? Возможно...Но это по любому напрямую связано с транспортной сетью.

 

 

Что это за шары? Что-то типа VoD? А приставка умеет видеть эти шары?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В мысле проблемы с подпиской? IGMP-таймеры срабатывают? Возможно...Но это по любому напрямую связано с транспортной сетью.

Что это за шары? Что-то типа VoD? А приставка умеет видеть эти шары?

 

Не... Откуда там VoD... :)

Просто Media Sharing можно с помощью меда плеера расшарить, либо с утилиткой от Филипса.

Приставка их не видит. Но сбивает телевизор с пути истинного.

Убрал телевизор и ком с ресурсами в другой VLAN, все заработало...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте!

Я только не давно подключился к Корбине. Для работы использую роутер cisco 851W-К9, здесь же в форуме нашел инструкцию по его настройке, настроил, работает, но... Установить соединение он может только с одним сервером Корбины, а именно с 85.21.0.255, который выдает маршрут на 85.21.0.254. Со всеми другими серверами соединение устанавливается, но через минуту разрывается, потому что они выдают маршрут на себя самого (т.е. если подключиться к серверу 85.21.0.15, то он выдаст дефолтный маршрут на 85.21.0.15 и через минуту по тайм-ауту, соединение разорвется).

Местные гуру или просто кто знает, как это победить?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте!

Я только не давно подключился к Корбине. Для работы использую роутер cisco 851W-К9, здесь же в форуме нашел инструкцию по его настройке, настроил, работает, но... Установить соединение он может только с одним сервером Корбины, а именно с 85.21.0.255, который выдает маршрут на 85.21.0.254. Со всеми другими серверами соединение устанавливается, но через минуту разрывается, потому что они выдают маршрут на себя самого (т.е. если подключиться к серверу 85.21.0.15, то он выдаст дефолтный маршрут на 85.21.0.15 и через минуту по тайм-ауту, соединение разорвется).

Местные гуру или просто кто знает, как это победить?

 

Приветствую.

Сдается мне ты чегото вообще не туда полез. 85.21.0.15 это vpn.corbina.ru, а тебе надо l2pt.corbina.ru читай 85.21.0.255. Разницу улавливаешь? Т.е первый работает по pptp протоколу, который циска пассроутит(может являться шлюзом для этого протокола), но не поддерживает. А вот второй сервак работает по l2tp протоколу, вот он циской поддерживается. И потом почему ты решил, что соединение с 85.21.0.15 вообще устанавливается? Скорее циска ждет запроса username и не дождавшись просто закрывает соединение. Ты бы хоть листинги какие представил.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сервера vpn.corbina.net тоже поддерживают протокол l2tp

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сервера vpn.corbina.net тоже поддерживают протокол l2tp

 

:) Ну тады ой :( Даже догадок строить нехочу. Собственно конфиг в студию, как и логи сессий.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Приветствую.

Сдается мне ты чегото вообще не туда полез. 85.21.0.15 это vpn.corbina.ru, а тебе надо l2pt.corbina.ru читай 85.21.0.255. Разницу улавливаешь? Т.е первый работает по pptp протоколу, который циска пассроутит(может являться шлюзом для этого протокола), но не поддерживает. А вот второй сервак работает по l2tp протоколу, вот он циской поддерживается. И потом почему ты решил, что соединение с 85.21.0.15 вообще устанавливается? Скорее циска ждет запроса username и не дождавшись просто закрывает соединение. Ты бы хоть листинги какие представил.

Я хоть и не общался с таким оборудованием раньше, но читать-то я умею и выводы делать на основе прочитанного тоже.

Сейчас у меня под рукой нет ни одного лога сессии, но всегда последней записью в нем является запись типа "Install route to 85.21.0.15", вот после того как он этот маршрут себе проинсталит, этот адрес 85.21.0.15 перестает быть доступен (я его пинговал для проверки во время установления туннеля, пока virtual-ppp1 - down, сервер пингуется, когда up - нет и маршрута к нему роутер не знает). И соединение с выданным публичным адресом (а я его успешно пингую) висит ровно минуту, после чего по таймауту разрывается.

torrr, вы, как я понимаю, в теме. Помогите пожалуйста разобраться с этой непоняткой. А то учитывая выкрутасы Корбины (сервера l2tp, как писал Олег, шейпят трафик и на высокоскоростных тарифах не дают скорость больше 1 Мб/сек), есть шанс остаться с неработающим через роутер интернетом...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
:D Ну тады ой :( Даже догадок строить нехочу. Собственно конфиг в студию, как и логи сессий.

Вот, собственно, лог сессии:

May 12 21:14:17.191: %LINK-3-UPDOWN: Interface Virtual-PPP1, changed state to up
May 12 21:14:17.195: Vp1 PPP: Using vpn set call direction
May 12 21:14:17.195: Vp1 PPP: Treating connection as a callout
May 12 21:14:17.195: Vp1 PPP: Session handle[52000036] Session id[93]
May 12 21:14:17.195: Vp1 PPP: Phase is ESTABLISHING, Active Open
May 12 21:14:17.195: Vp1 PPP: No remote authentication for call-out
May 12 21:14:17.195: Vp1 LCP: O CONFREQ [Closed] id 206 len 10
May 12 21:14:17.195: Vp1 LCP:	MagicNumber 0x39A89537 (0x050639A89537)
May 12 21:14:19.203: Vp1 LCP: Timeout: State REQsent
May 12 21:14:19.203: Vp1 LCP: O CONFREQ [REQsent] id 207 len 10
May 12 21:14:19.203: Vp1 LCP:	MagicNumber 0x39A89537 (0x050639A89537)
May 12 21:14:19.207: Vp1 LCP: I CONFREQ [REQsent] id 1 len 19
May 12 21:14:19.207: Vp1 LCP:	MRU 1460 (0x010405B4)
May 12 21:14:19.207: Vp1 LCP:	AuthProto CHAP (0x0305C22305)
May 12 21:14:19.207: Vp1 LCP:	MagicNumber 0x44C66421 (0x050644C66421)
May 12 21:14:19.207: Vp1 LCP: O CONFNAK [REQsent] id 1 len 8
May 12 21:14:19.207: Vp1 LCP:	MRU 1500 (0x010405DC)
May 12 21:14:19.207: Vp1 LCP: I CONFACK [REQsent] id 207 len 10
May 12 21:14:19.207: Vp1 LCP:	MagicNumber 0x39A89537 (0x050639A89537)
May 12 21:14:19.211: Vp1 LCP: I CONFREQ [ACKrcvd] id 2 len 19
May 12 21:14:19.211: Vp1 LCP:	MRU 1500 (0x010405DC)
May 12 21:14:19.211: Vp1 LCP:	AuthProto CHAP (0x0305C22305)
May 12 21:14:19.211: Vp1 LCP:	MagicNumber 0x44C66421 (0x050644C66421)
May 12 21:14:19.211: Vp1 LCP: O CONFACK [ACKrcvd] id 2 len 19
May 12 21:14:19.211: Vp1 LCP:	MRU 1500 (0x010405DC)
May 12 21:14:19.211: Vp1 LCP:	AuthProto CHAP (0x0305C22305)
May 12 21:14:19.211: Vp1 LCP:	MagicNumber 0x44C66421 (0x050644C66421)
May 12 21:14:19.211: Vp1 LCP: State is Open
May 12 21:14:19.211: Vp1 PPP: Phase is AUTHENTICATING, by the peer
May 12 21:14:19.239: Vp1 CHAP: I CHALLENGE id 1 len 27 from "bras15"
May 12 21:14:19.243: Vp1 CHAP: Using hostname from interface CHAP
May 12 21:14:19.243: Vp1 CHAP: Using password from interface CHAP
May 12 21:14:19.243: Vp1 CHAP: O RESPONSE id 1 len 30 from "roug"
May 12 21:14:19.307: Vp1 CHAP: I SUCCESS id 1 len 4
May 12 21:14:19.307: Vp1 PPP: Phase is FORWARDING, Attempting Forward
May 12 21:14:19.307: Vp1 PPP: Queue IPCP code[1] id[1]
May 12 21:14:19.311: Vp1 PPP SSS: forwarding request
May 12 21:14:19.311: Vp1 PPP SSS: Receive SSS-Mgr Connect-Local
May 12 21:14:19.311: Vp1 PPP: Phase is ESTABLISHING, Finish LCP
May 12 21:14:19.311: Vp1 PPP: Phase is UP
May 12 21:14:19.311: Vp1 IPCP: O CONFREQ [Closed] id 1 len 10
May 12 21:14:19.311: Vp1 IPCP:	Address 0.0.0.0 (0x030600000000)
May 12 21:14:19.311: Vp1 PPP: Process pending ncp packets
May 12 21:14:19.311: Vp1 IPCP: Redirect packet to Vp1
May 12 21:14:19.311: Vp1 IPCP: I CONFREQ [REQsent] id 1 len 10
May 12 21:14:19.311: Vp1 IPCP:	Address 85.21.0.15 (0x03065515000F)
May 12 21:14:19.311: Vp1 IPCP: O CONFACK [REQsent] id 1 len 10
May 12 21:14:19.311: Vp1 IPCP:	Address 85.21.0.15 (0x03065515000F)
May 12 21:14:19.315: Vp1 IPCP: I CONFNAK [ACKsent] id 1 len 10
May 12 21:14:19.315: Vp1 IPCP:	Address 89.178.130.236 (0x030659B282EC)
May 12 21:14:19.315: Vp1 IPCP: O CONFREQ [ACKsent] id 2 len 10
May 12 21:14:19.315: Vp1 IPCP:	Address 89.178.130.236 (0x030659B282EC)
May 12 21:14:19.319: Vp1 IPCP: I CONFACK [ACKsent] id 2 len 10
May 12 21:14:19.319: Vp1 IPCP:	Address 89.178.130.236 (0x030659B282EC)
May 12 21:14:19.319: Vp1 IPCP: State is Open
May 12 21:14:19.323: Vp1 IPCP: Install negotiated IP interface address 89.178.130.236
May 12 21:14:19.327: Vp1 IPCP: Install default route thru 85.21.0.15
May 12 21:14:19.327: Vp1 IPCP: Install route to 85.21.0.15

После чего таблица маршрутизации получает запись о дефолтном маршруте в 85.21.0.15 и все... интернету нема.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну я попробую помоч, на сколько знаний хватит. :P Во первых, а зачем все же ты хочешь логинится к 85.21.0.15 ? Мне просто интересно. Чем 85.21.0.255 не устраивает? Хотя конечно адрес 85.21.0.255 режет глаз, это вроде как бродкаст адрес и хостам они не назначаются. Почему собственно в таблице роутинга и пишется директ коннект(прамое подключение) интерфейса Virtual-PPP1 на 85.21.0.254. А обращаясь к 85.21.0.15 адресу, ты обращаешься непосредственно на сервер, поэтому и роутинг пишется соответствующий. Вообще я бы на твоем месте поигрался бы с mtu(читай размер пакета), это знаешь мощная штука, похоже что все беды у тебя от нее. У меня стоит 1032, поиграйся должно помочь. Если непонятки какие спрашивай. И дай все же конфиг, а то это похоже на гадание на кофейной гуще.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну я попробую помоч, на сколько знаний хватит. ;) Во первых, а зачем все же ты хочешь логинится к 85.21.0.15 ? Мне просто интересно. Чем 85.21.0.255 не устраивает? Хотя конечно адрес 85.21.0.255 режет глаз, это вроде как бродкаст адрес и хостам они не назначаются. Почему собственно в таблице роутинга и пишется директ коннект(прамое подключение) интерфейса Virtual-PPP1 на 85.21.0.254. А обращаясь к 85.21.0.15 адресу, ты обращаешься непосредственно на сервер, поэтому и роутинг пишется соответствующий. Вообще я бы на твоем месте поигрался бы с mtu(читай размер пакета), это знаешь мощная штука, похоже что все беды у тебя от нее. У меня стоит 1032, поиграйся должно помочь. Если непонятки какие спрашивай. И дай все же конфиг, а то это похоже на гадание на кофейной гуще.

Спасибо!

Вот конфиг:

Current configuration : 4467 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname roug
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 0 cisco
!
no aaa new-model
!
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool sdm-pool
import all
network 10.10.10.0 255.255.255.248
default-router 10.10.10.1
lease 0 2
!
ip domain lookup
ip domain name corbina.net
!
l2tp-class corbina
!
username roug privilege 15 secret 0 password
archive
log config
hidekeys
!
!
pseudowire-class p1
encapsulation l2tpv2
protocol l2tpv2 corbina
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface FastEthernet4
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
no cdp enable
!
interface Virtual-PPP1
description Corbina VPN
ip address negotiated
ip nat outside
ip virtual-reassembly
no cdp enable
ppp authentication chap callin
ppp chap hostname corbina
ppp chap password 0 corbina
pseudowire 85.21.0.15 10 pw-class p1
!
interface Vlan1
ip address 10.10.10.1 255.255.255.248
ip mtu 1072
ip tcp adjust-mss 1032
ip nat inside
!
ip nat inside source list lan interface FastEthernet4 overload
ip nat inside source list wan interface Virtual-PPP1 overload
!
ip route 10.0.0.0 255.0.0.0 dhcp
ip route 89.179.135.67 255.255.255.255 dhcp
ip route 85.21.79.0 255.255.255.0 dhcp
ip route 85.21.90.0 255.255.254.0 dhcp
ip route 195.14.50.1 255.255.255.255 dhcp
ip route 195.14.50.16 255.255.255.255 dhcp
ip route 195.14.50.21 255.255.255.255 dhcp
ip route 195.14.50.26 255.255.255.255 dhcp
ip route 195.14.50.93 255.255.255.255 dhcp
ip route 83.102.231.32 255.255.255.240 dhcp
ip route 85.21.108.16 255.255.255.240 dhcp
ip route 78.107.69.98 255.255.255.255 dhcp
ip route 85.21.88.130 255.255.255.255 dhcp
ip route 85.21.138.208 255.255.255.240 dhcp
ip route 85.21.52.254 255.255.255.255 dhcp
ip route 83.102.146.96 255.255.255.224 dhcp
ip route 78.107.23.0 255.255.255.0 dhcp
ip route 85.21.72.80 255.255.255.240 dhcp
ip route 85.21.0.255 255.255.255.255 dhc
!
no ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip access-list extended wan
permit ip 10.10.10.0 0.0.0.7 any
!
ip access-list extended lan
permit ip 10.10.10.0 0.0.0.7 10.0.0.0 0.255.255.255
permit ip 10.10.10.0 0.0.0.7 host 89.179.135.67
permit ip 10.10.10.0 0.0.0.7 195.14.50.0 0.0.0.128
permit ip 10.10.10.0 0.0.0.7 85.21.72.80 0.0.0.15
!
no cdp run
!
control-plane
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
privilege level 15
login local
transport input ssh
!
scheduler max-task-time 5000
!
end

А есть гарантии, что Корбина не приведет ВСЕ свои сервера к единой схеме работы? Или что 85.21.0.255 не исчезнет? :-) И мне просто не понятно почему оно так не работает, хотя должно.

mtu у меня было настроено как рекомендовано было здесь же на форуме. Пробовал поставить как у тебя, не помогло.

torr, а попробуйте сами подключиться любому серверу vpn.corbina.net может быть у вас получится, а я что-то делаю не так?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо!

torr, а попробуйте сами подключиться любому серверу vpn.corbina.net может быть у вас получится, а

 

:) Хотел бы да незнаю когда смогу. К компьютеру вечером не подойти,пока сынишку спать не уложу. А потом жена в интернете торчит :) и за всякие посягательства на интернет расстрел на месте. Может быть в выходные попробую. ;)

 

Теперь по существу. Включи service password-encryption , чтобы пароли в открытом виде не хранились, не панацея конечно, но все же. ip domain lookup имеет смысл если поднят днс сервер на циске, ну и для отладки. Поэтому если отладился и днс сервер не включил, выключи. Назначенные циске по dhcp днс сервера и так форварднутся тебе(при условии, что ты сам у циски по dhcp адрес получаешь). В описании pseudowire-class добавь в конце строчку ip local interface FastEthernet4, оно конечно необязательно, но если порыцца на сайте кошек, в мануалах присутствует. Посему я у себя добавил. Теперь описание mtu, убери ip mtu, достаточно только ip tcp adjust-mss - оно описывает размер транзитных пакетов. Иначе может быть полная фигня, у этих команд может быть разный приоритет. Дальше, где у тебя в роутинге ip route 0.0.0.0 0.0.0.0 Virtual-PPP1 ? Конешно оно работать не буит. Можно и без этой строчки жить, но как ты будешь ползать в интернет - загадка :( . И потом роуты, если лень можно не прописывать. Они получаются динамически по dhcp, и если потом куда-то не можешь зайти, можно прописать недостающие. И на последок, пропиши акцесс для интерфейсов только для себя. А то у тебя и vty открыт, и по http доступится можно. :D Вообщем отпишись о результатах.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

:D Хотел бы да незнаю когда смогу. К компьютеру вечером не подойти,пока сынишку спать не уложу. А потом жена в интернете торчит :D и за всякие посягательства на интернет расстрел на месте. Может быть в выходные попробую. ;)

 

Теперь по существу. Включи service password-encryption , чтобы пароли в открытом виде не хранились, не панацея конечно, но все же. ip domain lookup имеет смысл если поднят днс сервер на циске, ну и для отладки. Поэтому если отладился и днс сервер не включил, выключи. Назначенные циске по dhcp днс сервера и так форварднутся тебе(при условии, что ты сам у циски по dhcp адрес получаешь). В описании pseudowire-class добавь в конце строчку ip local interface FastEthernet4, оно конечно необязательно, но если порыцца на сайте кошек, в мануалах присутствует. Посему я у себя добавил. Теперь описание mtu, убери ip mtu, достаточно только ip tcp adjust-mss - оно описывает размер транзитных пакетов. Иначе может быть полная фигня, у этих команд может быть разный приоритет. Дальше, где у тебя в роутинге ip route 0.0.0.0 0.0.0.0 Virtual-PPP1 ? Конешно оно работать не буит. Можно и без этой строчки жить, но как ты будешь ползать в интернет - загадка :D . И потом роуты, если лень можно не прописывать. Они получаются динамически по dhcp, и если потом куда-то не можешь зайти, можно прописать недостающие. И на последок, пропиши акцесс для интерфейсов только для себя. А то у тебя и vty открыт, и по http доступится можно. :D Вообщем отпишись о результатах.

Я обязательно попробую добавить ip local interface FastEthernet4, когда доберусь до дому. :)

Этот маршрут ip route 0.0.0.0 0.0.0.0 Virtual-PPP1 я убрал, во время экспериментов и забыл вернуть его обратно когда постил конфиг :) Дело не внем. Его у меня успешно заменяет:

Virtual-PPP1
ppp ipcp route default
ppp ipcp dns accept

собственно лог сессии снимал с этими настройками и там явно видно:

Vp1 IPCP: Install default route thru 85.21.0.15

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В общем ни к чему позитивному мои ковыряния не привели... ;)

Вот текущая версия конфига:

Current configuration : 4467 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname roug

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

enable secret 0 cisco

!

no aaa new-model

!

ip cef

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool sdm-pool

import all

network 10.10.10.0 255.255.255.248

default-router 10.10.10.1

lease 0 2

!

ip domain lookup

ip domain name corbina.net

!

l2tp-class corbina

!

username roug privilege 15 secret 0 password

archive

log config

hidekeys

!

!

pseudowire-class p1

encapsulation l2tpv2

protocol l2tpv2 corbina

ip local interface FastEthernet4

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Dot11Radio0

no ip address

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface FastEthernet4

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

no cdp enable

!

interface Virtual-PPP1

description Corbina VPN

ip address negotiated

ip nat outside

ip virtual-reassembly

no cdp enable

ppp authentication chap callin

ppp ipcp route default

ppp ipcp dns accept

ppp chap hostname corbina

ppp chap password 0 corbina

pseudowire 85.21.0.15 10 pw-class p1

!

interface Vlan1

ip address 10.10.10.1 255.255.255.248

ip mtu 1072

ip tcp adjust-mss 1032

ip nat inside

!

ip nat inside source list lan interface FastEthernet4 overload

ip nat inside source list wan interface Virtual-PPP1 overload

!

ip route 10.0.0.0 255.0.0.0 dhcp

ip route 89.179.135.67 255.255.255.255 dhcp

ip route 85.21.79.0 255.255.255.0 dhcp

ip route 85.21.90.0 255.255.254.0 dhcp

ip route 195.14.50.1 255.255.255.255 dhcp

ip route 195.14.50.16 255.255.255.255 dhcp

ip route 195.14.50.21 255.255.255.255 dhcp

ip route 195.14.50.26 255.255.255.255 dhcp

ip route 195.14.50.93 255.255.255.255 dhcp

ip route 83.102.231.32 255.255.255.240 dhcp

ip route 85.21.108.16 255.255.255.240 dhcp

ip route 78.107.69.98 255.255.255.255 dhcp

ip route 85.21.88.130 255.255.255.255 dhcp

ip route 85.21.138.208 255.255.255.240 dhcp

ip route 85.21.52.254 255.255.255.255 dhcp

ip route 83.102.146.96 255.255.255.224 dhcp

ip route 78.107.23.0 255.255.255.0 dhcp

ip route 85.21.72.80 255.255.255.240 dhcp

ip route 85.21.0.255 255.255.255.255 dhc

!

no ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip access-list extended wan

permit ip 10.10.10.0 0.0.0.7 any

!

ip access-list extended lan

permit ip 10.10.10.0 0.0.0.7 10.0.0.0 0.255.255.255

permit ip 10.10.10.0 0.0.0.7 host 89.179.135.67

permit ip 10.10.10.0 0.0.0.7 195.14.50.0 0.0.0.128

permit ip 10.10.10.0 0.0.0.7 85.21.72.80 0.0.0.15

!

no cdp run

!

control-plane

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

privilege level 15

login local

transport input ssh

!

scheduler max-task-time 5000

!

end

Если заменить 85.21.0.15 на 85.21.0.255, то все начинает работать. Обратная замена приводит к неработоспособности интернента из-за недостижимости публичного шлюза. Спасибо, torr , что откликнулся. Жду помощи или дельного совета.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Приветствую. Извиняюсь что пропал. Собственно посоветовать особо нечего. Кроме того, что проверить соединение с 85.21.0.15 по l2tp из windows. Если будет работать, то можно будет эксперементировать. У меня просто нет времени. Если из мастдая ничего не заработает то и разговаривать не о чем. С другой стороны, если 85.21.0.255 работает, то почему бы не оставить. Для детальной отладки, неплохо бы было посмотреть что происходит на сервере, но по понятным причинам, этого сделать не получится. Поэтому посоветовать больше ничего не смогу. Удачи.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Приветствую. Извиняюсь что пропал. Собственно посоветовать особо нечего. Кроме того, что проверить соединение с 85.21.0.15 по l2tp из windows. Если будет работать, то можно будет эксперементировать. У меня просто нет времени. Если из мастдая ничего не заработает то и разговаривать не о чем. С другой стороны, если 85.21.0.255 работает, то почему бы не оставить. Для детальной отладки, неплохо бы было посмотреть что происходит на сервере, но по понятным причинам, этого сделать не получится. Поэтому посоветовать больше ничего не смогу. Удачи.

Спасибо.

Да, виндовый клиент устанавливает соединение со всеми серверами. :)

Для детальной отладки, неплохо бы было посмотреть что происходит на сервере, но по понятным причинам, этого сделать не получится.
А чем это поможет? Проблема в настройке роутера, насколько я понимаю.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А чем это поможет? Проблема в настройке роутера, насколько я понимаю.

 

Ну не скажи, иногда только в логе на сервере и можно вычислить почему не работает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах