Архивировано

Эта тема находится в архиве и закрыта для публикации сообщений.

Knoppix

Quake на FreeBSD

Рекомендованные сообщения

Решил на FreeBSD поиграть в Quake3,

поставил его из портов. Первая проблема с которой я столкнулся, он не находил default.cfg.

Как выяснилось надо было скачать фаил PAK0.PK3. и вставить его в baseq3.

Всё бы ничего, только вот ещё одна проблема:

quake3

Q3 1.32b freebsd-i386 Aug 11 2007

----- FS_Startup -----

Current search path:

/root/.q3a/baseq3

/usr/local/lib/quake3/baseq3

/usr/local/share/quake3/baseq3/pak8.pk3 (9 files)

/usr/local/share/quake3/baseq3/pak7.pk3 (4 files)

/usr/local/share/quake3/baseq3/pak6.pk3 (64 files)

/usr/local/share/quake3/baseq3/pak5.pk3 (7 files)

/usr/local/share/quake3/baseq3/pak4.pk3 (272 files)

/usr/local/share/quake3/baseq3/pak3.pk3 (4 files)

/usr/local/share/quake3/baseq3/pak2.pk3 (148 files)

/usr/local/share/quake3/baseq3/pak1.pk3 (26 files)

/usr/local/share/quake3/baseq3/PAK0.PK3 (3539 files)

/usr/local/share/quake3/baseq3

quake3/baseq3

 

----------------------

4073 files in pk3 files

execing default.cfg

couldn't exec q3config.cfg

couldn't exec autoexec.cfg

Hunk_Clear: reset the hunk ok

 

------- Input Initialization -------

------------------------------------

----- Client Initialization -----

----- Initializing Renderer ----

-------------------------------

----- Client Initialization Complete -----

----- R_Init -----

...loading libGL.so.1: Initializing OpenGL display

...setting mode 3: 640 480

Xlib: connection to ":0.0" refused by server

Xlib: No protocol specified

 

Error couldn't open the X display

...WARNING: could not set the given mode (3)

----- CL_Shutdown -----

RE_Shutdown( 1 )

-----------------------

----- CL_Shutdown -----

-----------------------

Sys_Error: GLimp_Init() - could not load OpenGL subsystem

 

 

Как я понимаю ему надо OpenGL.

Видяха у меня Geforce 6100 nvidea 410.

По дэфолту фря не ставит ни 3dfx ни OpenGL. Надо поставить специальный драйвер от nvidea. На их сайте он есть, всё бы ничего но вот только там для Linux дрова и для FreeBSD ( но только под XFree86 )

Неужели под X11 нету дров?

может я что то не понимаю?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот первая ошибка:

Xlib: connection to ":0.0" refused by server

Xlib: No protocol specified

 

Проблема не в OpenGL, а в том, что он не может к иксам подконнектиться даже.

 

> Current search path:

> /root/.q3a/baseq3

 

Под рутом что ли сидишь?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

У меня нативный q3 под линуксом не работал со звуком - помог вариант с ioquake3.org - там есть вариант и под солярис и под линукс и под netbsd и freebsd !установи и перепиши все файлы из папки виндового q3 в папку установки или наоборот!если поподробнее то спрашивай хотя я не имел дело с bsd

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ты вообще под X'ами запускаешь? :P

Под Linux ставил, у меня все бегало, под BSD тоже опыта не имею, к сожалению.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах