Mizanthrope

Настройка vpn-подключения в Gentoo. Gentoo way

Рекомендованные сообщения

2mih4i1

Вообще у тебя достаточно старая версия конфига, лучше проапдейтить до текущей.

 

>for vpnaddr in $(host l2tp.corbina.net | awk '{ print $NF }'); do route add $vpnaddr gw $GATEWAY dev eth0; done;

>я хз зачем это в конфиге, но с этим все работало=)

>l2tp у нас вроде tp.ul.corbina.net (Ульяновск)

>http://help.corbina.ru/internet/techinfo/

 

Тогда лучше прописать его.

 

>и еще такая бага была, впн только через ИП адрес соединял%)

>если впн не поднимать днс работает

 

>когда ррр0 поднимается с ошибкой то не хватает дефолтного маршута(тк интерфейс не поднят, а локальный удаляется)

 

для этого как раз в конфиге прописываются статические маршруты до всех нужных серверов, в том числе до днс.

 

>напишите/ткните носом

>в схему действий, что и для чего нужно

 

схема действий в принципе проста, если знать как и что ;)

при поднятии интерфейса в локалку прописываются все необходимые маршруты, затем поднимается vpn - все!

проблема с впн - у меня в комментариях - в корбине кривая топология, т.е. адрес впн-сервера совпадает с адресом шлюза по умолчанию, в результате чего автоматически создаваемый pppd маршрут смотрит в ppp0, а не в локалку, в винде я думаю это предусмотрено и проблем не возникает (там кстати так же прописываются все маршруты до всех локальных серверов).

у меня в скрипте для этого тоже предусмотрен обходной путь, кривой маршрут удаляется

VPN=`ifconfig | grep 'P-t-P' | awk '{print $3}' | awk -F: '{print $2}'`

route del $VPN dev ppp0

 

Удаление маршрута по умолчанию в локалку делается во избежание глюков (у кого-то встречались), да и вообще 2 разных маршрута по умолчанию как бы ни к чему.

 

>и почему такой гемор с линуксом?

>в винде тока адрес прописать и галку снять

 

в линуксе в общем-то тоже все просто :)

 

>роуты выведу позже

>в принципе по конфигу видно=)

>не поднимаются только с dev ppp0

>спасибо

 

Выведи еще /etc/resolv.conf до поднятия впн и после порпытки его поднять. Возможно у тебя автоматом прописываются днс, которые потом не могут распознать адрес vpn.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

вот=)

до

# /etc/init.d/net.eth0 start

...

 

# route -n

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

195.14.50.16 10.49.1.1 255.255.255.255 UGH 0 0 0 eth0

195.14.50.26 10.49.1.1 255.255.255.255 UGH 0 0 0 eth0

89.179.135.67 10.49.1.1 255.255.255.255 UGH 0 0 0 eth0

195.14.50.93 10.49.1.1 255.255.255.255 UGH 0 0 0 eth0

85.21.72.80 10.49.1.1 255.255.255.240 UG 0 0 0 eth0

10.49.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0

10.0.0.0 10.49.1.1 255.0.0.0 UG 0 0 0 eth0

127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

0.0.0.0 10.49.1.1 0.0.0.0 UG 0 0 0 eth0

 

некоторых маршрутов нехватает, тк их у нас нет=(

cat /etc/resolv.conf

# Generated by dhcpcd for interface eth0

search corbina.ru

nameserver 195.14.50.1

nameserver 195.14.50.21

 

после

 

# /etc/init.d/net.ppp0 start

...

 

# route -n

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

195.14.50.16 10.49.1.1 255.255.255.255 UGH 0 0 0 eth0

195.14.50.26 10.49.1.1 255.255.255.255 UGH 0 0 0 eth0

89.179.135.67 10.49.1.1 255.255.255.255 UGH 0 0 0 eth0

195.14.50.93 10.49.1.1 255.255.255.255 UGH 0 0 0 eth0

85.21.72.80 10.49.1.1 255.255.255.240 UG 0 0 0 eth0

10.49.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0

10.0.0.0 10.49.1.1 255.0.0.0 UG 0 0 0 eth0

127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

 

# cat /etc/resolv.conf

# Generated by dhcpcd for interface eth0

search corbina.ru

nameserver 195.14.50.1

nameserver 195.14.50.21

 

сейчас буду с конфигом развлекаться=)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Нет маршрутов до днс-серверов, используй последнюю версию конфигов, либо допиши в свой

route add 195.14.50.1 netmask 255.255.255.255 gw $GATEWAY

route add 195.14.50.21 netmask 255.255.255.255 gw $GATEWAY

 

И еще, у этих маршрутов маска неправильная, так не должно работать, 255.255.255.255 это маска хоста, а у тебя подсеть, судя по ключу -net

route add -net 195.14.50.16 netmask 255.255.255.255 gw $GATEWAY

route add -net 195.14.50.26 netmask 255.255.255.255 gw $GATEWAY

route add -net 89.179.135.67 netmask 255.255.255.255 gw $GATEWAY

 

p.s. лучше в техподдержке уточнить, какие днс правильные для твоего города, возможно, их вообще стоит прописать на автоматическое получение.

Изменено пользователем Mizanthrope

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

фигня какая то%)

днс вроде эти

иначе бы я сейчас не писал здесь=)

 

вот новый конфиг:

 

GATEWAY="10.49.1.1"

###----------------------------------------------###

dns_domain_lo="homenetwork"

 

config_eth0="dhcp"

modules="dhclient"

dhclient_eth0="-nw"

dns_servers_eth0="195.14.50.1 195.14.50.21"

dns_search_eth0="corbina.ru"

fallback_eth0="10.49.1.5 netmask 255.255.255.0"

 

###----------------------------------------------###

 

config_ppp0="ppp"

link_ppp0="pty 'pptp vpn.ul.corbina.net --nolaunchpppd --nobuffer --loglevel 0'"

username_ppp0='!!!!!!!!!!1'

password_ppp0='!!!!!!!!!!!!!'

pppd_ppp0="defaultroute lock noauth refuse-eap refuse-chap refuse-mschap nobsdcomp \

nopcomp noaccomp nodeflate persist maxfail 0 holdoff 10 lcp-echo-interval 60 lcp-echo-failure 10 password !!!!!!!!!!!!!"

 

preup() {

if [ "${IFACE}" = "ppp0" ]; then

/bin/mknod /dev/ppp c 108 0

route del default

fi

return 0

}

 

postup() {

if [ "${IFACE}" = "eth0" ]; then

# Адреса VPN-серверов берутся с DNS-сервера Корбины

for vpnaddr in $(host vpn.ul.corbina.net | awk '{ print $NF }'); do route add $vpnaddr gw $GATEWAY dev eth0; done;

for vpnaddr in $(host tp.ul.corbina.net | awk '{ print $NF }'); do route add $vpnaddr gw $GATEWAY dev eth0; done;

fi

 

if [ "${IFACE}" = "ppp0" ]; then

# Из-за того, что адрес VPN-сервера совпадает с адресом шлюза,

# создаваемый автоматически маршрут к VPN-серверу использует интерфейс ppp0, а не eth0, исправляем

VPN=`ifconfig | grep 'P-t-P' | awk '{print $3}' | awk -F: '{print $2}'`

route del $VPN dev ppp0

# Удаление шлюза по умолчанию в локалку и добавление шлюза по умолчанию в инет

route del default

route add default dev ppp0

fi

 

# Маршруты

route add -net 195.14.50.16 netmask 255.255.255.255 gw $GATEWAY

route add -net 195.14.50.26 netmask 255.255.255.255 gw $GATEWAY

route add -net 89.179.135.67 netmask 255.255.255.255 gw $GATEWAY

route add -net 10.0.0.0 netmask 255.0.0.0 gw $GATEWAY

route add -net 85.21.72.80 netmask 255.255.255.240 gw $GATEWAY

route add -net 195.14.50.93 netmask 255.255.255.255 gw $GATEWAY

route add -net 195.14.50.1 netmask 255.255.255.255 gw $GATEWAY

route add -net 195.14.50.21 netmask 255.255.255.255 gw $GATEWAY

 

return 0

}

 

postdown() {

# Добавление маршрута по умолчанию в локалку

if [ "${IFACE}" = "ppp0" ]; then

killall xl2tpd pppd

route add default dev eth0

fi

return 0

}

 

 

# Перед запуском vpn должен быть поднят eth0

depend_ppp0() {

need net.eth0

}

 

без -net он ругается=)

как бы это сеть из одного хоста=)

 

полтергейст

в лог ничего не пишет%)

 

завтра попробую через VPN L2TP

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вообще я добавляю маршруты вот так:

route add 195.14.50.22 dev eth0

или так

route add 195.14.50.22/32 dev eth0

 

Чтобы логировалось, убери параметр --loglevel 0 здесь

link_ppp0="pty 'pptp vpn.ul.corbina.net --nolaunchpppd --nobuffer --loglevel 0'"

 

и добавь сюда debug

pppd_ppp0="defaultroute lock noauth refuse-eap refuse-chap refuse-mschap nobsdcomp \

nopcomp noaccomp nodeflate persist maxfail 0 holdoff 10 lcp-echo-interval 60 lcp-echo-failure 10 password !!!!!!!!!!!!!"

 

>фигня какая то%)

>днс вроде эти

>иначе бы я сейчас не писал здесь=)

 

эти, но в маршрутах их не было

Изменено пользователем Mizanthrope

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ничего не помогает(

ладно хоть днс работать начал(маршруты прописал)

в логах ничего нет

l2tp не работает

 

интерфейс ррр0 вообще не поднимается

я хз что делать

мастдай меня погубит%)

как хоть посмотреть в чем дело?

 

спасибо

 

спасиба=)

почти разобрался

через л2тп работает

но в конфиге какой то баг(вроде, потом в процессе разберусь)

инет появился

 

следующий косяк:

в загрузке стоит net.ppp0, а стартует ррр1 О_о

мож разберусь

Изменено пользователем mih4i1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

*deleted*

Изменено пользователем Wapr Old

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

* sys-apps/openrc [ Masked ]

Latest version available: 9999

Latest version installed: [ Not Installed ]

Size of files: 0 kB

Homepage: http://roy.marples.name/openrc

Description: OpenRC manages the services, startup and shutdown of a host

License: BSD-2

 

Оно там реально нужно? Или можно заменить чем-нить?

 

И ещё, а почему адрес GW пишется жёстко, а не берётся из dhcp?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

2 Wapr Old

 

Оно там реально нужно? Или можно заменить чем-нить?

В sys-apps/baselayout версии 2, на которую я довольно давно перешел, система загрузки и синтаксис конфигов изменен к лучшему и система быстрее грузиться, что в свою очередь требует наличия sys-apps/openrc. У меня щас sys-apps/openrc-0.3.0-r1.

Но можно оставаться на baselayout-1, тогда и openrc не нужен, но тогда и синтаксис конфига должен быть старый.

 

И ещё, а почему адрес GW пишется жёстко, а не берётся из dhcp?

Не вижу способа узнать его в начале конфига. Ну и на моей памяти он менялся 1 раз за последние 3 года.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Привет всем!

город-Ульяновск=)

 

интернет нормально работал

на днях у корбиновцев полетела локалка

и впн сервер барахлил(

 

в винде сейчас все работает

в генте-нет(

 

 

 

конфиг такой

только вроде адреса были в виде ИП, т.к. ошибку выдавал

l2tp тоже не пашет(

ppp0 не поднимается

в логах ничего не было(

сейчас следующее

anon warn[pptp_gre_bind:pptp_gre.c:95]: connect: Network is unreachable

anon fatal[main:pptp.c:280]: Cannot bind GRE socket, aborting.

anon warn[pptp_gre_bind:pptp_gre.c:95]: connect: Network is unreachable

anon fatal[main:pptp.c:280]: Cannot bind GRE socket, aborting.

anon warn[pptp_gre_bind:pptp_gre.c:95]: connect: Network is unreachable

anon fatal[main:pptp.c:280]: Cannot bind GRE socket, aborting.

 

в чем/ком проблема?

 

маршруты до vpn tp сервера пропиши

 

2mih4i1

 

Со вчерашнего вечера корбина что-то опять намутила, как я понял, поменяли что-то на vpn-сервере, после чего сначала сыпались ошибки

pppd[20277]: MS-CHAPv2 Success packet is badly formed.

pppd[20277]: CHAP authentication failed

pppd[20277]: Connection terminated.

 

а теперь постоянно идет одна и та же ошибка, уже и сессию с их стороны прерывали, все одно и тоже

pppd[5584]: MS-CHAP authentication failed: E=691 Authentication failure

pppd[5584]: CHAP authentication failed

 

/etc/conf.d/net

 

"refuse-eap"

# "refuse-chap"

# "refuse-mschap"

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

2 wocsom

# "refuse-chap"

# "refuse-mschap"

 

это тут не при чем, должен работать ms-chap v2, сначала выяснилось, что действительно сессия у них повисла, потом покопавшись в инете, выяснил, что это глюк, который теперь есть и в корбине, а вернее в софте, который работает не по стандарту, там предлагали перекомпилять ppp, изменив кое-что в исходниках, но мне в это вдаваться было лень, просто перешел на l2tp.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Привет всем!

Подключаюсь по данному скрипту. Только одна небольшая проблемка после установления соединения по ppp0. Pppd продолжает ломится дальше, пытаясь подключить ppp1.

Вот кусок логов.

Oct 20 20:26:13 [pppd] Modem hangup
Oct 20 20:26:13 [pppd] Connection terminated.
Oct 20 20:26:13 [pppd] Couldn't allocate PPP unit 0 as it is already in use
Oct 20 20:26:13 [pppd] Using interface ppp1
Oct 20 20:26:13 [pppd] Connect: ppp1 <--> /dev/pts/0
Oct 20 20:26:13 [xl2tpd] init_network: Unable to bind socket: Address already in use. Terminating._
Oct 20 20:26:13 [pppd] Modem hangup
Oct 20 20:26:13 [pppd] Connection terminated.
Oct 20 20:26:13 [pppd] Couldn't allocate PPP unit 0 as it is already in use
Oct 20 20:26:13 [pppd] Using interface ppp1
Oct 20 20:26:13 [pppd] Connect: ppp1 <--> /dev/pts/0
Oct 20 20:26:13 [xl2tpd] init_network: Unable to bind socket: Address already in use. Terminating._

 

Не кто не в курсе как с этим бороться ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ну, я поборол это вот так: (rm /etc/init.d/net.ppp0 && ln -s /etc/init.d/xl2tpd /etc/init.d/net.ppp0) За неимением другого решения :))

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Привет всем!

Подключаюсь по данному скрипту. Только одна небольшая проблемка после установления соединения по ppp0. Pppd продолжает ломится дальше, пытаясь подключить ppp1.

Как вариант, поставить другой l2tpd, сам не пробовал.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

кстати, Мизантроп, у тебя в роутах ошибка... Если брать айпишник по диашсипи, то как минимум на три роута ругается... надо что-то делать. Я раньше не брал по диашсипи, а со статикой сидел, а тут вот перешел на Ъ-вей, и заметил.... Надо как-то отказаться от роутов по диашсипи :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Не обращал внимания но у меня в логах такая же проблема что и у Werebear.

 

Как решить не знаю :)

 

Werebear - ты как-то продвинулся в решении данного косяка?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ALEX.inf, у меня тоже была эта проблема. По сути она лишь место в логах засоряет, но все же, если как меня сильно напрягает - я уже подсказал решение данного вопроса. Пусть и не совсем Дженту-вей, зато эффективно (тогда, правда, и настройки ppp0, правда, в net.conf оказываются ненужны, зато все нормально соединяется).

 

ну, я поборол это вот так: (rm /etc/init.d/net.ppp0 && ln -s /etc/init.d/xl2tpd /etc/init.d/net.ppp0) За неимением другого решения smile.gif)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот так более дженту-вейно. Да и проблемы с двойным подключением нет.

 

cat /etc/conf.d/net

config_ppp0=( "ppp" )
link_ppp0="/dev/ppp"

preup() {
if [ "${IFACE}" = "ppp0" ]; then
	/etc/init.d/xl2tpd start
fi
return 0
}

predown() {
if [ "${IFACE}" = "ppp0" ]; then
	XL2TPD_PID=`cat /var/run/xl2tpd.pid`
	PPPD_PID=`ps -ef | awk -v xl2tpd_pid=${XL2TPD_PID} '\$3 == xl2tpd_pid {print \$2}'`
	kill -1 ${PPPD_PID}
	/etc/init.d/xl2tpd stop
	kill -9 ${PPPD_PID}
fi
return 0
}

 

 

cat /etc/ppp/ip-up.d/60-corbina.sh

#!/bin/sh

if [ "$1" = "ppp0"  ]; then
/sbin/ip ro del $5
fi

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

потестим, вот только вопрос, зачем вот это:

config_ppp0=( "ppp" )

link_ppp0="/dev/ppp"

если есть вот это

/etc/init.d/xl2tpd start

?

Изменено пользователем Ским

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
потестим, вот только вопрос, зачем вот это:

 

если есть вот это

 

?

 

если без этого получится - отпишите.

у меня работает с baselayout-2

Изменено пользователем andrey1982

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Использую скрипт из данного поста, в целом интернет работает, но есть несколько неприятных моментов:

1. когда стартует ppp выдаётся сообщение: "* WARNING: net.ppp0 has started, but is inactive". Это только мне так повезло или это у всех так?

Вот весь вывод:

/etc/init.d/net.ppp0 restart
* Bringing down interface ppp0
*   Running postdown ...
xl2tpd: не завершён ни один процесс
pppd: не завершён ни один процесс
SIOCADDRT: Файл существует
* Bringing up interface ppp0
*   Running preup ...
/bin/mknod: `/dev/ppp': Файл существует
*   Starting pppd in ppp0 ...																						   [ ok ]
*   Backgrounding ...
* WARNING: net.ppp0 has started, but is inactive

2. Переодически отваливается ppp, но автоматически почему не поднимается назад, хотя в конфиге написано:

pppd_ppp0="defaultroute
	   lock
	   noauth
	   refuse-eap
	   refuse-chap
	   refuse-mschap
	   nobsdcomp
	   nopcomp
	   noaccomp
	   nodeflate
	   persist
	   maxfail 0
	   holdoff 10
	   lcp-echo-interval 10
	   lcp-echo-failure 3
	   password <cuted>"

Что я сделал не так?

3. Прописанных роутов почему-то не хватает для работы corbina.tv хотя до перехода на этот скрипт всё работало.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ребят,так выложите уже нормальные конфиги пожалуйста. Делаю как в закрепленном посте-ничего не получается :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А у меня на установку маскированых пакетов пишет о несовместимости

 

linux # ACCEPT_KEYWORDS="~x86" emerge -av sys-apps/baselayout

These are the packages that would be merged, in order:

Calculating dependencies  waiting for lock on /var/db/.pkg.portage_lockfile									   ... done!
[ebuild	 U ] sys-apps/baselayout-2.0.0 [1.12.11.1] USE="-build (-bootstrap%) (-static%) (-unicode%*)" 23 kB
[ebuild  N	] sys-apps/openrc-0.4.2  USE="ncurses pam unicode -debug" 142 kB
[blocks B	 ] <sys-fs/udev-133 ("<sys-fs/udev-133" is blocking sys-apps/openrc-0.4.2)
[blocks B	 ] <sys-apps/sysvinit-2.86-r11 ("<sys-apps/sysvinit-2.86-r11" is blocking sys-apps/openrc-0.4.2)

Total: 2 packages (1 upgrade, 1 new), Size of downloads: 164 kB
Conflict: 2 blocks (2 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
А у меня на установку маскированых пакетов пишет о несовместимости

 

sys-apps/openrc с 4 версии требует, версия udev была старше sys-fs/udev-133 и sysvinit была старше sys-apps/sysvinit-2.86-r11. Другими словами просто размаскируй их.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

а я не ставил sys-apps/openrc и не собираюсь пока. пользую тот конфиг, что тут указан в первом посте со всеми новшествами и изменениями что там указаны, но только не оптимизированным под sys-apps/openrc. Всё пашет но проблема не поднятия впна при его падении существует. я просто в крон внёс проверку инета и если он упал то переподнимает его. это конечно паршивый выход из ситуации но он пашет да и впн падает не так часто так что вроде всё нормально.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

У меня тоже ВПН не поднимается. Т.е. pppd отваливается, а xl2tpd висит в процессах и всё.

 

messages

Feb 6 14:16:10 main xl2tpd[14756]: Maximum retries exceeded for tunnel 45943. Closing.

Feb 6 14:16:10 main pppd[14758]: Modem hangup

Feb 6 14:16:10 main pppd[14758]: Terminating on signal 15.

Feb 6 14:16:10 main pppd[14758]: Connection terminated.

Feb 6 14:16:10 main pppd[14758]: Connect time 9976.6 minutes.

Feb 6 14:16:10 main pppd[14758]: Sent 2620541678 bytes, received 3701974921 bytes.

Feb 6 14:16:10 main pppd[14758]: Connect time 9976.6 minutes.

Feb 6 14:16:10 main pppd[14758]: Sent 2620541678 bytes, received 3701974921 bytes.

Feb 6 14:16:10 main pppd[14758]: Exit.

Feb 6 14:16:10 main xl2tpd[14756]: Connection 38316 closed to 85.21.0.251, port 1701 (Timeout)

Feb 6 14:16:11 main xl2tpd[14756]: Calling on tunnel 45943

Feb 6 14:18:07 main xl2tpd[14756]: Can not find tunnel 45943 (refhim=0)

Feb 6 14:18:32 main last message repeated 30 times

 

syslog

Feb 6 14:16:47 main noip2[1869]: Can't get status for ppp0. (19)

Feb 6 14:16:56 main xl2tpd[14756]: Host name lookup failed for l2tp.corbina.net.

 

(правда у меня не джента)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Вот так более дженту-вейно. Да и проблемы с двойным подключением нет.

 

cat /etc/conf.d/net

config_ppp0=( "ppp" )
link_ppp0="/dev/ppp"

preup() {
if [ "${IFACE}" = "ppp0" ]; then
	/etc/init.d/xl2tpd start
fi
return 0
}

predown() {
if [ "${IFACE}" = "ppp0" ]; then
	XL2TPD_PID=`cat /var/run/xl2tpd.pid`
	PPPD_PID=`ps -ef | awk -v xl2tpd_pid=${XL2TPD_PID} '\$3 == xl2tpd_pid {print \$2}'`
	kill -1 ${PPPD_PID}
	/etc/init.d/xl2tpd stop
	kill -9 ${PPPD_PID}
fi
return 0
}

 

 

cat /etc/ppp/ip-up.d/60-corbina.sh

#!/bin/sh

if [ "$1" = "ppp0"  ]; then
/sbin/ip ro del $5
fi

 

Ага, вот спасибо, хорошо.

Только напрягся проблемой с ором в логах про повторные попытки подключений при имеющемся и тут же нашел решение :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ребят, помогите пожалуйста

делал всё по инструкции, локалка поднимается отлично, все локальные ресурсы работают

но вот инет на отрез отказывается

вол логи

Feb 18 23:00:43 local pppd[2288]: Using interface ppp0
pppd[2288]: Connect: ppp0 <--> /dev/pts/2
pptp[2322]: anon log[main:pptp.c:272]: The synchronous pptp option is NOT activated
pptp[2326]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 1 'Start-Control-Connection-Request'
pptp[2326]: anon log[ctrlp_disp:pptp_ctrl.c:738]: Received Start Control Connection Reply
pptp[2326]: anon log[ctrlp_disp:pptp_ctrl.c:772]: Client connection established.
pptp[2326]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 7 'Outgoing-Call-Request'
pptp[2326]: anon log[ctrlp_disp:pptp_ctrl.c:857]: Received Outgoing Call Reply.
pptp[2326]: anon log[ctrlp_disp:pptp_ctrl.c:896]: Outgoing call established (call ID 0, peer's call ID 45314).
pppd[2288]: MS-CHAP authentication failed: E=691 Authentication failure
pppd[2288]: CHAP authentication failed
pptp[2326]: anon log[ctrlp_disp:pptp_ctrl.c:928]: Call disconnect notification received (call id 45314)
pptp[2326]: anon log[ctrlp_disp:pptp_ctrl.c:787]: Received Stop Control Connection Request.
pptp[2326]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 4 'Stop-Control-Connection-Reply'
pptp[2326]: anon log[callmgr_main:pptp_callmgr.c:255]: Closing connection (shutdown)
pptp[2326]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 12 'Call-Clear-Request'
pppd[2288]: Modem hangup
pppd[2288]: Connection terminated.
pptp[2326]: anon log[call_callback:pptp_callmgr.c:78]: Closing connection (call state)

но логин и пароль точно правильные о_0

пробовал просто по средствам pptp из командной строки запускать, тоже самое

хотя если сделать точно так же с любого live-cd, то работает

при чём пароль принимает в том случае, если не запуская /etc/init.d/net.eth0 получить айпишник через dhcpcd при старте системы, но через секунду инет всё равно валится =) а далее снова ругается как в логе выше

в чём может быть дело и куда копать ?

Изменено пользователем spoteng

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

spoteng, пароль где прописан? в /etc/conf.d/net или в /etc/ppp/chap-secrets?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас