Mizanthrope

Настройка vpn-подключения в Gentoo. Gentoo way

Рекомендованные сообщения

Особенность здесь в том, что почти все сетевые настройки объединены для удобства в одном файле, как это и задумано в дженту.

Технические подробности можно увидеть здесь http://help.corbina.ru/internet/techinfo/

 

История изменений:

================================================================================

19.02.2009

- Изменение в конце инструкции: при подключении по l2tp строчку pppd_ppp0 надо заменить на другую, а не удалять. Так же убрана функция preup()

 

05.02.2009

- Изменен адрес l2tp-сервера на tp.corbina.net для всех городов

 

11.10.2008

- Подправлен раздел "Требования"

 

12.09.2008

- Изменен адрес l2tp-сервера

for vpnaddr in $(host tp.corbina.net | grep has | awk '{ print $NF }'); do route add $vpnaddr gw $GATEWAY dev eth0; done;

 

12.09.2008

- Добавлен еще один маршрут 233.32.240.0/24 via $GATEWAY для правильной работы IPTV.

- Изменены строчки для более точной выборки хостов

for vpnaddr in $(host vpn.corbina.net | grep has | awk '{ print $NF }'); do route add $vpnaddr gw $GATEWAY dev eth0; done;

for vpnaddr in $(host l2tp.corbina.net | grep has | awk '{ print $NF }'); do route add $vpnaddr gw $GATEWAY dev eth0; done;

 

11.09.2008

- Добавлено требование sys-apps/openrc, в результате установки которого формат многих файлов в /etc изменится, в том числе и /etc/conf.d/net, который уже приведен в соответствие новому формату. Подробнее можно прочитать здесь http://www.gentoo.org/doc/en/openrc-migration.xml

- Добавлены маршруты 224.0.0.0/4 via $GATEWAY и 172.16.16.0/24 via $GATEWAY для правильной работы IPTV.

================================================================================

 

Требования:

должны быть установлены

net-misc/dhcp

net-dialup/ppp

net-dialup/pptpclient

net-dns/bind-tools

sys-apps/baselayout (разрешить установку из нестабильной ветки, поместив sys-apps/baselayout в файл /etc/portage/package.keywords)

sys-apps/openrc (разрешить установку из нестабильной ветки, поместив sys-apps/openrc в файл /etc/portage/package.keywords)

При использовании l2tp - установить net-dialup/xl2tpd

 

Изменить под себя:

* eth0 - название сетевой

* fallback_eth0 - адрес, назначаемый в случае неполучения его по dhcp (можно взять из своих же, выданных ранее).

* username_ppp0='ЛОГИНВКОРБИНЕ'

* password_ppp0='ПАРОЛЬВКОРБИНЕ'

* GATEWAY - шлюз по умолчанию

* Во избежание автоматического запуска переименовать или перенести в другое место файлы /etc/ppp/ip-up.local и /etc/ppp/ip-down.local

 

 

Создаем конфиги

 

/etc/dhcp/dhclient.conf, в нем исключено забирание dns с dhcp-сервера, они не правильные.

timeout 40;
retry 30;
request subnet-mask, broadcast-address, time-offset, routers;

 

/etc/conf.d/net

GATEWAY="10.193.104.1"
config_eth0="dhcp"
modules="dhclient"
dhclient_eth0="-nw"
dns_servers_eth0="195.14.50.1 195.14.50.21"
dns_search_eth0="corbina.ru"
fallback_eth0="10.193.xx.xx netmask 255.255.248.0"

# Локальные ресурсы
routes_eth0="
195.14.50.1 via $GATEWAY
195.14.50.21 via $GATEWAY
85.21.138.214 via $GATEWAY
85.21.138.210 via $GATEWAY
85.21.88.130 via $GATEWAY
85.21.52.254 via $GATEWAY
85.21.138.208/28 via $GATEWAY
83.102.146.96/27 via $GATEWAY
78.107.23.0/24 via $GATEWAY
195.14.50.16 via $GATEWAY
195.14.50.26 via $GATEWAY
89.179.135.67 via $GATEWAY
62.205.179.146 via $GATEWAY
85.21.79.38 via $GATEWAY
10.0.0.0/8 via $GATEWAY
85.21.79.0/24 via $GATEWAY
85.21.90.0/24 via $GATEWAY
85.21.72.80/28 via $GATEWAY
195.14.50.93 via $GATEWAY
78.107.69.98 via $GATEWAY
224.0.0.0/4 via $GATEWAY
172.16.16.0/24 via $GATEWAY"

config_ppp0="ppp"
link_ppp0="pty 'pptp vpn.corbina.net --nolaunchpppd --nobuffer --loglevel 0'"
username_ppp0='ЛОГИНВКОРБИНЕ'
password_ppp0='ПАРОЛЬВКОРБИНЕ'
pppd_ppp0="defaultroute lock noauth refuse-eap refuse-chap refuse-mschap nobsdcomp \
nopcomp noaccomp nodeflate persist maxfail 0 holdoff 10 lcp-echo-interval 60 lcp-echo-failure 10 password ПАРОЛЬВКОРБИНЕ"

postup() {
if [ "${IFACE}" = "eth0" ]; then
# Адреса VPN-серверов берутся с DNS-сервера Корбины
	for vpnaddr in $(host vpn.corbina.net | awk '{ print $NF }'); do route add $vpnaddr gw $GATEWAY dev eth0; done;
	for vpnaddr in $(host tp.corbina.net | awk '{ print $NF }'); do route add $vpnaddr gw $GATEWAY dev eth0; done;
fi

if [ "${IFACE}" = "ppp0" ]; then
# Из-за того, что адрес VPN-сервера совпадает с адресом шлюза,
# создаваемый автоматически маршрут к VPN-серверу использует интерфейс ppp0, а не eth0, исправляем
	VPN=`ifconfig | grep 'P-t-P' | awk '{print $3}' | awk -F: '{print $2}'`
	route del $VPN dev ppp0
# Удаление шлюза по умолчанию в локалку и добавление шлюза по умолчанию в инет
	route del default
	route add default dev ppp0
fi

return 0
}

postdown() {
# Добавление маршрута по умолчанию в локалку
if [ "${IFACE}" = "ppp0" ]; then
   killall xl2tpd pppd
	route add default dev eth0
fi
return 0
}


# Перед запуском vpn должен быть поднят eth0
depend_ppp0() {
	need net.eth0
}

 

 

L2TP

 

При использовании l2tp надо поставить net-dialup/xl2tpd и создать конфиги /etc/xl2tpd/xl2tpd.conf и /etc/ppp/options.l2tp

 

/etc/xl2tpd/xl2tpd.conf

[global]
access control = yes

[lac corbina]
lns = tp.corbina.net
redial = yes
redial timeout = 10
require chap = yes
require authentication = no
name = ЛОГИНВКОРБИНЕ
ppp debug = yes
pppoptfile = /etc/ppp/options.l2tp
refuse pap = yes
autodial = yes

 

/etc/ppp/options.l2tp

name corbina
remotename l2tp
ipparam corbina
connect /bin/true
nodeflate
nobsdcomp
persist
maxfail 0
nopcomp
noaccomp
nodefaultroute
mru 1460
mtu 1460
noauth
user ЛОГИНВКОРБИНЕ
password ПАРОЛЬВКОРБИНЕ

 

изменить в конфиге /etc/conf.d/net строчку

link_ppp0="pty 'pptp vpn.corbina.net --nolaunchpppd --nobuffer --loglevel 0'"

на

link_ppp0="pty 'xl2tpd'"

 

а также заменить строчку

pppd_ppp0="defaultroute lock noauth refuse-eap refuse-chap refuse-mschap nobsdcomp \

nopcomp noaccomp nodeflate persist maxfail 0 holdoff 10 lcp-echo-interval 60 lcp-echo-failure 10 password ПАРОЛЬВКОРБИНЕ"

на

pppd_ppp0="remotename l2tp name corbina ipparam corbina connect /bin/true nodeflate noauth nobsdcomp nodeflate \

nopcomp noaccomp persist maxfail 0 user ЛОГИНВКОРБИНЕ password ПАРОЛЬВКОРБИНЕ"

Изменено пользователем Mizanthrope

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

postup() {

if [ "${IFACE}" = "eth0" ]; then

# Какие-то подсети

local rts_nets=(

# ?

"-net 85.21.79.0 netmask 255.255.255.0"

"-net 85.21.52.0 netmask 255.255.255.0"

"-net 85.21.90.0 netmask 255.255.255.0"

"-net 195.14.40.0 netmask 255.255.255.0"

"-net 10.0.0.0 netmask 255.0.0.0"

"-net 85.21.108.16 netmask 255.255.255.240"

# tv

"-net 83.102.146.96 netmask 255.255.255.224"

)

Не подскажешь что это обозначает local rts_nets ты удаляешь роуты ели да то для чего опиши по подробней.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Наоборот добавляю, ниже там прокомментил

# Добавляем маршруты, заданные в массивах rts_nets и rts_vpn

 

А что за маршруты в rts_nets, не знаю. Давно еще откуда-то отсюда с форумов брал.

tv это corbina.tv

Изменено пользователем Mizanthrope

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А почему бы не добавить dhcp_eth0="nogateway", тк когда 2 default шлюза трейсы нифига не ходят нормально (может это тока у меня )

и роуты local rts_nets можно перенести в routes_eth0=(), тк что они прописаны в роутах,

что в postup(), смысл не изменится.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ошибки при запуске конфига net : выдает их когда доходит до postup

 

при запуске системы выдает следующие :

 

Running postup function

/etc/conf.d/net: Line 79: host: command not found

SIOCADDRT : File exists

SIOCADDRT : File exists

SIOCADDRT : File exists

SIOCADDRT : File exists

 

Убрал описания ,моя строка номер 79: local rts_vpn=(`host vpn.corbina.net 195.14.50.1 | grep vpn | awk '{print $4}'`)

 

Хотя инет и локалка работает но хотелось бы исправить ошибку :D

Изменено пользователем Tediz

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Tediz,

> /etc/conf.d/net: Line 79: host: command not found

 

ну может быть у тебя действительно нет host? Он по моему идет в поставке с bind

 

> host vpn.corbina.net 195.14.50.1

 

в настоящее время локальные днс-серверы это:

213.234.192.8

85.21.192.3

 

195.14.50.1 это днс-сервер который выдает впн и он не обязан работать без впн.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А почему бы не добавить dhcp_eth0="nogateway", тк когда 2 default шлюза трейсы нифига не ходят нормально (может это тока у меня )

и роуты local rts_nets можно перенести в routes_eth0=(), тк что они прописаны в роутах,

что в postup(), смысл не изменится.

В принципе можно dhcp_eth0="nogateway" и добавить, т.к. статические маршруты прописаны, а при двух маршрутах по умолчанию трафик все равно идет на ppp0, т.к. он идет первым в таблице маршрутизации.

А какие именно трейсы не ходят?

Насчет "local rts_nets можно перенести в routes_eth0=()" - там маршруты для подсетей не работают, по-крайней мере я не нашел, как это сделать.

 

Ошибки при запуске конфига net : выдает их когда доходит до postup

 

при запуске системы выдает следующие :

 

Running postup function

/etc/conf.d/net: Line 79: host: command not found

SIOCADDRT : File exists

SIOCADDRT : File exists

SIOCADDRT : File exists

SIOCADDRT : File exists

 

Убрал описания ,моя строка номер 79: local rts_vpn=(`host vpn.corbina.net 195.14.50.1 | grep vpn | awk '{print $4}'`)

 

Хотя инет и локалка работает но хотелось бы исправить ошибку :lol:

Эту строку не убирай, просто поставь пакет bind либо bind-client (в генту это net-dns/bind-tools), иначе у тебя не будет маршрутов до впн-сервера и впн не будет работать. Т.к. я все-таки поставлю опцию nogateway для dhcp.

 

в настоящее время локальные днс-серверы это:

213.234.192.8

85.21.192.3

 

195.14.50.1 это днс-сервер который выдает впн и он не обязан работать без впн.

Недавно в поддержке сказали, что таких серверов вообще нет, а правильные это 195.14.50.21 и 195.14.50.1. И кстати один из них, кажется 213.234.192.8, действительно не отвечает на запросы dns.

Изменено пользователем Mizanthrope

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

1. Вместо ручного удаления и добавления "правильного" маршрута можно добавить "defaultroute" в pppd_ppp0 и удалить "nodefaultroute":

 

2. Зачем в ручную бэкапить и восстанавливать resolv.conf?

Мы ведь уже указали "usepeerdns" в pppd_ppp0 :lol:

 

так же проще...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

AL50

1. Из-за глюка в pppd он не добавляется.

 

2. У меня есть еще одно соединение ppp1, где resolv.conf другой.

К тому же как выяснилось, dhcp-сервер вообще выдает неправильные dns, сейчас у меня жестко прописаны 195.14.50.1 и 195.14.50.21 (для моего района).

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Насчет "local rts_nets можно перенести в routes_eth0=()" - там маршруты для подсетей не работают, по-крайней мере я не нашел, как это сделать.

 

 

routes_eth0=(
"default via 10.227.0.17"


"10.0.0.0 netmask 255.0.0.0 via 10.227.0.17"
"85.21.29.242 netmask 255.255.255.255 via 10.227.0.17"
"89.179.135.67 netmask 255.255.255.255 via 10.227.0.17"
...

 

Всё прекрасно работет

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

routes_eth0=(
"default via 10.227.0.17"
"10.0.0.0 netmask 255.0.0.0 via 10.227.0.17"
"85.21.29.242 netmask 255.255.255.255 via 10.227.0.17"
"89.179.135.67 netmask 255.255.255.255 via 10.227.0.17"
...

 

Всё прекрасно работет

Эти 3 роута нельзя добавить одной командой

Для первого будет add route -net

для остальных - route add

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Использую ваш способ, но имею затруднения, подробнее проблема описана в соседней теме

PPP поднимается? но доступа в инет нет :-(

 

Может я в ядре чего неправильно собрал?

Заранее благодарен за помощь

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот в этих путях не верно что-то с маской видать

 

"85.21.138.208/28 via $GATEWAY" 
"83.102.146.96/27 via $GATEWAY"
"85.21.72.80/28 via $GATEWAY"

 

на них постоянно вылетает ошибка. :unsure:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Не могу проверить, недавно поставил последний sys-apps/baselayout-2.0.0_rc6-r1, конфиг изменился. Попробуй

85.21.138.208/255.255.255.240 via $GATEWAY

или так

85.21.138.208 netmask 255.255.255.240 via $GATEWAY

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Собственно сделал как в первом посте, в общем такая проблема, как только vpn соединение рвётся, оно заного не подключается

 

Mar 24 21:26:28 local-server pppd[1217]: LCP terminated by peer
Mar 24 21:26:28 local-server pppd[1217]: Connect time 32.6 minutes.
Mar 24 21:26:28 local-server pppd[1217]: Sent 4551952 bytes, received 41119697 bytes.
Mar 24 21:26:28 local-server pptp[1225]: anon log[ctrlp_disp:pptp_ctrl.c:928]: Call disconnect notification received (call id 26850)
Mar 24 21:26:28 local-server pptp[1225]: anon log[ctrlp_disp:pptp_ctrl.c:787]: Received Stop Control Connection Request.
Mar 24 21:26:28 local-server pptp[1225]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 4 'Stop-Control-Connection-Reply'
Mar 24 21:26:28 local-server pptp[1225]: anon log[callmgr_main:pptp_callmgr.c:255]: Closing connection (shutdown)
Mar 24 21:26:28 local-server pptp[1225]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 12 'Call-Clear-Request'
Mar 24 21:26:28 local-server pptp[1225]: anon log[call_callback:pptp_callmgr.c:78]: Closing connection (call state)
Mar 24 21:26:28 local-server pppd[1217]: Modem hangup
Mar 24 21:26:28 local-server pppd[1217]: Connection terminated.
Mar 24 21:26:30 local-server pppd[1217]: Terminating on signal 15
Mar 24 21:26:31 local-server pppd[1217]: Exit.

Изменено пользователем Pentium02p

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Я из [tps2] двадцать четвертого марта нам сделали пиринг с [mit] , [nag] ........ , инет и локалка из линукса стали не доступны чего я только не делал.

Поменяли dns мой resolv.conf :

nameserver 213.234.192.8

nameserver 85.21.192.3

Поменяли шлюз gw= 10.119.8.1

Прописал ваш новый конфиг ,но толку ни какого :D

route -n

85.21.88.130 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

195.14.50.16 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

85.21.192.3 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

85.21.138.214 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

85.21.52.254 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

85.21.138.210 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

195.14.50.21 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

85.21.0.23 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

195.14.50.26 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

89.179.135.67 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

62.205.179.146 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

213.234.192.8 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

85.21.79.38 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

195.14.50.93 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

78.107.69.98 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

10.119.8.0 10.119.8.1 255.255.255.255 UGH 0 0 0 eth0

85.21.72.80 10.119.8.1 255.255.255.240 UG 0 0 0 eth0

85.21.138.208 10.119.8.1 255.255.255.240 UG 0 0 0 eth0

83.102.146.96 10.119.8.1 255.255.255.224 UG 0 0 0 eth0

85.21.90.0 10.119.8.1 255.255.255.0 UG 0 0 0 eth0

78.107.23.0 10.119.8.1 255.255.255.0 UG 0 0 0 eth0

85.21.79.0 10.119.8.1 255.255.255.0 UG 0 0 0 eth0

10.119.8.0 0.0.0.0 255.255.248.0 U 0 0 0 eth0

10.0.0.0 10.119.8.1 255.0.0.0 UG 0 0 0 eth0

127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

 

перезапуск /etc/init.d/net.eth0 restart выдает

 

* Unmounting network filesystems ... [ ok ]

* Stopping ppp0

* Bringing down ppp0 [ ok ]

* Running postdown function

xl2tpd: no process killed

* Stopping eth0

* Bringing down eth0

* Stopping dhclient on eth0 ... [ ok ]

* Shutting down eth0 ... [ ok ]

* Running postdown function

* Starting eth0

* Running preup function [ ok ]

* Bringing up eth0

* dhcp

* Running dhclient ... [ ok ]

* eth0 received address 10.119.11.245/21

* Adding routes

* 213.234.192.8 via 10.119.8.1 ... [ ok ]

* 85.21.192.3 via 10.119.8.1 ... [ ok ]

* 10.119.8.0 via 10.119.8.1 ... [ ok ]

* 85.21.0.23 via 10.119.8.1 ... [ ok ]

* 195.14.50.21 via 10.119.8.1 ... [ ok ]

* 85.21.138.214 via 10.119.8.1 ... [ ok ]

* 85.21.138.210 via 10.119.8.1 ... [ ok ]

* 85.21.88.130 via 10.119.8.1 ... [ ok ]

* 85.21.52.254 via 10.119.8.1 ... [ ok ]

* 85.21.138.208/28 via 10.119.8.1 ... [ ok ]

* 83.102.146.96/27 via 10.119.8.1 ... [ ok ]

* 78.107.23.0/24 via 10.119.8.1 ... [ ok ]

* 195.14.50.16 via 10.119.8.1 ... [ ok ]

* 195.14.50.26 via 10.119.8.1 ... [ ok ]

* 89.179.135.67 via 10.119.8.1 ... [ ok ]

* 62.205.179.146 via 10.119.8.1 ... [ ok ]

* 85.21.79.38 via 10.119.8.1 ... [ ok ]

* 10.0.0.0/8 via 10.119.8.1 ... [ ok ]

* 85.21.79.0/24 via 10.119.8.1 ... [ ok ]

* 85.21.90.0/24 via 10.119.8.1 ... [ ok ]

* 85.21.72.80/28 via 10.119.8.1 ... [ ok ]

* 195.14.50.93 via 10.119.8.1 ... [ ok ]

* 78.107.69.98 via 10.119.8.1 ... [ ok ]

* Running postup function

dev: Unknown host

dev: Unknown host

dev: Unknown host

dev: Unknown host

dev: Unknown host

* Mounting network filesystems ... [ ok ]

* Starting ppp0

* Running preup function

/bin/mknod: `/dev/ppp': Файл существует [ ok ]

* Bringing up ppp0

* ppp

* Running pppd ...

* Backgrounding ...

 

Инет не работает, локалка частично на homenet зайти могу на ftp.corbina.net нет

 

ping ya.ru

connect: Network is unreachable

 

Забивал в роуты

host vpn.corbina.ru

vpn.corbina.ru is an alias for view8.viewdns.corbina.net.

view8.viewdns.corbina.net has address 85.21.0.102

но он каждый раз новый чего делать не знаю :(

 

Сори всё разобрался , забыл сделать

/etc/dhcp/dhclient.conf, в нем исключено забирание dns с dhcp-сервера, они не правильные.

 

timeout 40;

retry 30;

request subnet-mask, broadcast-address, time-offset, routers;

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

У меня странная проблема. При использовании pptp все, вроде, нормально, а вот, когда запускаю xl2tp то пишет

/etc/init.d/net.ppp0 start
* Starting ppp0
*   Running preup function
/bin/mknod: `/dev/ppp': Файл существует																		 [ ok ]
*   Bringing up ppp0
*	 ppp
*	   Running pppd ...

И на этом замирает.

Причем, интернет работает и из другой консоли все вполне пингуется, а вот в из инит-скрипта не выходится оно.

Как пофиксить?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Особенность здесь в том, что почти все сетевые настройки объединены для удобства в одном файле, как это и задумано в дженту.

Огромное спасибо!

 

Перелез на xl2tp..

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Огромное спасибо!

 

Перелез на xl2tp..

И что, никаких подвисаний при старте системы? И нормально из скрипта выходит?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Всем привет. Второй час сижу туплю и не могу понять в чём проблема. Сделано всё по первому посту.

`/etc/init.d/net.eth0 restart` выдаёт следующее:

localhost ~ # /etc/init.d/net.eth0 restart
* Caching service dependencies ...																									[ ok ]
* Bringing down interface ppp0
*   Stopping pppd on ppp0																											 [ ok ]
*   Removing addresses
ppp0: error fetching interface information: Device not found
ppp0: error fetching interface information: Device not found
*	 Running postdown ...
pppd: не завершён ни один процесс
* Bringing down interface eth0
*   Stopping dhclient on eth0 ...																									 [ ok ]
*   Removing addresses
*	 10.227.43.207/21
*	 Running postdown ...
* Bringing up interface eth0
*   Running preup ...
*   dhcp ...
*	 Running dhclient ...																											[ ok ]
*	 received address 10.227.43.207/21																							   [ ok ]
*   Adding routes
*	 195.14.50.1 via 10.227.40.1 ...																								 [ ok ]
*	 195.14.50.21 via 10.227.40.1 ...																								[ ok ]
*	 85.21.138.214 via 10.227.40.1 ...																							   [ ok ]
*	 85.21.138.210 via 10.227.40.1 ...																							   [ ok ]
*	 85.21.88.130 via 10.227.40.1 ...																								[ ok ]
*	 85.21.52.254 via 10.227.40.1 ...																								[ ok ]
*	 85.21.138.208/28 via 10.227.40.1 ...																							[ ok ]
*	 83.102.146.96/27 via 10.227.40.1 ...																							[ ok ]
*	 78.107.23.0/24 via 10.227.40.1 ...																							  [ ok ]
*	 195.14.50.16 via 10.227.40.1 ...																								[ ok ]
*	 195.14.50.26 via 10.227.40.1 ...																								[ ok ]
*	 89.179.135.67 via 10.227.40.1 ...																							   [ ok ]
*	 62.205.179.146 via 10.227.40.1 ...																							  [ ok ]
*	 85.21.79.38 via 10.227.40.1 ...																								 [ ok ]
*	 10.0.0.0/8 via 10.227.40.1 ...																								  [ ok ]
*	 85.21.79.0/24 via 10.227.40.1 ...																							   [ ok ]
*	 85.21.90.0/24 via 10.227.40.1 ...																							   [ ok ]
*	 85.21.72.80/28 via 10.227.40.1 ...																							  [ ok ]
*	 195.14.50.93 via 10.227.40.1 ...																								[ ok ]
*	 78.107.69.98 via 10.227.40.1 ...																								[ ok ]
*   Running postup ...
SIOCADDRT: Файл существует
localhost ~ #  * Bringing up interface ppp0
*   Running preup ...
/bin/mknod: `/dev/ppp': Файл существует
*   Starting pppd in ppp0 ...																										 [ ok ]
*   Backgrounding ...
* WARNING: net.ppp0 has started, but is inactive

 

 

Сам конфиг вот:

# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /etc/conf.d/net.example and save your configuration
# in /etc/conf.d/net (this file :]!).
#dns_domain_lo="localhost"
#config_eth0=( "dhcp" )
#dhcp_eth0="192.168.0.1 nontp nonis"




GATEWAY="10.227.40.1"
config_eth0=( "dhcp" )
modules=( "dhclient" )
dhclient_eth0="-nw"
dns_servers_eth0="195.14.50.1 195.14.50.21"
dns_search_eth0="corbina.ru"
fallback_eth0=( "10.227.xx.xx netmask 255.255.248.0" )

# Локальные ресурсы
routes_eth0=(
"195.14.50.1 via $GATEWAY"
"195.14.50.21 via $GATEWAY"
"85.21.138.214 via $GATEWAY"
"85.21.138.210 via $GATEWAY"
"85.21.88.130 via $GATEWAY"
"85.21.52.254 via $GATEWAY"
"85.21.138.208/28 via $GATEWAY"
"83.102.146.96/27 via $GATEWAY"
"78.107.23.0/24 via $GATEWAY"
"195.14.50.16 via $GATEWAY"
"195.14.50.26 via $GATEWAY"
"89.179.135.67 via $GATEWAY"
"62.205.179.146 via $GATEWAY"
"85.21.79.38 via $GATEWAY"
"10.0.0.0/8 via $GATEWAY"
"85.21.79.0/24 via $GATEWAY"
"85.21.90.0/24 via $GATEWAY"
"85.21.72.80/28 via $GATEWAY"
"195.14.50.93 via $GATEWAY"
"78.107.69.98 via $GATEWAY"
)

config_ppp0=( "ppp" )
link_ppp0="pty 'pptp vpn.corbina.net --nolaunchpppd --nobuffer --loglevel 0'"
username_ppp0='anna61'
password_ppp0='877231'
pppd_ppp0=(
	"nodefaultroute"
	"usepeerdns"
	"lock"
	"noauth"
# Запретить все кроме MSCHAPv2
	"refuse-eap"
	"refuse-chap"
	"refuse-mschap"
# Запретить протоколы сжатия
	"nobsdcomp"
	"nodeflate"
#		"debug"
# Переподнимать до упора
	"persist"
	"maxfail 0"
# Время в секундах между попытками переподнятия упавшего VPN
	"holdoff 10"
# Через какой интервал времени в секундах посылать запросы, чтобы проверить жив канал или нет
	"lcp-echo-interval 10"
# Если lcp-echo-failure пингов не прошло, значит канал отвалился и его надо переподнимать
	"lcp-echo-failure 9"
)

preup() {
if [ "${IFACE}" = "ppp0" ]; then
/bin/mknod /dev/ppp c 108 0
route del default
fi
return 0
}

postup() {
if [ "${IFACE}" = "eth0" ]; then
# Адреса VPN-серверов берутся с DNS-сервера Корбины
	for vpnaddr in $(host vpn.corbina.net | awk '{ print $NF }'); do route add $vpnaddr gw $GATEWAY dev eth0; done;
	for vpnaddr in $(host l2tp.corbina.net | awk '{ print $NF }'); do route add $vpnaddr gw $GATEWAY dev eth0; done;
fi

if [ "${IFACE}" = "ppp0" ]; then
# Из-за того, что адрес VPN-сервера совпадает с адресом шлюза,
# создаваемый автоматически маршрут к VPN-серверу использует интерфейс ppp0, а не eth0, исправляем
	VPN=`ifconfig | grep 'P-t-P' | awk '{print $3}' | awk -F: '{print $2}'`
	route del $VPN dev ppp0
# Удаление шлюза по умолчанию в локалку и добавление шлюза по умолчанию в инет
	route del default
	route add default dev ppp0
fi

return 0
}

postdown() {
# Добавление маршрута по умолчанию в локалку
if [ "${IFACE}" = "ppp0" ]; then
   killall xl2tpd pppd
	route add default dev eth0
fi
return 0
}


# Перед запуском vpn должен быть поднят eth0
depend_ppp0() {
	need net.eth0
}

 

Только сильно не пинайте, если ситуация уж слишком глупая :(

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

username_ppp0='anna61'
password_ppp0='877231'

Только сильно не пинайте, если ситуация уж слишком глупая :(

Пароль поменять не забудьте, а то кто-нибудь еще его поменяет.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Пароль поменять не забудьте, а то кто-нибудь еще его поменяет.

Блин вот я лохонулся. Аж стыдно

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

У меня l2tp заработало только после того как в файле /etc/ppp/options.l2tp

изменил name corbina на name ЛОГИНВКОРБИНЕ

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

а если я себе статику взял, в конфиге менять что-нибуть надо?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

а если я себе статику взял, в конфиге менять что-нибуть надо?

Не обязательно. Хотя если хочется чтоб не болтались лишние маршруты, можно удалить ненужные из массива routes_eth0.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

я вот незнаю, может я что-то не так делаю, но у меня при таком подключении создается еще одна пара процессов xl2tpd и pppd и создают на tty12 куча флуда своими попытками второй раз приконнектиться... имхо, что-то тут не так :(.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

2Ским

у меня лишних процессов нет, но какой-то мусор сыпется с попыткой повторных коннектов, но т.к. инет работает нормально, я просто на это забил :unsure:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Привет всем!

город-Ульяновск=)

 

интернет нормально работал

на днях у корбиновцев полетела локалка

и впн сервер барахлил(

 

в винде сейчас все работает

в генте-нет(

 

# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d. To create a more complete configuration,
# please review /etc/conf.d/net.example and save your configuration
# in /etc/conf.d/net (this file :]!).
GATEWAY="10.49.1.1"

dns_domain_lo="homenet"

config_eth0=("dhcp")
dhcp_eth0="dns nontp nonis"

config_ppp0=( "ppp" )
link_ppp0="pty 'pptp vpn.ul.corbina.net --nolaunchpppd --nobuffer --loglevel 0'"
username_ppp0='!!!!!!!!!!!'
password_ppp0='!!!!!!!!!!!!!!!!'
pppd_ppp0=(
"nodefaultroute"
"usepeerdns"
"lock"
"noauth"
"refuse-eap"
"refuse-chap"
"refuse-mschap"
"nobsdcomp"
"nodeflate"
"persist"
"maxfail 0"
"holdoff 2"
"lcp-echo-interval 10"
"lcp-echo-failure 9"
)

preup() {
if [ "${IFACE}" = "ppp0" ]; then
/bin/mknod /dev/ppp c 108 0
route del default
fi
return 0
}

postup() {
if [ "${IFACE}" = "eth0" ]; then
route add -net vpn.ul.corbina.net netmask 255.255.255.255 gw $GATEWAY;
for vpnaddr in $(host l2tp.corbina.net | awk '{ print $NF }'); do route add $vpnaddr gw $GATEWAY dev eth0; done;
fi

if [ "${IFACE}" = "ppp0" ]; then
VPN=`ifconfig | grep 'P-t-P' | awk '{print $3}' | awk -F: '{print $2}'`
route del $VPN dev ppp0
route del default
route add default dev ppp0
fi
route add -net 195.14.50.16 netmask 255.255.255.255 gw $GATEWAY
route add -net 195.14.50.26 netmask 255.255.255.255 gw $GATEWAY
route add -net 89.179.135.67 netmask 255.255.255.255 gw $GATEWAY
route add -net 10.0.0.0 netmask 255.0.0.0 gw $GATEWAY
route add -net 85.21.72.80 netmask 255.255.255.240 gw $GATEWAY
route add -net 195.14.50.93 netmask 255.255.255.255 gw $GATEWAY

return 0
}

postdown() {
if [ "${IFACE}" = "ppp0" ]; then
killall xl2tpd pppd
route add default dev eth0
fi
return 0
}

depend_ppp0() {
need net.eth0
}

 

конфиг такой

только вроде адреса были в виде ИП, т.к. ошибку выдавал

l2tp тоже не пашет(

ppp0 не поднимается

в логах ничего не было(

сейчас следующее

anon warn[pptp_gre_bind:pptp_gre.c:95]: connect: Network is unreachable

anon fatal[main:pptp.c:280]: Cannot bind GRE socket, aborting.

anon warn[pptp_gre_bind:pptp_gre.c:95]: connect: Network is unreachable

anon fatal[main:pptp.c:280]: Cannot bind GRE socket, aborting.

anon warn[pptp_gre_bind:pptp_gre.c:95]: connect: Network is unreachable

anon fatal[main:pptp.c:280]: Cannot bind GRE socket, aborting.

 

в чем/ком проблема?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

2mih4i1

 

Со вчерашнего вечера корбина что-то опять намутила, как я понял, поменяли что-то на vpn-сервере, после чего сначала сыпались ошибки

pppd[20277]: MS-CHAPv2 Success packet is badly formed.

pppd[20277]: CHAP authentication failed

pppd[20277]: Connection terminated.

 

а теперь постоянно идет одна и та же ошибка, уже и сессию с их стороны прерывали, все одно и тоже

pppd[5584]: MS-CHAP authentication failed: E=691 Authentication failure

pppd[5584]: CHAP authentication failed

 

а вот по l2tp работает нормально

 

насчет твоей ошибки - очевидно не хватает какого-то маршрута, дай вывод команд

route -n

ping vpn.ul.corbina.net

 

насчет вот этой команды?

for vpnaddr in $(host l2tp.corbina.net | awk '{ print $NF }'); do route add $vpnaddr gw $GATEWAY dev eth0; done;

ты уверен, что у вас сервер l2tp это l2tp.corbina.net?

 

вообще работал ли раньше инет через l2tp с такими же настройками?

Изменено пользователем Mizanthrope

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

for vpnaddr in $(host l2tp.corbina.net | awk '{ print $NF }'); do route add $vpnaddr gw $GATEWAY dev eth0; done;

я хз зачем это в конфиге, но с этим все работало=)

l2tp у нас вроде tp.ul.corbina.net (Ульяновск)

http://help.corbina.ru/internet/techinfo/

 

я пользовался чисто ррр

вот решил попробовать по другому

 

и еще такая бага была, впн только через ИП адрес соединял%)

если впн не поднимать днс работает

 

когда ррр0 поднимается с ошибкой то не хватает дефолтного маршута(тк интерфейс не поднят, а локальный удаляется)

 

напишите/ткните носом

в схему действий, что и для чего нужно

 

и почему такой гемор с линуксом?

в винде тока адрес прописать и галку снять

 

роуты выведу позже

в принципе по конфигу видно=)

не поднимаются только с dev ppp0

спасибо

Изменено пользователем mih4i1

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас